Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1557 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Accès POP, IMAP à La Poste

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

Accès POP, IMAP à La Poste

n°823019
francoisch​1
Posté le 11-01-2015 à 18:31:26  profilanswer
 


Bonjour
 
Mon client de messagerie fait maison lit, très bien sur de nombreux serveurs mail, avec le très classique :

Code :
  1. @imap_open ("{".$serveur_entrant.$port.$protocole.$options."}".$boite, $identifiant, $mot_de_passe) )


 
Quand je tente de lire sur pop.laposte.net, port 110, pas d’option, j’ai :

Code :
  1. TLS/SSL failure for pop.laposte.net: SSL negotiation failed


 
Quand je tente de lire sur imap.laposte.net, port 993, option /ssl/novalidate-cert, j’ai :

Code :
  1. TLS/SSL failure for imap.laposte.net: SSL negotiation failed


 
Ce même code lit très bien chez Gmail, Free, … depuis plusieurs années et plante à La Poste depuis peu.
 
Merci par avance de votre aide.
 
Francois

mood
Publicité
Posté le 11-01-2015 à 18:31:26  profilanswer
 

n°823021
nnwldx
Posté le 11-01-2015 à 18:36:44  profilanswer
 

est ce qu'ils acceptent le pop ssl ?
as tu essayé sur le port 995 ?
 
est ce qu'ils acceptent imap ssl ?

n°823109
francoisch​1
Posté le 12-01-2015 à 10:41:59  profilanswer
 

J'ai essayé:
- le pop ssl, 995: TLS/SSL failure for imap.laposte.net: SSL negotiation failed
- l'imap non ssl: Connection reset by peer  
 
Je me demande si le serveur de la poste aurait fait des modifs pour augmenter la sécurité, façon Gmail par exemple.
 
Francois

n°823113
gen2
Posté le 12-01-2015 à 11:16:51  profilanswer
 

La poste a en effet fait de nombreuses modifs fin 2014 (je n'ai plus la date exacte en tête) :  
- refonte du webmail
- passage du quota de 2 à 5 Go
- obligation de passer par leur SMTP pour envoyer des mails depuis une adresse @laposte.net
 
Et il y a sûrement eu d'autres modifs notamment liées à la sécurité, mais je n'en sais pas plus.

n°823132
nnwldx
Posté le 12-01-2015 à 12:29:18  profilanswer
 

il faut que tu passes sur le pop.laposte.net sur le port 110 sans ssl.

n°823958
francoisch​1
Posté le 15-01-2015 à 18:50:26  profilanswer
 

J'ai naturellement essayé 110 sans ssl: erreur.
 
J'ai laissé 2 messages à la fonction Aide de La poste; j'attend.
 
Francois

n°823960
nnwldx
Posté le 15-01-2015 à 19:13:00  profilanswer
 

je ne pense pas que la poste viendra a ton aide.
Test avec un outlook pour voir si ca passe.

n°824003
bardiel
Debian powa !
Posté le 15-01-2015 à 21:54:46  profilanswer
 

gen2 a écrit :

- obligation de passer par leur SMTP pour envoyer des mails depuis une adresse @laposte.net


Pour envoyer depuis chez moi des mails @laposte.net, j'utilise le SMTP de mon FAI (Orange) [:spamatounet]  
Par contre, quelques soucis pour relever 2 adresses mails @laposte en IMAP en "même temps" depuis la même époque.


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°824016
francoisch​1
Posté le 15-01-2015 à 22:41:59  profilanswer
 

Je viens d'essayer sur laposte.net :
• POP 110 : connection reset by peer
• IMAP 993 SSL : TLS/SSL failure for imap.laposte.net: SSL negotiation failed,
• POP 995 SSL : TLS/SSL failure for imap.laposte.net: SSL negotiation failed,
• IMAP 143 : connection reset by peer
tous en erreur donc.
 
Mon problème: mon Client fonctionne sur un de mes sites Web utilisé par plusieurs dizaines de personnes.
 
Est ce que je dois leur dire de changer d'adresse, d'aller chez Free, Gmail, ...
 
Par contre, le Webmail de laposte.net fonctionne parfaitement, tant mieux pour eux, leur Client a bien été mis à jour.

n°824039
bardiel
Debian powa !
Posté le 16-01-2015 à 09:38:45  profilanswer
 

Mes paramètres pour Thunderbird :
- imap.laposte.net port 993
- smtp.laposte.net port 465
- sécurité de la connexion : SSL/TLS
- méthode d'authentification : Mot de passe normal
Ton client de messagerie "fait maison" il est fait en quoi ? PHP ?
Tu as regardé le manuel de PHP pour ajouter l'option "/tls" ?
Ta variable "$protocole" je suppose que c'est du genre "/service=imap" ?


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
mood
Publicité
Posté le 16-01-2015 à 09:38:45  profilanswer
 

n°824058
francoisch​1
Posté le 16-01-2015 à 10:37:47  profilanswer
 

Mon client est écrit en Php.
Mes paramètres:
  $serveur_entrant2 = "imap.laposte.net";
  $port2 = ":993";
  $protocole2 = "/imap";
  $options2 = "/ssl/novalidate-cert";
Où ajoutes tu l'option /tls?
 
Francois

n°824072
bardiel
Debian powa !
Posté le 16-01-2015 à 11:04:22  profilanswer
 

En lisant le manuel, à ton avis ? :D  
Sur $options2 évidemment...
A la place de /imap pour $protocole2, je tenterais aussi soit /imap4 soit  /imap4rev1


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°824087
francoisch​1
Posté le 16-01-2015 à 11:20:09  profilanswer
 

Option /tls: Connection reset by peer
imap4: TLS/SSL failure for imap.laposte.net: SSL negotiation failed,
 
Francois

n°824138
gen2
Posté le 16-01-2015 à 14:54:55  profilanswer
 

bardiel a écrit :


Pour envoyer depuis chez moi des mails @laposte.net, j'utilise le SMTP de mon FAI (Orange) [:spamatounet]  
Par contre, quelques soucis pour relever 2 adresses mails @laposte en IMAP en "même temps" depuis la même époque.


Ca fonctionne en envoyant un email depuis laposte.net vers une autre adresse laposte.net ?
 
Parce que vu qu'ils ont mis en place DKIM + SPF sur leurs serveurs, si tu ne passes pas par leur SMTP, tu vas vite te faire flaguer en spammeur. Et si tu envoies depuis une adresse laposte.net vers une autre adresse laposte.net avec un SMTP autre que celui de la Poste (celui de ton FAI par exemple), ton mail n'arrive jamais, enfin c'était le cas pour mes parents et pour moi, tous les 2 avec des adresses @laposte.net.

n°824144
gen2
Posté le 16-01-2015 à 15:05:20  profilanswer
 

francoisch1 a écrit :

Option /tls: Connection reset by peer
imap4: TLS/SSL failure for imap.laposte.net: SSL negotiation failed,
 
Francois


Tu peux nous donner ta fonction imap_open complète ?
Pour le /tls, tu l'a précisé comment ?
Ca devrait donner ça au final /imap/tls/novalidate-cert
Tu peux aussi essayer /ssl/notls/novalidate-cert.

n°824228
francoisch​1
Posté le 17-01-2015 à 10:29:53  profilanswer
 

Voila:
   /imap/tls/novalidate-cert donne  
Can't open mailbox {imap.laposte.net:993/imap/imap/tls/novalidate-cert}INBOX: invalid remote specification
    /ssl/notls/novalidate-cert donne
 TLS/SSL failure for imap.laposte.net: SSL negotiation failed,
 
Mon imap_open:
imap_open ("{".$serveur_entrant.$port.$protocole.$options."}".$boite, $identifiant, $mot_de_passe) )
très classique je crois,
et qui:
   fonctionne avec les autres serveurs mail
   fonctionnait depuis longtemps avec laposte
 
Grand merci de ton aide.
 
Ffrancois

n°824231
bardiel
Debian powa !
Posté le 17-01-2015 à 11:00:06  profilanswer
 

gen2 a écrit :

Ca fonctionne en envoyant un email depuis laposte.net vers une autre adresse laposte.net ?


Oui.
Par contre, Orange bloque si tu n'utilises pas leur SMTP... après je n'envoie pas 200 mails par jour, juste dans les 10-15.

francoisch1 a écrit :

/ssl/notls/novalidate-cert donne
 TLS/SSL failure for imap.laposte.net: SSL negotiation failed,


Et sans "/novalidate-cert" ça te donne quoi ?

Message cité 1 fois
Message édité par bardiel le 17-01-2015 à 11:26:08

---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°824267
gen2
Posté le 17-01-2015 à 17:54:17  profilanswer
 

francoisch1 a écrit :

Voila:
   /imap/tls/novalidate-cert donne  
Can't open mailbox {imap.laposte.net:993/imap/imap/tls/novalidate-cert}INBOX: invalid remote specification
    /ssl/notls/novalidate-cert donne
 TLS/SSL failure for imap.laposte.net: SSL negotiation failed,
 
Mon imap_open:
imap_open ("{".$serveur_entrant.$port.$protocole.$options."}".$boite, $identifiant, $mot_de_passe) )
très classique je crois,
et qui:
   fonctionne avec les autres serveurs mail
   fonctionnait depuis longtemps avec laposte
 
Grand merci de ton aide.
 
Ffrancois


Il faut que tu supprimes /imap de ta variable $options2.
 

bardiel a écrit :


Oui.
Par contre, Orange bloque si tu n'utilises pas leur SMTP... après je n'envoie pas 200 mails par jour, juste dans les 10-15.


Normalement, ils doivent laisser sortir si tu passes par un SMTP chiffré, soit sur le port 465, soit sur le 587.

n°824269
bardiel
Debian powa !
Posté le 17-01-2015 à 18:47:21  profilanswer
 

gen2 a écrit :

Normalement, ils doivent laisser sortir si tu passes par un SMTP chiffré, soit sur le port 465, soit sur le 587.


Oui... "normalement"... après c'est l'agrume, moi ça ne marche pas.


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°824271
gen2
Posté le 17-01-2015 à 19:05:17  profilanswer
 

Par contre, c'est bizarre, quand on teste une connexion sur l'imap de laposte avec openssl, aucun certificat n'est présenté :
 

Citation :

# openssl s_client -debug -connect imap.laposte.net:993
CONNECTED(00000003)
write to 0xbd4620 [0xbd46a0] (308 bytes => 308 (0x134))
0000 - 16 03 01 01 2f 01 00 01-2b 03 03 54 ba a3 d5 80   ..../...+..T....
0010 - 2a cb 59 75 f0 41 e4 d3-0f bb b2 fe c1 b8 7e 11   *.Yu.A........~.
0020 - 91 1a c7 96 a5 f1 95 00-fc 5a 08 00 00 92 c0 30   .........Z.....0
0030 - c0 2c c0 28 c0 24 c0 14-c0 0a 00 a3 00 9f 00 6b   .,.(.$.........k
0040 - 00 6a 00 39 00 38 00 88-00 87 c0 32 c0 2e c0 2a   .j.9.8.....2...*
0050 - c0 26 c0 0f c0 05 00 9d-00 3d 00 35 00 84 c0 12   .&.......=.5....
0060 - c0 08 00 16 00 13 c0 0d-c0 03 00 0a c0 2f c0 2b   ............./.+
0070 - c0 27 c0 23 c0 13 c0 09-00 a2 00 9e 00 67 00 40   .'.#.........g.@
0080 - 00 33 00 32 00 9a 00 99-00 45 00 44 c0 31 c0 2d   .3.2.....E.D.1.-
0090 - c0 29 c0 25 c0 0e c0 04-00 9c 00 3c 00 2f 00 96   .).%.......<./..
00a0 - 00 41 c0 11 c0 07 c0 0c-c0 02 00 05 00 04 00 15   .A..............
00b0 - 00 12 00 09 00 14 00 11-00 08 00 06 00 03 00 ff   ................
00c0 - 02 01 00 00 6f 00 0b 00-04 03 00 01 02 00 0a 00   ....o...........
00d0 - 34 00 32 00 0e 00 0d 00-19 00 0b 00 0c 00 18 00   4.2.............
00e0 - 09 00 0a 00 16 00 17 00-08 00 06 00 07 00 14 00   ................
00f0 - 15 00 04 00 05 00 12 00-13 00 01 00 02 00 03 00   ................
0100 - 0f 00 10 00 11 00 23 00-00 00 0d 00 22 00 20 06   ......#.....". .
0110 - 01 06 02 06 03 05 01 05-02 05 03 04 01 04 02 04   ................
0120 - 03 03 01 03 02 03 03 02-01 02 02 02 03 01 01 00   ................
0130 - 0f 00 01 01                                       ....
read from 0xbd4620 [0xbd9c00] (7 bytes => -1 (0xFFFFFFFFFFFFFFFF))
write:errno=104
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 0 bytes and written 308 bytes
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
---


 
J'ai aussi tenté de me faire un script php pour me connecter à ma boite laposte.net, mais j'obtiens les mêmes erreurs que toi (alors que comme toi, ce même script fonctionne vers d'autres IMAP).
Je me demande si leur conf ne serait pas foireuse...


Message édité par gen2 le 17-01-2015 à 19:07:28
n°824275
francoisch​1
Posté le 17-01-2015 à 19:18:53  profilanswer
 

Sans "/novalidate-cert",
 donc avec "/ssl/notls":  
TLS/SSL failure for imap.laposte.net: SSL negotiation failed,
 
Il n'y a pas imap.
 
Francois

n°824276
francoisch​1
Posté le 17-01-2015 à 19:25:33  profilanswer
 

laposte.net a sans conteste fait des modifs il y a 2, 3 semaines mais leur webmail fonctionne.
 
Je suis très ennuyé car mes gentils utilisateurs sont tous des débutants âgés et / ou handicapés; j'aimerai leur restituer leur client de messagerie très simplifié.
 
Francois

n°824279
nnwldx
Posté le 17-01-2015 à 19:52:35  profilanswer
 

tu avais fait le test avec un client outlook, thunderbird ?

n°824299
gen2
Posté le 18-01-2015 à 00:25:45  profilanswer
 

Chez moi, ça fonctionne très bien avec Thunderbird.
Par contre, je viens de tenter une connexion depuis Rainloop (http://rainloop.net/), et le test de connexion ne passe pas.
Donc le problème vient sûrement de la Poste. Après, ça passe avec Thunderbird qui est peut être plus laxiste que la fonction imap_open de PHP.

n°824308
francoisch​1
Posté le 18-01-2015 à 09:41:16  profilanswer
 

Je vais installer thunderbird, je vous dirai.
 
Francois

n°824408
gen2
Posté le 18-01-2015 à 21:31:09  profilanswer
 

Si ça ne passait pas avec Thunderbird, ils auraient déjà eu "quelques" plaintes.
Par contre, même si le nombre de personnes accédant à leur boîte mail laposte depuis un script PHP quelconque (rainloop, roundcube, script perso...) est plus faible que celui y accédant depuis thunderbird, tu ne dois pas être le seul. C’est étrange qu’ils n’aient pas rectifié le tir.
 
Tu n’as pas eu de retour d’ailleurs à ta demande faite par mail ?

n°824409
gen2
Posté le 18-01-2015 à 21:36:18  profilanswer
 

Tiens autre chose, j’avais vu ça hier sur la page d’aide de laposte :

Citation :

Blocage des mails en provenance d'OVH
Nous constatons depuis plusieurs jours des envois massifs de mails provenant d’OVH.
 
Un dispositif technique a été mis en place pour bloquer l’ensemble des mails provenant de cette plateforme. Cette mesure vise à préserver les utilisateurs de Laposte.net de lenteurs techniques et de mails « spam ».  
Nous ré-autoriserons la réception des mails émis par OVH dès que cet hébergeur aura pris les mesures nécessaires.
 
Nous regrettons cette situation indépendante de notre volonté.
 
L'équipe Laposte.net


 
Ton script PHP est hébergé où ?
Le test que j’ai fait hier a été réalisé depuis un serveur OVH, mais là tout de suite, je ne peux pas tester d’une autre plate-forme.

n°824417
gen2
Posté le 18-01-2015 à 22:11:52  profilanswer
 

Bon je viens de tenter depuis un serveur chez 1&1 et ça passe.
Donc j’en conclus que tu es hébergé chez OVH.
 
D’après ce ticket http://travaux.ovh.net/?do=details&id=12370, il ne devrait plus y avoir de blocage mais visiblement, ce n’est pas le cas.
Essaie de contacter le support OVH qui sera peut être plus rapide que celui de laposte pour avoir plus d’infos sur la situation.

n°824439
francoisch​1
Posté le 19-01-2015 à 09:38:53  profilanswer
 

Merci de ces infos précieuse, je vais solliciter le support OVH où est hébergé mon client.
 
Francois


Message édité par francoisch1 le 19-01-2015 à 09:55:19
n°824445
bardiel
Debian powa !
Posté le 19-01-2015 à 11:14:38  profilanswer
 

Sauf qu'il s'agit de la partie "lecture", par IMAP. Pas "l'envoie" par SMTP.
ça serait tout de même étonnant qu'ils aient aussi bloqué cette partie :lol:


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°824586
francoisch​1
Posté le 19-01-2015 à 21:20:47  profilanswer
 

Juste reçu de la poste:
"Vous avez repris contact avec le Service Client Laposte.net concernant un problème d’envoi et/ou de réception de mails provenant d’OVH.
Un dispositif technique a été mis en place pour bloquer l’ensemble des mails provenant de cette plateforme. Cette mesure vise à préserver les utilisateurs de Laposte.net de lenteurs techniques et de mails « spam ».
 
Nous ré-autoriserons la réception des mails émis par OVH dès que cet hébergeur aura pris les mesures nécessaires.
 
Nous regrettons cette situation indépendante de notre volonté et vous remercions de votre compréhension"

n°824667
gen2
Posté le 20-01-2015 à 15:53:55  profilanswer
 

bardiel a écrit :

Sauf qu'il s'agit de la partie "lecture", par IMAP. Pas "l'envoie" par SMTP.
ça serait tout de même étonnant qu'ils aient aussi bloqué cette partie :lol:


Justement, depuis un serveur OVH, l'accès au SMTP laposte est possible, pas l'IMAP.
Depuis un serveur 1&1 avec exactement le même script, les 2 serveurs répondent.
Donc il y a un blocage côté laposte.
 
Ils ont peut être réouvert leur accès SMTP et oublié de réouvrir l'accès IMAP  :??:

n°824697
francoisch​1
Posté le 20-01-2015 à 17:28:59  profilanswer
 

Pop et Imap restent bloqués par la poste.
 
Francois

n°824699
bardiel
Debian powa !
Posté le 20-01-2015 à 17:46:32  profilanswer
 

Donc ça parle côté LaPoste de "spam massif" côté OVH, mais... c'est en envoi. L'IMAP c'est le côté réception. Pas clair leur histoire, mais au moins ça "résout" le problème de francoisch1 :pt1cable:


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°824709
francoisch​1
Posté le 20-01-2015 à 18:31:01  profilanswer
 

Problème identifié mais pas résolu.

n°824711
nnwldx
Posté le 20-01-2015 à 18:34:17  profilanswer
 

Tu pourrais donner des détails de ton installation ?

n°824725
francoisch​1
Posté le 20-01-2015 à 19:33:42  profilanswer
 

Que veux tu savoir en plus de ce que je disais tout au début?

n°824733
nnwldx
Posté le 20-01-2015 à 19:55:53  profilanswer
 

Quel est le rôle de ton client, est ce un client comme outlook, thunderbird ?
Est ce que c'est script est executé chez toi ou est il hébergé sur un serveur de chez OVH ?
Si il est sur un serveur pourquoi poper les messages, pourquoi les utilisateurs ne se connectent ils pas directement sur le site la poste ?

n°824766
gen2
Posté le 20-01-2015 à 22:16:50  profilanswer
 

Tout est expliqué plus haut, il est hébergé chez OVH.
Et son client mail s'adresse à des personnes âgées ou handicapées qui maîtrisent mal l'informatique.
Je suppose donc qu'il s'agit d'une interface adaptée et simplifiée.

n°824808
francoisch​1
Posté le 21-01-2015 à 10:06:30  profilanswer
 

Un coup d'oeil à  
www.a4p.fr/esp1/martinot/
La messagerie
Lecture simplifiée
 
Francois


Message édité par francoisch1 le 21-01-2015 à 14:55:56
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Accès POP, IMAP à La Poste

 

Sujets relatifs
Acceder à mon routeur depuis internetProbleme acces internet sur PC carte wifi et ethernet actives
Comment fonctionne le multi poste avec un seul modemFreeBox V6 et second pont d'accès
Config Point accès CISICO WAP4410NAccès à mon serveur Windows perso depuis l'extérieur
[AIDE] Extension réseau avec un point d'accèsProbleme Prises reseaux pour acces internet
Accès public à un dossierChoix d'un équipement LAN et point d'accés Wifi
Plus de sujets relatifs à : Accès POP, IMAP à La Poste


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR