Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1806 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  Auto-hébergement et déconnexions surprenantes

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Auto-hébergement et déconnexions surprenantes

n°553051
apophyys
Posté le 28-11-2011 à 21:34:09  profilanswer
 

Bonsoir à vous,
 
J'ai créé un petit site familial et je souhaite l'héberger. Avant de passer à une solution "serveur dédié" plus tard, je souhaiterai d'abord l'héberger sur mon propre PC histoire de bien comprendre déjà le mécanisme de l'hébergement. Mon site n'a pas de nom de domaine (pour le moment, ce n'est pas dérangeant, je suis juste dans une phase d'essai).
 
Ce que je veux : pouvoir y accéder depuis n'importe quel PC connecté au net en rentrant seulement l'adresse IP. Normalement c'est bien possible non?  :D  
 
Donc je me suis renseigné, j'ai installé le package WAMP (Windows pour le moment, à terme ce sera sur Linux) et commencé à chercher pas mal sur le net pour comprendre le truc.
 
Ma situation : 2 PC connectés en wi-fi sur une Freebox V6, configurée en routeur et redirection du port 80 effectuée. Le PC 1 fait office de serveur, le PC 2 fait office de PC "extérieur".
 
Je peux me connecter via le PC 2 au site web mis sur le serveur (PC 1) en rentrant l'IP publique (de la Freebox) dans un navigateur qui me redirige correctement vers mon site. Cependant, cette connexion est interrompue au bout de quelques secondes. Le serveur WAMP se met hors-ligne pour une raison que j'ignore.
 
Je vous mets les log error et access d'Apache.
 

  • Error log
Spoiler :

[Mon Nov 28 21:21:07 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Nov 28 21:21:07 2011] [notice] Child 3744: Exit event signaled. Child process is ending.
[Mon Nov 28 21:21:08 2011] [notice] Child 3744: Released the start mutex
[Mon Nov 28 21:21:09 2011] [notice] Child 3744: All worker threads have exited.
[Mon Nov 28 21:21:09 2011] [notice] Child 3744: Child process is exiting
[Mon Nov 28 21:21:09 2011] [notice] Parent: Child process exited successfully.
[Mon Nov 28 21:21:12 2011] [notice] Apache/2.2.21 (Win32) PHP/5.3.8 configured -- resuming normal operations
[Mon Nov 28 21:21:12 2011] [notice] Server built: Sep 10 2011 11:34:11
[Mon Nov 28 21:21:12 2011] [notice] Parent: Created child process 3280
[Mon Nov 28 21:21:13 2011] [notice] Child 3280: Child process is running
[Mon Nov 28 21:21:13 2011] [notice] Child 3280: Acquired the start mutex.
[Mon Nov 28 21:21:13 2011] [notice] Child 3280: Starting 64 worker threads.
[Mon Nov 28 21:21:13 2011] [notice] Child 3280: Starting thread to listen on port 80.
[Mon Nov 28 21:21:13 2011] [notice] Child 3280: Starting thread to listen on port 80.
[Mon Nov 28 21:21:40 2011] [error] [client 192.168.0.254] File does not exist: C:/wamp/www/tests/SiteWeb/images/printer.gif, referer: http://monippublique/comment_venir.php
[Mon Nov 28 21:21:42 2011] [error] [client 192.168.0.254] File does not exist: C:/wamp/www/tests/SiteWeb/images/printer.gif, referer: http://monippublique/comment_venir.php
[Mon Nov 28 21:22:19 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Nov 28 21:22:19 2011] [notice] Child 3280: Exit event signaled. Child process is ending.
[Mon Nov 28 21:22:20 2011] [notice] Child 3280: Released the start mutex
[Mon Nov 28 21:22:21 2011] [notice] Child 3280: All worker threads have exited.
[Mon Nov 28 21:22:21 2011] [notice] Child 3280: Child process is exiting
[Mon Nov 28 21:22:21 2011] [notice] Parent: Child process exited successfully.
[Mon Nov 28 21:22:25 2011] [notice] Apache/2.2.21 (Win32) PHP/5.3.8 configured -- resuming normal operations
[Mon Nov 28 21:22:25 2011] [notice] Server built: Sep 10 2011 11:34:11
[Mon Nov 28 21:22:25 2011] [notice] Parent: Created child process 5384
[Mon Nov 28 21:22:26 2011] [notice] Child 5384: Child process is running
[Mon Nov 28 21:22:26 2011] [notice] Child 5384: Acquired the start mutex.
[Mon Nov 28 21:22:26 2011] [notice] Child 5384: Starting 64 worker threads.
[Mon Nov 28 21:22:26 2011] [notice] Child 5384: Starting thread to listen on port 80.
[Mon Nov 28 21:22:26 2011] [notice] Child 5384: Starting thread to listen on port 80.


 

  • Access log
Spoiler :

192.168.0.254 - - [28/Nov/2011:21:21:34 +0100] "GET /accueil.php HTTP/1.1" 200 2450
192.168.0.254 - - [28/Nov/2011:21:21:36 +0100] "GET /ferme_kerseach.php HTTP/1.1" 200 1846
192.168.0.254 - - [28/Nov/2011:21:21:38 +0100] "GET /fouesnant_region.php HTTP/1.1" 200 5707
192.168.0.254 - - [28/Nov/2011:21:21:40 +0100] "GET /comment_venir.php HTTP/1.1" 200 9430
192.168.0.254 - - [28/Nov/2011:21:21:40 +0100] "GET /images/printer.gif HTTP/1.1" 404 216
192.168.0.254 - - [28/Nov/2011:21:21:42 +0100] "GET /images/printer.gif HTTP/1.1" 404 216
192.168.0.254 - - [28/Nov/2011:21:21:43 +0100] "GET /contact_reservation.php HTTP/1.1" 200 9416
192.168.0.254 - - [28/Nov/2011:21:22:31 +0100] "GET /maison_a_louer.php HTTP/1.1" 200 2831


 
Avez-vous une idée d'où peut provenir le problème ? La solution est peut-être flagrante, auquel cas je tiens à m'excuser par avance. Cependant, je pars de 0 sur tout ce qui est création de site et hébergement, mais vu ma p'tite période de temps libre forcée, je la mets à profit pour apprendre tout ça ! Dans la plus grande humilité !
 
Je vous remercie pour votre aide.
 
(Windows 7, WAMPserver 2.2)

mood
Publicité
Posté le 28-11-2011 à 21:34:09  profilanswer
 

n°553054
Misssardon​ik
prévisible a posteriori
Posté le 28-11-2011 à 21:47:15  profilanswer
 

il y a un problème avec ton installation WAMP.
 
Est-ce que si tu ne tentes pas d'y accéder Apache finit quand même par planter ?


---------------
Que va-t-il se passer cette gelgamar ? vous le découvrirez janamont à 20h
n°553062
apophyys
Posté le 28-11-2011 à 23:02:09  profilanswer
 

Hmm, non je n'ai pas l'impression étant donné que quand je codais en php, j'actualisais mes pages très très souvent.

n°553121
apophyys
Posté le 29-11-2011 à 12:16:47  profilanswer
 

J'ai réinstallé WAMP suite à ta remarque Misssardonik. Mais, même résultat. Je suis obligé de relancer les services pour pouvoir réaccéder à mon site.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  Auto-hébergement et déconnexions surprenantes

 

Sujets relatifs
Multidomaines avec 1 hébergement"deconnexions" suspectes du hot spot
Déconnexions intempestives Windows 7Diriger domaine Directnom vers hébergement 1and1
Hébergement internationalEmpêcher la connexion auto aux lecteurs reseau NAS
Hébergement pour un blog wordpress ?Cherche hébergement Emails
Choix registrar pour auto-hébergement 
Plus de sujets relatifs à : Auto-hébergement et déconnexions surprenantes


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR