Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
460 connectés 

  FORUM HardWare.fr
  Windows & Software

  Windows 2k Server - Faire un routeur...

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Windows 2k Server - Faire un routeur...

n°618199
k1200
Posté le 25-03-2002 à 14:12:09  profilanswer
 

J'ai un Win2k server doit faire routeur entre un modem ADSL Zyxel 642ME et un intranet...
 
Sur le serveur j'ai 2 catre ethernet: une pour le modem et une pour l'intranet.
 
L'intranet fonctionne nickel, le serveur fait serveur DNS et DHCP et est la racine de mon domaine.
 
J'arrive bien a avoir le net sur le serveur mais impossible sur les clients...
 
J'ai utiliser la methode decrite sur ce site: http://perso.wanadoo.fr/windows2000/NAT.htm
 
Mais le net sur les client ne fonctionne pas... mais le dns a l'air de marcher (quand je tappe une adresse dans IE sur un client il me trouve bien l'adresse ip mais ne va pas plus loin...)
 
Je presise que le Zyxel est une sorte de router: on le configure depuis une page web en lui donnant le logon et le pass de la connexion et il n'y a rien a faire sur le pc pour ce connecter (pas besoin de protocole PPPoE).
 
J'ai activer le DNS forward sur le serveur DNS...
 
Si vous avez une idee de pourquoi ca ne marche pas... je suis proneur... autrement j'essayerais d'utiliser Winroute Pro mais je cherchais une solution gratuite...
 
Config du serveur
Carte -> modem:
ip: 192.168.1.2
masque: 255.255.255.248 (modem limiter a 4 postes)
passerel: 192.168.1.1 (modem)
DNS: 192.168.1.1 (modem)
 
Carte -> intranet
ip: 192.168.0.1
masque: 255.255.255.0
passerel: rien
DNS: 127.0.0.1
 
PC Client:
ip: 192.168.0.x
Masque: 255.255.255.0
Passerel: 192.168.0.1
DNS: 192.168.0.1

mood
Publicité
Posté le 25-03-2002 à 14:12:09  profilanswer
 

n°618208
serpent_49​fr
Posté le 25-03-2002 à 14:20:18  profilanswer
 

salut !!
 
bon, deja si tu veux faire un routeur il te faut 2 ip de classe differente, se sera mieux.
perso j'ai mis 10.10.1.1 sur la carte qui va vers le modem et 192.168.1.1 sur la carte de l'intranet.
ensuite, tu refais bien ton routage entre les deux carte.
 
sur le poste client tu mets l'ip 192.168.1.x passerelle : 192.168.1.1 (adresse intranet du serveur)
en DNS il faut mettre l'adresse DNS de ton fournisseur d'acces, par exemple 193.252.19.3 pour wanadoo.
 
le serveur DNS que tu as configuré sur ton serveur sert uniquement de DNS pour l'intranet et non pas pour internet.
 
voila, ca devrait fonctionner, si ca marche toujours pas, demande moi.
 
serpent49

n°618226
k1200
Posté le 25-03-2002 à 14:52:00  profilanswer
 

serpent_49fr a écrit a écrit :

salut !!
 
bon, deja si tu veux faire un routeur il te faut 2 ip de classe differente, se sera mieux.
perso j'ai mis 10.10.1.1 sur la carte qui va vers le modem et 192.168.1.1 sur la carte de l'intranet.
ensuite, tu refais bien ton routage entre les deux carte.



J'ai deja 2 resaux different: 192.168.0.x et 192.168.1.x
 

serpent_49fr a écrit a écrit :

 
sur le poste client tu mets l'ip 192.168.1.x passerelle : 192.168.1.1 (adresse intranet du serveur)
en DNS il faut mettre l'adresse DNS de ton fournisseur d'acces, par exemple 193.252.19.3 pour wanadoo.
 
le serveur DNS que tu as configuré sur ton serveur sert uniquement de DNS pour l'intranet et non pas pour internet.




J'essayerais de mettre les DNS de mon provider ce soir...
 

serpent_49fr a écrit a écrit :

 
voila, ca devrait fonctionner, si ca marche toujours pas, demande moi.
 
serpent49  




 
Encore merci

 

[jfdsdjhfuetppo]--Message édité par k1200--[/jfdsdjhfuetppo]

n°618246
serpent_49​fr
Posté le 25-03-2002 à 15:07:30  profilanswer
 

oups, ha oui, effectivement, j'avais pas vu es deux reseaux ;o)

n°618254
k1200
Posté le 25-03-2002 à 15:14:14  profilanswer
 

Je viens de penser a un truc...
 
Les DNS fonctionne tres bien meme sur les client vu que quand je ping une adresse au azzard, il trouve bien l'adresse IP mais il n'arrive pas a recevoire des donnees... C'est bien le routage qui foire...
 
Il faut que je configure mon serveur de facon a relier 2 resaux ensemble et non pas faire un partage de connextion... Vu que mon modem est vu comme un routeur sur le resaux...
 
Si je branche le modem sur mon hub et que je lui donne une adresse IP du resau ca fonctionne, tout les pc on le net mais ce n'ai pas du tout securiser...
 
C'est pour ca que je veux le mettre sur le serveur et utiliser apres un firewall (comme Zone Alarm) pour filtrer les acces au net...

n°618471
Jef34
Je ferai mieux demain
Posté le 25-03-2002 à 18:03:06  profilanswer
 

Tu suis là méthode ici : http://www.adsl-facile.com/Dossier [...] ssierID=15
 
Si tu l'as déjà fait, il suffit de rajouter les DNS de Wanadoo ou autre sur ton server DNS.
 
En effet, le server DNS va tenter de résoudre tous les nom en ip, mais ne pourra pas résoudre ceux d'internet bien sur.
 
Sous tu ajoutes manuellement les DNS de Wanadoo dans ton server DHCP :
Liste de DNS :
TONDNSINTERNE 192.168.0.1
DNSWANADOO 1 :193.252.19.3
DNSWANADOO 2 :193.252.19.4
 
 
Soit tu actives le redirecteur DNS (ce qui fait à mon avis un peu plus professionel) :
 
Donc il te faut activer le redirecteur DNS.
1. S'il existe une zone "." c'est du au fait que ton serveur DNS se considère comme un serveur root. Cela arrive lors de l'installation quand aucun serveur DNS n'est configuré sur l'interface réseau de la machine.
 
Supprimer cette zone, changera le comportement de ton serveur DNS qui pourra alors utiliser les redirecteurs. C'est la seule incidence.  
 
2.Dans l'interface d'administration du service DNS, tu fais un clic droit sur le nom de ton serveur, puis propriétés. Dans la fenêtre qui s'ouvre tu choisis l'onglet "redirecteurs / forwarders". Dans cet onglet tu actives l'utilisation des redirecteurs (case à cocher) puis tu indiques le adresses IP des DNS de ton FAI.
 
PS : J'ai la meme configuration Réseau que toi :
Win2k Server qui partage par Routage une connection ADSL.
CR interne : 10.10.1.1
CR externe : 192.168.0.1 sur modem ADSL
DHCP : Plage 10.0.0.3-10.0.0.255
DNS : 10.10.1.1
WINS : 10.10.1.1
Routeur : 10.10.1.1

 

[jfdsdjhfuetppo]--Message édité par Jef34--[/jfdsdjhfuetppo]

n°619958
k1200
Posté le 26-03-2002 à 19:41:35  profilanswer
 

Ja'i deja activer le redireceur DNS comme toi...
 
Mais le probleme est toujours la... depuis les client je trouve les IP externe mais il ne transfere pas les données des pages (le ping ne marche pas non plus)...
 
J'utilise un Modem Zyxel 642ME et j'ai pas de numero de telephone ou de login a faire pour me connecter au net... c'est le modem une fois configurer qui s'occupe de tout... et je crois que le probleme vient de la... Windows cherche a se loger sur le modem pour se connecter mais comme il n'y a pas besoin ca ne fonctionne pas...

n°619970
proner78
Posté le 26-03-2002 à 19:52:48  profilanswer
 

Ben en fait C la translation d'adresse qui ne fonctionne pas!!!
 
Tu dis que tu ne reçois pas de donnée, mais tu dis que si tu ping une adresse exterieur depuis un poste client tu vois bien son adresse IP. Il y a donc bien eu résolution d'adresse par ton DNS, donc pas de problème avec l'intranet.
 
Par contre je pense que (comme ton réseau à l'air bien configuré) que les paquets ICMP de ton ping reste reste bloqué au retour.
 
Il faudrait que tu puisses regarder ton traffic entrant et sortant sur ton serveur. Tu verras surement tes packet ICMP sortir et revenir mais rester bloqué.

n°620014
k1200
Posté le 26-03-2002 à 20:37:36  profilanswer
 

Oui mes DNS fonctionne bien... mais quand je ping la led du modem fait un leger sursaut puis rien... genre juste l'adresse ip qui passe... parce que quand je ping depuis le serveur la led clignottes bcp plus...

n°620391
k1200
Posté le 27-03-2002 à 08:26:47  profilanswer
 

up please...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software

  Windows 2k Server - Faire un routeur...

 

Sujets relatifs
Problèmes avec Office XP évaluation 30 jours sous Windows MEADLS et Windows NT 4.0 impossible???
Routeur - Table de routage : J'ai besoin d'un profDésactiver la touche NumLock à l'arrêt de Windows
Patch MP3 et DVD pour windows media player[HELP]Config Firewall (Routeur)
[Windows XP - NTFS ] C bien de faire la 1ère partcoh en NTFS ?Routeur ou Linux ?
comment del qqch du demarage de windows xp?? erreur protection windows ??
Plus de sujets relatifs à : Windows 2k Server - Faire un routeur...


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR