Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1905 connectés 

  FORUM HardWare.fr
  Windows & Software
  Win 10

  Réinstallation W10 sur SSD mais erreur winload.efi

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Réinstallation W10 sur SSD mais erreur winload.efi

n°3389922
thesparrow​gam3r
Posté le 02-01-2021 à 17:32:22  profilanswer
 

Bien le bonsoir!

 

Je viens vers vous pour un souci embêtant.
Je dois réinstaller windows (faire une clean install) sur un sdd, car je suis actuellement sous HDD.

 

J'ai donc fait une save de mes fichirs sensibles sur une clé autre.
J'ai ensuite pris une clé USB de 16go où j'ai placé l'installation de win10 grâce à leur outil. D'ailleurs elle a prit le nom de "ESD-USB" maintenant.
J'ai ensuite redémarré avec une priorité sur cette clé (je n'ai rien formaté nul part)
J'ai suivis les étapes d'installation (langue), puis j'ai sélectionné le SSD dans les disques où installer Win10 (il y a pas mal de partitions venues je crois de mon HDD)
Problème, lors du redémarrage où je suis censé découvrir mon bureau = écran bleu --> erreur 0x je sais plus combien avec "Winload.efi manquant". (je n'ai pas touché à la clé USB booté une seule fois après que l'outil d'installation windows ait fait son boulot.

 

J'ai dû alors retenter une installation = marche pas.
Je me suis crée donc 2 windows qui veulent pas démarrer à cause de ce winload.efi sur le ssd. Donc j'ai restauré mon HDD, tout récupéré et j'ai pu reprendre contrôle de mon bébé, mais pas sur mon SSD que j'ai formaté au complet, donc de nouveau vierge.

 

Ma question est alors = où ai-je merdé ? Je n'ai fais rien de plus que ce que je vous ai marqué, l'outil de réparation windows ne semblait pas fonctionner non plus lors de l'écran bleu. C'est comme si le démarrage à partir du SSD n'était pas possible, c'est un SSD Samsung 860EVO 500Go tout fraîchement sortit de son emballage, vierge.
Mon PC date de 2013 et est je pense bien en BIOS (edit: rectification c'est de l'UEFI). SSD pourtant reconnu par mon BIOS actuellement.

 

Un merci d'avance à celui qui me sauvera, sur le net tout est flou ou alors les sujets ne donnent pas la solution  :sweat:


Message édité par thesparrowgam3r le 02-01-2021 à 17:45:20
mood
Publicité
Posté le 02-01-2021 à 17:32:22  profilanswer
 

n°3389923
loriot83
Posté le 02-01-2021 à 17:47:26  profilanswer
 

Bonjour,
 
Ton installation avec hdd est bios ou uefi , un msinfo32 dans éxécuter te donnera l'information ligne mode bios .
Si ssd initialisé MBR install en mode bios hérité (legacy), si GPT installation en UEFI.
Lors de ton installation tu ne dois laisser que le ssd de connecté .
Sinon une capture écran de la gestion des disques pour info.
 
Tu confirmes l'UEFI , ok dans ce cas ton ssd est certainement initialisé en MBR et l'installation s'est faite pour mode BIOS,
 
regarde au niveau gestion des disques par un clic droit sur l'icone du disque si tu peux le convertir en GPT , si oui c'est qu'il est initialisé MBR,
 
passe le en GPT .


Message édité par loriot83 le 02-01-2021 à 18:00:14
n°3389924
thesparrow​gam3r
Posté le 02-01-2021 à 17:58:50  profilanswer
 

Après vérification c'est de l'UEFI
Théoriquement mon SSD est en GPT. Que veut donc dire installation en UEFI ?
Je laisserai le SSD uniquement lors de mon prochain essai, retenu. Ai-je besoin de formater quoi que ce soit sur mon HDD avant ? Ne serait-ce que quand je le rebrancherai ?

 

Et la petite capture bonus : https://www.zupimages.net/viewer.php?id=21/53/n1ij.png

 

EDIT : j'ajoute, nécessaire de désactiver le secure boot ? je ne l'ai pas fais auparavant.


Message édité par thesparrowgam3r le 02-01-2021 à 18:01:09
n°3389925
loriot83
Posté le 02-01-2021 à 18:14:20  profilanswer
 

Apparemment tu es bien en GPT sur le ssd, supprime le volume sur le ssd et recommence ton installation ssd en solo, pour le secure boot si la clef  
 
démarre  sans message d'erreur sécu c'est bon , tu peux essayer sans pour test.
 
Ne touche pas au hdd son windows étant  ok .


Message édité par loriot83 le 02-01-2021 à 18:16:40
n°3389928
thesparrow​gam3r
Posté le 02-01-2021 à 18:43:16  profilanswer
 

En supprimant le volume, ça me dit que l'ordre des partitions n'est pas recommandée, qu'il faut que le disque soit en NS(truc machin j'ai pas retenu), donc j'ai rebooté pour recréer le volume du SSD. Parce que sinon win10 ne pouvait y être installé.

 

Problème maintenant, c'est que windows ne peut pas s'installer sur le SSD car (je me souviens plus, je me déteste mon portable n'a pas save la photo), en gros il faut se référer au journal d'installation, mais ça me marque que la partition ne peut pas recevoir l'installation quoi (il n'y avait que celle-ci et celle réservée au MSR si je ne me trompe pas d'acronyme)


Message édité par thesparrowgam3r le 02-01-2021 à 18:43:33
n°3389929
loriot83
Posté le 02-01-2021 à 18:48:16  profilanswer
 

Tu peux poster une capture écran gestion des disques avec le ssd devant supporter la nouvelle installation car sur ta 1 ere capture je pense que ce n'est pas le bon (espace de stockage )


Message édité par loriot83 le 02-01-2021 à 18:51:16
n°3389930
Mobilis In​ Mobile
Posté le 02-01-2021 à 18:48:27  profilanswer
 

Il faut installer Windows directement sur l'espace non alloué du SSD, sans créer aucune partition avant !
 
Donc si tu as créé des partitions sur ton SSD lors de tes précédentes tentatives, il faut tout supprimer  
 
https://i1.wp.com/images.frandroid.com/wp-content/uploads/2019/10/screen-installer-5.png?ssl=1
 
En gros quand tu auras ça sur ton écran c'est bon, tu cliques sur suivant ( ne tient pas compte de la valeur de 50 Go, toi tu auras une valeur équivalente à la taille de ton SSD )


Message édité par Mobilis In Mobile le 02-01-2021 à 18:50:50

---------------
J'avais cessé de croire en dieu Je croyais en moi faute de mieux
n°3389931
thesparrow​gam3r
Posté le 02-01-2021 à 18:50:47  profilanswer
 

Ah mea culpa donc sur cet écran, je dois absolument tout supprimer ? J'aurais au moins un endroit où cliquer pour sélectionner l'installation de windows ?  :wahoo:  
 
parce que il y avait sur cet écran le SSD alloué donc, + une petite partie réservée je suppose par l'os, je la supprime également ?

n°3389932
Mobilis In​ Mobile
Posté le 02-01-2021 à 18:51:43  profilanswer
 

thesparrowgam3r a écrit :

Ah mea culpa donc sur cet écran, je dois absolument tout supprimer ? J'aurais au moins un endroit où cliquer pour sélectionner l'installation de windows ?  :wahoo:  
 
parce que il y avait sur cet écran le SSD alloué donc, + une petite partie réservée je suppose par l'os, je la supprime également ?


 
Oui tu supprimes tout, et tu lances l’installation depuis le secteur non alloué qui reste. W10 fait ses partitions tout seul comme un grand.


---------------
J'avais cessé de croire en dieu Je croyais en moi faute de mieux
n°3389937
thesparrow​gam3r
Posté le 02-01-2021 à 19:44:33  profilanswer
 

Bon j'avance mais je reste confus.

 

J'ai tout fait comme demandé, tout supprimé et cette fois winload.efi n'est plus un problème (+ j'ai désac le secure boot)
Mais nouveau problème = Windows 10 s'installe bien sur le SSD, sauf qu'il ne le lance pas. Il ne cesse de démarrer en route pour réinstaller l'OS encore et encore, comme s'il n'y avait pas d'OS déjà installé.

 

Sauf que je vois bien en remettant mon HDD que sur le SSD, windows est bien là ! bien installé avec tous ses dossiers ! Mais impossible de lancer et d'arriver sur le bureau avec seulement le SSD ...
J'ai tenté avec et sans la clé USB :
sans = bond dans le BIOS directement
avec = écran d'installation windows et tout ce qui s'ensuit en boucle
Je vous mets quelques captures au cas où de mon BIOS si besoin.
https://zupimages.net/viewer.php?id=21/53/cavc.jpg (les disques sans le HDD)
https://zupimages.net/up/21/53/ee8b.jpg (La clé n'est pas bootée en priorité à ce moment, le Hard diskest censé être je pense le SSD ? sinon il n'y est pas.)
https://zupimages.net/up/21/53/z5bi.jpg
https://www.zupimages.net/viewer.php?id=21/53/no7d.jpg comme demandé, je fais suivant à ce moment là.
https://www.zupimages.net/viewer.php?id=21/53/sjw8.jpg Ici la résolution / analyse n'a rien réparé lorsque je l'ai demandé.

 

EDIT: en regardant le fichier SrtTrail.txt, voilà ce que j'observe : https://www.zupimages.net/viewer.php?id=21/53/npei.png


Message édité par thesparrowgam3r le 02-01-2021 à 20:08:27
mood
Publicité
Posté le 02-01-2021 à 19:44:33  profilanswer
 

n°3389943
thesparrow​gam3r
Posté le 03-01-2021 à 02:03:15  profilanswer
 

Bon à force d'essayer, je pense avoir détruit mon Windows  :bounce:  
Littéralement, au point de ne plus pouvoir chopper de point de sauvegarde. Je vous épargne les 4 heures d'essais pour toute réparation en tout genre.
 
J'ai finis par réinstaller windows sur mon HDD (dieu merci j'avais mes saves sensibles ailleurs) et je garde mon SSD en stockage, il est trop têtu, j'ai bien cru perdre mon cher PC définitivement trop de fois pour m'entêter à nouveau. Sauf si quelqu'un sait clair et net où est le souci.  
 

n°3389948
nex84
Dura lex, sed lex
Posté le 03-01-2021 à 09:28:41  profilanswer
 

Vérifie que ta clé d'installation n'est pas corrompue ou refait la.
 
Par contre je ne vois pas pourquoi tes disques sont en mode "external".


---------------
#TeamNoBidouille || Come to the Dark Side, we have cookies || Mangez 5 fruits et légumes par an ! || Le digital, c'est les doigts
n°3389958
thesparrow​gam3r
Posté le 03-01-2021 à 14:20:47  profilanswer
 

C'est censé être marqué internal ?  
J'ai changé les ports 1 et 2 hier, ça n'avait rien changé non plus.

n°3389959
loriot83
Posté le 03-01-2021 à 15:00:12  profilanswer
 

Maintenant que tu as réinstallé w10 sur ton hdd tu as toujours la possibilité de cloner ton hdd sur le ssd but initial de ton sujet.


Message édité par loriot83 le 03-01-2021 à 15:00:28
n°3389961
thesparrow​gam3r
Posté le 03-01-2021 à 15:44:21  profilanswer
 

Mais ne me retrouverai-je pas encore avec un souci de démarrage à nouveau ? Ou bien est-ce plus sûr que la situation précédente ?
+ il faudrait que le SSD soit vierge à nouveau pour cloner dessus ? (parce que je n'ai pas manqué de temps pour installer des logiciels dessus actuellement)

Message cité 1 fois
Message édité par thesparrowgam3r le 03-01-2021 à 15:52:54
n°3389963
loriot83
Posté le 03-01-2021 à 15:57:48  profilanswer
 

Le fait de cloner ton hdd ne modifie en rien le contenu du hdd, tu pourras toujoours démarrer sur celui-ci si le clonage sur ssd échoue.
 
Le clonage terminé il faudra simplement aller dans le bios uefi pour lui indiquer le disque que tu veux démarrer en priorité lors du prochain boot.
 
un tutoriel pour clonage si tu l'envisages :
 
https://www.malekal.com/comment-cloner-son-disque-dur/
 
Ma préférence pour Macrium reflect.


Message édité par loriot83 le 03-01-2021 à 15:58:17
n°3389964
loriot83
Posté le 03-01-2021 à 16:09:57  profilanswer
 

thesparrowgam3r a écrit :


+ il faudrait que le SSD soit vierge à nouveau pour cloner dessus ? (parce que je n'ai pas manqué de temps pour installer des logiciels dessus actuellement)


 
Là c'est sûr qu'il faudra des manips supplémentaires pour isoler ta partition contenant tes logiciels en fin de volume ssd avec un logiciel tiers et garder la lettre et le nom de  
partition pour conserver le chemin de tes applications dans windows .
 
Il faut également que tu aies assez de place sur ssd pour transférer ton w10 fraichement installé , ta toute première capture indiquait un windows qui dépassait le téra octets .
 

n°3389965
thesparrow​gam3r
Posté le 03-01-2021 à 16:18:14  profilanswer
 

Disons que là maintenant, ce ne sont que quelques gigas posés dans le SSD, le HDD n'a que 70go utilisé sur les 1to
Donc je peux encore formater le ssd si besoin à partir du gestionnaire de disques ?

n°3389967
loriot83
Posté le 03-01-2021 à 17:24:26  profilanswer
 

Ok dans ce cas c'est moins problématique , tu peux les copier sur un autre support le temps de cloner et de valider le clonage.
Oui tu peux supprimer les volumes présents sur le ssd avec la gestion des disques .

n°3389969
thesparrow​gam3r
Posté le 03-01-2021 à 17:29:34  profilanswer
 

tout est prêt, j'ai supprimé le volume du ssd dans la gestion des disques, est-ce normal qu'il y ait une "unformatted primary" dedans ?
--> https://zupimages.net/viewer.php?id=21/53/dytq.png

 

Edit : ceci apparaît lorsque je le sélectionne, je dois recréer un volume pour le ssd ? https://zupimages.net/viewer.php?id=21/53/73j1.png


Message édité par thesparrowgam3r le 03-01-2021 à 17:35:35
n°3389970
loriot83
Posté le 03-01-2021 à 17:46:52  profilanswer
 

Oui c'est normal d'avoir cette partition MSR non formatée , elle est créée automatiquement par windows sur un disque initialisé GPT.
 
Par contre sur un disque avec un windows présent (en efi) il  est préconisé d'avoir en première partition la partition efi et ensuite cette partition MSR comme sur ton hdd.
 
Sélectionne pour clonage la partition efi en premier sur le ssd , et ensuite la unformatted,vaalide ces deux partition pour clonage et tu passeras ensuite sur la C mais  
 
en cloned partition properties car il lui faut réduire sa taille.


Message édité par loriot83 le 03-01-2021 à 17:48:46
n°3389971
thesparrow​gam3r
Posté le 03-01-2021 à 17:51:01  profilanswer
 

Le truc c'est que je dois créer un volume simple obligatoirement, autrement seule la Unformatted Primary est sélectionnable tandis que l'autre est grisée pour le ssd

 

et par ailleurs le soucis "Incompatible disk selected" continue à apparaître, j'ai lu qu'il fallait changer le sector size ? Mon HDD en a un de 512 et le ssd de 4096


Message édité par thesparrowgam3r le 03-01-2021 à 17:53:06
n°3389972
loriot83
Posté le 03-01-2021 à 18:05:23  profilanswer
 

Dans un premier temps tu ne sélectionnes que la part fat32 en première position , tu cliques sur clone this disk en dessous , il t'es demandé de selectionner un disk destinataire ,
 
tu sélectionnes ton ssd affiché et tu cliques sur deleted existing partition en dessous, le ssd est vide , tu déplaces à la souris la première partition en cliquant dessus et  tu la places sur le ssd,
 
next pour valider et tu fais la meme chose pour la partition non formattée après l'avoir sélectionnée.
 


Message édité par loriot83 le 03-01-2021 à 18:06:37
n°3389973
thesparrow​gam3r
Posté le 03-01-2021 à 18:09:10  profilanswer
 

Instructions claires et sans soucis, mais comme sur le screen plus haut "The target disk has an incompatible sector size for this operation. Please Choose a different disk" apparaît à nouveau, ça rend l'opération impossible.


Message édité par thesparrowgam3r le 03-01-2021 à 18:13:20
n°3389974
loriot83
Posté le 03-01-2021 à 18:18:18  profilanswer
 

Effectivement ça coince :
 
http://translate.google.com/transl [...] 50193.aspx


Message édité par loriot83 le 03-01-2021 à 18:18:37
n°3389975
thesparrow​gam3r
Posté le 03-01-2021 à 18:23:51  profilanswer
 

Oui j'ai vu cette page.
Certains préconisent un changement de "sector size" manuellement avec un logiciel dont je n'ai plus le nom.
Sachant que j'utilise bien du SATA et non USB.
 
 
Partant de cela, j'ai beaucoup manipulé mon PC et moi qui suis très attentif aux manipulations, j'ai bien assez torturé mon bon PC. Si tu penses qu'on bloque et que changer le sector size est bof, j'en resterai là avec mon  SSD en stockage, tu m'as déjà (et d'autres) bien aidé et je t'en suis reconnaissant ! Dans quelques années peut-être je changerai de PC et je m'assurerai d'un SSD installé par des pros, ce pc date de 7 ans parti de Boulanger alors je ne suis pas surpris des soucis de gauche à droite  :lol:  

n°3389976
loriot83
Posté le 03-01-2021 à 18:30:53  profilanswer
 

Pour l'instant jamais rencontré le problème sous macrium donc je découvre le problème, attendons l'intervention de plus expérimenté sur le sujet...


Message édité par loriot83 le 03-01-2021 à 18:31:29
n°3389977
thesparrow​gam3r
Posté le 03-01-2021 à 18:41:05  profilanswer
 

Sans faire mon ministre, j'ai déjà dépensé beaucoup de temps dans ces installations  :cry:  
Donc actuellement je replace mes logiciels sur le SSD, donc petit message à l'expert qui passerait par là, je suis ouvert aux analyses mais ne reviendrai sur ce souci qu'avec certitude qu'une solution fonctionne (c'est bien osé de dire ça quand ça concerne l'informatique  :o ). Toutes mes infos sont sur ce topic et si besoin je repasserai encore ici si d'autres détails sont demandés !  
(gracias néanmoins à vous, bonnes âmes)

n°3390140
koster
Posté le 07-01-2021 à 00:06:50  profilanswer
 

casse toi pas la tete va dans le boot menu et selectionne uefi partition 1 et voila

n°3390163
loriot83
Posté le 07-01-2021 à 12:59:57  profilanswer
 

En rejetant un oeil sur le sujet j'ai vu que tu avais essayé de cloner ton HDD vers ton SSD mais celui-ci faisait partie d'un pool de stockage que tu avais dû créer auparavant ,
 
voilà pourquoi tu n'arrives pas à cloner ton système, tu aurais dû le supprimer avant de cloner.
 
Pour info l'espace de stockage comporte bien 4096 bytes par secteurs d'où le message erreur de macrium.
 
https://nsa40.casimages.com/img/2021/01/07/210107125438611583.png
 
https://nsa40.casimages.com/img/2021/01/07/210107125438673588.png
 
Macrium annonce bien un Msft storage space pour le disk 3 et non pas les caractéristiques de ton SSD.


Message édité par loriot83 le 07-01-2021 à 13:10:08
n°3390183
thesparrow​gam3r
Posté le 07-01-2021 à 19:12:47  profilanswer
 

koster a écrit :

casse toi pas la tete va dans le boot menu et selectionne uefi partition 1 et voila

 

C'est notamment en faisant ça que tout a empiré et que j'ai dû engendrer une réinstall complète sur mon HDD, mon PC rebootait en boucle et dans les choix de boot le HDD se dupliquait (jusqu'à 7 fois) sans raison claire. +cette option apparaissait de façon irrégulière selon les démarrages, "UEFI partition1" se remplaçait fréquemment par le HDD (à moins qu'il se cachait dans une autre option de boot cachée mais mon BIOS n'a pas 200 onglets donc je ne saurais dire où)

 


Et pour Macrium, j'ai justement tenté sans le pool créée qui n'a pas fonctionné, et ensuite j'ai créée le pool avec là l'erreur enquiquinante.
Aujourd'hui j'ai pas mal d'installations sur le SSD donc tout décaler pour retenter serait embêtant, néanmoins je guetterai la première occasion pour le faire avec attention.


Message édité par thesparrowgam3r le 07-01-2021 à 19:14:20
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Win 10

  Réinstallation W10 sur SSD mais erreur winload.efi

 

Sujets relatifs
RAM W10[Résolu] Erreur Kernel Power 41 (63)
Problème stockage SSD NvmeLogiciel gratuit récupération de données sur SSD vierge
Erreur au démarrageCloner un SSD vers un SDD branché en USB
Réinstallation windows 10 avec licence Win7W10 store app pour ce forum
Code d'erreur 0xc0000185 au démarrageInstallation d'un Windows 10 propre sur un nouveau SSD (en + du HDD)
Plus de sujets relatifs à : Réinstallation W10 sur SSD mais erreur winload.efi


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR