Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2469 connectés 

  FORUM HardWare.fr
  Windows & Software
  Win NT/2K/XP

  UC à 100% dans les jeux, cas surprenant

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

UC à 100% dans les jeux, cas surprenant

n°2687229
MirageFL
Uplifted
Posté le 16-05-2007 à 21:48:44  profilanswer
 

Bonsoir à tou(te)s ! :jap:  
 
Voilà, j'espère que vous aurez le temps de tout lire car je vais essayer de détailler au mieux mon problème. ;)  
 
Je ne sais d'ailleurs pas si c'est un problème, mais c'est quand même assez bizarre :sweat:  
 
Dans certains jeux (Trackmania, UT2004, jeux PopCap Games...) je remarque souvent en quittant que la connexion au réseau sans-fil est coupée (Ce qui arrive lorsque les ressources système sont très sollicitées). Je fais donc un test en lançant le jeu et en ouvrant le gestionnaire de tâches (Ctrl Alt Suppr)
Comme il n'est pas possible de voir le jeu en même temps que le gestionnaire, je mets le jeu en mode fenêtré et je laisse le focus dessus, et je vois que le processus du jeu me pompe 100% de l'UC ! Dès lors, je ne m'étonne pas si la connexion se coupe. Lorsque je ne peux pas mettre en mode fenêtré, je lance Taskmgr avant de lancer le jeu et j'observe la courbe d'utilsation de l'UC, sans changement.
 
En revanche, lorsque je sélectionne la fenêtre du Taskmgr, ou que je réduis le jeu, les ressources de l'UC se libèrent... J'ai également essayé de baisser la priorité du processus, sans succès. J'ai aussi désactivé le son et changé les Catalyst (Passé de 7.4 à Omega 7.1).
 
Dans deux jeux PopCapGames (Des petits jeux sympas comme le Diamants d'MSN), ce problème ne se manifeste pas (Bejeweled 2 et Chuzzle), en revanche, il apparaît dans Feeding Frenzy 2. Dans Trackmania United ( :love: ), j'ai remarqué que le problème n'était PAS présent durant la phase des scans (Avant que le menu principal apparaisse, le jeu scanne tout le contenu additionnel, circuits, replays, skins...) :heink:  
 
Malgré l'UC utilisée à 100%, les jeux tournent parfaitement et sans ramer. J'avoue que je n'avais jamais vraiment fait attention à l'utilisation de l'UC, c'est la coupure désormais fréquente du wifi qui attiré mon attention.
 
Une petite précision : J'ai chopé le spyware AdobeR.exe mais je pense l'avoir entièrement supprimé (Base de registre, Kaspersky, Spybot, etc.. tout est à priori nickel) Du coup, j'ai formaté mon disque dur en mettant des sauvegardes sur un autre disque dur. :pfff:  
 
Le problème est toujours présent après formatage : le virus se serait-il transféré en douce sur le deuxième disque dur ? (Je sais qu'AdobeR est du genre à se propager sur tous les lecteurs...)
 
Honnêtement, je serais étonné, car XP tourne à 300 à l'heure, je n'ai pas remarqué le moindre ralentissement..
 
Voici ma config :
Carte mère : MSI K8N Neo 2 Platinum (Carte son Realtek A97)
Processeur : AMD Athlon 64 3200+
Carte graphique : Sapphire Radeon 9800 Pro 128Mo
Mémoire :
-2x Kingston 512Mo PC3200
-1x Générique 512Mo PC2100 (Que j'ai rajoutée récemment, je précise, je verrai ce que ça donne sans, je ne suis pas chez moi :jap: )
Disques durs :
-2x Western Digital IDE 7200 trs/min (200 + 120Go)
-1x Maxtor SATA2>USB2 7200 trs/min (300Go)
-1x Western Digital IDE>USB2 7200 trs/min (160Go)
Graveur DVD : Pioneer DVR-108
 
Vous voyez donc que la config n'est pas en cause à priori.. J'essaierai d'enlever la 3ème barrette de DDR dès demain, mais d'ici-là, n'hésitez pas à m'aider ! :hello:  
 
Voilà voilà, je pense avoir à peu près tout dit (Enfin, presque tout : Je suis déçuuuuuuu :cry:  :cry: )
 
Je vous remercie de prêter attention à ce long post, et vous souhaite une bonne soirée  :jap:

mood
Publicité
Posté le 16-05-2007 à 21:48:44  profilanswer
 

n°2687264
jerry58
Posté le 16-05-2007 à 22:49:57  profilanswer
 

Nan mais cherche pas, les jeux bouffent les ressources cpu au maximum, tout le temps! que tu possède un sempron 3000+ ou un core2d x6800, le cpu sera utilisé au max dans les jeux 3D . Il n'y a pas de soucis, c'est tout à fait normal !! c'est pour ça que le chois d'un bon processeur est important lors d'un changement de config...

n°2687328
MirageFL
Uplifted
Posté le 17-05-2007 à 11:38:28  profilanswer
 

C'est quand même étonnant que ça se produise dans un jeu PopCap qui prend 20Mo à tout péter, et non pas dans les deux autres..
Et comme je l'ai dit, c'est le fait que la connexion coupe plus souvent que d'habitude qui m'a alarmé :cry:

n°2687361
MirageFL
Uplifted
Posté le 17-05-2007 à 13:39:19  profilanswer
 

Un ami vient de tester TM avec le focus, il est entre 20 et 30% d'utilisation de l'UC. Il y a donc bien un problème ! Merci d'essayer de m'aider ;)

n°2687488
jerry58
Posté le 17-05-2007 à 19:22:55  profilanswer
 

dans le pire des cas , si tu as un doute comme celui-ci, essay de chopper un disque dur tou pourri fai une install de windows dessus et installe ce fameux jeu. si il tourne de la meme facon que chez ton ami, on aura déja ciblé un peu plus le problème étant donné qu'onn auras supprimé le doute de l'erreur matériel, en revanche si là le proc tourne toujour au taquet!! là ce sera inquiétant. Mais tu sais, souvent rien ne vaut une bonne réinstalle toute propre, c'est dingue le nombre de merde que l'on choppe sur le net

n°2687491
MirageFL
Uplifted
Posté le 17-05-2007 à 19:29:08  profilanswer
 

Logfile of HijackThis v1.99.1
Scan saved at 19:19:01, on 17/05/2007
Platform: Windows XP SP2 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)
 
Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\Explorer.EXE
C:\WINDOWS\system32\taskmgr.exe
D:\TrackMania United\TmUnited.exe
C:\Documents and Settings\-Mirage-\Bureau\Firefox\HijackThis.exe
 
R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = http://www.google.fr/ie
R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://www.google.fr
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant = http://www.google.fr/ie
R1 - HKCU\Software\Microsoft\Internet Explorer\SearchURL,(Default) = http://www.google.fr/keyword/%s
R1 - HKCU\Software\Microsoft\Internet Connection Wizard,ShellNext = http://g.msn.com/5meen_us/107?Plci [...] nspecified
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Liens
O2 - BHO: Aide pour le lien d'Adobe PDF Reader - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Fichiers communs\Adobe\Acrobat\ActiveX\AcroIEHelper.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_01\bin\ssv.dll
O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)
O2 - BHO: FDMIECookiesBHO Class - {CC59E0F9-7E43-44FA-9FAA-8377850BF205} - C:\Program Files\Free Download Manager\iefdmcks.dll
O4 - HKLM\..\Run: [TaskSwitchXP] C:\Program Files\TaskSwitchXP\TaskSwitchXP.exe
O4 - HKLM\..\Run: [Logitech Hardware Abstraction Layer] KHALMNPR.EXE
O4 - HKLM\..\Run: [AVP] "C:\Program Files\Kaspersky\avp.exe"
O4 - HKCU\..\Run: [VisualTaskTips] C:\Program Files\VisualTaskTips\VisualTaskTips.exe
O4 - Global Startup: Logitech SetPoint.lnk = ?
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_01\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Console Java (Sun) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_01\bin\ssv.dll
O9 - Extra button: Antivirus Internet - {1F460357-8A94-4D71-9CA3-AA4ACF32ED8E} - C:\Program Files\Kaspersky\scieplugin.dll
O18 - Protocol: livecall - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\MSNMES~1\MSGRAP~1.DLL
O18 - Protocol: msnim - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\MSNMES~1\MSGRAP~1.DLL
O20 - Winlogon Notify: klogon - C:\WINDOWS\system32\klogon.dll
O23 - Service: Kaspersky Anti-Virus 6.0 (AVP) - Unknown owner - C:\Program Files\Kaspersky\avp.exe" -r (file missing)
O23 - Service: Service de l'iPod (iPod Service) - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: NMIndexingService - Nero AG - C:\Program Files\Fichiers communs\Ahead\Lib\NMIndexingService.exe
O23 - Service: O&O Defrag - O&O Software GmbH - C:\WINDOWS\system32\oodag.exe
 
 
 
 
Merci de vos réponses :)
 
Voici mon log de Hijackthis.
 
Je viens de remarquer autre chose : lorsque j'ai le jeu en mode fenêtré et que je clique sur la barre de titre, les ressources proco se libèrent le temps que je maintienne le clic enfoncé (La fenêtre est toujours sélectionnée)
 
J'ai aussi essayé de voir en mode sans échec : pareil.
J'ai également vérifié les fréquences du processeur, aucun problème.

n°2687503
MirageFL
Uplifted
Posté le 17-05-2007 à 20:13:54  profilanswer
 

jerry58 a écrit :

Mais tu sais, souvent rien ne vaut une bonne réinstalle toute propre, c'est dingue le nombre de merde que l'on choppe sur le net


 
C'est déjà fait :cry: C'est pour ça que je pensais à AdobeR.exe qui se propageait d'un DD à l'autre (Vu que j'ai dû faire des sauvegardes)
 
A la limite en gravant les données, il ne copierait pas de saloperies ? Moi j'veux bien, mais avec 80Go de saves.... :heink:

n°2687514
Requin
Posté le 17-05-2007 à 21:21:41  profilanswer
 

Pour les jeux il est normal qu'un jeu utilise le maximum de cycles CPU à sa disposition. Le but étant quand même d'être le plus fluide possible dans l'animation des divers éléments.
 
Après il est vrai que certains jeux on un mécanisme de régulation qui les empêchent d'aller "trop vite", en particulier ce que tu nommes les "petits jeux". Mais la c'est chaque programmeur qui implémente à sa sauce ce genre de mécanismes.
 
Pour le WiFi, les coupures sont souvent dues à des facteurs environnementaux. Distance entre l'AP et ton PC, voisin qui utilise le même canal ou un canal proche, four microonde, transmetteur TV sans fil, ... et c'est clair que tu as plus de chances de remarquer une coupure en étant sur une partie en ligne que en surfant sur des pages Web.

n°2687527
MirageFL
Uplifted
Posté le 17-05-2007 à 22:05:24  profilanswer
 

C'est quand même étrange que quand je clique sur la barre de titre du jeu (Il continue à tourner, y compris le son !) tout se libère (Il ne rame pas pour autant)
 
Je viens de faire une install sur un DD à priori propre, rebelotte.
 
Pour la coupure du Wifi, je suis à 2 mètres de la Livebox avec un dongle Sagem XG-703. Et je n'ai pas installé de micro-ondes entre les deux récemment :D
 
C'est la forte utilisation des ressources qui est la cause des coupures, n'en doutons pas :jap:

n°2687594
Requin
Posté le 18-05-2007 à 09:17:43  profilanswer
 

Utilise un soft comme Mersene Prime qui stress le CPU pour vérifier ta théorie quant à l'utilisation des ressources CPU.
 
Pour les dongle, ma pensée va au fait que l'USB n'est pas vraiment un bus conçu pour le réseau et que les antennes de ce genre de dongle n'ont pas un gain extraordinaire, mais 2m c'est vrai que ca ne devrait pas poser problème. Regarde quand même qu'un voisin n'utilise pas un canal proche du tient (Idéal = 5 canaux de différence).


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Win NT/2K/XP

  UC à 100% dans les jeux, cas surprenant

 

Sujets relatifs
Balancer les jeux sur sa tv en gardant le bureau sur l'ecran pc !jeux video
lag dans les jeux avec vistaProblème capture ecran jeux
quel windows xp choisir pour les jeuxGarder automatiquement à jour ses drivers, logiciels, jeux...
Freeze à chaque accès disque dans les jeux Help Needed :cry:quel Windows pour les jeux ?
Vista et les anciens jeux 
Plus de sujets relatifs à : UC à 100% dans les jeux, cas surprenant


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR