Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
6296 connectés 

  FORUM HardWare.fr
  Windows & Software
  Win NT/2K/XP

  Boot Windows impossible en mode LBA !

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Boot Windows impossible en mode LBA !

n°2236092
- Fred -
007 Agent
Posté le 26-11-2005 à 20:30:22  profilanswer
 

Bonjour,
 
J'ai un disque dur de 160Go, que j'utilise en multiboot Windows/MacOS avec Grub comme suit :

  • /boot 500Mo Contient Grub
  • Windows 40Go Contient Windows
  • Tiger 14Go Contient MacOS
  • Partition étendue, avec données ...


Historiquement, j'ai installé mes systèmes avec mon disque dur en CHS, pour la compatibilité avec mon ancien PC qui ne gérait pas bien les disques de grande capacité. Linux et OSX bootent sans problème au delà des 1024 cylindres grâce au mode LBA, bien géré par Grub. Par contre, lorsque je tente de booter Windows en mode LBA, il ne démarre même pas ! Ecran noir après le script Grub, même pas de message d'erreur NTLDR qui ne semble pas lancé ... bref ça ne fonctionne pas.
 
J'ai tenté d'installer/réparer Windows en mode LBA, lancer fixboot en mode LBA, mais rien n'y fait : tant que je ne suis pas en mode CHS, Windows ne veut pas booter. Peut-être qu'il ne sais pas booter lorsque sa propre partition n'est pas la première du disque, mais j'ai des doutes ...
 
Si vous aviez une idée, pour faire démarrer mon Windows en mode LBA, ça m'enlèverait une bonne épine du pied : sans ce mode, je ne peux pas démarrer OSX, et je dois changer en permanence mes paramètres BIOS, sans compter que ce comportement est très curieux !
 
Merci !
 
 
En complément, voici mon menu.lst de Grub (sans les entrées Linux qui n'ont plus lieu d'être) :

# Pour mon MacOS ...
title  Apple MacOSX 10.4.3
root  (hd0,3)
makeactive
chainloader --force +1
 
# Pour mon Windows
title  Microsoft Windows XP Professionnel
root  (hd0,1)
savedefault
makeactive
chainloader +1


Message édité par - Fred - le 26-11-2005 à 20:31:15
mood
Publicité
Posté le 26-11-2005 à 20:30:22  profilanswer
 

n°2236528
- Fred -
007 Agent
Posté le 27-11-2005 à 11:35:22  profilanswer
 

Si ça peut vous aider, ma config :
A64 3200+
Asus A8N SLI Deluxe Bios 1001
DD Hitachi 7K250
 
C'est vraiment curieux comme problème, même avec le bootloader de Windows il ne veut pas démarrrer !

n°2239698
- Fred -
007 Agent
Posté le 29-11-2005 à 19:27:38  profilanswer
 

Euh ... up [:freekill]


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Win NT/2K/XP

  Boot Windows impossible en mode LBA !

 

Sujets relatifs
Windows XP Home Version OEM => Légal ???Ralentisement de WIndows
problèmes sur windows ( je pense)Probleme avec Windows Media Player
Impossible de rebooter sur le cd pour une réinstallationFormatage, aucun compte administrateur lors du lancement de windows
configuration alternative sous windows 2000 propartager le dossier windows sous xp pro
ecran bleu "Registry_error" sur nouvelle install windows...:(Un constat : SMB rapide sur windows, NFS plus rapide ss linux ...
Plus de sujets relatifs à : Boot Windows impossible en mode LBA !


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR