Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1528 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Macro Excel - valeur saisie dans une feuille existe dans autre feuille

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Macro Excel - valeur saisie dans une feuille existe dans autre feuille

n°2987909
pbardon98
Posté le 23-03-2011 à 15:48:43  profilanswer
 

:hello:  
 
Bonjour,
 
Est-ce que quelqu'un super sympa pourrait me guider sur la façon de créer un macro sous excel 2003 qui vérifie ceci:
 
Dans la colone C de la feuille 1, je vais manuellement entrer des Unités de Mesures.
L'ensemble des Unités de mesure autorisées se trouvent sur la feuille 2 colonne A2:A45
 
Je cherche à invalider la saisie en cas de non existance de la valeur saisie en Feuille1!C1 dans la Feuille2!A2:A45
 
Débutant, j'ai essayé pas mal de choses, y compris RECHERCHEV(), en vain
 
Merci à vous pour votre aide
Cordialement
Patrick


---------------
Patoche
mood
Publicité
Posté le 23-03-2011 à 15:48:43  profilanswer
 

n°2987916
Arl Guhr
Posté le 23-03-2011 à 16:20:10  profilanswer
 

Ailleur :
=SI(NB.SI(Feuil2!A:A;Feuil1!C1)<>1;"pas bon";"bon" )
Attention de ne pas avoir de doublons dans ta liste d'unités et c'est pas sensible aux majuscules exemple : ms vs mS (milliseconde, millisiemens si mes souvenirs sont bons)
 
ou
 
=SI(ESTERREUR(RECHERCHEV(C1;Feuil2!A:A;1;FAUX));"pas bon";"bon" )
 
Avec la mêmes réserves sur les majuscules


Message édité par Arl Guhr le 23-03-2011 à 16:22:19
n°2987919
pbardon98
Posté le 23-03-2011 à 16:28:52  profilanswer
 

Merci pour cette réponse. Je viens de tester, mais j'ai tjrs la même erreur dans la formule: #name?
Même chose avec RECHERCHEV. A priori, un pb avec ma version d'excel, je ne sais pas trop. Excel 2003 SP3
Peut-être une idée?
Merci en tout cas.

n°2987931
Arl Guhr
Posté le 23-03-2011 à 16:38:58  profilanswer
 

je suis sur 2007 FR
 
Les fonctions utilisée ont leur équivalent en 2003 mais peut-être pas sous le même nom ou dans la bonne langue!
edit : sinon pour tester j'avais mis A:A comme plage sur la feuille 2 mais vu l'erreur ça ne devrais pas venir de là.


Message édité par Arl Guhr le 23-03-2011 à 16:43:02
n°2987949
pbardon98
Posté le 23-03-2011 à 17:53:48  profilanswer
 

Merci pour votre aide.

n°2988290
dje69r
Arme de distraction massive
Posté le 24-03-2011 à 14:11:01  profilanswer
 

SI = IF
ESTERREUR = ISERROR
RECHERCHEV = VLOOKUP
NB.SI = COUNTIF
 

Citation :

Français Anglais
ABS ABS
ACOS ACOS
ACOSH ACOSH
ADRESSE ADDRESS
ALEA RAND
AMORLIN SLN
ANNEE YEAR
ARGUMENT ARGUMENT
ARRONDI ROUND
ASIN ASIN
ASINH ASINH
ATAN ATAN
ATAN2 ATAN2
ATANH ATANH
AUJOURDHUI TODAY
BDECARTYPE DSTDEV
BDECARTYPEP DSTDEVP
BDMAX DMAX
BDMIN DMIN
BDMOYENNE DAVERAGE
BDNB DCOUNT
BDNBVAL DCOUNTA
BDPRODUIT DPRODUCT
BDSOMME DSUM
BDVAR DVAR
BDVARP DVARP
CAR CHAR
CELLULE CELL
CHERCHE SEARCH
CHOISIR CHOOSE
CNUM VALUE
CODE CODE
COLONNE COLUMN
COLONNES COLUMNS
COS COS
COSH COSH
CROISSANCE GROWTH
CTXT FIXED
DATE DATE
DATEVAL DATEVALUE
DB DB
DDB DDB
DECALER OFFSET
DEGRES DEGREES
DETERMAT MDETERM
DROITE RIGHT
DROITEREG LINEST
ECARTYPE STDEV
ECARTYPEP STDEVP
ENT INT
EPURAGE CLEAN
EQUIV MATCH
ESTERR ISERR
ESTERREUR ISERROR
ESTLOGIQUE ISLOGICAL
ESTNA ISNA
ESTNONTEXTE ISNONTEXT
ESTNUM ISNUMBER
ESTREF ISREF
ESTTEXTE ISTEXT
ESTVIDE ISBLANK
ET AND
EXACT EXACT
EXP EXP
FACT FACT
FONCTION.APPELANTE CALL
FRANC DOLLAR
GAUCHE LEFT
HEURE HOUR
INDEX INDEX
INDIRECT INDIRECT
INFO INFO
INTPER IPMT
INVERSEMAT MINVERSE
JOUR DAY
JOURS360 DAYS360
JOURSEM WEEKDAY
LIGNE ROW
LIGNES ROWS
LN LN
LOG LOG
LOG10 LOG10
LOGREG LOGEST
MAINTENANT NOW
MAJUSCULE UPPER
MAX MAX
MEDIANE MEDIAN
MIN MIN
MINUSCULE LOWER
MINUTE MINUTE
MOD MOD
MOIS MONTH
MOYENNE AVERAGE
N N
NB COUNT
NB.SI COUNTIF
NB.VIDE COUNTBLANK
NBCAR LEN
NBVAL COUNTA
NOMPROPRE PROPER
NON NOT
NPM NPER
OU OR
PI PI
PRINCPER PPMT
PRODUIT PRODUCT
PRODUITMAT MMULT
RACINE SQRT
RADIANS RADIANS
RANG RANK
RECHERCHE LOOKUP
RECHERCHEH HLOOKUP
RECHERCHEV VLOOKUP
REGISTRE.NUMERO REGISTER.ID
REMPLACER REPLACE
REPT REPT
SECONDE SECOND
SI IF
SIGNE SIGN
SIN SIN
SINH SINH
SOMME SUM
SOMME.SI SUMIF
SOMMEPROD SUMPRODUCT
SOUS.TOTAL SUBTOTAL
STXT MID
SUBSTITUE SUBSTITUTE
SUPPRESPACE TRIM
SYD SYD
T T
TAN TAN
TANH TANH
TAUX RATE
TEMPS TIME
TEMPSVAL TIMEVALUE
TENDANCE TREND
TEXTE TEXT
TRANSPOSE TRANSPOSE
TRI IRR
TRIM MIRR
TRONQUE TRUNC
TROUVE FIND
TYPE TYPE
TYPE.ERREUR ERROR.TYPE
VA PV
VAN NPV
VAR VAR
VAR.P VARP
VC FV
VDB VDB
VPM PMT
ZONES AREAS


 
 
Source


---------------
Le cas Anne Hidalgo Madame Hidalgo vous êtes Maire d'une ville, pas d'un parcours santé :o Paris c'est la ville du progrès donc ici les couilles c'est une option :o²
n°2988302
pbardon98
Posté le 24-03-2011 à 14:33:08  profilanswer
 

Excellent. Merci beaucoup. ça marche now.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Macro Excel - valeur saisie dans une feuille existe dans autre feuille

 

Sujets relatifs
Recherche croisée dans excel 07[EXCEL] Pb macro et tableau croisée dynamique ...
Perte de la saisie automatique transfert outlook 2010Excel : Exporter des données vers du texte
[Excel] - graphique répartition plage horaireProtection de classeur excel
[excel] copier plusieurs celllules dans une autre feuille automatique?Imprimer bac manuel pour tout le classeur Excel
Plus de sujets relatifs à : Macro Excel - valeur saisie dans une feuille existe dans autre feuille


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR