Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1579 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [Exchange] Transfert d'un serveur à l'autre [Résolu]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Exchange] Transfert d'un serveur à l'autre [Résolu]

n°1236123
Gardien
Posté le 30-07-2003 à 09:54:45  profilanswer
 

Bonjour,
 
Suite au renouvellement d'un serveur je dois transférer tout le "contenu" du vieux serveur vers le nouveau. Pour les fichiers et imprimantes, l'anti-virus et l'outil de backup, j'en fais mon affaire.
 
Par contre, là ou ça se corse, c'est qu'il y a un Exchange à transférer. Existe-t-il un moyen autre que de l'installer et de le configurer à partir de zéro sur la nouvelle machine ?  
 
Ca serait cool si on pouvait copier des fichiers de conf parce que j'y connais pas grand chose à Exchange :/
 
Merci


Message édité par Gardien le 08-08-2003 à 14:37:51
mood
Publicité
Posté le 30-07-2003 à 09:54:45  profilanswer
 

n°1236146
brainbugs
Posté le 30-07-2003 à 10:25:28  profilanswer
 

tu installes ton nouveau serveur dans le meme domaine & organisation exchange. pis tu deplaces les bals.

n°1236386
Gardien
Posté le 30-07-2003 à 14:24:16  profilanswer
 

Ca m'a l'air d'etre une bonne méthode, seulement j'ai jamais touché a Exchange et j'en ai pas un sous la main pour m'entrainer. Donc si tu pouvais développer un peu, ca serait sympa.
 
Merci

n°1236391
Pims
Posté le 30-07-2003 à 14:26:42  profilanswer
 

Quelle version d'exchange ?
 
J'ai fait ca il y a 1 an en direct live sur le forum avec Exchange 5.5 !


---------------
Life is like a box of chocolate you never know what you gonna get.
n°1236393
brainbugs
Posté le 30-07-2003 à 14:28:53  profilanswer
 

Gardien a écrit :

Ca m'a l'air d'etre une bonne méthode, seulement j'ai jamais touché a Exchange et j'en ai pas un sous la main pour m'entrainer. Donc si tu pouvais développer un peu, ca serait sympa.
 
Merci


 
ben pour developper faudrait que je te mette les captures d'ecrans ;)

n°1236406
Gardien
Posté le 30-07-2003 à 14:42:23  profilanswer
 

Ca doit etre une "vieille" version d'exchange vu que ca tourne sur du NT4.
 
Bon, je verrai bien sur place ce que je peux faire. Si ca chie, mon patron comprendra peut etre que c'est risqué de répondre "Débrouille toi !" quand on lui explique qu'on a pas eu la formation pour faire ce qu'on nous demande ...

n°1236410
Pims
Posté le 30-07-2003 à 14:45:29  profilanswer
 

Oui il y a des chances que ce soit un 5.5 !
 
de grandes chances meme :)


---------------
Life is like a box of chocolate you never know what you gonna get.
n°1236418
brainbugs
Posté le 30-07-2003 à 14:57:31  profilanswer
 

Gardien a écrit :

Ca doit etre une "vieille" version d'exchange vu que ca tourne sur du NT4.
 
Bon, je verrai bien sur place ce que je peux faire. Si ca chie, mon patron comprendra peut etre que c'est risqué de répondre "Débrouille toi !" quand on lui explique qu'on a pas eu la formation pour faire ce qu'on nous demande ...


 
5.0 ou 5.5.
 
tu prends pas bcp de risque à installer un nouveau serveur.

n°1236425
Pims
Posté le 30-07-2003 à 15:08:03  profilanswer
 

Voila, tu as TOUT là !!
 
Bon courage et bonne lecture !!
 
http://forum.hardware.fr/forum2.ph [...] h=&subcat=
 
Et surtout:
 
http://forum.hardware.fr/forum2.ph [...] ic=&trash=
 


---------------
Life is like a box of chocolate you never know what you gonna get.
n°1236434
Gardien
Posté le 30-07-2003 à 15:21:12  profilanswer
 

Merci beaucoup !
 
Je commence la lecture de suite.

mood
Publicité
Posté le 30-07-2003 à 15:21:12  profilanswer
 

n°1241788
Gardien
Posté le 05-08-2003 à 10:39:50  profilanswer
 

Je vais faire la manip chez le client demain. J'ai lu tous les posts et la doc dispo sur le site microsoft et voila la procédure telle que je l'ai lu un peu partout :
 
 
- j'install un BDC dans mon domaine
- je copie le rep \Exchsrvr sur le BDC + le rep contenant les mailbox (qui se trouve dans mon cas sur un autre disque)
- je le deconnecte du reseau
- je le passe en PDC
- je le renomme avec le meme nom que mon PDC de prod
- j'install Exchange server + SP
- j'arrêtes les services Exchange
- je lance le perfwiz pour lui indiquer où se trouvent les mailbox
- je lance Isinteg -patch
- je redémarre les services
- je teste que le serveur Exchange fonctionne
- je débranche le serveur d'origine et je branche le nouveau sur le réseau.
 
Les questions que je me pose encore :  
 
Pour copier le rep \Exchsrvr et les mailbox, les services Exchange doivent etre arretés ?
 

n°1241791
com21
Modérateur
real men don't click
Posté le 05-08-2003 à 10:50:16  profilanswer
 

Gardien a écrit :


Les questions que je me pose encore :  
 
Pour copier le rep \Exchsrvr et les mailbox, les services Exchange doivent etre arretés ?
 
 


 
en toute logique je dirais oui, pour éviter que des mails soit perdu, car non sauvegardé.
 
il te suffit de prévenir tes utilisateurs que dans le cadre de la migration de serveur les bal seront out X heures.
 


---------------
Cherche geekette | Traquez vos billets d'€ | Don du sang | Don de moelle osseuse
n°1241831
Pims
Posté le 05-08-2003 à 11:59:56  profilanswer
 

Oui ca me semble correct sauf qu'il faut copier QUE les fichiers:
 
priv.edb
pub.edb
dir.edb
 
Les log est autre NON.


---------------
Life is like a box of chocolate you never know what you gonna get.
n°1242841
Gardien
Posté le 06-08-2003 à 12:34:53  profilanswer
 

Bonjour.
 
J'ai viré tous les users et arreté les services exchange.
 
J'ai copié les fichier *.edb du rep \exchsvr sans prob
 
Maintenant, il y a encore un rep \utilisateurs qui contient les mailbox de chaque user (des fichiers mailbox.pab). Or je ne peux pas copier ces fichiers car ils sont toujours ouverts par un prog ou un service. Lequel ?
 
help, il me reste qu'1 heure avant le retour des users !

n°1242854
SylvainDNS
Posté le 06-08-2003 à 12:56:09  profilanswer
 

Pourkoi faire si complique !
 
Tu installait ton nouveau server de Messagerie dans la meme organisation, et tu déplacais t'es bals, et tout ça tu pouvais le faire sans intéruption de service.
Ensuite sur le nouveau serveur tu récreais t'es connecteur Internet et autre, et une fois ça tu modifiait la redirection du smtp vers l'IP du new serveur.
 
Renomer un PDC c'est quand meme déconseiller.

n°1242859
Gardien
Posté le 06-08-2003 à 13:06:15  profilanswer
 

Aucun PDC n'est renommé dans cette procédure. Sinon, il s'agit a quelques points pret, de la procédure décrite par microsoft.
 
Mais ceci ne règle en rien mon problème : ces fichiers sont toujours lockés.
 
edit: dans la procédure les points "renommer le serveur" et "le passer en PDC" sont inversés.


Message édité par Gardien le 06-08-2003 à 13:10:16
n°1242861
SylvainDNS
Posté le 06-08-2003 à 13:10:44  profilanswer
 

en copiant Priv.edb et pub.edb je pensais qu'il falait le meme non netbios de machine

n°1242862
Gardien
Posté le 06-08-2003 à 13:14:06  profilanswer
 

oui c'est tout a fait exact. C'est pour ca que le nouveau serveur qui est actuellement BDC, je le déconnecte du réseau, je lui donne le meme nom que le PDC d'origine et je le passe en PDC.
 
Puis j'installe Exchange.
 

n°1242914
Pims
Posté le 06-08-2003 à 14:11:29  profilanswer
 

les .pab sont des carnets d'adresses personnel utilisé dans Outlook !!
 


---------------
Life is like a box of chocolate you never know what you gonna get.
n°1242962
Gardien
Posté le 06-08-2003 à 14:46:58  profilanswer
 

Oui c ce que google m'a appris. Par contre je comprends toujours pas pki ces fichiers sont lockés ...

n°1243551
Gardien
Posté le 07-08-2003 à 09:31:00  profilanswer
 

Bon, la ca chie grave ... Forcément tout ne pouvait pas bien se passer.
 
J'ai installé exchange et le sp3. Je l'ai arreté puis j'ai écrasé les .edb. Je relance pour faire le isinteg -patch : pas de bol il veut pas. Je m'affole pas, je lance le isinteg -pub -f ix -test alltests
et la :
"Jet unknow error while opening the IS databases"
 
La ca commence a me gonfler. Mais j'ai quand meme une idée de l'origine du prob : sur l'ancien serveur d'ou sont originaire les ebd, le nom d'annuaire du serveur est différent de celui que j'ai sur le nouveau serveur :/
 
En virant les fichiers log et chk j'arrive a démarrer le service d'annuarie. le isinteg -fix sur le pub fonctionne mais pas sur le priv :
"JET_errDatabaseInconsistent while opening the IS Database"
 
 
Je dois formater ?


Message édité par Gardien le 07-08-2003 à 09:40:51
n°1243587
Pims
Posté le 07-08-2003 à 10:04:51  profilanswer
 

ho punaise ....
 
Deja il faut faire attention au SP aussi !!
 
Le serveur d'origine était en SP3 ou en SP4 ?


---------------
Life is like a box of chocolate you never know what you gonna get.
n°1243618
Gardien
Posté le 07-08-2003 à 10:20:56  profilanswer
 

Jai les memes SP (le 3)
 
Mais cette histoire de nom d'annuaire j'ai pas compris a quel niveau de l'installation d'exchange ca se configure.
 
 
Sinon, j'ai essayé de réparer la base selon la proc de microsoft, mais ca plante en plein milieu (docteur watson) :/

n°1243628
SylvainDNS
Posté le 07-08-2003 à 10:25:34  profilanswer
 

T'as pas passer un hot fix du SP3 ?
J'ai déja eu ce probleme.
L'ideal aurai ete de monter un BDC, puis de le declarer en PDC du doamine, et enfin instaler un autre serveur en Exchange 5.5 avec l'ancien non, j'ai déja eu des probleme en renoman un PDC.

n°1243633
Gardien
Posté le 07-08-2003 à 10:28:32  profilanswer
 

J'ai installé aucun hotfix

n°1243643
SylvainDNS
Posté le 07-08-2003 à 10:32:19  profilanswer
 

t'as koi comme logs d'erreur dans le journal d'evenement ?

n°1243667
Gardien
Posté le 07-08-2003 à 10:44:59  profilanswer
 

J'ai (au boot) :
 
"Une erreur d'annuaire irrécupérable s'est produite. pour plus de détails choisissez le niveau d'information maximal."
 
puis  
 
"Impossible de démarrer la banque d'information mcirosoft exchange. Erreur 0x8004040f"

n°1243987
Gardien
Posté le 07-08-2003 à 14:51:37  profilanswer
 

Bon j'ai du neuf :
 
j'ai recopié les fichiers ebd. Cette fois ci ils sont en meilleurs état. Le isinteg -patch est passé sans souci. Le service banque d'information démarre sans problème.
 
Maintenant les services suivants ne démarrent toujours pas :
- agent de transfert de message
- evenements
Et le service Messagerie internet n'apparait plus dans la liste.
 
Je précise qu'un serveur dns est configuré sur la machine mais elle n'est pas connecté au réseau.  

n°1244010
Pims
Posté le 07-08-2003 à 15:16:54  profilanswer
 

Pour le service messagerie Internet, il faut le reconfigurer !!
 
-> admin exchange
 
Fichier -> nouveau -> service de messagerie internet
 
:)


---------------
Life is like a box of chocolate you never know what you gonna get.
n°1244023
Gardien
Posté le 07-08-2003 à 15:24:36  profilanswer
 

Salut,
 
J'ai supprimé la connexion messagerie internet et je l'ai recréé.
 
Seulement lors du lancement du service j'ai le message :
 
"Le service ou le groupe de dépendance n'a pas pu démarrer"
 
 
Visiblement c'est au niveau du service agente de transfert de message que ca coince. Dans l'observateur d'évènement il me laisse :  
 
"Une erreur d'annuaire irrécupérable s'est produite. pour plus de détails choisissez le niveau d'information maximal."  
 

n°1244679
Gardien
Posté le 08-08-2003 à 08:31:33  profilanswer
 

J'ai a peu pres tout essayé. Le service agent de transfert de message refuse toujours de démarrer ...
 
Je vais bientot devoir utiliser la technique longue :/


Message édité par Gardien le 08-08-2003 à 08:37:07
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [Exchange] Transfert d'un serveur à l'autre [Résolu]

 

Sujets relatifs
Serveur mail > changement de providerWord : Supprimer un tableau mais pas son contenu ? [Résolu]
Monter un réseau de 3 ordi (un serveur - 2 clients)Abyss Web Server - le serveur web qu'il est bien
Serveur mail fiable et performant : lequel choisir ?Vitesse de transfert via réseau winxp très lente
Plantage PC transfert gros fichier[résolu] nom de domaine chez ovh
Dependance des services (W2K) [Resolu][Resolu/Cause hacking]Ifrance/Free Les serveurs out, les mails aussi
Plus de sujets relatifs à : [Exchange] Transfert d'un serveur à l'autre [Résolu]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR