Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1478 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [VBA/Excel] Insertion de formules

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[VBA/Excel] Insertion de formules

n°1146737
dough29
Posté le 11-07-2005 à 17:14:42  profilanswer
 

Bonjour !
 
Voilà j'aimerais insérer une formule de calcul dans ma feuille Excel.
 
J'ai tenté ceci :
 
.Value = "=SOMME.SI($G$3:$G$147;$F150;J$3:J$147)"
 
et
 
.Value = "=SOMME.SI(G3:G147;F150;J3:J147)"
 
Tout deux me retournant une "erreur définie par l'application/l'objet".
 
J'ai vu FormulaR1C1 mais je sais pas si c'est cela qu'il faut appliquer.
 
Merci d'avance !

mood
Publicité
Posté le 11-07-2005 à 17:14:42  profilanswer
 

n°1146808
AlainTech
Pas trouvé? Cherche encore!
Posté le 11-07-2005 à 17:45:11  profilanswer
 

Le problème, c'est que tu ne nous dis pas le contenu de ton With ni l'endroit où est placé le code (feuille ou module).


---------------
Si on vous donne une info qui marche, DITES-LE!!!! ------ Si vous trouvez seul, AUSSI, votre solution peut servir à d'autres! ------ Je dois la majorité de mes connaissances à mes erreurs!
n°1147261
Lord Nelso​n
Posté le 11-07-2005 à 23:08:47  profilanswer
 

Salut,
 
Essaie ceci :
 
Range("C9" ).FormulaLocal = "=SOMME(C1:C2)"
par exemple.
 
FormulaLocal te permet d'entrer les formules dans la langue utilisée par Excel alors que Formula impose d'entrer les formules en anglais.
 
Ce qui donnerait ceci :
Range("C9" ).Formula = "=SUM(C1:C2)"
 
A+
 

n°1147389
dough29
Posté le 12-07-2005 à 08:04:28  profilanswer
 

Ca y est c'est résolu.
 
En fait il faut mettre les formules en anglais, soit ici =SUMIF...
 
Merci pour vos réponses !


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [VBA/Excel] Insertion de formules

 

Sujets relatifs
Ouvrir un userform sans passer par excel !!Comment utiliser cette classe PHP pour lire du Excel ?
[VBA EXCEL] fonction très simple qui renvoie #VALEUR...probleme de requte d insertion
[VBA]sauvegarde auto[VBA] copie d'un onglet supprime le mot de passe
creer des bookmarks en VBACopie d'une feuille sous excel
(VBA) Fonction imprimer dans menu contextuel 
Plus de sujets relatifs à : [VBA/Excel] Insertion de formules


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR