Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2345 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Transformer Formule en Macro

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Transformer Formule en Macro

n°2309740
chopin26
Posté le 10-01-2018 à 18:32:43  profilanswer
 

Bonjour,
j'ai besoin de transformer cette formule en macro.
Elle a pour fonction de supprimer un underscore dans un mot si le underscore est en 6ème position dans un mot.
La formule fonctionne parfaitement mais environ 30000 lignes à traiter.
 
=SI(TROUVE("_";A1)=6;SUBSTITUE(A1;"_";"" );A1)
 
A1 sera à remplacer par colonne A.
 
Merci pour vos contributions.


Message édité par chopin26 le 10-01-2018 à 22:45:31
mood
Publicité
Posté le 10-01-2018 à 18:32:43  profilanswer
 

n°2309746
patrice337​40
Avec la réponse, c'est facile.
Posté le 11-01-2018 à 01:23:09  profilanswer
 

Bonjour,
 
Si tu n'as que 30 000 lignes à traiter, utilises ta formule ça ira beaucoup plus vite que saisir, débugger  et exécuter une macro
 
Edit : il y bientôt 7 heures que tu as posé la question, cela serait fini depuis très longtemps.


Message édité par patrice33740 le 11-01-2018 à 01:25:36

---------------
Cordialement, Patrice
n°2310051
kiki29
Posté le 17-01-2018 à 11:35:29  profilanswer
 

Salut, affirmatif les formules sont plus rapides, sinon de la lecture :  
https://www.developpez.net/forums/b [...] edure-vba/
https://www.developpez.net/forums/b [...] ba-part-2/


---------------
Contributions : Excel/PDF avec Acrobat/PDFCreator/XPDF http://www.developpez.net/forums/d [...] ost8001071

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Transformer Formule en Macro

 

Sujets relatifs
Access une macro ne s'exécute pasmacro qui me renvoie le nom et le chemin d'un fichier
Word 2016 : Formulaire, insertions automatiques, Macro... ?Macro pour insertion ligne après saisie
macro pour filtrerExcel: étirer ma formule avec un changement d'onglet
Fermer workbook ouvert depuis une macro dans userform[Excel] macro outlook ne traite jamais dernier mail sauf si un seul
Macro de suppression pour wordenvois mail par macro sous excel
Plus de sujets relatifs à : Transformer Formule en Macro


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR