Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1718 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [VBA / Excel] supprimer une ligne sur deux

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[VBA / Excel] supprimer une ligne sur deux

n°2145736
revans971
Posté le 13-06-2012 à 17:59:03  profilanswer
 

bonjour,  
j'ai fais pas mal de recherche est je n'arrive pas a faire une macro qui permet de supprimer une ligne sur deux dans un tableau
je travail sur excel 2007
et j'aimerais savoir aussi comment faire une moyenne de mes points
merci d'avance

mood
Publicité
Posté le 13-06-2012 à 17:59:03  profilanswer
 

n°2146057
JBARBE
Posté le 16-06-2012 à 15:25:40  profilanswer
 

Bonjour,
 
Sub Supprimer_ligne()
 For i = 1 To 40000
  Cells(i, 1).EntireRow.Delete
  If Cells(i, 1) = "" Then Exit Sub
  Cells(i + 1).Select
 Next i
End Sub
 
 
Bien sur le For sera à modifier suivant les données !
 
Pour la moyenne :
 
=MOYENNE(C2:C6)
 
http://cjoint.com/?BFqpChwCI9f


Message édité par JBARBE le 16-06-2012 à 15:30:06

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [VBA / Excel] supprimer une ligne sur deux

 

Sujets relatifs
[VBA / Excel] Modéliser dette dynamiquement[VBA] Enregistrement de valeurs dans un fichier texte
Graphique excel[SQL Serveur] Restaurer un dump sans supprimer la réplication
VBA/EXCELsynchroniser deux fichiers excel avec macro
VBa : Dédoublonnage (Access 2007)Multi Filtrage d'un tableau Excel par macro
supprimer ligne d'excel par VBA[VBA Excel] Supprimer le contenu d'une ligne
Plus de sujets relatifs à : [VBA / Excel] supprimer une ligne sur deux


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR