Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
432 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [EXCEL] Problème avec la fonction SOMME.SI.ENS

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[EXCEL] Problème avec la fonction SOMME.SI.ENS

n°2283959
japps
Learn listening & teaching
Posté le 21-06-2016 à 13:46:52  profilanswer
 

Bonjour chers internautes,
je viens de rencontrer une problème pour le moins inhabituel dans l'utilisation de la fonction SOMME.SI.ENS (idem avec SOMME.SI)
 
En effet, le résultat renvoyé suite à l'application de cette fonction s'est avéré faux.
Pour vous donner une idée, je vous demande de la tester sur mon exemple et me prévenir si j'ai tort.
 
                        Colonne A                      Colonne B
  Ligne1         01000012200041901                   1
  Ligne2         01000012200041902                   2
 
Ce que je veux : Faire la somme des données de la colonne B si les valeurs en colonne A valent celles de la cellule A1 (01000012200041901)
 
Formule utilisée : =SOMME.SI($A$1:$A$2;A1;$B$1:$B$2)   OU =SOMME.SI.ENS($B$1:$B$2;$A$1:$A$2;A1)
 
Résultat obtenu : 3 au lieu de 1 qui est le bon résultat (selon la logique que j'ai expliquée)
 
Après plusieurs simulations, j'ai conclu que : IL FAUT EVITER D'APPLIQUER CES FONCTIONS (Et peut-être d'autres qui fonctionnent selon la mm logique) SUR UNE PLAGE DE CRITERES NUMERIQUE ( quoique en format texte) LORSQUE LE CRITERE RETENU (ici A1=01000012200041901) contient plus de 16 CARACTERES .
 
Quelqu'un peut-il confirmer l'erreur que j'ai constatée? Le reste, c'est vraiment un avis personnel qui pourrait aider...
 
MERCI.
 


---------------
Joel KOUADIO
mood
Publicité
Posté le 21-06-2016 à 13:46:52  profilanswer
 

n°2283979
Marc L
Posté le 21-06-2016 à 20:19:58  profilanswer
 

 
            Bonjour,
 
            hors sujet vu qu'ici c'est un forum de programmation VB/VBA/VBS ‼
 
            Et cela fonctionne avec cette formule :  =SOMMEPROD(($A$1:$A$2=A1)*$B$1:$B$2)  …

Message cité 1 fois
Message édité par Marc L le 21-06-2016 à 20:23:38
n°2284017
japps
Learn listening & teaching
Posté le 22-06-2016 à 11:13:53  profilanswer
 

Marc L a écrit :

 
            Bonjour,
 
            hors sujet vu qu'ici c'est un forum de programmation VB/VBA/VBS ‼
 
            Et cela fonctionne avec cette formule :  =SOMMEPROD(($A$1:$A$2=A1)*$B$1:$B$2)  …


 
Bonjour,
pas vraiment hors sujet dans la mesure où j'applique cette fonction dans EXCEL avec un code VBA.
Concernant ta formule, il y a d'autres aspects (des #N/A dans la colonne A par exemple) que je n'ai pas présenté qui pourraient déranger.
 
As-tu pu tester l'exemple pour confirmer le problème que j'ai eu stp ?

n°2284020
Takama13
Posté le 22-06-2016 à 11:50:26  profilanswer
 

Bonjour,
 
D'après le support office, il semble en effet que la précision numérique est de 15 chiffres :
 
https://support.office.com/fr-fr/ar [...] c00b05040f

n°2284022
Marc L
Posté le 22-06-2016 à 12:25:11  profilanswer
 

 
 
             Pas de souci avec  SOMME.SI  si le critère ne peut pas être convertit en nombre …
  


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [EXCEL] Problème avec la fonction SOMME.SI.ENS

 

Sujets relatifs
Fonction : Passer un élément d'array en paramètreUtilisation de la fonction COUNT() avec des valeurs NULL
Numéros de téléphone google vers excel[VBA] Travail sur fichier excel en arrière plan
[JS/Xml] Parser des éléments en fonction de la balise contenante?Fusion de lignes sur excel
Problème C# récupération de donnéeProblème avec la traduction google traduction api et c#
Probleme d'enregistrement[Excel] Création d'une requête SQL ?
Plus de sujets relatifs à : [EXCEL] Problème avec la fonction SOMME.SI.ENS


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR