Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1487 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Mon error_reporting ne fonctionne pas :/

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Mon error_reporting ne fonctionne pas :/

n°1276105
Dj YeLL
$question = $to_be || !$to_be;
Posté le 02-01-2006 à 22:17:40  profilanswer
 

Bonsoir,
 
Je ne comprends pas, je n'ai plus d'affichage de report d'erreur.
 
J'ai été mettre, dans mon php.ini, l'error_reporting à E_STRICT ... et rien.
 
Si sur ma page php je ne fais que ça :
 

if($_GET['test'] == 1) { ... }


 
... je n'ai pas d'erreur :/ Il devrait pourtant me dire undefined index test etc...
 
Idem si je fais un $a = $b + $c en n'ayant affecté aucune de ces 3 variables.
 
Quelqu'un aurait il une idée de ce qui se passe ?
 
Merci.


---------------
Gamertag: CoteBlack YeLL
mood
Publicité
Posté le 02-01-2006 à 22:17:40  profilanswer
 

n°1276108
Dj YeLL
$question = $to_be || !$to_be;
Posté le 02-01-2006 à 22:28:37  profilanswer
 

Pour info, mon display_errors est bien à 1 aussi.
 
Tjs pour info, j'utilise PHP 5.1.1


---------------
Gamertag: CoteBlack YeLL
n°1276123
Dj YeLL
$question = $to_be || !$to_be;
Posté le 02-01-2006 à 23:18:28  profilanswer
 

Bon, ne fonctionnant tjs pas après un redémarrage du PC, j'ai réinstallé le serveur, et maintenant ça remarche.
 
Je ne saurais jamais ce qui s'est passé.


---------------
Gamertag: CoteBlack YeLL
n°1276149
sielfried
Posté le 02-01-2006 à 23:44:15  profilanswer
 

A priori ce que tu voulais c'est E_STRICT | E_ALL, pas juste E_STRICT.
 
E_STRICT n'inclue pas E_ALL, il me semble.


---------------
StarCraft Professional Gaming Database | [Ze Topic] Starcraft/BroodWar
n°1276151
sielfried
Posté le 02-01-2006 à 23:47:47  profilanswer
 

Je viens de tester et je confirme.


---------------
StarCraft Professional Gaming Database | [Ze Topic] Starcraft/BroodWar
n°1276217
Dj YeLL
$question = $to_be || !$to_be;
Posté le 03-01-2006 à 10:27:54  profilanswer
 

Oui en effet, je m'en suis rendu compte après la réinstall du serveur. Mais le problème ne venait de toute façon pas de là car je n'avais absolument aucune erreur.Même en mettant à E_ALL.
 
Mais sinon tu as raison, E_ALL et E_STRICT se complètent :)
 
Merci.


---------------
Gamertag: CoteBlack YeLL

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Mon error_reporting ne fonctionne pas :/

 

Sujets relatifs
RUNTIME ERROR BESOIN D'AIDE![Linker error] undefined reference to 'IcmpSendEcho@'
[VBA]GetOpenFilename ne fonctionne pas[SQL Server]Reporting Services : Pages blanches à l'export des reports
TRansaction fonctionne en mode client/serveur ?parse error
[VBS] (résolu) copy overwrite fonctionne pas.. pourquoi?parse error trop bizzar
parse error impossible a detecter :/Liste déroulante fonctionne sous Firefox pas IE...
Plus de sujets relatifs à : Mon error_reporting ne fonctionne pas :/


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR