Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1188 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Besoin de php 4.2.x

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Besoin de php 4.2.x

n°1611887
Profil sup​primé
Posté le 15-09-2007 à 13:24:52  answer
 

Bonjour
 
Voilà je cherche à télécharger php 4.2.0 ou mieux encore 4.2.1.
Or impossible de le trouver. Je l'ai pris provisoirement de l'Easyphp 1.6, mais j'ai un problème avec l'accès à la base de donné mysql. En fait il y a pas d'extension php_mysql.dll c'est normale?
 
Merci


Message édité par Profil supprimé le 15-09-2007 à 13:51:34
mood
Publicité
Posté le 15-09-2007 à 13:24:52  profilanswer
 

n°1611896
WiiDS
20 titres en GC, 0 abandon, 0 DQ
Posté le 15-09-2007 à 14:22:49  profilanswer
 

Objection :o
 
Pourquoi tu veux une ancienne version de PHP ? [:mlc]


---------------
"I can cry like Roger. It's just a shame I can't play like him" - Andy Murray, 2010
n°1611897
weed
Posté le 15-09-2007 à 14:25:55  profilanswer
 

utiliser des anciennes fonction qui ne sont plus du tout utiliser par PHP5
 
nop c'est pas normal, avec easyphp1.5 ou 1.6 tu devrais pouvois te connecter à la base de données sans problème.

n°1611900
Profil sup​primé
Posté le 15-09-2007 à 14:48:38  answer
 

WiiDS a écrit :

Objection :o
 
Pourquoi tu veux une ancienne version de PHP ? [:mlc]


Le client nous paye pour quelques correctif sur son site web.
Il ne nous paye pas pour refaire le site en php5...

n°1611923
WiiDS
20 titres en GC, 0 abandon, 0 DQ
Posté le 15-09-2007 à 17:50:42  profilanswer
 

weed a écrit :

utiliser des anciennes fonction qui ne sont plus du tout utiliser par PHP5
 
nop c'est pas normal, avec easyphp1.5 ou 1.6 tu devrais pouvois te connecter à la base de données sans problème.


 
Y'a des anciennes fonctions qui ont été supprimées sur PHP 5 ? :/ Jamais eu de problème de compatibilité
 
 
 
Ok je comprends ;)


---------------
"I can cry like Roger. It's just a shame I can't play like him" - Andy Murray, 2010
n°1612160
weed
Posté le 17-09-2007 à 00:03:31  profilanswer
 

WiiDS a écrit :


 
Y'a des anciennes fonctions qui ont été supprimées sur PHP 5 ? :/ Jamais eu de problème de compatibilité
 


 
Pas à ma connaissance meme les classes à la php4 sont compatibles en PHP5. Je pensais au fonction qui etaient deja obsolète dans PHP4, qui ont été maintenu pour garder la compatibilité mais qui ont été supprimé en PHP5. Je pense qu'au bout d'un moment les fonctions sont supprimés. Ou sinon c'est peut etre une certaine syntaxe qui etait accepté mais qui ne l'est plus en PHP5.  
Pourquoi autant d'entreprise hesite ou traine des pieds pour migrer en PHP5 ? il doit bien y avoir une raison.
 
 
Pour MySQL, avec la version 4, on peux faire des jointures interne dans la clause WHERE et faire des jointures externe avec LEFT dans le FROM dans une même requete.  
Dans la dernier version de MySQL, la version 5, il n'est plus possible de faire un mix dans le WHERE et le FROM. Voila il faut savoir quand on fait une migration.

n°1612191
leflos5
On est ou on est pas :)
Posté le 17-09-2007 à 02:17:21  profilanswer
 

D'où l'intéret de coller un max aux standards pour ne pas avoir ce genre de surprises :)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Besoin de php 4.2.x

 

Sujets relatifs
besoin d'aide pour resolution equation scd. degré (vb)besoin d'explications pour PHP/PGSQL
besoin d'aide date php[python] (debutant) besoin d'un coup de main
portage d'un driver windows en qnx besoin d'aide urgentmouseover / area shape
[Résolu] Hiérarchie de menus : besoin de conseilsRésolu
Besoin d'aide pour requête SQLafficher image avec un checkbox - besoin d'exemple
Plus de sujets relatifs à : Besoin de php 4.2.x


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR