Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2287 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Php Affichage ...

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Php Affichage ...

n°1497708
jjssll
Posté le 01-01-2007 à 19:16:17  profilanswer
 

Est-ce-que avec ca je pourrais écrire du PHP dans ma page ? Car j'essaye tant bien que mal d'afficher mes instructions que j'ai taper en PHP dans ma page mais une fois   mon site dans EasyPHP, tout mon XHmtl s'affiche mais rien en Php, donc je voudrais voir si c'est dans mon code de départ que y'a le probleme ou si c'est moi qui sais pas me servir D'easyPHP .. :
 

Code :
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
  3. <head>
  4.  <title>Graphi-tiX</title>
  5.  <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-15" />
  6.  <meta http-equiv="Content-Style-Type" content="text/css" />
  7.  <meta http-equiv="Content-Language" content="fr" />
  8.  <link rel="stylesheet" media="screen" type="text/css" title="Design" href="plop.css" />
  9. </head>

mood
Publicité
Posté le 01-01-2007 à 19:16:17  profilanswer
 

n°1497710
sielfried
Posté le 01-01-2007 à 19:20:52  profilanswer
 

Ton fichier a bien l'extension .php ? Tu accèdes bien à ta page via http (<=> pas de "file:///" dans l'url ?)
 
Sinon, où est le PHP là-dedans ? :o

n°1497711
jjssll
Posté le 01-01-2007 à 19:27:51  profilanswer
 

Oui, il fonctionne en interne (http://127.0.0.1/SIte/) .. Toute ma page s'affiche sauf un texte php que j'ai taper. Je suis certaine que l'orthographe est bonne ... D'ou le probleme peut til venir ? Merci d'avance

n°1497713
sielfried
Posté le 01-01-2007 à 19:30:11  profilanswer
 

Fait voir le code complet, avec le PHP ?

n°1497716
jjssll
Posté le 01-01-2007 à 19:34:37  profilanswer
 

Juste un exemple, je completerai par la suite car mon vrai code est sur un autre pc ...
 

Code :
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
  3. <head>
  4.  <title>Graphi-tiX</title>
  5.  <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-15" />
  6.  <meta http-equiv="Content-Style-Type" content="text/css" />
  7.  <meta http-equiv="Content-Language" content="fr" />
  8.  <link rel="stylesheet" media="screen" type="text/css" title="Design" href="plop.css" />
  9. </head>
  10. <body>
  11. <div id="conteneur">
  12.  <h1 id="header"><a href="etape1.html" title="Colored Design - Accueil"><span></span></a></h1>
  13.   <?php echo "Exemple de ce qui ne s'affiche pas!";?>
  14.  <center>
  15. <form method="post" action="traitement.php">
  16.        <label>Pseudo : <input type="text" name="pseudo" /></label>
  17.        <label>
  18.            Mot de passe :
  19.            <input type="password" name="pass" />  <input type="submit" />
  20.        </label>
  21.  
  22. </form></center>


Message édité par jjssll le 01-01-2007 à 19:36:17
n°1497718
sielfried
Posté le 01-01-2007 à 19:37:45  profilanswer
 

Ton fichier se nomme comment ?

n°1497720
sielfried
Posté le 01-01-2007 à 19:39:53  profilanswer
 

En fait t'avais déjà posté ici :
http://forum.hardware.fr/forum2.ph [...] w=0&nojs=0
 
Pas besoin de refaire un topic. -_-

Message cité 1 fois
Message édité par sielfried le 01-01-2007 à 19:40:10
n°1497723
jjssll
Posté le 01-01-2007 à 19:42:57  profilanswer
 

Deso d'avOir refait un ....... :) !  
 
Mon fichier se note Index.php ...


Message édité par jjssll le 01-01-2007 à 19:43:17
n°1497724
sielfried
Posté le 01-01-2007 à 19:45:12  profilanswer
 

Dans la source html de ta page, à l'endroit où il y est censé y avoir le PHP, y a quoi ?

n°1497727
jjssll
Posté le 01-01-2007 à 19:47:46  profilanswer
 

Juste ca qui devrait afficher une phrase mais rien! :  
 
   <?php echo "Exemple de ce qui ne s'affiche pas!";?>

mood
Publicité
Posté le 01-01-2007 à 19:47:46  profilanswer
 

n°1497788
sielfried
Posté le 02-01-2007 à 09:42:40  profilanswer
 

Bref ton PHP est pas interprété. Le plus simple serait de réinstaller EasyPHP je suppose, voire mieux, de le virer et de mettre Wamp.

n°1498009
rufo
Pas me confondre avec Lycos!
Posté le 02-01-2007 à 16:33:08  profilanswer
 

sielfried a écrit :

En fait t'avais déjà posté ici :
http://forum.hardware.fr/forum2.ph [...] w=0&nojs=0
 
Pas besoin de refaire un topic. -_-


 
Je me disais bien que ce topic m'en rappelait un autre...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Php Affichage ...

 

Sujets relatifs
[PHP] <BR /> dans base SQL à traduire pour l'affichage[PHP/MySQL debutant] Affichage d'un enreg apres l'autre
PHP Affichage sur plusieurs pages[PHP/Javascript] PB lors de l'affichage de caractère dans une page
Différence d'affichage de date entre ASP et PHP via SQLServer[HTML] [PHP] problème d'affichage dans une frame
[PHP/MYSQL] Affichage de tables dans le menu puis ...Affichage de pages PHP
Affichage gallerie PHP[PHP/MYSQL] affichage d'une table sur une page
Plus de sujets relatifs à : Php Affichage ...


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR