Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1827 connectés 

  FORUM HardWare.fr
  Programmation
  Langages fonctionnels

  Excel formule avec si(et(ou

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Excel formule avec si(et(ou

n°2267536
fsgirl
Posté le 11-10-2015 à 05:48:23  profilanswer
 

Bonjour,
 
Voici le tableau que j'ai :
A1="Femelle 1"
B1="Male 1"
C1="Vie 2"
D1="Male 1"
A2="Dominique"
B2="Dominique"
C2="Groenland"
D2="Dominique"
 
Je cherche une formule dans excel 2013 qui regroupe toutes ces conditions :
- si B1="Objet 1" ou B1="Ethnie 2" ou B1="Male 1"  
ET que
- si les cellules A2, B2, C2 et/ou D2 contiennent "Ouganda" et/ou "Groenland"
- alors la cellule A4 affiche "Ouganda"
 
J'ai essayé cette formule :  
=SI(OU(ET($B$1="Objet 1";$B$1="Ethnie 2";$B$1="Male 1" );ET($A$2="Ouganda";$B$2="Ouganda";$C$2="Ouganda";$D$2="Ouganda";$A$2="Groenland";$B$2="Groenland";$C$2="Groenland";$D$2="Groenland" )));"Ouganda";"" )  
 
Mais elle n'affiche rien alors que 3 conditions sont réunies pour afficher "Ouganda" en A4 : "Male 1" en B1 et "Male 1" en D1 ET "Groenland" en C2
 
Pouvez-vous m'aider SVP ??!!
 
Je suis perdue !!
 
Merci


Message édité par fsgirl le 11-10-2015 à 05:51:32
mood
Publicité
Posté le 11-10-2015 à 05:48:23  profilanswer
 

n°2267537
Profil sup​primé
Posté le 11-10-2015 à 05:55:46  answer
 

Bonjour, tu a 4 '(' et 5 ')'.
Le texte "Ouganda", "" ) est hors instruction me semble t'il.

n°2267538
fsgirl
Posté le 11-10-2015 à 06:04:16  profilanswer
 

Bonjour,  
 
Je viens de rectifier en  
=SI(OU(ET($B$1="Objet 1";$B$1="Ethnie 2";$B$1="Male 1" );ET($A$2="Ouganda";$B$2="Ouganda";$C$2="Ouganda";$D$2="Ouganda";$A$2="Groenland";$B$2="Groenland";$C$2="Groenland";$D$2="Groenland" ));"Ouganda";"" )
 
mais A4 toujours vide


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Langages fonctionnels

  Excel formule avec si(et(ou

 

Sujets relatifs
Rajout formule dans scriptAdapter une formule au nombre de cellules qu'elle solicite
Formule Excel !!aide pour formule excel
[EXCEL 2010] Formule résultat cellule X en fonction de YFormule matricielle Excel ou code VBA
[VBA] Remplacer une formule dans plusieurs feuilles du classeurEtirer la formule de plusieurs lignes jusqu'en bas de mon tableau
Formule EXCEL[résolut]PHPEXCEL impossible de lire le contenu d'une
Plus de sujets relatifs à : Excel formule avec si(et(ou


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR