Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1192 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  [résolut]PHPEXCEL impossible de lire le contenu d'une

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[résolut]PHPEXCEL impossible de lire le contenu d'une

n°2189074
Akim13
Posté le 06-05-2013 à 11:34:20  profilanswer
 

Bonjour,
 
Sur phpexcel je peu tout lire sur toutes les colonnes sauf la dernière colonne AD, je bloque dessue car je ne sais pas lire une colonne qui contient une formule.
 
Le fichier Excel est un fichier fournit par mon fournisseur, donc je suis obliger de l’utilisé comme il est.
 
La colonne AD contient la description
Exemple de la ligne 3 Colonne AD : *HDMI HighSpeed et compatibilité HDCP.
 
Mais quand j’ouvre le fichier excel sur mon pc et que je fais bouton droit pour copier le texte (juste pour tester car je ne travail que sur php), magie j’ai la description complète (je ne sais pas d’où elle sort lol), mais ca m’intéresse beaucoup.
 
Voir le résultat de la copie
 

"*HDMI HighSpeed et compatibilité HDCP  
*Vidéo HD non compressées jusqu'à 1080p @ 60Hz à 100m
*Transfers video, audio et HDCP sur un cordon RJ45 !  
*Audio TrueHD, DTS-HD Master Audio
*Supporte la 3D (avec périphériques 3D)  
 
Emetteur  
entrée HDMI  
sortie "

Les colonnes contiennent la même formule sauf A3 qui change : A3 = ligne 3, A4 = ligne 4 etc…
=RECHERCHEV(A3;'\\SRV004\Doc_CUC\INFORMATIQUE\Scripts\[BaseFTPProduit.xlsm]Caracteristiques'!A$7:B$15000;2;FAUX)
 
Mon echo donne ceci
// =VLOOKUP(A3,#REF!,2,FALSE)
 
 
Merci d'avance


Message édité par Akim13 le 08-05-2013 à 16:51:07
mood
Publicité
Posté le 06-05-2013 à 11:34:20  profilanswer
 

n°2189346
Akim13
Posté le 08-05-2013 à 15:54:24  profilanswer
 

problème résolut


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  [résolut]PHPEXCEL impossible de lire le contenu d'une

 

Sujets relatifs
afficher le nombre d'enregistrement à chaque lignePHPExcel pdf
PHPExcel erreur ddl client versionChanger ligne d'un fichier texte
Couper/coller ligne en fonction N° de commandeerreur formule excel
Regler la hauteur de la page selon le contenuTrouver la 1ere ligne vide d'un tableau et écrire dans les cellules
insérer une ligne en desous d'une autre sous conditioninsérer une ligne en desous d'une autre sous condition
Plus de sujets relatifs à : [résolut]PHPEXCEL impossible de lire le contenu d'une


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR