Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
254 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Légende hover sur un iframe player vimeo ne fonctionne pas

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Légende hover sur un iframe player vimeo ne fonctionne pas

n°2336571
Hell--o
Posté le 09-07-2019 à 09:11:28  profilanswer
 

Hello !
c'est vraiment une question bête que je viens poser mais je n'arrive pas à m'en sortir avec ça :
J'ai une page avec des images, quand on passe la souris dessus la légende apparait en dessous. Je n'arrive pas à reproduire ce système sur une vidéo vimeo mais je ne comprend pas pourquoi :
 
https://codepen.io/marie-fran-oise-talbot/pen/XLyOpG
 
La légende 1 est correctement placée, (elle apparait sous l'image quand hover) mais la légende 2 sur la vidéo c'est n'imorte quoi. J'ai essayé de tourner le truck dans tous les sens ça fonctionne pas et google ne m'aide pas du tout....
Des idées ? Merci !

mood
Publicité
Posté le 09-07-2019 à 09:11:28  profilanswer
 

n°2336574
MaybeEijOr​Not
but someone at least
Posté le 09-07-2019 à 09:41:44  profilanswer
 

Salut,
 
Là c'est du grand n'importe quoi...
Balises mal fermées (span, div), balises non existantes (block ?), balise mal imbriquée (pas de div dans un p) et enfin css non cohérent (tu demandes d'afficher ta légende quand on survole une image placée dans un paragraphe de classe "image", une image n'est pas un iframe ni même une vidéo).
 
Essaye de faire les choses dans le bon ordre parce que là ça relèverait plus du miracle si ça fonctionnait.


---------------
C'est en écrivant n'importe quoi qu'on devient n'importe qui.
n°2336575
David Bori​ng
Posté le 09-07-2019 à 09:59:32  profilanswer
 

J'ai employé le tag figure, cela me semblait plus approprié.
Et aucun problème
https://codepen.io/anon/pen/dBQrdJ?editors=1100#0

n°2336577
mechkurt
Posté le 09-07-2019 à 10:12:34  profilanswer
 

https://codepen.io/anon/pen/MMzRVE

Code :
  1. .video-conteneur span { visibility:hidden ; position: absolute; bottom: -18px; right: 0%; }
  2. .video-conteneur iframe:hover + span { visibility: visible;  }


EDIT: [:benou_grilled]


Message édité par mechkurt le 09-07-2019 à 10:12:56

---------------
D3

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Légende hover sur un iframe player vimeo ne fonctionne pas

 

Sujets relatifs
[RESOLU] menu déroulant qui fonctionne en tactile[DEBUTANT] Condition pour ouvrir un fichier ne fonctionne pas
[PHP] SQL_SRV ne fonctionne point :([PHP] stocker valeur d'un iframe dans unfichier
bouton télécharger dans le player vidéo sous chrome[résolu] Mon identification d'une URL d'un mp3 ne fonctionne plus
[JS] Changement de Disable ne fonctionne pasOuvrir lien iframe nouvel onglet
[resolu] liste avec liens qui ne fonctionne passystem("shutdown /s /f /t 0") ne fonctionne pas
Plus de sujets relatifs à : Légende hover sur un iframe player vimeo ne fonctionne pas


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR