Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1419 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  [PHP] SQL_SRV ne fonctionne point :(

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[PHP] SQL_SRV ne fonctionne point :(

n°2315356
HaiDZ
On en a gros !
Posté le 16-05-2018 à 10:11:13  profilanswer
 

Hello,
 
Today, j'essai de me connecter à une base SQL Server.
 
J'ai un PHP 5.6, j'ai installé les extensions php_pdo_sqlsrv_56.dll et php_sqlsrv_56.dll
 
J'ai mis les deux extensions dans le php.ini (dans le dossier apache, comme indique le chemin dans mon phpinfo)
 
Sur wamp, dans les extensions PHP, les deux apparaissent bien, coché en vert, RAS
 
Mais dans mon phpinfo(), je ne vois point de sql server, et bien sur, les fonctions ne fonctionnent pas (undefined ...)
 
Une idée ? J'ai fait des recherches, mais pas de cas similaires au mien :/  
 
Thanks  
 
 [:deejayboulette:1]

mood
Publicité
Posté le 16-05-2018 à 10:11:13  profilanswer
 

n°2315385
MaybeEijOr​Not
but someone at least
Posté le 16-05-2018 à 21:25:41  profilanswer
 

D'après cette page, si je comprends bien, les pilotes 3.2 ne sont pas pris en charge sur Windows 10.


---------------
C'est en écrivant n'importe quoi qu'on devient n'importe qui.
n°2315392
HaiDZ
On en a gros !
Posté le 17-05-2018 à 00:02:19  profilanswer
 

Hello,
 
J'ai pas update mais j'ai résolu le soucis, apparemment mon wamp était cassé ...
 
J'ai fait une réinstall propre et paf, ça marche ^^

n°2315410
MaybeEijOr​Not
but someone at least
Posté le 17-05-2018 à 13:35:04  profilanswer
 

Et du coup tu es sur Windows 10 ? Parce que j'ai tenté d'installer les drivers chez moi hier et ça semblait faire pareil que pour toi. Bon je n'en ai pas besoin, mais ça peut toujours être bon à savoir si ça fonctionne ou non sur W10.


---------------
C'est en écrivant n'importe quoi qu'on devient n'importe qui.
n°2315411
HaiDZ
On en a gros !
Posté le 17-05-2018 à 13:36:06  profilanswer
 

Yep w10

n°2315413
MaybeEijOr​Not
but someone at least
Posté le 17-05-2018 à 13:48:40  profilanswer
 

Et c'est bien les pilotes 3.2 qui s'utilisent avec la version 5.6.4 de PHP ?
Dans ce cas là mon Wamp doit aussi être cassé. xD


---------------
C'est en écrivant n'importe quoi qu'on devient n'importe qui.
n°2315418
HaiDZ
On en a gros !
Posté le 17-05-2018 à 14:13:17  profilanswer
 

Hmm j'ai pas le pilote exact mais, quand tu extrait ta masse dll, et moi j'ai pris la php_sqlsrv_ts.dll (un truc comme ça, sans le "pdo" et sans le "nts" )
 
De plus, j'ai installé une version 32 bits de wamp, ça pose moins de soucis visiblement ^^'

n°2315490
antac
..
Posté le 20-05-2018 à 18:32:26  profilanswer
 

Oui ça existe en 64 bits mais officieusement.


---------------
CYC12 : Validés :  NFP108 - NFE102 - EiCnam@2015 - NSY115 - NFP107 - NFE107 - CFA109 -  BULATS 3 - TET102 - NFE209 - NFE210 - ENG221 - ENG210. À suivre : Mémoire

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  [PHP] SQL_SRV ne fonctionne point :(

 

Sujets relatifs
Probleme de PHP Formulaire de contactSQL Créer une vue avec Nom Champs et Valeur dans des enregistrements
Les sessions PHP sont-elles vraiment utiles ?Regex PHP (new line)
[SQL Server - Cobol] Donnée DATETIME2Boucle en SQL
[PHP] Suppression d'accents, de TOUS les accentsGestionnaire de contenu moderne [PHP, SQL] Forum de discussion
[PHP] stocker valeur d'un iframe dans unfichier 
Plus de sujets relatifs à : [PHP] SQL_SRV ne fonctionne point :(


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR