Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1848 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Gros problème de liens dans mon site..

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Gros problème de liens dans mon site..

n°1380118
Djdiox
Posté le 02-06-2006 à 17:53:28  profilanswer
 

Je vais essayer de mieux explique car je me rend compte que ce n'est pas tres claire...

 

Je suis donc en train d'essayer de mettra a jour ce site:

 

http://www.dance-station.org

 

L' architecture du site est assez simple.

 

A la racine du serveur se trouve tout mes pages liées et tous mes dossiers, mes pages sont liées a un template dreamweaver (.dwt) qui se trouve dans le dossier "Templates".

 

http://lediox.be/1.gif

 

Dans ce dossier se trouve le template qui est la base de toutes mes pages.

 

Jusque la tout fonctionne très bien...

 

Maintenant j'ai créer un dossier test au même niveau que le reste pour pouvoir faire
des essais

 


http://lediox.be/2.gif

 

Dans ce dossier test j'ai transférer tout le site tel qu'il est a la racine du serveur (comme sur les images). Donc apprioris tout devrais se comporter de manière identique quand je fais des essais a partir de:

 

http://www.dance-station.org/test

 


que quand je fais des essais a partir de:

 

http://www.dance-station.org

 

Mais la j'ai un problème avec mes liens à partir du fichier de template (qui dans ce cas ci est évidemment dans un dossier "Templates" qui se trouve dans le dossier de test au même niveau que les autres pages vu que j'ai recopier identiquement l'arobrescence dans ce dossier test).  

 

En fait tous mes liens, ceux du menu gauche et de menu haut du site (que je vous invites a visiter pour mieux visualiser) sont définis dans le fichier de template.

 

Avant que je reprenne les mise a jours il n'y avait pas de css et les liens vers les pages étaient définis comme ceci:

 

<a href="../Classique.asp?lib=Street%20Funk"style="text-decoration: none">Classique</a>

 

<a href="../hip-hop.asp?lib=Hip-Hop"style="text-decoration: none">Hip-Hop</a>

 

etc...

 

j'ai changé ces liens par:

 

<a href="../classique?lib=Street%20Funk">Classique</a>

 

<a href="../hip-hop.asp?lib=Hip-Hop">Hip-Hop</a>

 


J'ai enlever le text-décoration dans le lien car je l'ai définis dans une css linker au template...

 

Mon problème est que après ces changement qui sont pourtant des liens propres quand je clique sur ces liens a partir de ce chemin:

 

http://www.dance-station.org/test/une_page.asp

 

j'obtiens des liens absolus de ce type (ici par exemple j'ai cliqué sur classique):

 

http://www.dance-station.org/test/Templates/%22../ classique.asp?lib=Classique%22style=%22text-decoration:  

 

(l'espace est mis expres ici sinon il n'affiche pas mon lien ici sur ce firum)

 

Je ne comprend pas pourquoi déjà il affiche un lien absolu alors que j'ai bien mis un "../" et je ne vois pas ce que vient encore faire ce "text-decoration:" que j'ai pourtant enlever..

 

En tout logique je devrais avoir de liens comme ceci car comme définis dans le template:

 

<a href="../classique?lib=Street%20Funk">Classique</a>

 

<a href="../hip-hop.asp?lib=Hip-Hop">Hip-Hop</a>

 

et cela devrais pointer comme ceci :

 

http://dance-station.org/test/classique.asp

 

http://dance-station.org/test/hip-hop.asp

  

Qu'elqu'un aurait une explication ?? car je ne comprend vraiment pas la..

 

J'espere avoir été claire et merci d'avance (n'hésite pas a aller visiter le site pour mieux comprendre ce que j'ai essayer d'expliquer)

 

Merci encore  :Hola:  :Hola:

mood
Publicité
Posté le 02-06-2006 à 17:53:28  profilanswer
 

n°1380340
Djdiox
Posté le 03-06-2006 à 09:18:32  profilanswer
 

personne ?


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Gros problème de liens dans mon site..

 

Sujets relatifs
Probleme sur DataGridView sous VB DotNet[jsp] problème sur un useBean
Probleme validation xhtmlProblème en Access
Ouvrir un site depuis un autreLes iframes: problème pour le référencement!
site avec NVUFieldset: problème de centrage de la légende sous Opéra
compteur pr siteje voudrais votre avis sur mon site
Plus de sujets relatifs à : Gros problème de liens dans mon site..


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR