Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2302 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  class CSS != balise style 0o [auto-résolu]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

class CSS != balise style 0o [auto-résolu]

n°1789806
bartsword
Posté le 20-09-2008 à 17:03:53  profilanswer
 

Hello,
je suis sur un problème que je n'arrive vraiment pas à cerner... Je me tourne donc vers vous pour un petit coup de pouce.
 
Donc voilà, je suis en train de crée (coder) un blog et j'ai incorporer le fameux TinyMCE pour la rédaction des articles. Le problème c'est que j'aimerais pouvoir mettre en forme certains composants comme les listes à puces, les paragraphes, les liens hypertextes, les images... Donc j'ai cherché comment faire et j'ai trouvé. Il suffit de rajouter une liste déroulante comme composant de tinyMCE relié à une css et enfin choisir la class correspondante dans la liste.  
 
Bon alors j'ai fait ça, mais problème pour mes images il n'y a pas moyen de lui mettre une margin-left=0 alors que c'est exactement l'attribut que lui met tinyMCE quand on le fait manuellement (et ça marche manuellement)... Mais en lui mettant ma class pas moyen d'avoir mon margin-left. Comme c'est assez compliquer à expliquer avec des mots, voici les exemples en images :  
 
http://img386.imageshack.us/my.php?image=test1pw3.jpg
Là j'ajoute mon image et je change manuellement ses propriétés
Et voici le résultat :  
http://img386.imageshack.us/my.php?image=test2cw3.jpg
On remarque que l'image est bien alignée à gauche (trait rouge)
 
http://img294.imageshack.us/my.php?image=vtest1ex4.jpg
La je recommence la même opération en attribuant simplement une class à mon image
Voici le résultat :  
http://img254.imageshack.us/my.php?image=vtest2vr4.jpg
 
Donc on remarque bien que l'alignement n'est pas bon. Je vais maintenant vous montrer en quoi je n'arrive pas à cerner le problème, voici mon css :  

Code :
  1. .Images {
  2. margin-left: 0px;
  3. margin-right: 0px;
  4. border: solid 1px black;
  5. width: 550px;
  6. }


 
et voici le code générer dans le premier exemple (l'alignement est bon):  

Code :
  1. <p><img style="margin-left: 0px; margin-right: 0px;" src="http://blog.manu-bd.info/images/Fleur/arbre-de-nuit.jpg" alt="" /></p>


 
et dans le deuxième exemple (en passant par la liste déroulant):  

Code :
  1. <p><img class="Images" src="http://blog.manu-bd.info/images/Fleur/arbre-de-nuit.jpg" alt="" width="600" height="495" /></p>


 
Donc on remarque bien que dans le deuxième exemple, l'image prend bien l'attribut border par exemple alors pourquoi pas le margin-left   [:albator7k]  ???
 
Merci de votre aide si vous pourrez m'en apporter...
 
 [:atog]
 
EDIT: Allez savoir pourquoi, il suffisait de mettre un float:right dans la class css de mon image


Message édité par bartsword le 20-09-2008 à 21:50:56

---------------
_____________________________
mood
Publicité
Posté le 20-09-2008 à 17:03:53  profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  class CSS != balise style 0o [auto-résolu]

 

Sujets relatifs
Mon Richtextbox ne s'actualise pas .(Edit::Résolu)[CSS] Petit prob avec l'attribut font-size (Résolu)
[JS] recherche calendrier javascript style thunderbirdMenu html CSS (ul li) [resolu]
[Résolu]Pb récupération plusieurs valeurs d'un formulaire dans un mailQuestion style de lien aux pros du HTML/CSS
Les fichiers de style CSS ne se chargent pas! 
Plus de sujets relatifs à : class CSS != balise style 0o [auto-résolu]


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR