Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1194 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  probleme étrange avec mes cartes réseau... [urgent svp]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme étrange avec mes cartes réseau... [urgent svp]

n°595804
benj63
Posté le 25-11-2004 à 09:31:21  profilanswer
 

Salut,
 
J'ai un ordinateur sous RedHat 9, sur lequel il y a 3 cartes réseaux :
 
 - 2 interfaces "3Com 3c59x" sur la carte mère
 - 1 carte "Intel EtherExpress/1000"
 
 
Je n'utilise que 2 cartes :
 
 - 1 interface "3com 3c59x" pour la connexion à Internet  
 - la carte "Intel EtherExpress/1000" pour la connexion à un réseau local en 192.168....
 
 
Je souhaiterai définir les cartes en eth0 et eth1 en fonction de leur MAC adresse.
 
Grâce au panneau de configuration réseau de RedHat9, j'ai choisi quelles cartes étaient activées, j'ai configuré les paramètres réseaux, etc... et tout foncionnait. Jusqu'à récemment, j'ai redémarré la machine et apparemment l'ordre des cartes eth0, eth1 est chamboulé, et je n'arrive plus à me connecter à mon réseau local en 192.168.... (mais je peux me connecter à Internet). Ce n'est pas un problème de cables, ni de switch, tout va bien de ce côté.
 
Quand je démarre le panneau de configuration réseau de RedHat9, un message m'indique :
 

eth1 a un alias au module e1000 dans modules.conf, au lieu
du module actuellement chargé 3c59x !


 
c'est bizarre, car dans le panneau de configuration réseau, eth1 est bien associé à ma carte e1000 (comme je le souhaite !) et si je regarde /etc/modules.conf j'ai :
 

alias eth0 3c59x
alias eth1 e1000
alias scsi_hostadapter aic7xxx
alias usb-controller usb-ohci
alias eth2 3c59x


 
ce qui est correct !
 
 
en faisant ifconfig -a j'obtiens :
 

eth0      Lien encap:Ethernet  HWaddr 00:**:**:**:**:B1
          inet adr:81.255.***.*** Bcast:81.255.***.*** Masque:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6460 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8624 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:100
          RX bytes:1985228 (1.8 Mb)  TX bytes:6519520 (6.2 Mb)
          Interruption:18 Adresse de base:0x1800
 
eth1      Lien encap:Ethernet  HWaddr 00:**.**.**.**:B2
          inet adr:192.168.2.1  Bcast:192.168.2.255  Masque:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:473 errors:0 dropped:0 overruns:0 carrier:473
          collisions:0 lg file transmission:100
          RX bytes:0 (0.0 b)  TX bytes:28380 (27.7 Kb)
          Interruption:19 Adresse de base:0x1880
 
lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:31546 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31546 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:6836183 (6.5 Mb)  TX bytes:6836183 (6.5 Mb)


 
il ne semble pas y avoir d'erreur, c'est ce que je veux... alors pourquoi ne puis-je pas me connecter sur mon réseau local, et pourquoi le panneau de configuration du réseau de RedHat me pose ce problème de configuration ?? Y'a-t'il d'autres fichiers à modifier pour configurer le réseau ??
 
Merci pour votre aide  :jap:  :jap:


---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
mood
Publicité
Posté le 25-11-2004 à 09:31:21  profilanswer
 

n°595828
e_esprit
Posté le 25-11-2004 à 10:44:50  profilanswer
 

J'ai l'impression que par defaut il active eth1 sur ta seconde interface "3Com 3c59x" sur la carte mère, d'ou le message :

eth1 a un alias au module e1000 dans modules.conf, au lieu
du module actuellement chargé 3c59x !


 
Y a moyen de voir la section des messages de demarrage qui causent des interfaces réseaux ?


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°595934
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-11-2004 à 14:27:38  profilanswer
 

cat /etc/iftab


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  probleme étrange avec mes cartes réseau... [urgent svp]

 

Sujets relatifs
Faire des schémas réseau pas trop mochesProbleme démarage Gnome - GDM
[Nvidia 6629] [Mandrake 10.1] Problème Lightmapprobleme installation slack 10 [résolu :jap:]
Nagios : probleme de cgi[SHELL] help, probleme de pipe
Probleme chargement des modulesDemande d'aide aux pros des cartes TV...
Besoin d'aide pour une configuration assée poussé d'un réseau linuxProbleme d'instalation de fedora core 3
Plus de sujets relatifs à : probleme étrange avec mes cartes réseau... [urgent svp]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR