Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2021 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  [Nvidia 6629] [Mandrake 10.1] Problème Lightmap

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Nvidia 6629] [Mandrake 10.1] Problème Lightmap

n°595652
leto
Posté le 24-11-2004 à 20:58:34  profilanswer
 

J'ai pas mal de problèmes avec ces drivers nvidia :  
 
Deja , sur glxgears avec une geforce4 ti4200 (cf ma config dans mon profil):

% glxgears
4934 frames in 5.0 seconds = 986.800 FPS
5740 frames in 5.0 seconds = 1148.000 FPS


 
Alors que je faisais 3 fois mieux avec mon ancienne config (moins puissante et meme carte graphique).
 
De plus , si je lance un jeu utilisant le moteur de Quake3 (essayé avec Q3, Q3-UT3 , Wolfenstein ET) avec les textures en mode "lightmap" : Affichage déuguelasse, toutes les textures sont foirées, aucun texte n'est lisible, impossible de jouer .  
Le plus étrange, c'est que c'est apparu du jour au lendemain, ca a bien marché pendant quelques jours .  
Capture d'écran :  
http://img6.exs.cx/img6/1696/prob_q3.jpg
 
Aucun problème sur tuxracer :/
 
En mode vertex , ca marche bien, mais c'est LENT :/ :(
 
Essayé en AGP8x et 4x : meme problème.
 
OS: Mandrake 10.1 i686
Proc: AMD64 3000+
Resol: 1280*1024
 
 
Si quelqu'un sait d'ou ca peut venir ... Merci d'avance .
 
Quelques détails :  

% cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        4x
Fast Writes:     Disabled
SBA:             Enabled
% cat /proc/driver/nvidia/cards/0
Model:           GeForce4 Ti 4200 with AGP8X
IRQ:             16
Video BIOS:      04.28.20.10.00
Card Type:       AGP
% lsmod | grep agp
amd64-agp               8584  1
agpgart                27752  2 amd64-agp
% lsmod | grep nv
nvidia               3462972  12
% glxinfo | grep direct
direct rendering: No


Message édité par leto le 30-11-2004 à 18:02:50
mood
Publicité
Posté le 24-11-2004 à 20:58:34  profilanswer
 

n°595653
Profil sup​primé
Posté le 24-11-2004 à 21:01:09  answer
 

MMM regarde dans nvidia-settings si tu as pas mis l'anti-aliasing ou autre ... Car ca bouffe énormement de FPS !

n°595660
leto
Posté le 24-11-2004 à 21:11:36  profilanswer
 

Non , la case "override application settings" n'est pas cochée :/

n°595662
Profil sup​primé
Posté le 24-11-2004 à 21:13:49  answer
 

Tu as fait un top pour voir si il y avait pas un prog de fond type msec_find ou rmpq ...

n°595664
leto
Posté le 24-11-2004 à 21:18:23  profilanswer
 

21:17 leto@mdk ~% ps aux | grep -i msec
leto     18770  0.0  0.0  1960  776 pts/0    S+   21:17   0:00 grep -i msec
21:17 leto@mdk ~% ps aux | grep -i rpm
leto     18772  0.0  0.0  1960  768 pts/0    R+   21:17   0:00 grep -i rpm


 
Non, rien :/
Et rien qui consomme le CPU lorsque je joue, a part le jeu (90% disons) et X (10%) .
 
Mais le prob principal c'est la corruption des textures, cf la capture d'écran que j'ai mis dans le post 1 .

n°595699
leto
Posté le 24-11-2004 à 22:13:19  profilanswer
 

X me prend bcp de CPU ... C'est surement l'une des sources du problème :/ Après : Pourquoi :??: Quelle que soit la priorité donnée a quake3 (j'ai essayé en nice -5 et en nice 10 ), il lutte avec X pour avoir les ressources ... étrange .


Message édité par leto le 24-11-2004 à 22:23:09
n°595803
leto
Posté le 25-11-2004 à 09:27:03  profilanswer
 

up

n°595917
leto
Posté le 25-11-2004 à 13:48:35  profilanswer
 

up

n°597624
leto
Posté le 29-11-2004 à 15:45:38  profilanswer
 

up

n°597636
_darkalt3_
Proctopathe
Posté le 29-11-2004 à 16:04:34  profilanswer
 

Perso, j'ai toujours eu qq problemes avec les drivers nvidia, sauf les 44.96 (ou juste suivants, je ne sais plus); j'ai pas le temps de chercher pourquoi/comment, et ma machine est exploitable, donc je les gardes sur un coin du disque.
 
Pourquoi pas tenter une version antérieure dedits drivers ?

mood
Publicité
Posté le 29-11-2004 à 16:04:34  profilanswer
 

n°597672
leto
Posté le 29-11-2004 à 16:36:15  profilanswer
 

C'est ce que je vais faire si je trouve pas de solution, mais c'est qd mm pas l'idéal , surtout que c'est le seul probleme, et qu'il est apparu d'un jour a l'autre :/

n°597771
Riot
Buy me a riot
Posté le 29-11-2004 à 19:14:58  profilanswer
 

euh par contre, agpgart et le driver nvidia en meme temps, c'est censé marché???

n°597847
leto
Posté le 29-11-2004 à 20:52:31  profilanswer
 

A part les problèmes que je mentionne dans le premier post, ca marche très bien .

n°598334
leto
Posté le 30-11-2004 à 17:56:15  profilanswer
 

% glxinfo | grep direct
direct rendering: No


 
Ca aussi c'est mauvais :/

n°598342
THRAK
- THR4K -
Posté le 30-11-2004 à 18:03:17  profilanswer
 

Il utilise peut être pas les bons modules glx... (donc ceux de nvidia en version 6629).
 
As-tu tenter de désinstaller entièrement les drivers et de les réinstaller à partir de ceux fournis sur le site officiel à nvidia ?


---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°598348
leto
Posté le 30-11-2004 à 18:07:44  profilanswer
 

j'essaie ca

n°598372
Dark_Schne​ider
Close the World, Open the Net
Posté le 30-11-2004 à 18:30:35  profilanswer
 

et surtout vérifie le load glx
 
http://www.linux-wizard.net/howto. [...] le=3#xfree
http://www.linux-wizard.net/howto. [...] ticle=3#pb


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°598421
leto
Posté le 30-11-2004 à 19:26:29  profilanswer
 

Ok c'était donc ca, il faut reinstaller les pilotes nvidia après une mise a jour de Xorg .


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  [Nvidia 6629] [Mandrake 10.1] Problème Lightmap

 

Sujets relatifs
probleme installation slack 10 [résolu :jap:]mandrake 10.0 et 10.1
Install Mandrake 10.1 et RAIDNagios : probleme de cgi
Perte de l'USB sur mandrake 10.1[SHELL] help, probleme de pipe
Mise à jour mandrake 10.1 communitymandrake 10.1, steam et linux
Probleme chargement des modulesPb de permission d'accès sur dossiers/fichiers Mandrake
Plus de sujets relatifs à : [Nvidia 6629] [Mandrake 10.1] Problème Lightmap


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR