Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1036 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  problème partage connexion internet sous debian

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

problème partage connexion internet sous debian

n°1114099
jeremyp3
Posté le 17-02-2009 à 22:13:56  profilanswer
 

bonjour,
 
j'aimerai partager ma connexion internet  avec debian mais je rencontre un problèmes en efet, je n'arrive pas a faire sortir internet sur la seconde interface.
 
j'explique ma config test
internet sur un routeur ayant l'IP 192.168.0.3 relier a eth0  
 
mon réseau LAN relier sur eth1 ayant pour IP 192168.8.x
 
j'ai suivi plusieurs tuto traitant de la chose mais rien a faire internet ne passe toujours pas sur eth1
 
si vous pourriez me venir en aide
 
merci d'avence,
 
Jérémy

mood
Publicité
Posté le 17-02-2009 à 22:13:56  profilanswer
 

n°1114104
Fork Bomb
Obsédé textuel
Posté le 17-02-2009 à 22:18:29  profilanswer
 

T'es passé par là ?
>> http://formation-debian.via.ecp.fr/firewall.html


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1114109
jeremyp3
Posté le 17-02-2009 à 22:41:19  profilanswer
 

bonjour,
 
  les tuto que j'ai suivi ressemblai a ça
 
mais ... sa marche pas
 
si vous voulez des fichiers de config pour regarder  
 
dites moi

n°1114110
Fork Bomb
Obsédé textuel
Posté le 17-02-2009 à 22:42:37  profilanswer
 

Tu l'as utilisé ce tuto-là ?


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1114113
jeremyp3
Posté le 17-02-2009 à 22:44:03  profilanswer
 

j'ai fait tout ce qu'il y a dans ce tuto

n°1114120
jeremyp3
Posté le 17-02-2009 à 22:54:10  profilanswer
 

j'envoie quelque fichiers de config pour accélérrer le traitement du soucis
 
 
 ifconfig
 
eth0      Lien encap:Ethernet  HWaddr 00:13:8F:5E:EA:3A                                                                        
          inet adr:192.168.0.3  Bcast:192.168.0.255  Masque:255.255.255.0                                                      
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                                                                  
          RX packets:509 errors:0 dropped:0 overruns:0 frame:0                                                                
          TX packets:7267 errors:0 dropped:0 overruns:0 carrier:0                                                              
          collisions:0 lg file transmission:1000                                                                              
          RX bytes:48354 (47.2 KiB)  TX bytes:516238 (504.1 KiB)                                                              
          Interruption:169 Adresse de base:0x4000                                                                              
                                                                                                                               
eth1      Lien encap:Ethernet  HWaddr 00:0C:76:B6:07:AE                                                                        
          inet adr:192.168.8.1  Bcast:192.168.8.255  Masque:255.255.255.0                                                      
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                                                                  
          RX packets:7118 errors:0 dropped:0 overruns:0 frame:0                                                                
          TX packets:410 errors:0 dropped:0 overruns:0 carrier:0                                                              
          collisions:0 lg file transmission:1000                                                                              
          RX bytes:516162 (504.0 KiB)  TX bytes:86968 (84.9 KiB)                                                              
          Interruption:193 Adresse de base:0xcc00                                                                              
                                                                                                                               
lo        Lien encap:Boucle locale                                                                                            
          inet adr:127.0.0.1  Masque:255.0.0.0                                                                                
          UP LOOPBACK RUNNING  MTU:16436  Metric:1                                                                            
          RX packets:289 errors:0 dropped:0 overruns:0 frame:0                                                                
          TX packets:289 errors:0 dropped:0 overruns:0 carrier:0                                                              
          collisions:0 lg file transmission:0                                                                                  
          RX bytes:131356 (128.2 KiB)  TX bytes:131356 (128.2 KiB)                                                            
                                                                                                                                /etc/network/interface
 
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
 
# The loopback network interface
#auto lo
#iface lo inet loopback
 
auto eth0
iface eth0 inet dhcp
 
auto eth1
iface eth1 inet static
address 192.168.8.1
netmask 255.255.255.0
network 192.168.8.0
   broadcast 192.168.8.255
ethtool -s eth1 speed 1000 duplex full autoneg off  
 
c'est tout bon normalement  ça

n°1114146
o'gure
Modérateur
Multi grognon de B_L
Posté le 18-02-2009 à 08:02:34  profilanswer
 

La bonne procédure est la suivante :
Sur ton poste linux :
1. Activation du routage :  sysctl -w net.ipv4.ip_forward=1
2. Puis tu as deux solutions :
   - si sur ton routeur 192.168.0.1 tu peux rajouter des routes => tu mets eth0 en adressage fixe et tu indiques au routeur que joindre 192.168.8.0/24 le trafic doit etre envoyer à l'adresse fixe que tu as configurée sur eth0. C'est la meilleure solution
 
  - si tu ne peux pas, il te reste à faire un truc sal qui s'appelle du NAT et qui est expliqué partout sur le net :
   iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
 
 
Ensuite sur les postes clients :
1. tu configures le poste client en adresse IP (automatique si tu as un serveur DHCP sur ce brin réseau) ou fixe
2. tu configures les serveurs DNS (selon ta configuration ou selon ton FAI)
3. tu indiques la passerelle par défaut (192.168.8.1)


---------------
Ton Antoine commence à me les briser menus !
n°1114391
jeremyp3
Posté le 18-02-2009 à 18:24:59  profilanswer
 

bonjour,
 
j'ai effectivement un serveur dhcp qui fonctionne sur ce linux a merveuille lui
 
j'ai fait ces deux choses mais sa marche toujours pas  
 
pour le routeur  et les routes je préfèrerai qu'il reste indépendants puisque c'est simplement pour test que je met ce routeur
 
merci d'avence

n°1114397
o'gure
Modérateur
Multi grognon de B_L
Posté le 18-02-2009 à 18:53:17  profilanswer
 

jeremyp3 a écrit :

j'ai fait ces deux choses mais sa marche toujours pas


D'une part c'est ç et non s, d'autre part c'est un peu léger comme description du problème.

 

Donc donne nous les résultats des commandes suivantes :
sur ton linux qui doit faire office de routeur :

ifconfig
route -n
cat /etc/resolv.conf
sysctl net.ipv4.ip_forward    
ping -c 1 66.102.9.99
iptables -t filter -L -v -n
iptables -t nat -L -v -n

 

sur un équipement derrière ton linux qui doit faire office de routeur, en espérant que ce soit un linux, sinon essaye de trouver les commandes/informations similaires (adressage, passerelle par défaut, dns, ping passerelle et  d'une adresse de google, puis en utilisant le nom de www.google et pour terminer le firewall ) :

ifconfig
route -n
cat /etc/resolv.conf
ping 192.168.8.1
ping -c 1 66.102.9.99
ping www.google.fr
iptables -t filter -L -v -n



Message édité par o'gure le 18-02-2009 à 18:58:07

---------------
Ton Antoine commence à me les briser menus !
n°1114412
jeremyp3
Posté le 18-02-2009 à 19:26:44  profilanswer
 

le temps que je face les manip sous linux
 
je vous répond pour le windows puisque j'avai déjà testez tout ça au paravent
ping 192.168.8.1 répond
 
ping vers une adresse IP sur l'internet répond pas
 
ping vers google.fr ne répond pas non plu
 
l'adressage est bon  niveaux dhcp
 
donc c'est bien internet qui passe pas
 
merci

mood
Publicité
Posté le 18-02-2009 à 19:26:44  profilanswer
 

n°1114414
Modération
Posté le 18-02-2009 à 19:34:51  answer
 

jeremyp3> Fais attention à ton orthographe, tu as tout ton temps pour écrire un post. C'est particulièrement désagréable de te lire.
 
Des fautes, oui, tout le monde en fait, mais il y a des limites...

n°1114415
o'gure
Modérateur
Multi grognon de B_L
Posté le 18-02-2009 à 19:35:58  profilanswer
 

Il me manque des réponses par rapport à windows :
- vérifie que la passerelle est bien renseignée via dhcp (normalement tu dois la voir dans le ipconfig)
- vérifie que tu résouds correctement les noms de domaine (nslookup www.google)


---------------
Ton Antoine commence à me les briser menus !
n°1114417
jeremyp3
Posté le 18-02-2009 à 19:40:14  profilanswer
 

voici les manips
 
ifconfig vous l'avez en haut
 
route -n
debian:~# route -n                                                              
Table de routage IP du noyau                                                    
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface    
192.168.254.2   0.0.0.0         255.255.255.255 UH    0      0        0 tun0    
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0    
192.168.254.0   192.168.254.2   255.255.255.0   UG    0      0        0 tun0    
192.168.8.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1    
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0    
 
resolf.conf
nameserver 192.168.0.1
 
sysctl net.ipv4.ip_forward    
net.ipv4.ip_forward = 0                                                          (je crois qu'il faux que ce sois "1"
 
PING 66.102.9.99 (66.102.9.99) 56(84) bytes of data.                            
64 bytes from 66.102.9.99: icmp_seq=1 ttl=242 time=52.4 ms                      
                                                                                 
--- 66.102.9.99 ping statistics ---                                              
1 packets transmitted, 1 received, 0% packet loss, time 0ms                      
rtt min/avg/max/mdev = 52.403/52.403/52.403/0.000 ms                              
 
debian:~# iptables -t filter -L -v -n                                                                                          
Chain INPUT (policy DROP 0 packets, 0 bytes)                                                                                  
 pkts bytes target     prot opt in     out     source               destination                                                
                                                                                                                               
  149 14776 ACCEPT     0    --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        state RELATED,ESTABLISHED                                                                                              
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:20                                                                                                            
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:21                                                                                                            
   11   560 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:8080                                                                                                          
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:25                                                                                                            
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:4662                                                                                                          
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:53                                                                                                            
    0     0 ACCEPT     udp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        udp dpt:53                                                                                                            
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:80                                                                                                            
    0     0 ACCEPT     tcp  --  eth0   *       0.0.0.0/0            0.0.0.0/0                                                  
        tcp dpt:139                                                                                                            
    0     0 ACCEPT     udp  --  eth0   *       0.0.0.0/0            0.0.0.0/0                                                  
        udp dpt:139                                                                                                            
    0     0 ACCEPT     0    --  lo     *       0.0.0.0/0            0.0.0.0/0                                                  
                                                                                                                               
  143 15592 REJECT     0    --  *      *       0.0.0.0/0            0.0.0.0/0                                                  
        reject-with icmp-port-unreachable                                                                                      
                                                                                                                               
Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)                                                                              
 pkts bytes target     prot opt in     out     source               destination                                                
                                                                                                                     
Chain OUTPUT (policy ACCEPT 318 packets, 59704 bytes)                                                                          
 pkts bytes target     prot opt in     out     source               destination                                                
               
 
Chain PREROUTING (policy ACCEPT 68 packets, 5222 bytes)                                                                        
 pkts bytes target     prot opt in     out     source               destination                                                
                                                                                                                               
Chain POSTROUTING (policy ACCEPT 26 packets, 2720 bytes)                                                                      
 pkts bytes target     prot opt in     out     source               destination                                                
    7  1331 MASQUERADE  0    --  *      eth1    0.0.0.0/0            0.0.0.0/0                                                
                                                                                                                               
Chain OUTPUT (policy ACCEPT 33 packets, 4051 bytes)                                                                            
 pkts bytes target     prot opt in     out     source               destination                                                
 
 
vvoila ça devrai allé ...
 
P.S désolé pour les fautes modérateur


Message édité par jeremyp3 le 18-02-2009 à 20:18:47
n°1114419
jeremyp3
Posté le 18-02-2009 à 19:51:54  profilanswer
 

pour windows, la passerelle est correctemeent configurer j'ai vérifier
 
je ne comprend pas ceux qui manque au niveaux de windows puisque j'ai pas accès a internet
 
merci d'avence

n°1114426
o'gure
Modérateur
Multi grognon de B_L
Posté le 18-02-2009 à 20:17:37  profilanswer
 

Au niveau de windows, vérifie tes DNS (mets 192.168.0.1 si le DHCP n'a pas renseigné le bon)
Au niveau de linux tu n'as pas suivi correctement ce que je t'ai indiqué, donc pour corriger :

 
  • Comme je te l'ai dit au dessus sinon ça ne marchera jamais...

sysctl -w net.ipv4.ip_forward=1    

 
  • Ce masquerade, il faut le faire sur eth0  ( cf. mon premier post). Vue que tu as rentré autre chose :

iptables -t nat -F POSTROUTING


puis la bonne ligne de conf (cf. celle de mon post au dessus)

 


Et fait attention à ton orthographe, la modération va te sanctionner, politique du forum !


Message édité par o'gure le 18-02-2009 à 20:18:11

---------------
Ton Antoine commence à me les briser menus !
n°1114427
jeremyp3
Posté le 18-02-2009 à 20:21:53  profilanswer
 

pourtant dans se fichier de configuration c'est le bon qui est marquer
# Uncomment the next line to enable Spoof protection (reverse-path filter)
net.ipv4.conf.default.rp_filter=1
 
# Uncomment the next line to enable TCP/IP SYN cookies
#net.ipv4.tcp_syncookies=1
 
# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.conf.default.forwarding=1
 
# Uncomment the next line to enable packet forwarding for IPv6
#net.ipv6.conf.default.forwarding=1

n°1114430
o'gure
Modérateur
Multi grognon de B_L
Posté le 18-02-2009 à 20:25:29  profilanswer
 

jeremyp3 a écrit :

pourtant dans se fichier de configuration c'est le bon qui est marquer
# Uncomment the next line to enable Spoof protection (reverse-path filter)
net.ipv4.conf.default.rp_filter=1

 

# Uncomment the next line to enable TCP/IP SYN cookies
#net.ipv4.tcp_syncookies=1

 

# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.conf.default.forwarding=1

 

# Uncomment the next line to enable packet forwarding for IPv6
#net.ipv6.conf.default.forwarding=1


Ce n'est pas parce qu'un fichier est renseigné qu'il est pris en compte...
Par ailleurs, de quel fichier s'agit-il (emplacement exact) ?

 

Fais ce que je te dis, après on verra pour la persistance après un reboot...


Message édité par o'gure le 18-02-2009 à 20:25:45

---------------
Ton Antoine commence à me les briser menus !
n°1114432
jeremyp3
Posté le 18-02-2009 à 20:27:54  profilanswer
 

ok je suis en train de tester
 
pour le fichiers c'est /etc/sysctl.conf
 

n°1114434
jeremyp3
Posté le 18-02-2009 à 20:31:32  profilanswer
 

voila ça marche  !  

n°1114435
jeremyp3
Posté le 18-02-2009 à 20:32:54  profilanswer
 

je tante un  
reboot

n°1114436
o'gure
Modérateur
Multi grognon de B_L
Posté le 18-02-2009 à 20:34:56  profilanswer
 

Tente, avec un e ; ça ne marche pas...
 
Pour la règle de firewall, il faut faire un script dans le bon runlevel (/etc/rc2.d/ normalement), pour le net.ipv4.ip_forward=1    rajoute le dans le fichier (texto), j'ai toujours un doute (ce fichier est-il utilisé ou non), sinon rajoute la commande entière dans le script.


---------------
Ton Antoine commence à me les briser menus !
n°1114442
jeremyp3
Posté le 18-02-2009 à 20:45:58  profilanswer
 

bonjour,
 
donc j'ai tantés et biensur ça ne marchais pas
 
j'ai seulement rajouter la ligne    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE  
 
 
et sa c'est mis a marcher direct
 
je vais rajouter cette règles dans le script iptables
 
merci, je passe le post en résolu

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  problème partage connexion internet sous debian

 

Sujets relatifs
Probleme Installation FEDORA 10[Problème RESOLUT]/dev/ttyS : permission denied sous linux
[mandriva2009]probleme de loginProbleme de GRUB...
aide installation debianProblème couleurs QT4
Partage d'1imprimante éthernet sur 2 sous réseau différent, possible ?apt-get install, update probleme
probleme configuration réseau 
Plus de sujets relatifs à : problème partage connexion internet sous debian


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR