Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2437 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Résolu] WoL Debian fonctionne dans certains cas

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] WoL Debian fonctionne dans certains cas

n°983601
Gavrinis
Open your mind
Posté le 25-11-2007 à 10:03:15  profilanswer
 

Bonjour tout le monde,
 
Tout d'abord je précise que j'ai déjà fait une recherche et qu'elle ne m'a pas été très fructueuse, certes des topics existent déjà à ce sujet mais ça ne m'a pas avancé.
 
 
Voici le problème, j'aimerais réveiller mon serveur Debian à partir d'une autre machine du réseau. Pour cela je sais que j'ai besoin d'une carte gérant le WoL, que cette option soit activé dans le BIOS, ... en bref tout ceci est déjà fait. Preuve que le WoL est opérationnel, quand je débranche le câble réseau du serveur au routeur et que je le reconnecte aussitôt le PC s'allume tout seul :). Mais quand je cherche à le réveiller en lui envoyant un paquet magique, rien n'y fait :(.
 
 
Quelqu'un peut-il m'aider ?
 
PS : cette utilisation n'est pas dans un but de "jouer" avec cette fonction ou de faire le gros fade mais tout simplement pour une utilisation de backup pour la nuit ;).
 
 
Merci d'avance


Message édité par Gavrinis le 27-11-2007 à 21:41:56
mood
Publicité
Posté le 25-11-2007 à 10:03:15  profilanswer
 

n°983608
zecrazytux
Posté le 25-11-2007 à 10:54:10  profilanswer
 

:hello:
 
Nous avons eu des problèmes sur certain ordinateurs sur une solution à base de Mandriva... Peut être est ce le même problème ?
 
voici donc une piste à explorer: http://edutice.mandriva.com/forums/viewtopic.php?id=15


Message édité par zecrazytux le 25-11-2007 à 10:54:50
n°983683
Gavrinis
Open your mind
Posté le 25-11-2007 à 15:20:33  profilanswer
 

merci pour votre aide mais j'avais déjà essayé avec

Code :
  1. ethtool -s eth0 wol g

et si je me sers de l'argument "-i" sur halt c'est encore pire car le câble réseau ne le réveille plus :(.

n°983702
zecrazytux
Posté le 25-11-2007 à 17:38:59  profilanswer
 

c'est étrange... le même  envoi de magic packet à une autre machine fonctionne t'il ?

n°983705
Riot
Buy me a riot
Posté le 25-11-2007 à 17:50:36  profilanswer
 

Gavrinis a écrit :

merci pour votre aide mais j'avais déjà essayé avec

Code :
  1. ethtool -s eth0 wol g

et si je me sers de l'argument "-i" sur halt c'est encore pire car le câble réseau ne le réveille plus :(.


Ton pb vient peut-être de ton routeur, il ne garde peut-être pas l'adresse mac de la carte réseau à réveiller en mémoire.
Pour régler ça, j'ai donné un bail permanent à ma carte réseau.
 
Avec ça + la ligne de commande que tu as donné plus haut + le réglage dans le bios, tout marche nickel chez moi.


---------------
Be the one with the flames.
n°983780
Gavrinis
Open your mind
Posté le 25-11-2007 à 20:28:26  profilanswer
 

Riot a écrit :

Ton pb vient peut-être de ton routeur, il ne garde peut-être pas l'adresse mac de la carte réseau à réveiller en mémoire.
Pour régler ça, j'ai donné un bail permanent à ma carte réseau.
 
Avec ça + la ligne de commande que tu as donné plus haut + le réglage dans le bios, tout marche nickel chez moi.


Tu veux dire que tu attribues une IP "static" via DHCP en utilisant l'adresse MAC ? (si oui moi aussi :D)
 
Pour ce qui est du routeur non se n'est pas lui car j'ai essayé d'allumer un PC sous Windows depuis le terminal d'un Mac et il s'est allumé sans problème.

n°983781
Riot
Buy me a riot
Posté le 25-11-2007 à 20:30:46  profilanswer
 

Gavrinis a écrit :


Tu veux dire que tu attribues une IP "static" via DHCP en utilisant l'adresse MAC ? (si oui moi aussi :D)
 
Pour ce qui est du routeur non se n'est pas lui car j'ai essayé d'allumer un PC sous Windows depuis le terminal d'un Mac et il s'est allumé sans problème.


Oui.
 
J'ai pas d'autre idée alors, dsl.


---------------
Be the one with the flames.
n°983817
utb diablo
.: :. 4 ever xo0
Posté le 25-11-2007 à 21:30:14  profilanswer
 

faut aussi que le routeur l'autorise, faut ouvrir le port 0 je crois bien, ou le 9 en udp et autoriser le trafic broadcast :)
 
mais le WoL n'a aucun rapport avec l'adressage d'ip par dhcp ou avec la nature du système installé, seul la carte reseau et les config du bios comptent


---------------
Au royaume des aveugles, les borgnes sont rois xo0
n°983821
TKz
Posté le 25-11-2007 à 21:35:32  profilanswer
 

utb diablo a écrit :

faut aussi que le routeur l'autorise, faut ouvrir le port 0 je crois bien, ou le 9 en udp et autoriser le trafic broadcast :)
 
mais le WoL n'a aucun rapport avec l'adressage d'ip par dhcp ou avec la nature du système installé, seul la carte reseau et les config du bios comptent


+1
ce topic n'a rien à faire dans OSA ...

n°983832
Gavrinis
Open your mind
Posté le 25-11-2007 à 22:22:41  profilanswer
 

Pour ce qui est du routeur ça passe vu que ...

Gavrinis a écrit :

Pour ce qui est du routeur non se n'est pas lui car j'ai essayé d'allumer un PC sous Windows depuis le terminal d'un Mac et il s'est allumé sans problème.


mood
Publicité
Posté le 25-11-2007 à 22:22:41  profilanswer
 

n°984286
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 26-11-2007 à 17:51:08  profilanswer
 

Tu utilise bien etherwake en root pour envoyer le magic packet ?

n°984305
Gavrinis
Open your mind
Posté le 26-11-2007 à 19:09:32  profilanswer
 

non j'utilise le programme wakeonlan

n°984314
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 26-11-2007 à 19:47:23  profilanswer
 

Pas bon, ça n'envoie pas de magic packet.

n°984374
Gavrinis
Open your mind
Posté le 26-11-2007 à 22:39:23  profilanswer
 

ah bizarre pourtant ça m'allume bien un PC sous Windows :??:

n°984388
TKz
Posté le 27-11-2007 à 00:25:30  profilanswer
 

Gavrinis a écrit :

ah bizarre pourtant ça m'allume bien un PC sous Windows :??:


Windows n'a RIEN à voir dans l'histoire (linux non plus d'ailleurs), et wakeonlan envoie bien un magic packet ...

n°984391
Nonor_
Ubuntu c'est supaire
Posté le 27-11-2007 à 00:43:40  profilanswer
 

Il y a quelques années j'avais essayé aussi de faire ça et ça marchait pas non plus (debian).
J'aimerais bien aussi avoir la solution. Et ce sujet a bien sa place dans OSA puisqu'on essaye d'envoyer le magic packet depuis un pingouin et que ça marche pas...

n°984449
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 27-11-2007 à 09:03:29  profilanswer
 

Non non et non. Wakeonlan est un script perl qui forge un paquet à destination du port 'discard'. Ca n'est pas un magic paket, mais apparament vous saviez mieux donc je pense que je vais vous laisser galérer.

n°984450
zecrazytux
Posté le 27-11-2007 à 09:10:24  profilanswer
 

M300A a écrit :

Non non et non. Wakeonlan est un script perl qui forge un paquet à destination du port 'discard'. Ca n'est pas un magic paket, mais apparament vous saviez mieux donc je pense que je vais vous laisser galérer.


 
:D

n°984577
acheron2
Posté le 27-11-2007 à 11:56:24  profilanswer
 

TKz a écrit :


Windows n'a RIEN à voir dans l'histoire (linux non plus d'ailleurs), et wakeonlan envoie bien un magic packet ...


et si, le wake on lan dépend également de l'OS, plus précisément du pilote de ta carte réseau, qui doit laissé cette fonctionnalité activé après avoir réinitialisé le hardware...

n°984619
TKz
Posté le 27-11-2007 à 12:56:25  profilanswer
 

acheron2 a écrit :


et si, le wake on lan dépend également de l'OS, plus précisément du pilote de ta carte réseau, qui doit laissé cette fonctionnalité activé après avoir réinitialisé le hardware...


Ce qui il me semble est laissé par défaut, en tout cas sur un 8139 sur debian c'est le cas ...
Au passage : http://gsd.di.uminho.pt/jpo/software/wakeonlan/
C'est quand même l'auteur qui écrit "Wakeonlan is a Perl script that sends 'magic packets' ..."
 
Et pour le problème de Gavrinis, as tu essayé de modifier ton modules.conf pour ajouter :
"options ethX enable_wol=1" ?
 
X le numéro de ton interface

Message cité 1 fois
Message édité par TKz le 27-11-2007 à 12:57:32
n°984728
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 27-11-2007 à 15:06:42  profilanswer
 

TKz a écrit :


Ce qui il me semble est laissé par défaut, en tout cas sur un 8139 sur debian c'est le cas ...
Au passage : http://gsd.di.uminho.pt/jpo/software/wakeonlan/
C'est quand même l'auteur qui écrit "Wakeonlan is a Perl script that sends 'magic packets' ..."
 
Et pour le problème de Gavrinis, as tu essayé de modifier ton modules.conf pour ajouter :
"options ethX enable_wol=1" ?
 
X le numéro de ton interface


 
Oui bah peut mettre mais quand tu met l'option 'g' je crois avec ethtool (aka magic packet) la carte attend un paquet ethernet forgé, que seul etherwake peut faire en root. wakelone envoie un paquet udp sur le port discard. Je maintiens.

n°984912
Gavrinis
Open your mind
Posté le 27-11-2007 à 20:27:34  profilanswer
 

J'ai essayé toutes les possibilités de configurer le WoL avec ethtool et soit c'est trop sensible (l'ordi se réveille dès qu'on accède au réseau sans pour autant vouloir allez vers lui) soit il ne se passe rien.
 
Tant pis je vais abandonner alors :(
 
 
Si ça peut aider quelqu'un voici mes différents essais, ça passera peut-être vous :
ethtool -s eth0 wol p|u|m|b|a|g|s|d
 

  • p  Wake on phy activity
  • u  Wake on unicast messages // trop sensible
  • m  Wake on multicast messages
  • b  Wake on broadcast messages // trop sensible
  • a  Wake on ARP
  • g  Wake on MagicPacket(tm)
  • s  Enable SecureOn(tm) password for MagicPacket(tm)
  • d  Disable (wake on nothing). This option clears all previous options.

n°984917
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 27-11-2007 à 20:35:14  profilanswer
 

Putain mes messages ils sont transparents ou bien vous comprenez rien ?

n°984922
Riot
Buy me a riot
Posté le 27-11-2007 à 20:38:01  profilanswer
 

Ptain, je comprends pas, j'utilise wakeonlan et ça marche pas ...
Pourtant j'ai bien utilsé ethtool pour préparer ma carte réseau.


---------------
Be the one with the flames.
n°984928
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 27-11-2007 à 20:48:53  profilanswer
 

PUTAIN SI VOUS AVEZ MIS LA CARTE EN MODE MAGIC PACKET AKA 'G' IL FAUT UTILISER ETHERWAKE ET PAS WAKEONLAN

n°984930
o'gure
Modérateur
Multi grognon de B_L
Posté le 27-11-2007 à 20:56:04  profilanswer
 

M300A a écrit :

Putain mes messages ils sont transparents ou bien vous comprenez rien ?


Non non je les vois bien

M300A a écrit :

PUTAIN SI VOUS AVEZ MIS LA CARTE EN MODE MAGIC PACKET AKA 'G' IL FAUT UTILISER ETHERWAKE ET PAS WAKEONLAN


C'est presque pas une raison pour gueuler [:cupra]


---------------
Ton Antoine commence à me les briser menus !
n°984933
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 27-11-2007 à 20:57:45  profilanswer
 

Bah j'ai perdu une heure la dessus y'a pas un mois et ça fait trois fois que je leur explique le problème. C'est un peu ennervant quand même non ?

n°984934
o'gure
Modérateur
Multi grognon de B_L
Posté le 27-11-2007 à 21:00:56  profilanswer
 

Je comprend mais bon, un minimun de calme tout ca :/ [:cupra]

 

Bon Gavrinis tu as compris ce M300A a expliqué ou alors tu le zappes complètement ?


Message édité par o'gure le 27-11-2007 à 21:01:18

---------------
Ton Antoine commence à me les briser menus !
n°984943
Gavrinis
Open your mind
Posté le 27-11-2007 à 21:26:20  profilanswer
 

non j'ai compris

n°984944
o'gure
Modérateur
Multi grognon de B_L
Posté le 27-11-2007 à 21:26:55  profilanswer
 

Et ca fonctionne ou tu as encore des problèmes ?


---------------
Ton Antoine commence à me les briser menus !
n°984947
Gavrinis
Open your mind
Posté le 27-11-2007 à 21:34:06  profilanswer
 

effectivement ça fonctionne :ouimaitre:

n°984951
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 27-11-2007 à 22:01:09  profilanswer
 

:sarcastic:
 
L'important c'est que vous ayez apris quelque chose quand même :)

n°984952
o'gure
Modérateur
Multi grognon de B_L
Posté le 27-11-2007 à 22:06:08  profilanswer
 

Faudrait juste que tu travailles un petit peu sur ta pédagogie :p [:aloy]
[:cupra]


Message édité par o'gure le 27-11-2007 à 22:06:14

---------------
Ton Antoine commence à me les briser menus !
n°984953
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 27-11-2007 à 22:07:34  profilanswer
 

PUTAIN ELLE TE PLAIT PAS MA PEDAGOGIE ? :D

n°984968
TKz
Posté le 27-11-2007 à 23:09:42  profilanswer
 

M300A a écrit :

PUTAIN ELLE TE PLAIT PAS MA PEDAGOGIE ? :D


Bon, t'avais raison, en revanche, je comprend pas l'appellation magic packet ?!
Pourquoi certains tools disent qu'ils envoient des magics packets alors que c'est pas vrai ? Quelle est la différence avec un "vrai" magic packet ?
 
Merci  :jap:

n°984970
zecrazytux
Posté le 27-11-2007 à 23:26:49  profilanswer
 

M300A a écrit :

PUTAIN ELLE TE PLAIT PAS MA PEDAGOGIE ? :D


 
moi j'aime bien, j'avais envi de poster un " :p " a chaque réponse \O/ ;)

n°985018
Hrolf
Posté le 28-11-2007 à 08:50:30  profilanswer
 

TKz a écrit :


Bon, t'avais raison, en revanche, je comprend pas l'appellation magic packet ?!
Pourquoi certains tools disent qu'ils envoient des magics packets alors que c'est pas vrai ? Quelle est la différence avec un "vrai" magic packet ?
 
Merci  :jap:


 
Si je me rappel bien en fait l'OS et le chargement du drivers laisse tes cartes dans des modes differents.
 
Le "vrais" WoL ne traitera que les paquets de la couche ethernet, donc un "MagicPacket" qui est une trame ethernet spécial, qui est un traitement purement Hardware.
Dans d'autres cas une partie de l'OS/du drivers reste chargé en mémoire, il est donc capable de  traiter des infos des couches de protocole suppérieur(en l'occurence ici l'UDP) et peut reveiller le PC "en veille" et non pas le PC "eteint" c'est pour ça que ça amrche avec windows qui doit être non pas eteint mais en veille prolonge (STR ou STD).
 
Si je me rappel bien on les appels "WoL Hardware" et "WoL internet" respectivement pour faire la difference.
 
Après, mes derniers tests date d'il y a plus de 6 ans, donc ma mémoire fait peut être faillite depuis le temps  :o


---------------
Il y a trois sortes de mensonges : les mensonges, les gros mensonges et les statistiques !
n°985043
Riot
Buy me a riot
Posté le 28-11-2007 à 09:39:13  profilanswer
 

Riot a écrit :

Ptain, je comprends pas, j'utilise wakeonlan et ça marche pas ...
Pourtant j'ai bien utilsé ethtool pour préparer ma carte réseau.


 

M300A a écrit :

PUTAIN SI VOUS AVEZ MIS LA CARTE EN MODE MAGIC PACKET AKA 'G' IL FAUT UTILISER ETHERWAKE ET PAS WAKEONLAN


 
[:afrojojo]


---------------
Be the one with the flames.
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Résolu] WoL Debian fonctionne dans certains cas

 

Sujets relatifs
Erreur de compilation driver nvidia (résolu)[Resolu]Arret du disque dur répété sur hp 8510p
serveur de sauvegarde debianChanger de gestionnaire de fenetres sous debian
Debian ETCH, command lpadmin not found ??APACHE 2 sous DEBIAN vérification de code à la compilation
[resolu] [debian etch] serveur ntp[RESOLU] SWITCH, PASSERELLE et prises de tête
Debian : Son à réactiver après chaque démarrage 
Plus de sujets relatifs à : [Résolu] WoL Debian fonctionne dans certains cas


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR