Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2145 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Erreur de compilation driver nvidia (résolu)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Erreur de compilation driver nvidia (résolu)

n°983459
nikwist
Posté le 24-11-2007 à 16:11:28  profilanswer
 

Bonjour, j'ai un soucis lors de l'installation du driver nvidia. Je vois vraiment pas d'où ça peut venir.
 
J'utilise les sources du noyau 2.6.23.
 
Ici, c'est le driver 1.0-9755-pkg1 parce que j'en ai essayé plusieurs mais j'ai la même erreur sur chaque.
 
 

Citation :

In file included from include/linux/list.h:8,
                    from include/linux/preempt.h:11,
                    from include/linux/spinlock.h:49,
                    from include/linux/seqlock.h:29,
                    from include/linux/time.h:8,
                    from include/linux/timex.h:57,
                    from include/linux/sched.h:53,
                    from include/linux/utsname.h:35,
                    from /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src
   /nv/nv-linux.h:19,
                    from /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src
   /nv/nv.c:14:
   include/linux/prefetch.h: In function ‘prefetch_range’:
   include/linux/prefetch.h:62: warning: pointer of type ‘void *’ used in a
   rithmetic
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: At top level
   :
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:110: error: e
   xpected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before â
   €˜*’ token
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function  
   â€˜nvos_create_alloc’:
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:460: error: â
   €˜nv_pte_t_cache’ undeclared (first use in this function)
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:460: error: (
   Each undeclared identifier is reported only once
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:460: error: f
   or each function it appears in.)
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function  
   â€˜nvos_free_alloc’:
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:492: error: â
   €˜nv_pte_t_cache’ undeclared (first use in this function)
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function  
   â€˜__nv_setup_pat_entries’:
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:955: warning:
   comparison between signed and unsigned
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function  
   â€˜__nv_restore_pat_entries’:
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:981: warning:
   comparison between signed and unsigned
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function  
   â€˜nv_kern_cpu_callback’:
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1287: warning
   : comparison between signed and unsigned
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1294: warning
   : comparison between signed and unsigned
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function  
   â€˜nvidia_init_module’:
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1420: error:  
   â€˜nv_pte_t_cache’ undeclared (first use in this function)
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1420: error:  
   too many arguments to function ‘kmem_cache_create’
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1554: error:  
   void value not ignored as it ought to be
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function  
   â€˜nvidia_exit_module’:
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1581: error:  
   void value not ignored as it ought to be
   /tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1685: error:  
   â€˜nv_pte_t_cache’ undeclared (first use in this function)
   make[4]: *** [/tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.o
   ] Erreur 1
   make[3]: *** [_module_/tmp/selfgz6930/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src
   /nv] Erreur 2
   make[2]: *** [modules] Erreur 2
   NVIDIA: left KBUILD.
   nvidia.ko failed to build!
   make[1]: *** [module] Erreur 1
   make: *** [module] Erreur 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file


 
Je voudrais pouvoir rejouer à UT  [:jocenbsp]


Message édité par nikwist le 11-01-2008 à 19:53:22
mood
Publicité
Posté le 24-11-2007 à 16:11:28  profilanswer
 

n°983461
Riot
Buy me a riot
Posté le 24-11-2007 à 16:17:09  profilanswer
 

aptitude update
aptitude install module-assistant
m-a a-i nvidia
 
et roulez jeunesse ;)


---------------
Be the one with the flames.
n°983483
nikwist
Posté le 24-11-2007 à 17:09:28  profilanswer
 

Ça ne me crée pas le module nvidia ça [:online]  
 
Ca installe le driver proprio ?

n°983484
Riot
Buy me a riot
Posté le 24-11-2007 à 17:10:15  profilanswer
 

Ben oué.


---------------
Be the one with the flames.
n°983485
nikwist
Posté le 24-11-2007 à 17:15:12  profilanswer
 

c'est bizarre, parce que ça m'a pas créé mon module ; j'ai du rater un truc :/

n°983486
Riot
Buy me a riot
Posté le 24-11-2007 à 17:16:48  profilanswer
 

Comment t'es sûr de ça ?


---------------
Be the one with the flames.
n°983487
Riot
Buy me a riot
Posté le 24-11-2007 à 17:18:05  profilanswer
 

Ah ok, t'es en 2.6.23.
Je peux rien pour toi alors, vu que ce noyau n'est pas encore dispo dans Debian.


---------------
Be the one with the flames.
n°983488
nikwist
Posté le 24-11-2007 à 17:24:13  profilanswer
 

arf.

 

je suis sous debian, je suis allé cherché les sources sur kernel.org >_<

 

tu me conseillerais de repasser en 2.6.22 ?


Message édité par nikwist le 24-11-2007 à 17:24:33
n°983490
Riot
Buy me a riot
Posté le 24-11-2007 à 17:26:57  profilanswer
 

oué. En 2.6.22 avec les paquets Debian + la méthode que j'ai donné plus haut.


Message édité par Riot le 24-11-2007 à 17:27:26

---------------
Be the one with the flames.
n°983491
nikwist
Posté le 24-11-2007 à 17:28:23  profilanswer
 

ok j'essaierai ça quand je rentrerai ce soir.
 
merci

mood
Publicité
Posté le 24-11-2007 à 17:28:23  profilanswer
 

n°983590
nikwist
Posté le 25-11-2007 à 01:18:32  profilanswer
 

J'ai réussi à compiler le module, donc c'était bien le problème du noyau.
 
C'est bon avec le 2.6.22.
 
Petite question par contre : j'ai modifié le driver dans le fichier xorg.conf en remplaçant 'nv' par 'nvidia' mais ça ne marche pas. Pourtant j'ai chargé le module.
 

Citation :

Section "Device"
        Identifier      "nVidia Corporation NV34 [GeForce FX 5200]"
        Driver          "nvidia"
        BusID           "PCI:2:0:0"
EndSection


 
Le log de Xorg me donne ça :
 

Citation :

(II) Module nvidia: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Video Driver
(EE) NVIDIA(0): ============= WARNING WARNING WARNING WARNING =============
(EE) NVIDIA(0): This server has a video driver ABI version of 2.0 but this
(EE) NVIDIA(0):     driver is designed to work with versions before 2.0.
(EE) NVIDIA(0):     Please check http://www.nvidia.com/ for driver updates or
(EE) NVIDIA(0):     downgrade to an X server with a supported driver ABI.
(EE) NVIDIA(0): ===========================================================

n°983698
nikwist
Posté le 25-11-2007 à 17:21:20  profilanswer
 

J'ai essayé d'utiliser l'option -ignoreABI comme stipulé sur certains sites, mais il veut quand même me faire le test ABI. Là ça m'échappe.

n°983770
e_esprit
Posté le 25-11-2007 à 20:04:16  profilanswer
 

tu le passes comment le -ignoreABI ?


Message édité par e_esprit le 25-11-2007 à 20:04:24

---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°983786
nikwist
Posté le 25-11-2007 à 20:38:16  profilanswer
 

je l'ai mis directement dans xorg.cong (comme expliquer dans la doc man) :
 

Citation :

Section "ServerFlags"
Option "IgnoreABI" "off"
EndSection


 
Et j'ai aussi essayer dans le script de configuration de gdm, comme expliquer là : http://mail.gnome.org/archives/gdm [...] 00016.html
 
Aucun des deux ne marche chez moi.

n°983800
e_esprit
Posté le 25-11-2007 à 21:03:09  profilanswer
 

Oui mais là il est à off [:delarue2]


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°983802
Riot
Buy me a riot
Posté le 25-11-2007 à 21:04:17  profilanswer
 

[:ddr555]


---------------
Be the one with the flames.
n°983857
nikwist
Posté le 25-11-2007 à 23:39:27  profilanswer
 

e_esprit a écrit :

Oui mais là il est à off [:delarue2]


en fait je l'avais mis en off pour voir parce qu'en on ça marchait pas :D

n°983996
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 26-11-2007 à 10:41:04  profilanswer
 

Au passage ton erreur plus haut ça ressemble fortement à un drivers i386 sur de l'amd64... Faudrait choisir la bonne arch hein :D
 
Sinon +1 pour le kernel debian et m-a évidemment.

n°984292
nikwist
Posté le 26-11-2007 à 18:18:02  profilanswer
 

Nan mais j'ai un AMD XP hein. Le retour au noyau 2.6.22 a résolu ce problème. C'est plus ça le soucis :p

n°984976
nikwist
Posté le 27-11-2007 à 23:46:06  profilanswer
 

Manifestement j'ai posé une sacré colle.
 
Ou alors je suis trop con et c'est tellement évident que je vois pas la solution :cry:

n°985072
e_esprit
Posté le 28-11-2007 à 10:17:26  profilanswer
 

essayes deja de le lancer à la main, sans GDM, depuis une console :
startx -- -ignoreABI


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°985073
Riot
Buy me a riot
Posté le 28-11-2007 à 10:19:47  profilanswer
 

C'est marrant, j'ai pas eu à passer cette option quand je suis passé à Xorg 7.3 ... :??:

 


edit : ah, ce sont les 97.55 dont il est question, ok. J'ai rien dit.


Message édité par Riot le 28-11-2007 à 10:20:31

---------------
Be the one with the flames.
n°986534
nikwist
Posté le 02-12-2007 à 11:50:01  profilanswer
 

e_esprit a écrit :

essayes deja de le lancer à la main, sans GDM, depuis une console :
startx -- -ignoreABI


j'ai toujours la même erreur :/

 

mais c'est bizarre, l'option devrait marcher ; personne n'a le même problème ?


Message édité par nikwist le 02-12-2007 à 11:50:35
n°986540
Riot
Buy me a riot
Posté le 02-12-2007 à 12:33:49  profilanswer
 

Nan, t'as pas moyen de mettre des drivers plus récents ?


---------------
Be the one with the flames.
n°986542
nikwist
Posté le 02-12-2007 à 12:43:03  profilanswer
 

j'ai déjà les plus récents : NVIDIA-Linux-x86-100.14.11-pkg1

n°986545
Riot
Buy me a riot
Posté le 02-12-2007 à 12:58:15  profilanswer
 

Mais t'as quelle version d'Xorg ?
Moi j'ai ça :

Citation :

X.Org X Server 1.4.0
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.1~git20071119-1)


(1ères lignes du log)


Message édité par Riot le 02-12-2007 à 12:58:40

---------------
Be the one with the flames.
n°986558
nikwist
Posté le 02-12-2007 à 13:45:02  profilanswer
 

La même.

n°1000783
nikwist
Posté le 11-01-2008 à 19:52:58  profilanswer
 

J'ai résolu le problème, en installant les nouveaux drivers et en répondant "oui" à la question "Voulez-vous que les changements dans le xorg.conf soient générés automatiquement ?"
 
J'avais pas du le faire la dernière fois :/
 
Alors maintenant je vais me pendre 48H par les pieds pour corriger mon incompétence  :pfff:

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Erreur de compilation driver nvidia (résolu)

 

Sujets relatifs
[Resolu]Arret du disque dur répété sur hp 8510ppilote nvidia qui n'existe pas
APACHE 2 sous DEBIAN vérification de code à la compilationerreur de segmentation - Bidwatcher et Mdv2008
erreur guildwars avec crossover linux[resolu] [debian etch] serveur ntp
[RESOLU] SWITCH, PASSERELLE et prises de têteCompilation E17, manque ecore-config.
[RESOLU] UBUNTU install ADSL[Résolu] Fluxbox et gnome ne cohabitent pas bien
Plus de sujets relatifs à : Erreur de compilation driver nvidia (résolu)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR