Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2016 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Debian] Connexion internet à traver le réseau local

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Debian] Connexion internet à traver le réseau local

n°458414
Dunwael
Posté le 17-04-2004 à 21:30:48  profilanswer
 

Bonjour à tous,  
 
Je me vois obligé de demander de l'aide puisque je suis incapable de trouver sur le net une solution à mon problème (faut dire je dois être le seul)...
 
Je possède une Debian Sid 2.6.5 (mise à jour récente 12-04-04) connecté à un modem routeur par dhcp, comme 2 autres PC (un XP un Debian). Tout fonctionnait parfaitement jusqu'à avant hier matin...
 
J'allume le pc, et pas de connexion internet :
ping www.google.fr --> unknown host
ping 216.239.51.101 --> 100 % packet loss
 
 Je peux pinguer mon routeur, les deux autres pc. Ils peuvent eux acceder au net, la partition Windows du pc problématique aussi, mais impossible depuis Debian
 
La table de routage est correcte (et identique à celle du second pc qui fonctionne) et n'ayant rien changé depuis la veille, je m'interroge ...
 
Puis, hier, après d'infructueux essais de tout et de n'importe quoi, je me décide à vous demander de l'aide, et du coup je lance mozilla sur le pc défaillant (pur réflexe  :sarcastic: ) Et là ca marche alors que une demi-heure auparavant rien.
 
Je me gratte la tête, mais profite de nouveau du net sur mon cher PC, puis je reboote sous XP histoire de me fowarder mes mails reçus durant la panne afin de les avoir archivés sous linux. Je reboote la Debian. Et rebelote, plus de connexion internet...
 
1°) Je désespère
2°) Je ne veux pas attendre un hypothétique retour mystérieux du net, l'informatique étant une science inexacte uniquement sous Windows ; Je veux comprendre et résoudre !
3°) Je voudrais bien pouvoir rebooter au éteindre le pc en toute sécurité de temps en temps, aussi, juste histoire de pas être privé du net par une simple panne de courant ou une soeur perplexe face à KDE
 
Merci d'avance pour votre aide (Au secours !)

mood
Publicité
Posté le 17-04-2004 à 21:30:48  profilanswer
 

n°458453
911GT3
en roue libre
Posté le 17-04-2004 à 22:34:28  profilanswer
 

et si tu fais un traceroute vers l'exterieur, ça bloque où ?

n°458484
Dunwael
Posté le 17-04-2004 à 23:27:29  profilanswer
 

traceroute 66.102.9.104 (au lieu de www.google.fr car pas de DNS) -->
 
 
Traceroute to 66.102.9.104 (66.102.9.104), 30 hops max, 38 byte packets
 
 1  * * *
 2  212.129.20.230 (212.129.20.230)  63.713 ms  63.312 ms  61.931 ms
 3  213.36.82.62 (213.36.82.62)  64.057 ms  61.873 ms  62.174 ms
 4  213.36.82.110 (213.36.82.110)  63.810 ms  63.745 ms  62.058 ms
 5  212.129.8.6 (212.129.8.6)  62.059 ms  63.746 ms  63.930 ms
 6  213.200.76.201 (213.200.76.201)  66.186 ms  65.865 ms  61.812 ms
 7  213.200.81.57 (213.200.81.57)  70.057 ms  69.851 ms  70.053 ms
 8  195.66.226.125 (195.66.226.125)  71.936 ms  67.853 ms  71.930 ms
 9  * * *
 
De 2 à 7, c'est mon fournisseur d'accès... Si je trace une autre IP, là aussi il bloque après mon FAI; Après avoir comparé avec un tracert sur le PC XP où j'écris en ce moment, je constate que la trace se perd toujours à la passerelle précédent l'IP tracée...

n°458485
911GT3
en roue libre
Posté le 17-04-2004 à 23:37:48  profilanswer
 

:pt1cable:

n°458488
Dunwael
Posté le 17-04-2004 à 23:47:55  profilanswer
 

lol, c'est aussi ma réponse à ce fascinant problème. Si encore aucun de mes PC, debian comme XP, ne pouvaient se connecter, je saurais à quoi m'en tenir...

n°458537
911GT3
en roue libre
Posté le 18-04-2004 à 09:56:53  profilanswer
 

J'ai fait le même traceroute pour voir et

traceroute to 66.102.9.104 (66.102.9.104), 30 hops max, 38 byte packets
 1  pacha (192.168.0.1)  0.403 ms  0.293 ms  0.230 ms
 2  lns-p19-4-81-56-20-254.adsl.proxad.net (81.56.20.254)  5.965 ms  5.381 ms  5.346 ms
 3  stmaurice-6k-1-a5.routers.proxad.net (213.228.14.254)  5.645 ms  6.448 ms  6.714 ms
 4  cbv-6k-2-a6.routers.proxad.net (213.228.3.7)  25.167 ms  6.780 ms  6.581 ms
 5  lambdanet.FreeIX.net (213.228.3.243)  6.753 ms  7.081 ms  7.588 ms
 6  PZU-1-ge020.fr.lambdanet.net (217.71.96.85)  26.866 ms  6.680 ms  6.583 ms
 7  F-1-pos300.de.lambdanet.net (217.71.96.33)  27.390 ms  18.169 ms  17.405 ms
 8  F-8-eth300-98.de.lambdanet.net (217.71.105.66)  27.869 ms  18.688 ms  18.777 ms
 9  Google-F.de.lambdanet.net (217.71.111.38)  29.148 ms  19.614 ms  18.385 ms
10  216.239.48.146 (216.239.48.146)  57.739 ms  57.997 ms  58.344 ms
11  64.233.174.50 (64.233.174.50)  58.754 ms  57.985 ms 216.239.49.9 (216.239.49.9)  58.887 ms
12  64.233.175.185 (64.233.175.185)  58.994 ms  58.706 ms 64.233.174.186 (64.233.174.186)  58.187 ms
13  64.233.174.18 (64.233.174.18)  61.461 ms  60.938 ms  60.590 ms
14  * * *
15  * * *
16  * * *
17  * *


 
Pourtant, j'accède sans problème au site. L'explication doit encore être ailleurs.

n°458540
Dunwael
Posté le 18-04-2004 à 10:09:07  profilanswer
 

Le plus drôle, c'est que j'hésite à chercher : La je suis entrain de répondre avec ma debian, comme "promis" la connexion s'est rétablie toute seule pendant la nuit (soupir...)
 
Dès que vous désirez que je tente autre chose, je rebooterai (lol nerveux jaune) !

n°458975
Dunwael
Posté le 19-04-2004 à 05:01:54  profilanswer
 

Je vais pêter un boulon, je pense... Petite modification de GRUB, donc reboot obligatoire (en serant les dents) et ...
 
 
Plus de connexion internet...
Et faut que ca m'arive pile le matin ou je dois relever mes emails avant de partir à l'autre bout de la France !  
 
Finalement Linux et Windows, même combat chez moi. Je pense ressortir  mon vieil Amstrad CPC... Vous croyez qu'on peut le faire naviguer sur internet ???

n°464478
Dunwael
Posté le 26-04-2004 à 21:37:12  profilanswer
 

Ok, problème résolu n'importe comment...
 
C'était le script dhcp qui effaçait le resolv.conf à chaque démarrage (je n'ai pas très bien compris pourquoi) ; Ne voulant pas toucher au script, j'ai interdit l'accès au fichier en écriture et du coup j'ai trois-quatre messages d'erreur au démarrage, mais au moins je conserve ma connexion au net !
 
Merci à 911GT3 pour ton aide !

n°464504
Humidifier
Posté le 26-04-2004 à 22:26:58  profilanswer
 

Quel est la gueule de ton /etc/network/interfaces
 
Perso voici le mien:
# L'interface "loopback"
auto lo
iface lo inet loopback
 
# L'interface "eth0" (Freebox) connectée à Internet (configuration par DHCP)
auto eth0
iface eth0 inet dhcp
 
# L'interface "eth1" connectée au réseau local (IP privée fixe)
auto eth1
iface eth1 inet static
        address 192.168.0.1
        netmask 255.255.255.0
        name Carte Ethernet
        broadcast 192.168.0.255
        network 192.168.0.0

mood
Publicité
Posté le 26-04-2004 à 22:26:58  profilanswer
 

n°464979
Dunwael
Posté le 27-04-2004 à 15:19:01  profilanswer
 

Humidifier a écrit :

Quel est la gueule de ton /etc/network/interfaces
 


 
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
 
# This entry denotes the loopback (127.0.0.1) interface.
auto lo
iface lo inet loopback
 
# This entry was created during the Debian installation
# Carte réseau Gigabit -- Connectée au routeur par dhcp
auto eth0
iface eth0 inet dhcp
~

n°466219
monstermax
Posté le 28-04-2004 à 23:52:11  profilanswer
 

j'ai deja eu ce genre de probleme. ayant 2 connexions sur la meme machine, mon fichier resolv.conf etait ecrasé regulierement par le dhcp de ma connexion cable. pour resoudre (pas tres proprement) le probleme j'ai ajouté dans le cron un script ki reecrase le resolv.conf par une copie que j'ai fait.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Debian] Connexion internet à traver le réseau local

 

Sujets relatifs
Conf réseau sur MDK 10.0Debian noyau 2.6.5 . probleme avec bind. spécialiste a l'aide svp.
Installer Debian sur un disque de 160 gognome 2.6 pour debian debian
Openbsd : selectionner un autre driver pour la carte reseau[Debian SID] pb de scanner
[Debian]Comment attribuer automatiquement ip a une carte rezo pcmcia ?Carte Raid SCSI Adaptec 2120S ininstallable sur debian ?
question sur debianProblème mots de passe sur réseau domestique
Plus de sujets relatifs à : [Debian] Connexion internet à traver le réseau local


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR