Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1559 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  RADEON AIW, j'arrive pas installer les pilotes GAto => pb résolu

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

RADEON AIW, j'arrive pas installer les pilotes GAto => pb résolu

n°192747
cedricbrun
Posté le 21-11-2002 à 12:10:44  profilanswer
 

Bah vraiment j'y arrive pô,  
XFREE plante completement au demarrage..
J'ai viré tous ce qui était DRM sur mon noyau,  
J'ai compilé DRM-kernel de chez gatos et insereé RADEON.O dans le noyaux.  
ET zou, Xfree par dans un mauvais trip ..
 
HELLP !


Message édité par cedricbrun le 24-11-2002 à 13:11:41
mood
Publicité
Posté le 21-11-2002 à 12:10:44  profilanswer
 

n°192749
Mjules
Modérateur
Parle dans le vide
Posté le 21-11-2002 à 12:13:55  profilanswer
 

et si tu nous donnait 1 peu + de renseignements hein ...


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°192814
cedricbrun
Posté le 21-11-2002 à 13:52:51  profilanswer
 

Mjules a écrit a écrit :

et si tu nous donnait 1 peu + de renseignements hein ...




Bah je suis sous Debian 3R0.0.
Xfree4.1
Je voulais les pilotes les plus récents de chez Gatos afin d'avoir un bon support materiel et surtout pour la TV.
 
J'ai pas dû bien piger l'installation, C pas clair pour moi..
Si quelqu'un l'avait déjà fait ce serait cwel ;)


Message édité par cedricbrun le 21-11-2002 à 14:01:21
n°193747
cedricbrun
Posté le 23-11-2002 à 09:51:48  profilanswer
 

Voici la démarche que j'ai suivie :
d'abord j'ai installé le kernel 2.4.19 et activé le suport DRM pour RADEON.
redemmarage, test, OK, le DRI fonctionne (GLXGEARS > 700 fps)
 
Ensuite j'ai voulu installer les derniers pilotes pour avoir un meilleur support de la Télé, e par la même occasion une meilleure accélération materielle..
 
Je ramène l'archive ATI2.trucmuch pour XFREE 4.1 et je la décompresse comme indiqué là ou il faut.
je vire le module RADEON de mon noyau histoire de pas creer de conflits...
Je redemmarre => plus de DRM, GLXGEARS : 60-70 fps
 
J'ai ensuite essayé de compiler l'archive drm-kernel de chez gatos...Je l'ai collée direct dans les sources de mon noyaux à la place du support DRM classique,  en remplaçant le fichier Makefile par le fichier Makefile.kernel,Je compile: OK,  
Je redémarre => Xfree Plante au démarrage et fait planter tout mon beau Nux, ouin!!!!
 
Comment dois-je faire SVP ?

n°193749
mean
Posté le 23-11-2002 à 09:59:27  profilanswer
 

Upgrade en Xfree4.2, et prend les derniers gatos
 
J'ai cru comprendre que le couple 4.1 et gatos etait pas genial

n°193752
cedricbrun
Posté le 23-11-2002 à 10:08:57  profilanswer
 

mean a écrit a écrit :

Upgrade en Xfree4.2, et prend les derniers gatos
 
J'ai cru comprendre que le couple 4.1 et gatos etait pas genial



Pour XFree 4.2 faut que j'installe les sources alors ?!?
Y'a pas de .deb ?

n°193756
mean
Posté le 23-11-2002 à 10:19:18  profilanswer
 

Sisi il y en a
http://people.debian.org/~branden/sid/i386/
 
Tu remplaces sid par woody
   

n°193760
cedricbrun
Posté le 23-11-2002 à 10:32:27  profilanswer
 

mean a écrit a écrit :

Sisi il y en a
http://people.debian.org/~branden/sid/i386/
 
Tu remplaces sid par woody
   
 




Bah  quand je remplace sid par woddy y'a pu de packages.. :??:

n°193771
jyp
>-<o>-<
Posté le 23-11-2002 à 11:34:08  profilanswer
 

chez moi les derniers drivers gatos (V15), ne marchent pas avec ma radeon AIW! mais je n'ai pas de problème avec la version 14, par contre, j'utilise la dernière version AV viewer (0.10.8), j'utilise xfree 4.2.1 sur une Gentoo 1.2
 
Sinon une p'tite question, on peut utiliser un autre soft AV viewer pour regarder la TV? Xawdecode par exemple?


---------------
Jyp
n°193773
jyp
>-<o>-<
Posté le 23-11-2002 à 11:38:22  profilanswer
 

mean a écrit a écrit :

Upgrade en Xfree4.2, et prend les derniers gatos
 
J'ai cru comprendre que le couple 4.1 et gatos etait pas genial




Il y a juste à décompresser ATI-4.1.0.i386.tar.gz dans /usr!
ton répertoire (de xfree) s'appelle bien X11R6


Message édité par jyp le 23-11-2002 à 11:38:49

---------------
Jyp
mood
Publicité
Posté le 23-11-2002 à 11:38:22  profilanswer
 

n°194009
cedricbrun
Posté le 23-11-2002 à 21:01:43  profilanswer
 

jyp a écrit a écrit :

 
Il y a juste à décompresser ATI-4.1.0.i386.tar.gz dans /usr!
ton répertoire (de xfree) s'appelle bien X11R6




Mon repertoire est OK.
J'ai déjà décompressé l'archive dans /usr
Ils seraient donc installés alors ?
Comment le verifier  ??  
Quand je des-installe le module radeon de mon noyaux j'ai plus d'acclélération 3D, c donc ce module qui est utilisé et pas celui de gatos nan?
 

n°194028
jyp
>-<o>-<
Posté le 23-11-2002 à 21:40:00  profilanswer
 

tu as compilé AV viewer? sinon, compile le puis tu verras si tu as télé ou pas!


---------------
Jyp
n°194115
cedricbrun
Posté le 24-11-2002 à 09:32:01  profilanswer
 

jyp a écrit a écrit :

tu as compilé AV viewer? sinon, compile le puis tu verras si tu as télé ou pas!




Bah j'arrive bien à avoir la télé, donc ça marche...Mais lequel des pilotes est utilisé pour l'accélération, là est la question!
 
Quelqu'un sait comment le verifier ?
 
Accesoirement j'ai pas de son avec ma TV, mais C surement un problème de config, j'i pas encore instalé ALSA, y'a que OSS qui marche.

n°194128
jyp
>-<o>-<
Posté le 24-11-2002 à 10:50:34  profilanswer
 

Pour l'accélération 3d drivers DRI
http://dri.sourceforge.net/
 
fait un glxinfo si ta ca direct rendering: Yes tu as la 3D
ou glxgears et tu dois être à plus de 1000
 
un p'tit lien pour la 3D :
http://atifrst.nexenservices.com/index.php3?article=6
 
Pour le son tu as bien relier ta carte graphique à la carte son? le volume n'est pas à 0?


---------------
Jyp
n°194166
cedricbrun
Posté le 24-11-2002 à 12:20:15  profilanswer
 

Ma question est :
 Comment savoir si le module DRI utilisé est celui inclu dans le noyaux ou si c'est celui de gatos ?
 
Pour le son : oui ma carte est bien relièe  :sarcastic:
Avec Kmixer j'ai le son non muté et le volume monté (de ma line in)
 
ps : j'utilise Xawtv et non AViewer, je l'ai pas encore essayé celui-ci


Message édité par cedricbrun le 24-11-2002 à 12:21:38
n°194177
jyp
>-<o>-<
Posté le 24-11-2002 à 12:50:29  profilanswer
 

tu utilises toujours xfree 4.1? si oui, tu utilise les drm du kernel car il n'y a pas drm gatos pour xfree 4.1
sinon, (dans le cas xfree 4.2.X) tu utilise les drivers drm gatos


---------------
Jyp
n°194190
cedricbrun
Posté le 24-11-2002 à 13:10:57  profilanswer
 

jyp a écrit a écrit :

tu utilises toujours xfree 4.1? si oui, tu utilise les drm du kernel car il n'y a pas drm gatos pour xfree 4.1
sinon, (dans le cas xfree 4.2.X) tu utilise les drivers drm gatos
 




 
OKY
ça explique le plantage général quand je colle le drm-kernel avec Xfree 4.1 .
Merci beaucoup.
donc le mieux ce serait quand même de passer à Xfree 4.2... Tu sais si les perfs sont bien meilleures ou pas ?
 
 

n°194212
jyp
>-<o>-<
Posté le 24-11-2002 à 14:09:04  profilanswer
 

chez moi (radeon AIW) les drivers drm gatos me provoquent des plantages système avec certains jeux : Racer, Soldier Of Fortune et d'autre...


---------------
Jyp
n°194283
cedricbrun
Posté le 24-11-2002 à 15:52:46  profilanswer
 

jyp a écrit a écrit :

chez moi (radeon AIW) les drivers drm gatos me provoquent des plantages système avec certains jeux : Racer, Soldier Of Fortune et d'autre...




Dans ce cas je patienterai un peu, je vais d'abord essayer de regarder la TV ave Linux...  
AAAAARRRRGH je commence à arriver à faire marcher tout mon mato sous Nux, je connais un petit Zindows qui va sauter môa!


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  RADEON AIW, j'arrive pas installer les pilotes GAto => pb résolu

 

Sujets relatifs
Premiere utilisation de linux et pas moyen d installer carte reseaux!Pro de IMP : Imap support = no dans test.php RESOLU, mais autre prob !
pb compilation transcode sur mdk 9.0 [résolu][Debian] Comment installer le plus simplement la distrib ??
[cywin] Comment installer les packagesUnresolved Symbol et noyau 2.5.47 [Résolu, MAJ de modutils]
Son mais pas d image avec Xine et les divx[resolu] MAIS CA RAME! help!w2k advanced server en ntfs : je veux installer linux sur le meme DD
[MDK 8.2] Je n'arrive pas a lancer le script HLStats 1.02 [Résolu] 
Plus de sujets relatifs à : RADEON AIW, j'arrive pas installer les pilotes GAto => pb résolu


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR