Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1885 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Prob urpmi mandrake 10.1 off

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Prob urpmi mandrake 10.1 off

n°595752
alex4910a
Posté le 24-11-2004 à 23:52:22  profilanswer
 

Bonsoir à tous ! J'ai un petit probleme avec urpmi pour l'instal de kde 3.3.1. J'ai ajouté kde a mes sources, fait un urpmi --auto-select -v mais une fois fini, kde est completement cassé (plus d'icones, plus aucun prog ne se lance). Le seul moyen que j'avais trouvé pour installé kde est le rpm -Fvh --force *.rpm + quelques manips, ce qui fait quand meme bien bordel !
Pourquoi urpmi merde comme sa ? Et pourquoi y a t'il autant de problemes de dependances avec les rpms ? Car c'est le seul truc que je reproche a mandrake, et c'est également le seul truc qui me fait hésiter entre la mandrake 10.1 off et la gentoo 2004.3 (emerge pose bcp moins de probs !).
Quelqu'un a un moyen pour installer kde fiablement et proprement ? Car la il me faut presque prier avant une instal de kde pour qu'elle marche...

mood
Publicité
Posté le 24-11-2004 à 23:52:22  profilanswer
 

n°595783
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-11-2004 à 05:07:28  profilanswer
 

utilise gentoo alors !
http://forum.hardware.fr/hardwaref [...] 3363-1.htm
 
 
de toute façon les packages kde 3.3 pour mdk 10.1 ne sont ps supporté et ce que tu les prennes des CD ( si ceux de la Community merdent c'est normale, pas testés suffisament ), et ceux de club dispo sont fait par des contributeurs externes.
 
de même si tu ne sais aps lire les message pour voir que c'est rarement un pb de dep mais souvent un pb de conflict ( à cause d'un fichier qui a changé de package et que le gars qui a fait le package ne sais pas .. ) mais bon


Message édité par Dark_Schneider le 25-11-2004 à 05:09:51

---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°595854
alex4910a
Posté le 25-11-2004 à 12:11:30  profilanswer
 

Ben, oui mais les conflicts que j'ai c'est avec l'ancien kde 3.2.3. Comment les passer sans tout casser ? Et rpm -Fvh met a jour les fichiers déjà présents mais installe t'il aussi les paquets qui ne sont pas déjà sur le systeme ?

n°595899
alex4910a
Posté le 25-11-2004 à 13:24:21  profilanswer
 

Personne ?

n°595913
j_c_p
Linux user
Posté le 25-11-2004 à 13:41:22  profilanswer
 

faut apprendre à RTFMer avt de critiquer :o.

n°595927
alex4910a
Posté le 25-11-2004 à 14:18:10  profilanswer
 

?

n°595930
alex4910a
Posté le 25-11-2004 à 14:19:47  profilanswer
 

Y aurais pas un site qui explique COMPLETEMENT urpmi (commandes, fonctionnement, ...) ?

n°595932
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-11-2004 à 14:25:01  profilanswer
 

man urpmi
http://www.linux-wizard.net/howto. [...] article=42
 
mais le pb vient de toi. il y a un topic !!!!!!!


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°595954
alex4910a
Posté le 25-11-2004 à 15:34:56  profilanswer
 

Au fait pourquoi SuSE (par exemple), dit dans leur doc de faire rpm -Fvh pour mettre a jour kde a la place de rpm -Uvh ? Quel est la différence entre les deux ?

n°595959
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-11-2004 à 15:44:57  profilanswer
 

man rpm
 
 

Citation :


            rpm -U [options_installation] <fichier_paquetage>+
 
       Ceci  met  à  jour  ou installe le paquetage installé actuellement à la
       version du nouveau RPM.  Ceci est la  même  chose  que  l'installation,
       sauf que les autres versions du paquetage sont supprimées du système.
 
            rpm [-F|--rafraîchir] [options_installation] <fichier_paquetage>+
 
       Ceci  mettra  à  niveau  les paquetages, mais uniquement si une version
       plus ancienne existe actuellement.
 
       Le <fichier_paquetage> peut être spécifié par  une  URL  ftp  ou  http,
       auquel  cas  le  paquetage sera téléchargé avant d'être installé.  Voir
       OPTIONS FTP/HTTP pour obtenir des informations sur le  support  intégré
       de ftp et http par RPM.


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
mood
Publicité
Posté le 25-11-2004 à 15:44:57  profilanswer
 

n°595961
alex4910a
Posté le 25-11-2004 à 15:47:48  profilanswer
 

Donc si je comprend bien, avec rpm -Fvh si un paquetage est déjà installé il sera mis a jour, mais si il n'est pas installé, il ne sera pas installé par la commande alors qu'avec rpm -Uvh, si.

n°595964
alex4910a
Posté le 25-11-2004 à 15:55:44  profilanswer
 

Au fait, sa change de sujet mais est ce qu'un noyau 2.6.9-cko3 correctement configuré fonctionnera bien avec la mandrake ?

n°595965
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-11-2004 à 15:55:48  profilanswer
 

en effet


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°595968
alex4910a
Posté le 25-11-2004 à 16:01:24  profilanswer
 

Ok, merci ! Et pour l'histoire du kernel au dessus ?

n°595981
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-11-2004 à 16:28:25  profilanswer
 

je te le déconseille


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°596056
alex4910a
Posté le 25-11-2004 à 19:19:43  profilanswer
 

Pourquoi ?

n°596175
alex4910a
Posté le 26-11-2004 à 00:58:06  profilanswer
 

quelqu'un ?

n°596498
Dark_Schne​ider
Close the World, Open the Net
Posté le 26-11-2004 à 17:24:22  profilanswer
 

il se peut que certains pacths et/ou fonctionnalités spécifiques aux noyau mdk ne soit pas dans ton nouveau noyau.
 
mais bon, tu peux touurs essayer, tu verras bien ...
 
mais bon avant apprend à utiliser le système et notamment urpmi et rpm et à réagir quand 2 packages entrent en conflict ( soit forcer, soit virer le package qui est en conflict et mettre ensuite la nouvelle version de ce package )


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Prob urpmi mandrake 10.1 off

 

Sujets relatifs
[résolu] Mandrake 10.1 Changement à la hussarde AGP vers PCI express[Nvidia 6629] [Mandrake 10.1] Problème Lightmap
mandrake 10.0 et 10.1Install Mandrake 10.1 et RAID
Perte de l'USB sur mandrake 10.1Mise à jour mandrake 10.1 community
mandrake 10.1, steam et linuxPb de permission d'accès sur dossiers/fichiers Mandrake
Installation de mandrake 10.1? problèmeprobleme son via sous mandrake 10.1
Plus de sujets relatifs à : Prob urpmi mandrake 10.1 off


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR