Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
957 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  xmms refuse de s'intaller..[Résolu (avec des bouts de urpmi dedans)]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

xmms refuse de s'intaller..[Résolu (avec des bouts de urpmi dedans)]

n°544068
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 12:15:30  profilanswer
 

:hello:  
 
J'essaye d'installer xmms 1.2.10 sur une Mandrake 10.
Ca bloque au ./configure sur ceci:

Citation :

checking for glib-config... no
checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
 

or y a glib 2.0 déjà installé... :kaola:  
 
Comment on résoud ce problème?


Message édité par power600 le 22-08-2004 à 08:54:47
mood
Publicité
Posté le 21-08-2004 à 12:15:30  profilanswer
 

n°544069
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 12:21:02  profilanswer
 

pourquoi veux tu installer xmms ?
de mémoire tu avais déja fait un précédent post que tu as semble t'il effacé
accessoirement il te demande de d'avoir la partie devel de glib d'installé .
enfin il existe des rpms pour xmms donc pourquoi vouloir encore une fois le compilé ?

n°544070
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 21-08-2004 à 12:22:13  profilanswer
 

mikala> c'est un autre pseudo qui a posé cette question (multi ?)

n°544072
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 12:26:10  profilanswer
 

peut etre j'ai un peu eu la flemme de chercher mais c'est vrai que la liste de multi est impressionnante :D

n°544075
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 12:29:57  profilanswer
 

?!?
Je n'ai pas souvenir d'avoir fait un topic ici, surtout pas sur le même sujet....Et j'ai pas l'habitude d'effacer mes rares topics.:)
 
Si un autre a posé la question sur ce problème j'ai pas trouvé (fait une recherche avant de poster).
 
Et pourquoi pas un RPM? ben, j'ai tellement l'habitude d'installer avec un ./configure & make & make install que je l'ai encore fait comme ça :p
 
P.S: Le forum voit pas actuellement tous mes multis  :whistle:
 
EDIT: J'ai cherché à installer glib-devel mais ça a foiré aussi..


Message édité par power600 le 21-08-2004 à 12:35:51
n°544103
Joseph Des​ire
Posté le 21-08-2004 à 12:58:47  profilanswer
 

Je faisais comme toi avant, mais finallement quand XMMS 1.2.9 se trouve sur le cd (le 1 et 2 me semble t-il), et bien c'est vachement plus reposant...  :)  
 
Et en plus ca marche de suite !


Message édité par Joseph Desire le 21-08-2004 à 12:59:39
n°544106
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 13:01:07  profilanswer
 

power600> si tu veux xmms 1.2.10 il est fourni ici http://www.eslrahc.com/10.0 :)

n°544111
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:03:14  profilanswer
 

Joseph Desire a écrit :

Je faisais comme toi avant, mais finallement quand XMMS 1.2.9 se trouve sur le cd (le 1 et 2 me semble t-il), et bien c'est vachement plus reposant...  :)  
 
Et en plus ca marche de suite !

Oui c'est ce que je vais faire mais j'aurais bien aimé savori comment résoudre ça..
l'install de glib-devel réclame gtk-devel noarch ou un truc comme ça maintenant  :pt1cable:


Message édité par power600 le 21-08-2004 à 13:04:41
n°544113
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 13:04:31  profilanswer
 

xmms étant en gtk , c'est normal que cela entraine cette implication ;)

n°544114
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:05:51  profilanswer
 

mikala a écrit :

xmms étant en gtk , c'est normal que cela entraine cette implication ;)

Ben, y a gtk d'installé aussi. Je poste avec un Firefox 0.9 qui en a besoin, je crois, et qui s'est installé sans problème..
 
je vais voir sur ton lien. :p
 
je croyais avoir installé tous les machins de développement mais j'ai du rater une étape ..


Message édité par power600 le 21-08-2004 à 13:07:11
mood
Publicité
Posté le 21-08-2004 à 13:05:51  profilanswer
 

n°544117
cycojesus
Mèo Lười
Posté le 21-08-2004 à 13:06:49  profilanswer
 

power600 a écrit :

:hello:  
 
J'essaye d'installer xmms 1.2.10 sur une Mandrake 10.
Ca bloque au ./configure sur ceci:

Citation :

checking for glib-config... no
checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
 

or y a glib 2.0 déjà installé... :kaola:  
 
Comment on résoud ce problème?


 
XMMS veux du Gtk 1 et il ne trouve pas, tu n'as que du Gtk 2. Cherche un package pour Mandrake ou essaye beep media player (xmms en gtk2).


---------------
Chết rồi ! ✍ ⌥⌘ http://github.com/gwenhael-le-moine/slackbuilds/
n°544121
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:11:49  profilanswer
 

cycojesus a écrit :

XMMS veux du Gtk 1 et il ne trouve pas, tu n'as que du Gtk 2. Cherche un package pour Mandrake ou essaye beep media player (xmms en gtk2).

Citation :

[root@PC2 bmp-0.9.6.1]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/power600/Nouveau: /home/power600/Nouveau: No such file or directory
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.1.0 gtk+-2.0 gthread-2.0 pangoft2... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
configure: error: "Cannot find glib2/gtk2/pango"

Rhaah  [:armelanuel]  [:twixy]


Message édité par power600 le 21-08-2004 à 13:12:18
n°544132
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:20:41  profilanswer
 

Même le xmms du CD refuse de s'installer parce que "libxmms1[== 1.2.10-0.1mdk]  est non satisfait"  
 
je vais retourner à Red hat parce que mandrake c'ets toujours pas ça  :heink:

n°544133
SuperZell
Posté le 21-08-2004 à 13:24:19  profilanswer
 

tu vas sur http://urpmi.org/easyurpmi/index.php
tu configure tes sources, puis urpmi xmms en root spa dur pourtant  :o

n°544139
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:30:42  profilanswer
 

Déjà essayé ça.
Tout ce qu'il sait dire maintenant c'est "base de données urpmi vérouillée"...

n°544143
esox_ch
Posté le 21-08-2004 à 13:31:56  profilanswer
 

C'est pas ce que dit mandrake quand il y a des mises a jour en cours et qu'on essaie d'utiliser urpmi ?


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°544145
SuperZell
Posté le 21-08-2004 à 13:32:44  profilanswer
 

power600 a écrit :

Déjà essayé ça.
Tout ce qu'il sait dire maintenant c'est "base de données urpmi vérouillée"...


 
c'est que ta surement urpmi ou rpmdrake qui tourne qq part reboot
ya pas de raison pour que sa ne marche pas
 
ta bien mit les source main contrib plf etc...??

n°544146
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:37:31  profilanswer
 

Déjà rebooté plusieurs fois (suis souvent sous windows aussi)
Pour les sources, comment on peut vérifier ça?

n°544150
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 13:41:16  profilanswer
 

cat /etc/urpmi/urpmi.cfg :o
on connaitra tes sources .
ceci dit le plus simple est de virer toutes tes sources et de les configurer a partir d'easy urpmi (puis de rajouter la source indiqué plus haut pour le xmms que tu veux :o )

n°544154
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:45:58  profilanswer
 

Citation :

[root@PC2 power600]# cat /etc/urpmi/urpmi.cfg
[root@PC2 power600]#

Y a plus rien, même pas les 3 CD (qu'il connaissait au début):o  
 
J'avais déjà trouvé cette page easy urpmi mais ça n'a jamais marché....
Et cet OS est d'une lenteur...La vieille Red Hat 8 sur l'autre machine est bien plus vivace  :heink:


Message édité par power600 le 21-08-2004 à 13:47:18
n°544157
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 13:53:15  profilanswer
 

hum :o
bah ajoutes les sources qui vont bien
genre  

Citation :

urpmi.addmedia --update 10-0-Official-updates ftp://ftp.proxad.net/pub/Distribu [...] /10.0/RPMS with ../base/hdlist.cz
urpmi.addmedia 10-0-Official-main ftp://ftp.proxad.net/pub/Distribu [...] drake/RPMS with ../base/hdlist.cz
urpmi.addmedia 10-0-Official-contrib ftp://ftp.proxad.net/pub/Distribu [...] ntrib/i586 with ../../i586/Mandrake/base/hdlist2.cz
urpmi.addmedia eslrahc http://www.eslrahc.com/10.0/ with hdlist.cz


eventuellement si tu veux avoir un kernel plus rapide tu peux utiliser ceux de svetljo
comme son site est un peu lent tu as celui de thac's plus rapide  

Citation :

urpmi.addmedia thacs.rpms http://rpm.nyvalls.se/10.0/RPMS with hdlist.cz


en urpmisant le kernel-multimedia-2.6.7-1.mm.1mdk :)
il y a aussi avec les drivers nvidia/ati qui vont bien ;)

n°544160
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 13:56:58  profilanswer
 

Citation :

[root@PC2 power600]# urpmi.addmedia --update 10-0-Official-updates ftp://ftp.proxad.net/pub/Distribu [...] /10.0/RPMS with ../base/hdlist.cz
média 10-0-Official-updates ajouté
base de données urpmi vérouillée
[root@PC2 power600]# urpmi.addmedia 10-0-Official-main ftp://ftp.proxad.net/pub/Distribu [...] drake/RPMS with ../base/hdlist.cz
média 10-0-Official-main ajouté
base de données urpmi vérouillée
[root@PC2 power600]# urpmi.addmedia 10-0-Official-contrib ftp://ftp.proxad.net/pub/Distribu [...] ntrib/i586 with ../../i586/Mandrake/base/hdlist2.cz
média 10-0-Official-contrib ajouté
base de données urpmi vérouillée
[root@PC2 power600]# urpmi.addmedia eslrahc http://www.eslrahc.com/10.0/ with hdlist.cz
média eslrahc ajouté
base de données urpmi vérouillée
[root@PC2 power600]# cat /etc/urpmi/urpmi.cfg
[root@PC2 power600]#
 

Mais c'est quoi ce merdier  :sweat:

n°544166
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 14:01:35  profilanswer
 

ta base est vérouillée  :o
rm /var/lib/urpmi/.RPMLOCK /var/lib/urpmi/.LOCK

n°544179
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 14:13:48  profilanswer
 

mikala a écrit :

ta base est vérouillée  :o

Voui, mais je me demande justement comment j'ai fait ça  :pt1cable:  
cette fois la mise à jour des media semble marcher  :jap:

n°544236
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 15:17:09  profilanswer
 

Bon, le urpmi remarche et a installé xmms..mais ce con ferme dès que je lui fais lire un fichier :/

n°544239
SuperZell
Posté le 21-08-2004 à 15:23:27  profilanswer
 

power600 a écrit :

Bon, le urpmi remarche et a installé xmms..mais ce con ferme dès que je lui fais lire un fichier :/


c'est un bug connu sa, essaye de le lancer en console et recherche sur le forum j'ai déja vu sa quelque part.
 
installe aussi xmms-arts xmms-alsa xmms-oss etxc et essay avec un autre plugin de sortie


Message édité par SuperZell le 21-08-2004 à 15:24:20
n°544241
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 15:24:18  profilanswer
 

hum :o
tu as installé xmms-alsa ? ( urpmi xmms-alsa )
 
 et choisit d'utiliser alsa en sortie dans la configuration de xmms ?

n°544243
SuperZell
Posté le 21-08-2004 à 15:25:05  profilanswer
 

mikala a écrit :

hum :o
tu as installé xmms-alsa ? ( urpmi xmms-alsa )
 
 et choisit d'utiliser alsa en sortie dans la configuration de xmms ?


 
grillai  :D

n°544245
JerryCrazy
Le plus crazy des crazy
Posté le 21-08-2004 à 15:25:58  profilanswer
 

ouher,a l'origine,il tourne en OSS :o


---------------
JerryCrazy - My Digital Life - Ferrovia.be - Jeux Linux
n°544246
mikala
Souviens toi du 5 Novembre...
Posté le 21-08-2004 à 15:26:06  profilanswer
 


:non:
regarde ta date d'édition , regarde la date de mon post .

n°544248
JerryCrazy
Le plus crazy des crazy
Posté le 21-08-2004 à 15:26:43  profilanswer
 

sinon,moi,je prefere Beep Media Player , c'est basé sur XMMS mais au moin,c'est en GTK 2 :whistle:


---------------
JerryCrazy - My Digital Life - Ferrovia.be - Jeux Linux
n°544249
SuperZell
Posté le 21-08-2004 à 15:29:18  profilanswer
 

JerryCrazy a écrit :

sinon,moi,je prefere Beep Media Player , c'est basé sur XMMS mais au moin,c'est en GTK 2 :whistle:


 
Chez moi sa bug de partout et puis on peut pas ajouter un repertoire pour qui ce démerde tout seul, obliger de tt faire a la main  :heink:
 
 

Citation :

regarde ta date d'édition , regarde la date de mon post .


 
ro deux pauvres secondes  :D


Message édité par SuperZell le 21-08-2004 à 15:30:37
n°544250
JerryCrazy
Le plus crazy des crazy
Posté le 21-08-2004 à 15:31:41  profilanswer
 

superzell a écrit :

Chez moi sa bug de partout et puis on peut pas ajouter un repertoire pour qui ce démerde tout seul, obliger de tt faire a la main  :heink:

hum... heu,bah,j'ai aucun bug moi , on a pas du tester la meme version,car,je n'utilise plus que ça... XMMS est parti au oubliette.. et puis,daprès ce que j'ai compris,il ne passeront pas en GTK 2 alors bon,je veu bien que ce n'est pas totalement utile,mais,faut quand meme savoir passer a autre chose (je parle des devs)  [:spamafote]


---------------
JerryCrazy - My Digital Life - Ferrovia.be - Jeux Linux
n°544253
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 15:37:45  profilanswer
 

superzell a écrit :

c'est un bug connu sa, essaye de le lancer en console et recherche sur le forum j'ai déja vu sa quelque part.
 
installe aussi xmms-arts xmms-alsa xmms-oss etxc et essay avec un autre plugin de sortie

Lancé en console ça marche  :??:  
 
En sortie y a OSS 1.2.9..Je lui mets xmms-alsa pis si avec ça il est pas content..... :kaola: [:ddr555]
 
EDIT: "pas de paquetage nommé xmms-alsa"...
"


Message édité par power600 le 21-08-2004 à 15:39:48
n°544313
Dark_Schne​ider
Close the World, Open the Net
Posté le 21-08-2004 à 18:11:49  profilanswer
 

il faut installer xmms-arts et/ou xmms-alsa puis choisir comme sortie sonore ALSA ou arts.
 
ce bug est due a soundwrapper.
 
les packages xmms-alsa et xmms-arts sont dispo.
 
xmms-arts et xmms-alsa sont dispos dans al source main ( et donc normalement dans les 3 CD ).
 
si il est dit que le apckage n'existe pas, cela signifie que vois sources sont mal configurées.
 
 
http://easyurpmi.zarb.org
http://www.linux-wizard.net/howto. [...] e=42#urpmi


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°544454
power600
Schtroumpférateur grognon
Posté le 21-08-2004 à 21:50:31  profilanswer
 

Bon, j'ai cherché du côté des source et il y avait bien un problème mais j'ai pas trouvé quoi précisément. maintenant urpmi trouve xmms et les plugins qui vont avec.
J'ai du le désinstaller et le réinstaller pour que ça marche et cette fois il fonctionne...
Merci à tous notamment à Mikala et Dark_Schneider :jap:
 
P.S: Le plugin Alsa fait un truc bizarre, ça saute comme un vinyle rayé?!!? [:armelanuel]  
Par contre avec aRts c'est nikel.

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  xmms refuse de s'intaller..[Résolu (avec des bouts de urpmi dedans)]

 

Sujets relatifs
Mandrake 10.0 Official, l'install freeze [résolu]probleme de drivers ATI (résolu!!)
PAs de son avec carte TV (résolu)[FEDORA2] aumix & carte son [Résolu]
[Kde] Problème avec KSycoca <== Résolu[Résolu]Problème avec pack d'ciones sous kde
xmms, police moche ??Install linux sil3112(résolu)
[résolu]pb compil xine-lib (./configure)Connexion Internet avec modem 56k par kppp : marche pas. [RESOLU]
Plus de sujets relatifs à : xmms refuse de s'intaller..[Résolu (avec des bouts de urpmi dedans)]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR