Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1807 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  probleme de drivers ATI (résolu!!)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme de drivers ATI (résolu!!)

n°543571
sly007
Rhââââ Lovely...
Posté le 20-08-2004 à 12:38:34  profilanswer
 

Hello! J'ai un probleme avec les derniers drivers pour ma Radeon 9600 : pas moyen d'avoir d'acceleration 3D  :fou: En fait, tout marchait bien, sauf un probleme de sortie TV (ecran noir pour les dvd divx, bref, tout ce qui bouge, alors qu'un diaporama, pas de problemes...) Je me dis essayons les derniers, on verra... Alors c'est parti
#urpme fglrx  
#init 3
je me loggue en root, et  
rpm -Uvh --force ~/fglrx-xx.rpm
Pas de message d'erreur, donc je continue avec  
#fglrxconfig
Que je rêgle comme d'hab
#cd /usr/X11R6/lib
#rm libGL.so.1  
#ln -s libGL.so.1.2 libGL.so.1
 
Et le glxinfo me donne ca!!!
[root@localhost sylvain]# glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
    GLX_ATI_render_texture
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess
 
 
Bref, Mesa, et M****!!!  :fou: Alors je me dis que ca doit venir du dernier driver, et je decide de remettre l'ancien en attendant de trouver une solution pour le nouveau... ET ben rebelotte!!! pa moyer de mettre l'ancien!!!!! Ou plutot me résultat!!!  
Le log de Xfree aussi est bizarre
 
WW) fglrx(0): Kernel Module version does *not* match driver.
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe1919000 at 0x40266000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
 
 
Bref, j'y ccomprends rien... Help!  :??:  :(  :pt1cable:  :bounce:  :ouch:


Message édité par sly007 le 21-08-2004 à 16:35:19
mood
Publicité
Posté le 20-08-2004 à 12:38:34  profilanswer
 

n°543575
jc the gre​at
Posté le 20-08-2004 à 12:42:37  profilanswer
 

fais voir:
cat /etc/modprobe.preload
cat /etc/modules.conf
 
tu es en 2.6 ou 2.4 ?

n°543577
psebcopath​e
Posté le 20-08-2004 à 12:45:20  profilanswer
 

Pas 36  solutions, refait un fglxconfig .
Faut tjs faire une sauvegarde de ces fichiers de paramètres( XFree86-config-4)
Sinon, en faisant un urpme, normalement un urpmi ***.rpm classique marche, sans l'option --force.

n°543579
psebcopath​e
Posté le 20-08-2004 à 12:45:58  profilanswer
 

ah oui effectivement tu as bien fait un modprobe fglrx avant de lancer xfree ??


Message édité par psebcopathe le 20-08-2004 à 12:46:18
n°543857
sly007
Rhââââ Lovely...
Posté le 20-08-2004 à 22:02:06  profilanswer
 

désolé de la lenteur, mais Tiscali se galere grave depuis 3-4 jours... Bref, mon probleme semble effectivement venir du module (fglrx est bien chargé, puisque dans modprobe.preload...)
[root@localhost sylvain]# cat /etc/modprobe.preload
# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line.  Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules
ovcamchip
nvidia-agp
bttv card=34 tuner=03
fglrx

 
[root@localhost sylvain]# cat /etc/modules.conf
 
probeall usb-interface usb-ohci ehci-hcd
alias eth1 sk98lin
above snd-cmipci snd-pcm-oss
alias ieee1394-controller ohci1394
alias eth0 forcedeth
alias sound-slot-0 snd-cmipci
options bttv radio=0 card=34 tuner=3 gbuffers=4

 
Je suis sur un 2.6.3-13mdk, avec nvidia-agp, et cela marchait tres bien hier encore... (au fait il y a aussi un module nvidia_agp, mais ca ne marche pas mieux avec...)
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

n°543904
psebcopath​e
Posté le 20-08-2004 à 23:13:47  profilanswer
 

pkoi nvidia agp alors que tu as une ati ???
Sinon pour vérifier que ton modules est bien chargé fais un "lsmod"

n°544032
sly007
Rhââââ Lovely...
Posté le 21-08-2004 à 10:19:38  profilanswer
 

nvidia-agp carte ma carte mere est sur nForce2... donc, nvidia-agp pour la gestion du port AGP... Sinon, oui, tous les modules st bien en place... Mais je viens de voir que le rpm propose une dizaine de modules suivant le noyau... peut être un bug de ce coté... je vais prendre le glrx-2.6.3.13mdk.ko et le renommer en fglrx.o on verra... par contre, il faut qu'il soit dans quel dossier pour que ce soit celui la qui se charge?
Merci!!

n°544086
WhatDe
Posté le 21-08-2004 à 12:46:39  profilanswer
 

Quand je vois comment j'ai eu facile avec ma gentoo et ma 9800pro alors que je débute sous linux  :ange:  
 
Un bête tutorial et c'était réglé: http://odin.prohosting.com/wedge01 [...] n-faq.html

n°544120
sly007
Rhââââ Lovely...
Posté le 21-08-2004 à 13:10:08  profilanswer
 

Bon. Pour faire clair, je suis sous Mandrake, pas sous gentoo et donc, pas la même soupe, les noyaux mandrake étant bien particuliers... Ensuite c'est très loin de la première fois que j'ai à installer ces drivers sur une Mandrake puisque j'ai fait passer la moitié de mes amis ainsi que toute la famille sous linux... Et ils avaient tous des Radeons... Alors les histoires de "Bêtes" tutoriaux... Merci quand même...

n°544125
SuperZell
Posté le 21-08-2004 à 13:14:33  profilanswer
 

tu ferais mieux de desinstaller tes ancien drivers ( et de suprimer a la main les modules créés) et d'installer les pilotes avec:
 
rpm -ihv --force --replacefiles lesdrivers.rpm
 
chez moi sa a marcher nikel et apres fglrxconfig  :D

mood
Publicité
Posté le 21-08-2004 à 13:14:33  profilanswer
 

n°544171
sly007
Rhââââ Lovely...
Posté le 21-08-2004 à 14:06:38  profilanswer
 

connaissais pas -replacefiles... ca fait quoi exactement?
urpme ne vire pas les anciens modules? Si la réponse est non, c'est à peu près sûr que mon problême vient de la...

n°544209
sebf11
Posté le 21-08-2004 à 14:41:01  profilanswer
 

je vois que je suis pas le seul à avoir des problems :-(

n°544215
SuperZell
Posté le 21-08-2004 à 14:46:27  profilanswer
 

sly007 a écrit :

connaissais pas -replacefiles... ca fait quoi exactement?
urpme ne vire pas les anciens modules? Si la réponse est non, c'est à peu près sûr que mon problême vient de la...


 
--replacefiles force le remplacement des fichiers a l'install (pour écraser les lib de mesa)
 
et je ne pensse pas que urpme effaces les modules. (en tout cas chez moi sa les a pas effacer)
 
pensse a redémarer avant d'essayer de voir si tu a l'accelération (pour recharger le module)

n°544247
sly007
Rhââââ Lovely...
Posté le 21-08-2004 à 15:26:12  profilanswer
 

:bounce:  :D Merci beaucoup Superzell!!! c'était bien le vieux module (celui du 2.6.7) qui tournait... forcément, ca "matchait" pas le kernel!!!

n°544408
sebf11
Posté le 21-08-2004 à 20:53:24  profilanswer
 

On fé comment pour suprimer les anciens drivers? parce que j'ai le meme problem??

n°544678
psebcopath​e
Posté le 22-08-2004 à 17:42:09  profilanswer
 

Sebf11 a écrit :

On fé comment pour suprimer les anciens drivers? parce que j'ai le meme problem??


[:bambookillah]  
lis plus haut !
[:ben2655]


Message édité par psebcopathe le 22-08-2004 à 17:42:32

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  probleme de drivers ATI (résolu!!)

 

Sujets relatifs
PAs de son avec carte TV (résolu)[Mandrake 10] Problème avec XFree
[Mandrake 10] Utiliser la sortie TV d'une Ati 9200[xawdecode - plugins] probleme de compilation
[Alsa] Probleme depuis l'install de KDEProbleme d'installation : Sara
Probléme de son sous mandrake 10.0probleme incomprehensible avec Heartbeat
[FEDORA2] aumix & carte son [Résolu][Kde] Problème avec KSycoca <== Résolu
Plus de sujets relatifs à : probleme de drivers ATI (résolu!!)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR