Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1666 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Apache2/debian ne veut pas exécuter les .cgi (mais download)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Apache2/debian ne veut pas exécuter les .cgi (mais download)

n°1381939
Deadlock
Feck off, cup !
Posté le 10-10-2015 à 17:45:58  profilanswer
 

Bonjour,

 

J'ai un peu testé tous les workarounds trouvés à droite/à gauche sans succès.
J'ai un apache2 qui tourne sans soucis depuis des années sur un RPI sous raspbian qui me sert de proxy (mod_proxy) pour les différents services de mon réseau local.

 

J'ai installé NUT pour monitorer les UPS attachés à mes NAS ainsi qu'un webgui en CGI.
Mais lorsque je me connecte à l'URL censée m'afficher le GUI http://localhost/nut/upsstats.cgi, le browser me propose de télécharger le binaire upsstats.cgi au lieu de l’exécuter.

 

J'ai activé mes modules cgi et cgid (confirmé par apache2 -M) et créé le site suivant:

 

ScriptAlias /nut /usr/lib/cgi-bin/nut                                                                                                                        
<Directory /usr/lib/cgi-bin/nut>                                                                                                                              
        Order allow,deny                                                                                                                                      
        Allow from all                                                                                                                                        
        AllowOverride None                                                                                                                                    
        Options ExecCGI                                                                                                                                      
        AddHandler cgi-script .cgi                                                                                                                            
</Directory>                                

 

J'ai ajouté +ExecCGI aux options dans 000-default site:

 

       ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/                                                                                                              
        <Directory /var/www/>                                                                                                                                
                Options Indexes FollowSymLinks MultiViews +ExecCGI                                                                                            
                AllowOverride None                                                                                                                            
                Order allow,deny                                                                                                                              
                allow from all                                                                                                                                
        </Directory>

 

Et là je n'ai plus d'idée ... j'ai bien entendu reload/restart apache.

 

Merci d'avance pour votre aide :jap:


Message édité par Deadlock le 10-10-2015 à 17:46:35

---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
mood
Publicité
Posté le 10-10-2015 à 17:45:58  profilanswer
 

n°1381949
agentsteel
Posté le 10-10-2015 à 21:41:20  profilanswer
 

Le 1er snippet de conf (qui pourrait s'appeler "nut.conf" ), tu l'as mis dans /etc/apache2/conf.d/ ?
 
N'hésite pas à carrément stopper Apache2 ( /etc/init.d/apache2 stop ) puis start.
 
Et aussi, regarder les logs pour déceler une éventuelle erreur de conf.


---------------
http://agentoss.wordpress.com/
n°1381953
Deadlock
Feck off, cup !
Posté le 10-10-2015 à 22:34:25  profilanswer
 

agentsteel a écrit :

N'hésite pas à carrément stopper Apache2 ( /etc/init.d/apache2 stop ) puis start.


Oh putain ça fonctionne :ouch:
Ben merci pour le tuyau !


---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Apache2/debian ne veut pas exécuter les .cgi (mais download)

 

Sujets relatifs
Cloner configuration debian (ec2)[Résolu] impossible de reinstaller nginx sur debian jessie
Gros soucis avec subversion sur Debian Jessie[debian] probleme de copie automatique
[resolu] configuration reperoire utilisateur apache2Wifi ac sous Debian et problème de vitesse
[Debian]Impossible de connecter utilisateurs LDAP/SAMBA autre que rootFTP Problème de bridage en download avec connexion tres haut debit
PrimTux distribution GNU/Linux pour l'école basée sur Debian 8.0Installation SOGo sur Debian
Plus de sujets relatifs à : Apache2/debian ne veut pas exécuter les .cgi (mais download)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR