Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2092 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  ubuntu sur raq 550

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

ubuntu sur raq 550

n°929844
reiben2k
Posté le 03-07-2007 à 15:40:28  profilanswer
 

Bonjour, j'essai d'installer ubuntu sur un raq 550 et je suis coincé au moment du boot sur le reseau.
 
 
 
J'ai suivi le tuto de http://hugues.lepesant.com/              
et http://www.le-vert.net/howto/raq550/    
 
J'ai utilisé edgy pour debootstrap :
 
$ sudo debootstrap edgy /nfsroot-x86/ http://fr.archive.ubuntu.com/ubuntu/
 
voila ce qui s'affiche a la fin sur la console hyperterminal

Code :
  1. IP-Config: Got DHCP answer from 192.168.1.42, my address is 192.168.1.49
  2. IP-Config: Complete:
  3.       device=eth0, addr=192.168.1.49, mask=255.255.255.0, gw=255.255.255.255,
  4.      host=192.168.1.49, domain=, nis-domain=(none),
  5.      bootserver=192.168.1.42, rootserver=192.168.1.42, rootpath=
  6. NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
  7. Looking up port of RPC 100003/2 on 192.168.1.42
  8. Looking up port of RPC 100005/1 on 192.168.1.42
  9. VFS: Mounted root (nfs filesystem).
  10. Freeing unused kernel memory: 112k freed
  11. FATAL: kernel toKernel panic: Attempted to kill init!
  12. o old
  13. <6>disabling network interfaces.
  14. Rebooting in 5 seconds..waiting for devices to flush..........done


 
le serveur dhcp fonctionner :
 

Code :
  1. Jul  3 14:37:53 srvubuntu dhcpd: DHCPDISCOVER from X:X:X:X:X:Xvia eth1
  2. Jul  3 14:37:53 srvubuntu dhcpd: DHCPOFFER on 192.168.1.49 to X:X:X:X:X:X
  3. Jul  3 14:37:53 srvubuntu dhcpd: DHCPREQUEST for 192.168.1.49 (192.168.1.42) fro
  4. Jul  3 14:37:53 srvubuntu dhcpd: DHCPACK on 192.168.1.49 to X:X:X:X:X:X via eth1
  5. Jul  3 14:38:13 srvubuntu mountd[4178]: authenticated mount request from 192.168.1.49:800 for /nfsroot-x86 (/nfsroot-x86)


 
Des idées??
 
PS : j'ai un pc sur ubuntu edgy en 192.168.1.42 , un pc windows connecté en serie sur le raq 550.
 
Merci d'avance.  

mood
Publicité
Posté le 03-07-2007 à 15:40:28  profilanswer
 

n°929978
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 03-07-2007 à 18:08:46  profilanswer
 

C'est assez bizarre.
T'as bien fais un chroot i386 ?

n°930182
reiben2k
Posté le 04-07-2007 à 11:06:03  profilanswer
 

M300A a écrit :

C'est assez bizarre.
T'as bien fais un chroot i386 ?


 
Salut, j'ai repris l'installation en effacant le dossier /nfsroot-x86 , puis je l'ai recréé et :
 
$ sudo debootstrap --arch i386 edgy /nfsroot-x86/ http://fr.archive.ubuntu.com/ubuntu/
 
 
le serveur nfs et dhcp ont l'air de fonctionner :

Code :
  1. $ rpcinfo -p
  2.    program no_version protocole  no_port
  3.     100000    2   tcp    111  portmapper
  4.     100000    2   udp    111  portmapper
  5.     100024    1   udp  32770  status
  6.     100024    1   tcp  36873  status
  7.     100003    2   udp   2049  nfs
  8.     100003    3   udp   2049  nfs
  9.     100003    4   udp   2049  nfs
  10.     100003    2   tcp   2049  nfs
  11.     100003    3   tcp   2049  nfs
  12.     100003    4   tcp   2049  nfs
  13.     100021    1   udp  32781  nlockmgr
  14.     100021    3   udp  32781  nlockmgr
  15.     100021    4   udp  32781  nlockmgr
  16.     100021    1   tcp  42381  nlockmgr
  17.     100021    3   tcp  42381  nlockmgr
  18.     100021    4   tcp  42381  nlockmgr
  19.     100005    1   udp    891  mountd
  20.     100005    1   tcp    894  mountd
  21.     100005    2   udp    891  mountd
  22.     100005    2   tcp    894  mountd
  23.     100005    3   udp    891  mountd
  24.     100005    3   tcp    894  mountd


 
J'ai toujours les memes messages dans la console (hyperterminal), affichage du syslog me donne la meme chose.
 
Un point noir du tuto symlinker wmlinux.gz que je n'ai pas fait, mais je ne vois pas ce qu'il faut faire.
 
Merci pour vos lumieres.
 
EDIT : le raq peut-il démarrer sur un systeme ubuntu?
 
Pour la gestion des connexions series voila ce que j'ai fait sur ubuntu :
 

Code :
  1. Autoriser les connexions séries :
  2. $ cd /nfsroot-x86/etc/event.d/
  3. $ sudo cp tty1 T0   /* servira pour créer la connexion série  */
  4. Modification des fichiers et renommage (faire la même manipulation pour tty1 à tty6)
  5. Etape A
  6. $ sudo nano tty1
  7. Commentez toutes les lignes avec le signe # puis sauvegardez le fichier. Vous devriez obtenir ceci :
  8. # tty1 - getty
  9. #
  10. # This service maintains a getty on tty1 from the point the system is
  11. # started until it is shut down again.
  12. #start on runlevel-2
  13. #start on runlevel-3
  14. #start on runlevel-4
  15. #start on runlevel-5
  16. #stop on shutdown
  17. #respawn /sbin/getty 38400 tty1
  18. Etape B
  19. Renommez le fichier
  20. $ sudo mv tty1 tty1.backup
  21. Refaire létape A et B pour les fichiers tty2 à tty6
  22. Remarque : le renommage des fichiers n'est pas obligatoire mais il permet de voir qu'ils ne sont pas actifs.
  23. Modification du fichier T0 dans /nfsroot-x86/etc/event.d/
  24. $ sudo nano T0
  25. Modifiez le afin d'obtenir ceci :
  26. # T0 - getty
  27. #
  28. # This service maintains a getty on T0 from the point the system is
  29. # started until it is shut down again.
  30. start on runlevel-2
  31. start on runlevel-3
  32. start on runlevel-4
  33. start on runlevel-5
  34. stop on shutdown
  35. T0:23:respawn:/sbin/getty -L ttyS0 115200 vt102



Message édité par reiben2k le 04-07-2007 à 11:09:51
n°930382
reiben2k
Posté le 04-07-2007 à 15:44:29  profilanswer
 

Bon j'ai remplacé le mini systeme ubuntu par une debian sarge et ca passe. J'ai cependant le probleme dû a la connexion T0 (respawn too fast).
J'ai bien tenté de faire un MAKEDEV all , ou MAKEDEV tty0 mais cela ne veut pas fonctionner.
 
(chroot)
./MAKEDEV: warning: can't read /proc/devices
./MAKEDEV: don't know how to make device "all"

n°930407
reiben2k
Posté le 04-07-2007 à 16:24:01  profilanswer
 

J'ai résolu le probleme en faisant ceci :
 
$ cd /nfsroot-x86/dev
$ sudo MAKEDEV ttyS0
 
J'accède bien a l'invite de commande dans la console

n°930427
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 04-07-2007 à 17:16:09  profilanswer
 
n°930662
reiben2k
Posté le 05-07-2007 à 12:02:18  profilanswer
 

Merci , beaucoup :)
Je suis coincé au moment de formater le swap :
 
Command (m for help): q
 
/dev# mkswap /dev/hda5
mkswap: error: swap area needs to be at least 40kB
Usage: mkswap [-c] [-v0|-v1] [-pPAGESZ] [-L label] /dev/name [blocks]
 
J'ai exactement les memes partitions que vous (sauf la taille du home car j'ai 2 disques de 80 Go), par contre au premier affichage des partitions, elles etaient en raid, je ne sais pas si c'est de la que vient le probleme.
Je vais chercher pour mon probleme de swap.
 
[EDIT] Résolu en faisant : # shutdown -r now
puis en rebootant le raq sur le réseau sur le serveur nfs.
Les partitions n'étaient pas encore prises en compte.


Message édité par reiben2k le 05-07-2007 à 14:16:09
n°930756
reiben2k
Posté le 05-07-2007 à 16:29:09  profilanswer
 

Re, bon lors du téléchargement des sources pour le noyau, il me manque le patch linux-2.6.19.1-cobalt_x86-2 qui n'est plus disponible sur le site.
 
Voici un des liens que j'ai trouvé a la place :
 
ftp://www.404ster.com/pub/gentoo- [...] ical.patch
 
J'ai téléchargé le noyau correspondant 2.6.19.2


Message édité par reiben2k le 05-07-2007 à 16:42:11
n°930837
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 05-07-2007 à 22:06:57  profilanswer
 

http://gentoo.404ster.com/
 
Part plutot sur un 2.6.20.1 :) (Voir un .21, le patch s'applique surement)

n°930993
reiben2k
Posté le 06-07-2007 à 10:36:46  profilanswer
 

Installation terminée !!!
J'ai pris le noyau linux 2.6.20.1 (tant qu' a faire), et j'ai modifier votre doc pour la prise en charge du raid : ca marche impec :)
Ca reboot bien sur un systeme linux, j'ai plus qu'a installer lamp dessus :)
 
Un grand merci pour cette doc
 
PS : je peux vous envoyer les modifications pour la gestion du raid

mood
Publicité
Posté le 06-07-2007 à 10:36:46  profilanswer
 

n°931081
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 06-07-2007 à 11:31:18  profilanswer
 

Je veux bien en effet !
 
Cette doc à déjà sauvé beaucoup e monde mais n'a jamais pu être terminée faute de temps.
 
N'hésite pas à remonter les fautes d'orthographe, coquilles et autres.

n°933074
reiben2k
Posté le 11-07-2007 à 14:05:58  profilanswer
 

Salut, je viens de me rendre compte que les disques raid ne sont pas ceux que j'avais configurés :) . Je vais reprendre l'installation depuis le début puis je posterai ici les modifications pour la prise en charge du raid.
A noter pour tout le monde que, je n'essaie plus d'installer ubuntu sur le raq (ça n'a pas marché chez moi, le raq refuse de booter), l'installation concerne une debian sarge.

n°933090
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 11-07-2007 à 14:24:46  profilanswer
 

Tu peux le faire en Etch, ça marchera aussi bien :)
 
(PS: Debian Stable c'est Etch, Sarge c'est obsolete)

n°1108792
zunix65
Posté le 29-01-2009 à 23:06:12  profilanswer
 

Bonjour,
 
Désolé de détérer ce vieux post, mais il est vraiement dans l'axe de ce que recherche, et les participants devraient peut être m'aider....
 
J'ai un raq 550, avec un disque sur la baie 1.
En gros, en suivant les tutos, j'en suis a l'étape de configuration/compil du noyau. J'ai choisi une debian etch, avec un noyau 2.6.23.
J'ai appliqué le patch téléchargé sur ftp://www.404ster.com/pub/gentoo- [...] nel-2.6.x/ et en suis au make menuconfig ...
Et la, c'est le drame. Je crois me souvenir qu'il y a une taille max du kernel sur les Raq, aussi la config est importante...  
Quelles options dois-je utiliser ? Sur le tuto http://hugues.lepesant.com/?p=13 on peut récupérer un fichier .config pour un noyau 2.4. Mais dans mon cas, que me conseillez vous d'utiliser?
 
En attendant vos réponses, j'ai lancé une compilation avec des options choisies un peu a la louche... Mais je doutes du résultat. Comment vous y êtes vous pris ?
 
Merci par avance.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  ubuntu sur raq 550

 

Sujets relatifs
Connexion RTC difficile sous Ubuntupb ubuntu 7.04 wifi bloque le systeme
[Ubuntu 7.04] Comment definir une connexion wifi par defaut ?[Ubuntu 7.04] Firefox Clic lien -> ouverture nouvelle fenetre
[Ubuntu] FGLRX et vraie accélération 3D (matérielle)Problème d'installation Ubuntu
problème de micro sous ubuntuUbuntu, Wine, CD Jaquette et imprimante ...
[Ubuntu] Comment gérer les compil et install à la mainMac OS + Ubuntu + XP sur Ibook ?
Plus de sujets relatifs à : ubuntu sur raq 550


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR