Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1656 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Samba & Partage d'imprimante

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Samba & Partage d'imprimante

n°224790
SCREAM78
Posté le 16-02-2003 à 13:52:12  profilanswer
 

Bonjour,
 
Je dispose d'une imprimante Brother HL-1440 que je souhaite partager sur mon serveur (RH7.3), je l'ai installé sans pb. L'impression depuis le poste linux marche tres bien (elle est connectée sur le port USB). J'ai réalisé le partage de l'imprimante grâce à SAMBA. J'arrive à imprimer dessus mais sous windows (apres avoir installé les drivers bien sur) j'arrive pas à voir l'état de l'imprimante (dans les imprimantes je la vois mais y'a marqué "Accès refusé, impossible de se connecter" )
Voici ce que j'ai mit dans samba :
 
[Brother_HL-1440]
   comment = Imprimante Laser 14 ppm 1200x600dpi
   printable = yes
 
[printers]
   comment = Toutes les imprimantes
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
;   guest ok = yes
   valid users = admin guigui
   printable = yes
 
Les utilisateurs admin et guigui marchent tres bien avec le partage de fichiers et une sécurité niveau user.
Ceux qui ont des imprimantes partagées vous arrivez a voir l'état de l'imprimante ?? Merci d'avance pour votre aide


Message édité par SCREAM78 le 16-02-2003 à 13:56:27
mood
Publicité
Posté le 16-02-2003 à 13:52:12  profilanswer
 

n°224827
bobor
tueur de n44b
Posté le 16-02-2003 à 15:17:00  profilanswer
 

j'allais poster le même sujet car j'ai exactement le même problème et je bloque dessus depuis 15 jours!
 
Le plus étonnant est que tout marchait correctement depuis plusieurs mois. J'ai rien changé. J'ai lancé une grosse impression. Les 20 premières pages se sont bien imprimées puis bloquage et maintenant, accès rafusé, impossible de se connecter à l'imprimante.
 
J'imprime bien depuis linux, et les répertoires partagés sont bien visibles.
 
je ne sais plus quoi faire. Si jamais tu trouves la soluce, préviens moi car là je crise.


---------------
Gitan des temps modernes
n°224830
SCREAM78
Posté le 16-02-2003 à 15:18:22  profilanswer
 

Ah ben comme quoi je ne suis pas tout seul :D.
Tu peux mettre la partie concernant ton imprimante du smb.conf ici stp ?

n°224831
bobor
tueur de n44b
Posté le 16-02-2003 à 15:20:51  profilanswer
 

c'est pareil et j'ai essayé plusieurs conf, toujours le même problème. Le pire c'est que cela marchait avant  :fou:


---------------
Gitan des temps modernes
n°224838
SCREAM78
Posté le 16-02-2003 à 15:34:46  profilanswer
 

Arf :D on a pas de chance ... moi j'ai regardé plusieurs doc et c'est comme cela qu'ls font ;) ... mais toi c bizarre par contre :(

n°225181
SCREAM78
Posté le 17-02-2003 à 15:27:01  profilanswer
 

Up :) merci

n°225183
Mjules
Modérateur
Parle dans le vide
Posté le 17-02-2003 à 15:30:03  profilanswer
 

essaye de décommenter (au moins temporairement) l'accès guest (ou public) pour voir si c'est un problème de droit.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°225265
bobor
tueur de n44b
Posté le 17-02-2003 à 17:33:21  profilanswer
 

j'avais déjà décommenté (j'ai toutes les configs possibles) et toujours pareil.
 
Je ne suis même pas sûr que cela vienne de samba car ma config a marché plusieurs mois et je n'ai pas fait de mise à jour de samba, je crois.


---------------
Gitan des temps modernes
n°225691
bobor
tueur de n44b
Posté le 18-02-2003 à 15:38:14  profilanswer
 

:bounce:


---------------
Gitan des temps modernes
n°225750
bobor
tueur de n44b
Posté le 18-02-2003 à 18:23:24  profilanswer
 

petit progrès: j'ai décommenté dans mime.convs et mime.types (/etc/cups) les drivers raw.
 
J'ai toujours connection refusée MAIS ça imrpime  :pt1cable: ....au bout de 3 à 4 minutes  :ouch:  
 
allez un d'aide et SCREAM78, dis moi si ça t'aide


---------------
Gitan des temps modernes
mood
Publicité
Posté le 18-02-2003 à 18:23:24  profilanswer
 

n°225778
bobor
tueur de n44b
Posté le 18-02-2003 à 19:21:59  profilanswer
 

et en rajoutant use client driver = yes
je n'ai plus accès refusé. Par contre j'ai chronométré: 5 minutes pour imprimer une page de test!!! :ouch:  
 
avant je n'avais pas ce problème de lenteur. Es-tu sous XP SP1?
 
J'ai également essayé en configurant sous windows "imprimer directement" mais même problème.


---------------
Gitan des temps modernes
n°225841
SCREAM78
Posté le 18-02-2003 à 21:11:55  profilanswer
 

MJules > J'ai mit "guest ok= yes" ca arrange les choses apparement (avec le "use client driver = yes" )
 
Bobor > J'imprime depuis 2000 SP3 mais j'ai les memes symptomes sous XP SP1. Par contre moi l'impression marche nickel ... ca demarre au quart de tour. Tu as la meme imprimante que moi ? ou c'est juste le même problème d'état d'imprimante sous windows ?
Le "use client driver = yes" tu l'as mit ou ? dans la section [printers] ? (je l'ai mit la ... dit moi si c pas bon)
La ca s'améliore avec le "guest ok= yes" et le "use client driver = yes", il me met pret dans l'état de l'imprimante (sur la fenetre générale) par contre qd je double clique sur l'imprimante il m'ouvre une fenetre ou y'a marqué en haut le meme message qu'avant : "Accès refusé, impossible de se connecter"


Message édité par SCREAM78 le 18-02-2003 à 21:12:24
n°225847
bobor
tueur de n44b
Posté le 18-02-2003 à 21:43:23  profilanswer
 

je l'ai mis dans printers
as tu modifié les mimes.* dans /etc/cups?


---------------
Gitan des temps modernes
n°225872
SCREAM78
Posté le 18-02-2003 à 23:33:39  profilanswer
 

Ben apparement chez moi c'était déja commenté ,on parle bien de cette ligne la :
#application/octet-stream       application/vnd.cups-raw        0       -
 
@+

n°225873
bobor
tueur de n44b
Posté le 18-02-2003 à 23:35:04  profilanswer
 

oui faut la décommenter dans les 2 fichiers


---------------
Gitan des temps modernes
n°225881
clockover
That's the life
Posté le 19-02-2003 à 00:10:57  profilanswer
 

Vous avez plins d infos sur ce probleme ici meme:
http://forum.hardware.fr/forum2.ph [...] h=&subcat=

n°227466
cooleric
Posté le 23-02-2003 à 19:02:21  profilanswer
 

Bon jai la meme imprimante mais mon probleme est plus embettant : jarrive pas a installer limprimante et donc je ne peux meme pas imprimer depuis linux...
 
Jai essayé plusieurs tuto mais ils font appel a des utilitaires de configuration et je prefererai faire ca a la main.. donc si aan a un tuto ou tout est fait manuellement je prefere

n°227470
SCREAM78
Posté le 23-02-2003 à 19:19:35  profilanswer
 

Il me semble qu'il est déconseillé d'editer le fichier /etc/printcap à la main. Moi je l'ai installé en 15s avec l'utilitaire printtool. Tu as quoi comme distribution.
 
Pour en revenir au pb de ce topic.
J'ai installé l'imprimante sur le pc de mon père (win98) et chez lui ca fonctionne nickel ... il a pas l'accès refusé.
Il faut que j'essaye avec cups.

n°227475
cooleric
Posté le 23-02-2003 à 19:25:30  profilanswer
 

J'ai une gentoo.
 
Si qqn pouvait me passer les sources de lpd ca maiderait.
Et puis les sources de printtool aussi alors.
 
Merci

n°227521
bobor
tueur de n44b
Posté le 23-02-2003 à 22:03:29  profilanswer
 

je pense vraiment que cela vienne du SP1 tout ça. Avant tout marchait. Maintenant dès que j'accède à l'imprimante, cela coupe momentanément la liaison entre le poste de travail et le serveur! Il faut attendre presque une minute pour récupérer la liaison!
 
Est-ce que qq'un arrive à faire marcher son imprimante sous cups/samba avec XP SP1?


---------------
Gitan des temps modernes
n°227538
clockover
That's the life
Posté le 23-02-2003 à 23:51:22  profilanswer
 

bobor... toute tes reponses sont ds le topic ke j ai cité....  :sarcastic:

n°227546
bobor
tueur de n44b
Posté le 24-02-2003 à 00:10:50  profilanswer
 

le lien ne marche pas et si c'est le topic auquel je pense, je n'y ai pas trouvé la réponse. L'impression marche mais est extrêment lente, et le réseau se coupe quand j'accède à l'imprimante.


---------------
Gitan des temps modernes
n°227587
SCREAM78
Posté le 24-02-2003 à 09:37:57  profilanswer
 

Bobor > C juste un petit coupé collé ratté ... prend le lien après le 1er point d'interrogation et ca marchera ;)
En tout cas le pb est le meme sous XP (SP1) et 2000 (SP3) ... ca m'etonne que ca vienne des drivers qd meme (c les meme pour XP et 2000 et j'ai installé les derniers dispos sur le site de brother). Je vais essayer cups quand j'aurai un peu de temps.

n°227607
bobor
tueur de n44b
Posté le 24-02-2003 à 10:36:58  profilanswer
 

est-ce que qq'un peut me mettre son cupsd.conf? ou me le transmettre par mail?
 
mon smb.conf est identique aux autres posts, tout est bien décommenté et pourtant l'impression merde toujours


---------------
Gitan des temps modernes
n°227626
bobor
tueur de n44b
Posté le 24-02-2003 à 11:34:17  profilanswer
 

j'ai réglé le problème à priori: c'était le firewall qui_ bloquait le port 139 dans un sens et le port 445. C'est étonnant car cela marchait avant. Le port 445 je suis assez étonné car je ne le connaissais pas. Je vais tester en désactivant le port 445 pour voir si ça marche quand même car j'aime pas les gruyères!


---------------
Gitan des temps modernes
n°227636
SCREAM78
Posté le 24-02-2003 à 12:07:48  profilanswer
 

Moi c'est pas un pb de firewall mais j'ai tjs le pb "Accès refusé, impossible de se connecter" sous XP & 2000

n°227687
bobor
tueur de n44b
Posté le 24-02-2003 à 13:06:42  profilanswer
 

le port 445 est bien nécessaire au moment de l'overture des imprimantes. C'est vraiment étonnant car il était strictement fermé depuis plusieurs mois et cela marchait. Le SP1 change-t-il qq chose?
 
SCREAM:
- as-tu bien DEcommenté les drivers raw dans /etc/cups/mimes.* ?
- redonne ton [printers] de smb.conf
- ouvre tes ports sur le firewall (tout en ACCEPT pour dédouaner cette partie)


---------------
Gitan des temps modernes
n°227967
SCREAM78
Posté le 24-02-2003 à 19:59:35  profilanswer
 

- pour les drivers raw c'est fait :
Fichier mime.convs
 
application/octet-stream        application/vnd.cups-raw        0       -
 
Fichier mime.types (pour celui la je suis pas sur car y'a une autre ligne plus loin ou y'a "#application/octet-stream" et y'a un commentaire au dessus qui concerne les raw)
 
application/vnd.cups-raw        (string(0,<1B>E) + !string(2,<1B>%0B)) \
                                string(0,<1B>@) \
                                (contains(0,128,<1B>%-12345X) + \
                                 (contains(9,512,"LANGUAGE=PCL" ) \
                                  contains(9,512,"LANGUAGE = PCL" )))
 
 
- smb.conf :
 
[BrotherHL1440]
   comment = Imprimante Laser 14 ppm 1200x600dpi
   printable = yes
 
[printers]
   comment = Toutes les imprimantes
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
;   guest ok = yes
   valid users = admin guigui lehembre kara elisa
   use client driver = yes
   printable = yes
 
- en local le firewall accepte tout ... je logue tout ce qui est drop ... j'ai fait un tail -f /var/log/message et je ne vois rien de rejeter. Je pense pas que ca vienne de lui

n°227972
bobor
tueur de n44b
Posté le 24-02-2003 à 20:05:51  profilanswer
 

dans mimes.type il faut décommenter la ligne octet/stream
 
smb.conf:
- rajoute dans [global]
load printers = yes
printcap name = cups
printing = cups
 
- rajoute dans [printers]
print command = lpr-cups -P %p -o raw %s -r
 
- l'autre item n'est pas utile
 
et voili


---------------
Gitan des temps modernes
n°228038
SCREAM78
Posté le 24-02-2003 à 21:02:27  profilanswer
 

Heu ca marche plus du tout en faisant ce que tu m'as dit ... j'arrive meme pas a sortir une feuille.
J'ai lancé le demon cups aussi ... ca a rien changé (g touché en rien a la conf de base).

n°228042
bobor
tueur de n44b
Posté le 24-02-2003 à 21:03:31  profilanswer
 

quand tu relances cupsd, refait un restart sur samba


---------------
Gitan des temps modernes
n°228051
SCREAM78
Posté le 24-02-2003 à 21:12:08  profilanswer
 

C'est ce que je rajoute dans le smb.conf qui fait merder ... car en gardant les lignes décommenter dans les mimes.* ca fonctionne normalement.
Un autre truc ... j'ai pas lpr-cups dans le path ... j'ai lpr.cups moi (RH7.3).

n°228061
bobor
tueur de n44b
Posté le 24-02-2003 à 21:34:14  profilanswer
 

bah je vois pas. Mets public = yes et guest ok = yes
retire valid users. Au moins pour les tests. Pour le lpr-cups, c'est ce que j'ai et ça marche. Je peux pas t'en dire plus sur ce point car je n'ai pas de programme lpr-cups. Je pense que c'est interne à samba. Donc essaie quand même avec lpr-cups et pas lpr.cups.
 
Le reste=tout pareil


---------------
Gitan des temps modernes
n°228664
Muuthauwg
Posté le 25-02-2003 à 21:34:12  profilanswer
 

Vous avez pas été chercher bien loin...
http://forum.hardware.fr/forum2.ph [...] h=&subcat=

n°229432
SCREAM78
Posté le 26-02-2003 à 21:00:33  profilanswer
 

Ben dsl ... j'avais dû tappé +partage +imprimante et je l'avais pas vu.
Mais bon ... le lien que tu as posté a déja été évoqué plus haut : no comment

n°230600
Muuthauwg
Posté le 28-02-2003 à 13:46:35  profilanswer
 

SCREAM78 a écrit :

Ben dsl ... j'avais dû tappé +partage +imprimante et je l'avais pas vu.
Mais bon ... le lien que tu as posté a déja été évoqué plus haut : no comment  


Ouais mais le mien il dit pas "Désolé se sujet n'existe pas !"

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Samba & Partage d'imprimante

 

Sujets relatifs
Probleme SAMBA avec clients W2k [ RESOLU ]samba au secours
[mdk9 et samba] Quelqu'un pourrait me donner son sbm.conf ?configuration samba :argh
Linux : installation d'imprimante PSMY a-t-il qqn par ici qui sait configurer/utiliser samba ?
Probleme imprimante - /dev/lp0samba 2.2.7 sur une redhat 7.3
Partage d'internet entre deux pc en réseau par cable croisé[Samba] Partage d'imprimante
Plus de sujets relatifs à : Samba & Partage d'imprimante


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR