Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
3463 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  renseigner le wifi dans le fichier interfaces...

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

renseigner le wifi dans le fichier interfaces...

n°1153180
dams78
développateur
Posté le 05-08-2009 à 18:17:03  profilanswer
 

bonsoir,
j'installe une debian sur le portable de mon père
un thinkpad avec un carte wifi intel 3945ABG
 
lors de l'installation debian m'a proposé d'installer le paquet iwlwifi-3945 (non-free)
j'ai continuer l'installation via le câble et maintenant j'aimerai activer le wifi
 
j'ai donc installer le paquet  firmware-iwlwifi, apparement ça suffit de ce que j'ai lu
j'ai activé le module iwl3945 (dans le fichier /etc/modules)
et j'ai configurer mon fichier interface à peu près comme ça
 
allow-hotplug wlan0
iface wlan0 inet dhcp
       wireless-essid freenux
       wireless-key1 blabla
 
je redémarre, et la pas de wifi
un ifconfig me montre que le lo
un ifconig -a me montre eth0, wmaster0, wlan0, irda0
je retrouve ces interface avec un iwlist scann, où d'ailleurs aucune interface supporte un scan wifi
il me dit même que wlan0 est down, donc un petit coup de ifup wlan0 => déjà configuré
 
je m'y perd un peu là
 
merci de votre aide
 
--edit
changement de titre car avancement du problème
ancient titre : carte wifi intel sous debian (driver 3945)


Message édité par dams78 le 13-08-2009 à 08:16:49

---------------
dam's (debianer), ma galerie Flickr
mood
Publicité
Posté le 05-08-2009 à 18:17:03  profilanswer
 

n°1153192
l0g4n
Proxmox&Beer
Posté le 05-08-2009 à 20:19:29  profilanswer
 

Euh...
Pourquoi faire simple quand on peut faire compliquer ?
Après l'installation de firmware-iwlwifi et de iwlwifi-3945, vérifie la présence de wpa_supplicant...
Ensuite, utilise un fichier interfaces des plus simples :
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
 
# The loopback network interface
auto lo
iface lo inet loopback
 
Suffit largement, puis utilise nm-manager...
Ah, et puis, tu y arrivera mieux avec ifconfig wlan0 up...

n°1153194
dams78
développateur
Posté le 05-08-2009 à 20:37:41  profilanswer
 

j'ai pas de paquet iwlwifi-3945, il a l'aire d'être compris dans firmware-iwlwifi
 
je connais pas nm-manager c'est quoi?
 
sinon normalement un iwlist scann devrai fonctionner (je me base de mon expérience sur mon portable, mais c'est vrai que j'ai jamais trouvé ça très simple le wifi sous linux)


---------------
dam's (debianer), ma galerie Flickr
n°1153199
l0g4n
Proxmox&Beer
Posté le 05-08-2009 à 21:54:05  profilanswer
 

iwlist scan ne fonctionne que si la carte est allumée :D
Généralement, c'est le problème principal...
Fait un ifconfig wlan0 up avant...
Par contre, par nm-manager, j'entend le soft graphique qui permet de se connecter à un réseau autrement qu'en ligne de commande...
La CLI, c'est bien, mais la GUI, s'pas mal non plus, c'est quoi ton gestionnaire de bureau ? KDE ? Gnome ?

n°1153200
dams78
développateur
Posté le 05-08-2009 à 21:56:24  profilanswer
 

ya "normalement" gnome et kde d'installé
c'est pas pour moi le portable alors j'ai fait que du mode console en root pour l'instant
ifconfig wlan0 up ne fonctionnait pas, je vais essayer de recopier ce qu'il disait


---------------
dam's (debianer), ma galerie Flickr
n°1153202
dams78
développateur
Posté le 05-08-2009 à 22:02:58  profilanswer
 

en gros il me dit qu'il trouve pas le périf


---------------
dam's (debianer), ma galerie Flickr
n°1153213
l0g4n
Proxmox&Beer
Posté le 06-08-2009 à 00:10:41  profilanswer
 

Euh, pas activé, faut titiler le bouton...
Et/où installer le script/paquet qui te permettra d'utiliser le dit bouton...

n°1153236
dams78
développateur
Posté le 06-08-2009 à 07:40:03  profilanswer
 

aaaaaaaa
j'ai pas l'habitude de ces portables un peu récent (moi je suis encore avec une carte pcmcia...), donc effectivement je dois peut être activer le wifi manuellement
je testes ça ce soir
 
merci de ton aide


---------------
dam's (debianer), ma galerie Flickr
n°1153617
dams78
développateur
Posté le 06-08-2009 à 23:43:14  profilanswer
 

alors j'ai eu l'occassion de tester rapidement
j'ai appuyé sur plusieurs bouton et le wifi c'est activé
par contre je dois avoir un problème soit d'intensité du signal, soit de dhcp
car j'ai pas d'adresse ip, mais un iwlist scan me trouve bien mon wifi
 
je réessayerai dans le weekend
merci de ton aide


---------------
dam's (debianer), ma galerie Flickr
n°1153626
l0g4n
Proxmox&Beer
Posté le 07-08-2009 à 00:30:50  profilanswer
 

Normal...
Essaie les interfaces graphiques, car, même si j'adore coder sur vim en CLI, le petit network manager dans la barre des tâches, il est quand même plus pratique que iwconfig...

mood
Publicité
Posté le 07-08-2009 à 00:30:50  profilanswer
 

n°1154091
dams78
développateur
Posté le 10-08-2009 à 09:56:40  profilanswer
 

j'en suis toujours au même point, un iwconfig me montre que je capte plus ou moins mon wifi, j'ai le bon essid, le signal à l'aire d'être bon, mais impossible de se connecter au point d'accès
je ne comprend pas pourquoi, sur mon autre portable cela fonctionne nickel
d'ailleurs la différence entre un iwconfig sur les deux portables et bien le point d'accès, sur l'un j'ai un message du type "accès impossible" et sur l'autre j'ai l'adresse de ce point d'accès
 
j'ai pas encore essayer en mode graphique, je peux utiliser quel outil sachant que pour l'instant c'est une installation de base, seul gnome est installé


---------------
dam's (debianer), ma galerie Flickr
n°1154113
l0g4n
Proxmox&Beer
Posté le 10-08-2009 à 11:42:48  profilanswer
 

Euh, dis moi, aurait tu du filtrage par adresse mac ?
Genre, un pitti bouton derrière le routeur/box pour autoriser la connexion ? ( p-e sur les livebox... )

n°1154133
dams78
développateur
Posté le 10-08-2009 à 12:41:13  profilanswer
 

je suis sur une freebox,
j'ai effectivement du filtrage mais juste pour mon portable
à la rigueur je peux essayer de mettre celui de mon père
mais bon avec mon téléphone j'arrive à me connecter au wifi donc...


---------------
dam's (debianer), ma galerie Flickr
n°1154138
l0g4n
Proxmox&Beer
Posté le 10-08-2009 à 12:51:36  profilanswer
 

Euh...
Appuis sur le piti bouton wifi sous/derrière la livebox avant de tenter une connexion...
Ah mon avis, sa sera magique...
Tu ne peux pas avoir de filtrage "juste pour le portable" le principe du filtrage d'adresse mac, c'est toutes les refuser, sauf celles contenues dans la table d'adresses, ou, éventuellement, toutes les accepter sauf celles dans la table, mais c'est plus rare ><...

n°1154139
dams78
développateur
Posté le 10-08-2009 à 12:53:55  profilanswer
 

ha oui non, j'ai pas réfléchit
en fait j'ai un filtrage "dhcp" pour assigner toujours la même ip à mon portable
 
sinon j'ai une freebox et non une live box
je viens d'aller jeter un coup d'oeil à mon compte, je vois pas d'option qui bloquerai la visibilité du point d'accès


---------------
dam's (debianer), ma galerie Flickr
n°1154164
l0g4n
Proxmox&Beer
Posté le 10-08-2009 à 13:50:37  profilanswer
 

Arf...
Donc tu constate la présence du réseau, mais tu ne peux t'y connecter...
Que dit dmesg lors des tentatives de connexion ?

n°1154174
dams78
développateur
Posté le 10-08-2009 à 14:10:32  profilanswer
 

oui c'est ça, j'ai pas le pc là avec moi, je tenterai de mettre plus de messages ce soir, mais comme je le disais la différence est flagrante avec un iwconfig
sur mon portable je vois toutes les informations
sur le portable de mon père, il indique bien le nom du wifi, le mode, etc. en revanche l'adresse du point d'accès est indéterminé


---------------
dam's (debianer), ma galerie Flickr
n°1154180
l0g4n
Proxmox&Beer
Posté le 10-08-2009 à 14:20:44  profilanswer
 

L'adresse ? l'adresse mac ou l'adresse IP ?
Si ce n'est qu'un manque d'adresse IP, tente un sudo dhclient ....

n°1154200
dams78
développateur
Posté le 10-08-2009 à 15:21:02  profilanswer
 

c'est plus l'adresse mac mais du point d'accès
pour le dhclient j'ai testé sans succès
j'ai aussi essayé de rentrer moi même l'adresse ip du portable (dans network/interface) mais pareil sans succès
la problème vient vraiment de ce wifi, il le voit mais n'arrive pas à s'y connecter...


---------------
dam's (debianer), ma galerie Flickr
n°1154219
l0g4n
Proxmox&Beer
Posté le 10-08-2009 à 18:26:48  profilanswer
 

Tu relance le réseau après avoir fait la config ?

n°1154224
dams78
développateur
Posté le 10-08-2009 à 19:31:13  profilanswer
 

la config je la fait directement via le fichier interface, si je le modifie je redémarre histoire d'être sûr
sinon j'ai aussi essayé avec un iwconfig... mais sans résultat


---------------
dam's (debianer), ma galerie Flickr
n°1154747
dams78
développateur
Posté le 12-08-2009 à 20:21:12  profilanswer
 

donc un iwconfig histoire de voire à quel wifi je suis rattaché me renvoie bien le nom de mon wifi mais au niveau du point d'accès, j'ai un beau : "Not Associated"


---------------
dam's (debianer), ma galerie Flickr
n°1154751
dams78
développateur
Posté le 12-08-2009 à 20:33:41  profilanswer
 

j'ai réussit via un iwconfig en précisant le channel
j'ai modifié mon fichier interface, là il redémarre, croisons les doigts :)
 
bon alors en fait ça marche avec un iwconfi à la main
mais pas en rajouter les options dans le fichier interface
ça m'arrange pas trop ça


Message édité par dams78 le 12-08-2009 à 20:45:45

---------------
dam's (debianer), ma galerie Flickr
n°1154757
dams78
développateur
Posté le 12-08-2009 à 20:54:48  profilanswer
 

alors pour résumé, ça ça marche pas


# The loopback network interface
auto lo
iface lo inet loopback
 
# The primary network interface
allow-hotplug wlan0
iface wlan0 inet dhcp
      wireless-mode managed
      wireless-essid troy
      wireless-channel 11
      wireless-rate auto
      wireless-key1 XXXXXXX
 


 
et ça ça fonctionne (mais seulement rentré à la main, j'ai essayé de le coller dans /etc/rc.local mais sans succès


iwconfig wlan0 essid troy key XXXXXXXXX mode managed rate auto channel 11


 
mais alors pourquoi?


---------------
dam's (debianer), ma galerie Flickr
n°1154758
l0g4n
Proxmox&Beer
Posté le 12-08-2009 à 20:58:24  profilanswer
 

wireless-key1 XXXXXXX  ?
Bah, tente toujours : wireless-key XXXXXXX ...
Oui, je sais, c'est pour les clés multiples, mais tant qu'a faire, autant supprimer tout risque d'erreur...

n°1154765
dams78
développateur
Posté le 12-08-2009 à 21:38:31  profilanswer
 

j'avais testé, mais c'est vrai que maintenant que j'ai rajouté le canal on sait jamais


---------------
dam's (debianer), ma galerie Flickr
n°1155401
dams78
développateur
Posté le 15-08-2009 à 10:32:25  profilanswer
 

up...
personne ne sait pourquoi ça fonctionne en ligne de commande et pas dans le fichier?


---------------
dam's (debianer), ma galerie Flickr
n°1155429
l0g4n
Proxmox&Beer
Posté le 15-08-2009 à 12:37:17  profilanswer
 

Non...
T'a plus qu'a attendre que les grand maîtres te viennent en aide...
Quand tu modifie le fichier, tu fait un /etc/init.d/networking restart ? Quelles sont les dernières lignes du dmesg après sa ?

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  renseigner le wifi dans le fichier interfaces...

 

Sujets relatifs
heartbeat avec 2 interfaces réseauWU-FTPD : création Dossiers/Fichier en 777
Ubuntu Studio et Freebox en WifiFichier video .gom ?
suppression de certain \n dans un fichier csvtrier un fichier (sort,...)
Recherche chaine dans un fichier texte avec script shellsupprimer un fichier commençant par $
rechercher la chaine de caractère $(function() { dans un fichier 
Plus de sujets relatifs à : renseigner le wifi dans le fichier interfaces...


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR