Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1713 connectés 

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme de rpm

n°735699
got
Posté le 29-09-2005 à 16:51:48  profilanswer
 

Bonjour,
je rencontre un probleme avec ma base rpm. j'essai de desinstaller un package mais rpm -e "package" me dit qu'il y a 2 package avec le meme nom. ce qui est apparement le cas il ne fait pas d'erreur. par contre je ne sais pas commment effacer ces "2" paquets?  
j'ai essayé un rpmdb --rebuild mais il m'a changer les 2 clef de place mais les 2 clef sont toujour là...  
 
quelqu'un aurait 'il une idée? ou un autre métode de deisnstallation de package...  
 
sans desinstaller ce package je n'arrive pas a installer la nouvelle version de celui ci (samba) et c'est po cool ;-)
 
 
Merci

mood
Publicité
Posté le 29-09-2005 à 16:51:48  profilanswer
 

n°735727
bobuse
Posté le 29-09-2005 à 18:04:40  profilanswer
 

Tu es sous quelle distribution ?
Utiliser directement rpm, c'est un peu maso ...
Ta distribution a surement un outil bien foutu qui te simplifierait la vie et éviterait de faire des bétises ...


---------------
get amaroK plugin
n°735928
got
Posté le 30-09-2005 à 10:06:33  profilanswer
 

sous fedora core 4...
j'ai essayé yum aussi mais il a pas l'air de trouver les MAJ pour samba...

n°736044
plainsofpa​in
Pingouino's lover
Posté le 30-09-2005 à 15:00:33  profilanswer
 

up2date est fait exprès pour ca
 
S'il te trouve pas de maj, c'est qu'il n'y a pas de maj officielles


---------------
http://www.alsacreations.com , http://www.openweb.eu.org. Mon CV : http://cv.roane-irkana.net/. Exemple à ne surtout pas suivre : www.worldinternet.be
n°736887
got
Posté le 03-10-2005 à 08:52:11  profilanswer
 

bah apparemment si parce que mon samba est en 3.0.14a-2 et sur www.samba.org on est en 3.0.20a en stable version??!!

n°736911
shaddy
j'aime la gym
Posté le 03-10-2005 à 10:11:00  profilanswer
 

c'est pas forcément une raison. Par exempe gnome 2.12 est sorti mais sur mandriva on est toujours sous gnome... 2.8  [:airforceone]  :cry: Quand une nouvelle version d'un programme sort, on n'a pas le rpm directement tout chaud le lendemain. Fais confiance à ton gestionnaire de paquets, s'il ne voit pas d'update, que tes media sont à jour, alors pas de problèmes ! :)  
Va voir sur les serveurs ftp de tes sources si tu veux en être sûr, que le paquet n'a pas été mis à jour.


---------------
Ubuntu c'est nul ! Tu l'installes et puis ça marche ... y a rien à bidouiller. rm -rf /  
n°736954
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-10-2005 à 12:21:03  profilanswer
 

mettre à jour un programme n'est pas si simple que cela.
 
sous Linux, en général des programmes dépendent d'un autre.
 
Par exemple tous ls programmes permettant d'accéder à des partages widnows dépendent de la version de samba et surtout de libsmb. Or une nouvelle version de samba peut être incompatible avec les anciennes au niveau API ( il faut carrément modifier le code source des programmes utilisant samba ) ou ABI ( il faut recompiler les programmes dépendant de samba ). Donc une distribution décide d'utiliser une version précise du programme et se contente de rester à cette version. Si il y a des mises à jours de sécu, alors elle backporte les patch de sécu pour sa version. Il est trop risqué d'utiliser une nouvelle version qui elle même peut introduire ses propres bugs.


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°737005
got
Posté le 03-10-2005 à 13:29:56  profilanswer
 

soit ..merci pour les infos...
moi qui voulai juste installer l'interface swat pour samba au début.... !  
 

n°737043
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-10-2005 à 14:56:06  profilanswer
 

tu prends le package swat livré et packagé par ta distribution sur les CD et/ou sur les FTP
 
Pour utiliser les FTP, il faut configurer correctement ton gestionnaire de package. Cf doc de ta distro.


Message édité par Dark_Schneider le 03-10-2005 à 14:56:47

---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php

Aller à :
Ajouter une réponse
 

Sujets relatifs
[Samba] probleme dans la config de la corbeille reseau[C] Problème avec la fonction sqrt [Résolu]
Partage de connexion (problème) win<->linuxpetit probleme sur whax (linux live version)!
[Résolu] Problème pour démarrer XPprobleme avec le serveur samba
[menu] problème avec le menu gnome sous MandrivaProblème de routage sous une Debian Sarge
Probleme avec SME[nautilus] problème d'icones.
Plus de sujets relatifs à : probleme de rpm


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR