Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1966 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  fuse et probleme de boot

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

fuse et probleme de boot

n°1029819
sylvaing
Posté le 05-04-2008 à 02:04:06  profilanswer
 

Bonjour a tous,
 
(distribution: Scientific Linux 4)
 
Afin d acceder a mon disque dur reseau via samba, j ai du installer fuse (configure make make install). J'ai egalement du faire un truc dans le noyau (make modules_install) afin de rendre le module fuse accessible par modprobe fuse. Tout q tres bien marche jusqu au reboot. Probleme, au reboot, j ai eu le message : unable to resolve 'LABEL=\home' .
Au boot, j ai le choix entre plusieurs noyaux. L'ancien noyau fonctionne quand a lui. Je pensais que le probleme venait de Grub, mais je n ai pas trouver de difference dans /boot/grub/grub.conf entre les 2 noyaux :( Je n ai aucune possibilite de me connecter au reseau avec l ancien noyau, et j en ai besoin :( il me faut le nouveau :(
 
Est ce que vous avez une idee de ce qui a bien pu se passer et sur le remede ? comment regler unable to resolve 'LABEL=\home' ???
 
Merci a tous

mood
Publicité
Posté le 05-04-2008 à 02:04:06  profilanswer
 

n°1029827
Mjules
Modérateur
Parle dans le vide
Posté le 05-04-2008 à 09:33:08  profilanswer
 

ça ressemble à un montage qui ne se fait pas bien.
 
as tu modifié le fichier /etc/fstab (poste le contenu pendant qu'on y est) ?
 
il y a quoi dans ton montage samba ?  
 
il n'y a avait pas fuse directement sur ta distro ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1029844
sylvaing
Posté le 05-04-2008 à 11:21:40  profilanswer
 

Mjules a écrit :

ça ressemble à un montage qui ne se fait pas bien.
 
as tu modifié le fichier /etc/fstab (poste le contenu pendant qu'on y est) ?
 
il y a quoi dans ton montage samba ?  
 
il n'y a avait pas fuse directement sur ta distro ?


 
Voici le fichier /etc/fstab:
 
# This file is edited by fstab-sync - see 'man fstab-sync' for details
#LABEL=/                 /                       ext3    defaults        1 1
/dev/sda5                 /                       ext3    defaults        1 1
#LABEL=/usr              /usr                   ext3    defaults        1 2
/dev/sda6              /usr                   ext3    defaults        1 2
#LABEL=/usr/local        /usr/local                    ext3    defaults        1 2
/dev/sda7        /usr/local                    ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
LABEL=/home            /local                  ext3    defaults        1 2
#/dev/sda9            /local                  ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
LABEL=swap         swap                    swap    defaults        0 0
/dev/hdc                /media/cdrecorder       auto    pamconsole,exec,noauto,managed 0 0
/dev/sdb1               /media/usbdisk          vfat    pamconsole,exec,noauto,iocharset=utf8,noatime,sync,managed 0 0
 
le fichier /etc/inittab:
 
#
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#               Modified for RHS Linux by Marc Ewing and Donnie Barnes
#
# Default runlevel. The runlevels used by RHS are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
#  
id:5:initdefault:
# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit
l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6
# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now
# When our UPS tells us power has failed, assume we have a few minutes
# of power left.  Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.  
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"
# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"
# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6
# Run xdm in runlevel 5
x:5:respawn:/etc/X11/prefdm -nodaemon
 
le fichier /etc/grub.conf:
 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/hda5
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=50
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
#hiddenmenu
#password --md5 $1$EkczV1$6/YBmiReGZtXZrdIrYGiq0
title Scientific Linux SL Release 4.0 (Beryllium) (2.6.9-42.0.3.ELsmp)
 root (hd0,4)
 kernel /boot/vmlinuz-2.6.9-42.0.3.ELsmp ro root=LABEL=/ quiet rhgb  
 initrd /boot/initrd-2.6.9-42.0.3.ELsmp.img
title Scientific Linux SL Release 4.0 (Beryllium) (2.6.9-34.0.1.ELsmp)
 root (hd0,4)
 kernel /boot/vmlinuz-2.6.9-34.0.1.ELsmp ro root=LABEL=/ quiet rhgb  
 initrd /boot/initrd-2.6.9-34.0.1.ELsmp.img
title Windows
 rootnoverify (hd0,1)
 chainloader +1
 
le fichier ~/.smb/fusesmb.cache
 
/WORKGROUP/192.168.1.2/PUBLIC
/WORKGROUP/192.168.1.2/DATA
/WORKGROUP/192.168.1.2/DOWNLOAD
 
 
En lancant le 2nd noyaux indique dans /etc/grub.conf, la machine demarre, mais en bootant sur le 1er noyau (dont j ai absolument besoin), j ai l erreur indique dans le premier post au boot :( Je ne comprend pqs, il n y a pas de difference... Quelqu un a une idee ?

n°1030145
sylvaing
Posté le 06-04-2008 à 12:56:05  profilanswer
 

Il semblerait que ce soit mon module lvm qui ne serait plus dans le noyau. Quelqu un sait il comment je peux le remettre ?


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  fuse et probleme de boot

 

Sujets relatifs
[Debian] Problème iptables et NatProblème de compilation sous Mandriva
NFS et nième problème de droitsproblème avec postfix et maildrop
Problème xgl[résolu] FreeBSD Probleme avec df
Probleme Serveur Samba GHOSTSquid 2.6 Stable, problème avec un site utilisant l'authentification
Probleme detection interface reseau 
Plus de sujets relatifs à : fuse et probleme de boot


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR