Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1487 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Gentoo 2008_beta2 kde 4 only compilé via gcc-4.3 -march=core2[Résolu]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Gentoo 2008_beta2 kde 4 only compilé via gcc-4.3 -march=core2[Résolu]

n°1038837
trouble_fe​te
Posté le 30-04-2008 à 23:58:40  profilanswer
 

Bonsoir, je m'apprete a installer une Gentoo 64 bits avec gcc-4.3 sur mon PC "de production", mais je n'ai pas trouvé s'il fallait prendre l'archive stage 3 IA64 ou AMD64, a priori ce serait la AMD64 mais j'aimerais avoir confirmation (http://gentoo-wiki.com/Safe_Cflags#Intel_Core_Solo.2FDuo.2C_Pentium_Dual-Core_Txxxx)
 
Ensuite j'ai un gros problème avec la variable CHOST sachant que dans le CFLAGS j'aurais -march=core2.
 
d'origine la CHOST du stage 3 est rempli comme ceci:
 

Citation :

CHOST="ia64-unknow-linux-gnu"


 
mais sur certains sites j'ai trouvé aussi cette variante: (comme sur wikipedia par exemple)

Citation :

x86_64-pc-linux-gnu


 
mais sans savoir si elle convient avec le stage 3 amd64 ou plutot ia64 :??: a moins que ça ne fasse aucune différence (ce qui me semble bien etre le cas)
 
j'imagine par extrapolation que le stage 3 d'origine AMD64 doit etre rempli comme ceci:

Citation :

amd64-unknow-linux-gnu

(supposition quasi gratuite)
edit: supposition perdu, avec le stage 3 amd64 on a ceci:

Citation :

x86_64-pc-linux-gnu


bref si qqun peut m'aider pour ma CHOST et me dire quel stage 3 prendre entre amd64 et ia64, afin de compiler une Gentoo 64 bits avec -march=core2 (grace a gcc-4.3) merci beaucoup je suis proche du but ! (avec kde 4, j'ai déjà préparé les package.* adequat pour que seul kde 4 soit compilé)
 
 :ange:
 
Et vive mc pour lire le contenu des fichiers de conf dans les archives bz2 sans devoir décompresser, surtout quand on a plus de place  :pt1cable:


Message édité par trouble_fete le 08-05-2008 à 13:37:45

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
mood
Publicité
Posté le 30-04-2008 à 23:58:40  profilanswer
 

n°1038844
deK
watching for beerz on the wing
Posté le 01-05-2008 à 00:15:11  profilanswer
 

IA64 c'est pour les procos Itanium.
 
Sur ton C2D, il te faut la i386 si tu veux du 32 bits, et la AMD64 si tu veux du 64 bits.


---------------
Feed HA/V          
n°1038846
trouble_fe​te
Posté le 01-05-2008 à 00:17:10  profilanswer
 

deK a écrit :

IA64 c'est pour les procos Itanium.
 
Sur ton C2D, il te faut la i386 si tu veux du 32 bits, et la AMD64 si tu veux du 64 bits.


 
Je te remerci énormement  :love:  
 
 :sol:


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1038849
Rasthor
Liberté et Patrie
Posté le 01-05-2008 à 00:22:26  profilanswer
 

J'ai une Gentoo 64bits sur un Core2Duo. Ca marche nickel en 64bits. Quelques petits détails avec Firefox, Flash, mais sinon ça roule.
 
IA64 => Processeur professionel Itanium / Itanium2 => hors de propos ici.
 
Dans ton cas, c'est bien AMD64 qu'il te faut.
 
Et y'a exactement TOUT ce dont tu as besoin de savoir dans la doc prévue pour:
http://www.gentoo.org/doc/fr/handb [...] -amd64.xml
 
Pour ton CHOST:
 
"La variable CHOST définit l'architecture de votre machine. Sa valeur devrait déjà être définie. Ne modifiez pas cette variable, car cela rendrait votre système inutilisable. Si la valeur de la variable CHOST ne vous semble pas correcte, il est possible que vous ayez utilisé une mauvaise archive stage3."  
 
Donc ton CHOST est bien "x86_64-pc-linux-gnu". :jap:
 
Dans mon cas, j'utilise -march=nocona, mais effectivement, avec GCC 4.3, tu devrais pouvoir utiliser -march=core2
 
Bon courage. :hello:
 

n°1038850
trouble_fe​te
Posté le 01-05-2008 à 00:25:03  profilanswer
 

Rasthor a écrit :

J'ai une Gentoo 64bits sur un Core2Duo. Ca marche nickel en 64bits. Quelques petits détails avec Firefox, Flash, mais sinon ça roule.
 
IA64 => Processeur professionel Itanium / Itanium2 => hors de propos ici.
 
Dans ton cas, c'est bien AMD64 qu'il te faut.
 
Et y'a exactement TOUT ce dont tu as besoin de savoir dans la doc prévue pour:
http://www.gentoo.org/doc/fr/handb [...] -amd64.xml
 
Pour ton CHOST:
 
"La variable CHOST définit l'architecture de votre machine. Sa valeur devrait déjà être définie. Ne modifiez pas cette variable, car cela rendrait votre système inutilisable. Si la valeur de la variable CHOST ne vous semble pas correcte, il est possible que vous ayez utilisé une mauvaise archive stage3."  
 
Donc ton CHOST est bien "x86_64-pc-linux-gnu". :jap:
 
Dans mon cas, j'utilise -march=nocona, mais effectivement, avec GCC 4.3, tu devrais pouvoir utiliser -march=core2
 
Bon courage. :hello:
 


 
Merci beaucoup pour ce post on ne peut plus clair  :jap:  
 
j'ai fait un test de compil de gentoo 32 bits avec gcc-4.3, mis a part devoir mettre un ebuild indépendamment de portage pour avoir boost-1.35.0  (le boost 1.34 de portage est incompilable avec les gcc d'avant 4.3) j'ai pas eu de problème de compilation mais je ne suis pas au bout sur le pc de test car c'est un Pentium 3 a 500Mhz, 160Mo de SDR PC 133 et... il est lent !  
 
lol


Message édité par trouble_fete le 01-05-2008 à 00:25:45

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1038880
Tom_
Posté le 01-05-2008 à 10:35:29  profilanswer
 

Boost-1.35 est dans portage, mais masqué donc pas besoin d'ebuild externe. ;)
 
Le passage a GCC-4.3 se passe plutôt bien, et un bon nombre d'applis récalcitrantes ont déja été patchés par les developpeurs. Et pour les autres, tu peux généralement trouver des patchs sur le bugzilla : http://bugs.gentoo.org/show_bug.cgi?id=198121

n°1038919
trouble_fe​te
Posté le 01-05-2008 à 14:19:56  profilanswer
 

Ah ça y est c'est dans portage boost-1.35 ça doit faire peu de temps :)
 
merci pour le lien a patch mais il va me falloir apprendre a patcher avec ce genre de patch, ce que je ne sais pas encore faire (me suis jamais penché sur la question jusque là, vu que j'en avais pas besoin...)
 
Enfin je pense que ça reste jouable
 
ça y est j'ai eu mon premier paquet qui chiotte c'est celui-ci:

Citation :

kde-base/kdnssd-4.0.3


Mais le message est clair ce sera résolu sans soucis a priori:
 

Citation :

* This package requires 'net-dns/avahi' to be built with the following USE flags: 'mdnsresponder-compat*'.
 * Flags marked with an * are missing.
 *
 * ERROR: kde-base/kdnssd-4.0.3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *     kdnssd-4.0.3.ebuild, line   22:  Called kde4-meta_pkg_setup
 *        kde4-meta.eclass, line  134:  Called kde4-base_pkg_setup
 *        kde4-base.eclass, line  329:  Called kde4-functions_check_use
 *   kde4-functions.eclass, line  516:  Called die
 * The specific snippet of code:
 *              die "Missing USE flags found"
 *  The die message:
 *   Missing USE flags found


 
Je regle ça et je fait un --resume...
 
Edit: résolu sans soucis effectivement.
 
Pour info j'ai compilé pas mal de paquet là avec gcc-4.3, voici ceux qu'il me reste actuellement:
(sur un emerge -avD kde-base/kde-meta:kde-4, car je veux que l'environnement kde complet soit testé avant de compiler ça sur le "vrai" pc)
 

Citation :

[ebuild  N    ] kde-base/blinken-4.0.3  USE="-debug -htmlhandbook" 0 kB
[ebuild  N    ] kde-base/ktouch-4.0.3  USE="-debug -htmlhandbook" 0 kB
[ebuild  N    ] kde-base/kturtle-4.0.3  USE="-debug -htmlhandbook" 0 kB
[ebuild  N    ] kde-base/kcron-4.0.3  USE="-debug -htmlhandbook" 0 kB
[ebuild  N    ] kde-base/kuser-4.0.3  USE="-debug -htmlhandbook" 0 kB
[ebuild  N    ] kde-base/kdebase-meta-4.0.3  0 kB
[ebuild  N    ] kde-base/kdeaccessibility-meta-4.0.3  0 kB
[ebuild  N    ] kde-base/kdeedu-meta-4.0.3  0 kB
[ebuild  N    ] kde-base/kdeadmin-meta-4.0.3  USE="-lilo" 0 kB
[ebuild  N    ] kde-base/kde-meta-4.0.3  USE="accessibility" 0 kB
[ebuild  N    ] gnome-extra/libgsf-1.14.7  USE="gnome python -bzip2 -debug -doc" 573 kB
[ebuild  N    ] gnome-base/librsvg-2.20.0  USE="gnome zlib -debug -doc" 453 kB
[ebuild  N    ] media-gfx/imagemagick-6.3.8.3-r1  USE="X jpeg perl png svg tiff truetype xml zlib -bzip2 -djvu -doc -fontconfig -fpx -graphviz -gs -hdri -jbig -jpeg2k -lcms -nocxx -openexr -q32 -q8 -wmf" 8,587 kB
[ebuild  N    ] gnome-base/nautilus-2.20.0-r1  USE="X esd gnome -beagle -debug -tracker" 4,802 kB
[ebuild  N    ] gnome-base/gnome-mount-0.6  USE="gnome -debug" 456 kB


Message édité par trouble_fete le 02-05-2008 à 16:05:57

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1038948
Tom_
Posté le 01-05-2008 à 16:30:38  profilanswer
 

Pour patcher c'est assez simple, perso je fais comme ca :  
- je copie /usr/portage/categorie/programme dans /usr/local/portage/categorie/programme (/usr/local/portage est mon overlay perso)
- tu peux faire du ménage dans /usr/local/portage/categorie/programme en virant les versions d'ebuilds inutiles
- je copie le patch que j'ai trouvé sur le net dans /usr/local/portage/categorie/programme/files
- j'ouvre l'ebuild que je veux patch et j'ajoute : epatch "${FILESDIR}/nom_du_patch.patch" dans la partie src_unpack avant toutes les actions comme eautoreconf, elibtoolize etc ..
- ensuite, tu fais ebuild ton_ebuild.ebuild manifest
 
Et ca roule. :D

n°1038949
trouble_fe​te
Posté le 01-05-2008 à 16:34:10  profilanswer
 

Merci beaucoup Tom_ ! pour le moment tout se compile sans necessiter de patch mais il me reste un paquet de paquets a compiler quand même  :sweat: (quasiment tous des paquets de kde-4, voir la liste de ce qui reste a compiler ds mon post précédent celui-ci je le mets a jour au fur et a mesure que les compil passent :whistle: )


Message édité par trouble_fete le 01-05-2008 à 16:53:50

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1038951
trouble_fe​te
Posté le 01-05-2008 à 17:29:53  profilanswer
 

Bon j'en ai assez vu je passe a la pratique, j'ai un peu peur  :sweat:  
 
voila c'est parti je vais booter le livecd Gentoo amd64 sur mon pc de production et refaire l'instal de zero avec directement gcc-4.3 en -march=core2, avec kde-4 uniqument.
 
Je vous dirais si ça a été et ce que j'ai du faire en cas de prob, j'ai quand même un 3eme PC de secours qui lui n'est jamais bidouillé  :whistle: un ptit Athlon 850Mhz avec 640Mo de SDR PC 133, il rend bien des services aussi celui là...(Gentoo dessus bien évidemment)
 
Edit: n'hésitez pas a regarder ma liste des paquets restants a compiler sur le pentium 3, certe c'est en 32 bits (-march=pentium3) mais c'est quand même kde-4 compilé avec gcc-4.3  :whistle: pour le moment ça compile toujours sans soucis  :heink:
 
Aaahhh autant en 32 bits ça a l'air de bien se passe, autant en 64 je suis toujours en train d'essayer de compiler gcc-4.3.0 il se laisse pas faire  :heink:  :sweat:
 
Bon j'abandonne le 64 bits, ça fait 3 ans que j'essaye d'y passer décidement il veut pas de moi, tant pis ce sera pour la 2009.0 le prochain test (la 2008 en r2 étant beugué j'ai même plus envi de tester la 2008 ^^)
 
en 32 bits au moins ça marche (mon pc de test a beaucoup avancé) je ne parviens même pas a compiler gcc-4.3 en 64 bits, trop fort quand même.
 
et comme mon pc de prod doit etre rapidement de nouveau opérationnel j'abandonne l'idée du 64 bits, mais je retenterais quand Gentoo 2009.0 sortira ;)
 
Edit: ben ça alors en fait je n'arrive plus a compiler gcc-4.3.0, en 64 comme en 32 bits  alors que sur le pentium 3 ça c'est bien passé je ne comprend plus rien bref tant pis, je vais compiler sur mon core 2 duo avec -march=prescott avec gcc-4.2.3... (le 64 bits ne m'interessait qu'avec gcc-4.3.0 a cause de -march=core2)
 
voila voila :D par contre j'installe bien kde-4 c'est la seule chose qui, normalement, ne doit poser aucun soucis...
 
quelle aventure folklorique, difficile de trouver la logique bien que normalement l'informatique soit plutot logique  :whistle:


Message édité par trouble_fete le 02-05-2008 à 15:02:37

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
mood
Publicité
Posté le 01-05-2008 à 17:29:53  profilanswer
 

n°1040653
trouble_fe​te
Posté le 08-05-2008 à 01:51:48  profilanswer
 

Finalement j'y suis arrivé, apres moultes péripéties.... là je suis déjà parvenu a recompiler tout system avec -march=core2 (j'ai du patcher gcc sinon le 4.3 inclu pourtant dans portage ne se compile pas en 64 bits)
 
ça m'a l'air bien parti toussa
 
apres il restera kde 4 a recompiler dans world, je verrais bien ce que ça fera  :whistle: (c'est une install faite de zero sans kde 3, les packages.* sont adaptés pour n'installer QUE kde 4)
 
Si ça interesse des gens je pourrais faire une sorte de petit guide, pour installer comme je l'ai fait la Gentoo 2008.0_beta2 dans la branche amd64 et compiler la dessus gcc-4.3  
 
puis kde-4, qui s'est bien compilé avec -march=nocona avec le gcc-4.2.3, j'attends de voir ce que ça va donner avec gcc-4.3 en -march=core2 et jvous dis quoi ça va aller vite vu que j'ai un E6550 oc/ de 2,33@3,1Ghz (FSB a 444) avec le ventirad d'origine ;) (sans augmentation du vcore ! vive la révision G0) j'ai 2Go de PC 8500 en dual channel également pour aller bien avec :D (oui de nos jours ça fait peu de ram je sais :o )
 
Edit: world fait 646 paquetages, c'est rien de ça  :whistle:
 
Oh pis tient pendant que ça compile je vais jouer a Nexuiz  :lol:


Message édité par trouble_fete le 08-05-2008 à 01:57:51
n°1040705
trouble_fe​te
Posté le 08-05-2008 à 13:35:44  profilanswer
 

Bingo j'ai compilé toute ma Gentoo 2008.0_beta2 (dont j'ai synchro portage avant) avec gcc-4.3 avec -march=core2, excepté ... gcc-4.2.3
 
il n'a pas voulu se compiler avec gcc-4.3, est-ce pke c'est gcc-4.3 ou bien a cause du -march=core2 je n'en sais rien et en fait je m'en fou.
 
pour info je n'ai eu aucun bug a aucun moment pour compiler system et world avec kde 4 (si j'excepte le patch que j'ai du appliquer a gcc-4.3)
 
 :sol:


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Gentoo 2008_beta2 kde 4 only compilé via gcc-4.3 -march=core2[Résolu]

 

Sujets relatifs
MAJ vers Mandriva spring 2008 probleme PPOE[Résolu] ddclient ubuntu 8.04
[Résolu] Mail automatique + tableau html[RESOLU] Plus d'acces à PhpMyAdmin en installant .htaccess
Memory dumper ? [Résolu][GENTOO] purger la file SMTP et connaitre son état.
[RESOLU]OpenVPN fonctionne bien sauf que...grub error 22 [Résolu]
Installation iwp2100 Debian lenny[RESOLU]Grep et les espaces -> Résolu
Plus de sujets relatifs à : Gentoo 2008_beta2 kde 4 only compilé via gcc-4.3 -march=core2[Résolu]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR