Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
945 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Debian] Problème à l'installation de bureau+gestionnaire de fenêtres.

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

[Debian] Problème à l'installation de bureau+gestionnaire de fenêtres.

n°450834
Okysp
Rien.
Posté le 07-04-2004 à 13:06:25  profilanswer
 

Hello,
Je suis en ce moment un tutorial pour une installation/configuration/utilisation de Debian et je suis actuellement en Sid.
Je viens d'installer le serverx et tout s'est bien passé.
Au moment d'installer le bureau+gestionnaire de fenêtres (gnome+sawfish):

Code :
  1. # apt-get install gnome-session nautilus gnome-control-center gnome-applets gnome-icon-theme sawfish-gnome


La console me renvoie qu'elle doit installer des dépendances mais qu'elles ne seront pas installées, et ensuite, elle me renvoie ça:

Code :
  1. E: paquet defectueux.


Enfin quelque chose comme ça...
Ma question est simple; savez-vous d'où vient ce problème et comment le corriger? :??:
Merci d'avance. :jap:

mood
Publicité
Posté le 07-04-2004 à 13:06:25  profilanswer
 

n°450838
Klaimant
?
Posté le 07-04-2004 à 13:09:24  profilanswer
 

dpkg -i --force-all /var/cache/apt/archives/le_paquet qui te pose problème, et tu reprends ton apt :)


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°450854
Okysp
Rien.
Posté le 07-04-2004 à 13:16:09  profilanswer
 

Merci. :jap:
Je pourrais savoir ce que ta commande fait s'il te plait?
C'est juste parce que j'ai pas encore beaucoup de notions sous Linux et que j'aimerais savoir ce que ça fait. :)

n°450861
Klaimant
?
Posté le 07-04-2004 à 13:19:27  profilanswer
 

ben les flags l'indique dpkg (programme d'installation de paquet de debian) -i (install) --force-all (force l'installation, nécessaire quand un paquet est "cassé" )


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°450871
Okysp
Rien.
Posté le 07-04-2004 à 13:22:45  profilanswer
 

Merci pour les explications, je vais essayer ça.
Au fait, il existe un topic pour donner les problèmes rencontrés sur Debian?
 
Edit: le paquet defecteux c'est à cause du fichier mal uploadé sur le ftp des packages?


Message édité par Okysp le 07-04-2004 à 13:24:31
n°450876
Klaimant
?
Posté le 07-04-2004 à 13:23:44  profilanswer
 

topic unique debian je pense :)


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°450881
Okysp
Rien.
Posté le 07-04-2004 à 13:25:07  profilanswer
 

Klaimant a écrit :

topic unique debian je pense :)


Je l'avais jamais vu. :/
 
PS: j'ai édité mon message plus haut...

n°450898
Klaimant
?
Posté le 07-04-2004 à 13:29:24  profilanswer
 

tu feras une recherche quand ca remarchera ou tu peux regarder dans le topic débutant, je crois que le lien s'y trouve :)


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°450901
Okysp
Rien.
Posté le 07-04-2004 à 13:30:53  profilanswer
 

Ok, merci pour tout, je te tiens au courant si tu veux. :p ;)

n°450908
Klaimant
?
Posté le 07-04-2004 à 13:32:58  profilanswer
 

Ben reviens si tu as d'autres questions/problèmes ;)
 
:hello:


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
mood
Publicité
Posté le 07-04-2004 à 13:32:58  profilanswer
 

n°450911
Jar Jar
Intaigriste
Posté le 07-04-2004 à 13:34:43  profilanswer
 

Klaimant a écrit :

dpkg -i --force-all /var/cache/apt/archives/le_paquet qui te pose problème, et tu reprends ton apt :)

NON.
 
Jamais de --force à moins de savoir exactement ce que tu fais.


Message édité par Jar Jar le 07-04-2004 à 13:35:03
n°450921
Okysp
Rien.
Posté le 07-04-2004 à 13:36:36  profilanswer
 

Ah...
Ca se complique? :D

n°450940
Klaimant
?
Posté le 07-04-2004 à 13:41:23  profilanswer
 

Jar Jar a écrit :

NON.
 
Jamais de --force à moins de savoir exactement ce que tu fais.


 
Ben la il le sait, c'est pour un paquet de gnome :O ya pas mise en danger du système :O


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°450947
Okysp
Rien.
Posté le 07-04-2004 à 13:43:33  profilanswer
 

Allez hop, je vais tester ça tout de suite. :)

n°450955
Jar Jar
Intaigriste
Posté le 07-04-2004 à 13:45:05  profilanswer
 

Klaimant a écrit :

Ben la il le sait, c'est pour un paquet de gnome :O ya pas mise en danger du système :O

Mais non bordel ! Si tu fais un --force-all ça ne résout rien du tout, et par la suite il refusera d'installer quoi que ce soit tant que le problème ne sera pas réglé !
 
OkYsP : si tu postais le message d'erreur plutôt ? Et d'ailleurs, tu tiens absolument à utiliser sawfish et non metacity ?

n°450958
Klaimant
?
Posté le 07-04-2004 à 13:46:49  profilanswer
 

Mouarf, pour mon kde 3.2 avant qu'il arrive dans sid, j'avais toujours des problèmes sur des paquets... J'ai toujours fait des force-all et ca installait le paquet défectueux et mon système n'est pas mort, et j'ai continué à pouvoir faire mes majs ...


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451006
Okysp
Rien.
Posté le 07-04-2004 à 14:04:16  profilanswer
 

Jar Jar => je ne connais aucun des deux, je suis un tutorial...Donc bon. :/
Quand j'essaie d'installer seulement "gnome-session", il me dit que c'est sûrement pas le package qui est défectueux parce que j'en ai selectionné qu'un à installer (pas sûr) et que je devrais repporter le "bogue". :D
 
Klaimant => j'ai essayé ta commande, d'abord sans "--force-all", ça ne fonctionne pas donc après j'ai essayé avec, et il me dit que le package n'existe pas (logique, l'apt-get install ne fonctionne pas donc le package n'est pas téléchargé...).

n°451088
Okysp
Rien.
Posté le 07-04-2004 à 14:37:13  profilanswer
 

Je vais essayer de changer les sources d'apt...

n°451140
Okysp
Rien.
Posté le 07-04-2004 à 15:01:27  profilanswer
 

Non, rien à faire.
Apparement le problème vient du fait qu'il ne veut pas mettre à jour plein de dépendances.
Sinon vous me conseillez d'installer quoi? Sachant que j'aurais bien voulu installer Gnome quand même. :/

n°451166
Jar Jar
Intaigriste
Posté le 07-04-2004 à 15:25:11  profilanswer
 

Tu peux taper 'apt-get install gnome' et me donner le message d'erreur ?

n°451471
Okysp
Rien.
Posté le 07-04-2004 à 18:44:27  profilanswer
 

Désolé pour le retard, je vais essayer ça tout de suite.
C'est possible de faire un screenshot ou de copier ce message? :??:
Merci. :jap:

n°451480
Klaimant
?
Posté le 07-04-2004 à 18:53:56  profilanswer
 

copié oui tu peux essayer apt-get install gnome > out.txt


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451482
Okysp
Rien.
Posté le 07-04-2004 à 18:57:11  profilanswer
 

Merci. :jap:

n°451524
Okysp
Rien.
Posté le 07-04-2004 à 19:55:53  profilanswer
 

Bon là je suis sous lynx parce que j'ai pas moyen d'enregistrer le fichier txt. :D
Sous vim y'a une commande pour copier tout le texte?

n°451528
Klaimant
?
Posté le 07-04-2004 à 19:57:33  profilanswer
 

heu je sais pas


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451535
Okysp
Rien.
Posté le 07-04-2004 à 20:01:30  profilanswer
 

Ou alors comment je fais pour monter mon lecteur de disquette qui se trouve là: /dev/fd0 ?
Oui j'vais y arriver...
 
Edit: c'est bon, voilà le message d'erreur après la longue commande:
 

Code :
  1. Lecture des listes de paquets...
  2. Construction de l'arbre des dépendances...
  3. Certains paquets ne peuvent être installés. Ceci peut signifier
  4. que vous avez demandé l'impossible, ou bien, si vous utilisez
  5. la distribution unstable, que certains paquets n'ont pas encore
  6. été créés ou ne sont pas sortis d'Incoming.
  7. L'information suivante devrait vous aider à résoudre la situation :
  8. Les paquets suivants contiennent des dépendances non satisfaites :
  9.   gnome-applets: Dépend: libbonoboui2-0 (>= 2.4.3) mais ne sera pas installé
  10.                  Dépend: libgail-common (>= 1.4.1) mais ne sera pas installé
  11.                  Dépend: libgail17 (>= 1.4.1) mais ne sera pas installé
  12.                  Dépend: libglade2-0 (>= 2.0.0) mais ne sera pas installé
  13.                  Dépend: libgnomecanvas2-0 (>= 2.4.0) mais ne sera pas installé
  14.                  Dépend: libgnomeui-0 (>= 2.4.0.1-2) mais ne sera pas installé
  15.                  Dépend: libpanel-applet2-0 (>= 2.4.0) mais ne sera pas installé
  16.                  Dépend: gnome-panel (>= 2.4.0) mais ne sera pas installé
  17.   gnome-control-center: Dépend: libbonoboui2-0 (>= 2.4.3) mais ne sera pas installé
  18.                         Dépend: libglade2-0 (>= 2.0.0) mais ne sera pas installé
  19.                         Dépend: libgnome-desktop-2 (>= 2.4.1) mais ne sera pas installé
  20.                         Dépend: libgnomecanvas2-0 (>= 2.4.0) mais ne sera pas installé
  21.                         Dépend: libgnomeui-0 (>= 2.4.0.1-2) mais ne sera pas installé
  22.                         Dépend: capplets mais ne sera pas installé
  23.   gnome-session: Dépend: libbonoboui2-0 (>= 2.4.3) mais ne sera pas installé
  24.                  Dépend: libgnomecanvas2-0 mais ne sera pas installé
  25.                  Dépend: libgnomeui-0 mais ne sera pas installé
  26.   nautilus: Dépend: libbonoboui2-0 (>= 2.4.3) mais ne sera pas installé
  27.             Dépend: libeel2-2 (>= 2.4.1) mais ne sera pas installé
  28.             Dépend: libgail-common (>= 1.4.1) mais ne sera pas installé
  29.             Dépend: libgail17 (>= 1.4.1) mais ne sera pas installé
  30.             Dépend: libglade2-0 (>= 2.0.0) mais ne sera pas installé
  31.             Dépend: libgnome-desktop-2 (>= 2.4.1) mais ne sera pas installé
  32.             Dépend: libgnomecanvas2-0 (>= 2.4.0) mais ne sera pas installé
  33.             Dépend: libgnomeui-0 (>= 2.4.0.1-2) mais ne sera pas installé
  34.             Dépend: libnautilus2-2 (>= 2.4.2) mais ne sera pas installé


Message édité par Okysp le 07-04-2004 à 20:11:24
n°451541
Okysp
Rien.
Posté le 07-04-2004 à 20:12:00  profilanswer
 

Up pour que vous voyiez l'edit. :D

n°451547
Klaimant
?
Posté le 07-04-2004 à 20:19:17  profilanswer
 

apt-get install libbonoboui2-0


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451549
Okysp
Rien.
Posté le 07-04-2004 à 20:22:28  profilanswer
 

J'avais déjà essayé mais il me dit qu'il lui des dépendance à lui aussi...

n°451554
Klaimant
?
Posté le 07-04-2004 à 20:41:27  profilanswer
 

ben tu descends petit à petit et tu cherches le paquet dépendant le plus bas :D


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451567
Okysp
Rien.
Posté le 07-04-2004 à 21:02:54  profilanswer
 

C'est ce que je viens faire:
Je tombe à un moment sur le fichier libglade2-0, qui lui veut donc pas non plus s'installer, je regarde alors ses dépendances et les installes toutes, sans problème... mais après, je peux toujours pas installer libglade2-0, il me ressort les dépendances, alors que je les ai installés!
J'ai fait, à tout hazard: apt-get install =force libglade2-0, et là, il me semble qu'il m'a balancé que ce paquet n'existait pas. :heink:
 
Edit: ce serait pas les sources de mon apt qui seraient pourries? Vous utilisez lesquelles vous pour la Sid?


Message édité par Okysp le 07-04-2004 à 21:03:44
n°451575
Klaimant
?
Posté le 07-04-2004 à 21:10:51  profilanswer
 

# Debian officiel
deb http://security.debian.org/ stable/updates main
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb http://non-us.debian.org/debian-non-US sid/non-US main contrib non-free
 
# Mplayer
deb ftp://ftp.nerim.net/debian-marillat/ unstable main
 
# paquet kde3.2 rc1
#deb http://people.debian.org/~ccheney/kde-3.1.95/ ./
#deb http://people.debian.org/~bab/kde-3.2 ./
 
#Net Panzer
deb http://mentors.debian.net/debian unstable main


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451579
Okysp
Rien.
Posté le 07-04-2004 à 21:14:59  profilanswer
 

J'avais pas les mêmes, je vais tester les tiennes, merci.

n°451581
krtek
Just Do It
Posté le 07-04-2004 à 21:20:14  profilanswer
 

Sauf erreur libglade2-0 est cassé, il ne s'installe pas non plus chez moi...
 
Suffit dattendre 2-3 jour je penses, que les maintenairs mettent tout cela a jour...

n°451592
Okysp
Rien.
Posté le 07-04-2004 à 21:34:08  profilanswer
 

C'est bien ce que je pensais. :o
Merci de m'avoir prévenu. :jap:
Ca arrive souvent ce genre de désagrément? :??:

n°451593
Klaimant
?
Posté le 07-04-2004 à 21:35:17  profilanswer
 

OkYsP a écrit :

C'est bien ce que je pensais. :o
Merci de m'avoir prévenu. :jap:
Ca arrive souvent ce genre de désagrément? :??:


 
Non, mais c vrai que le jours de ton install c balo :D mets KDE ca roxxe les ours polaires russes en caleçons rouges


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451595
Okysp
Rien.
Posté le 07-04-2004 à 21:36:31  profilanswer
 

J'adore ton expression. [:rofl]
"apt-get install kde" tout simplement? Rien à configurer après, juste à faire "startx"? :??:

n°451597
krtek
Just Do It
Posté le 07-04-2004 à 21:41:36  profilanswer
 

Si qq truc a configurer, mais debconf devrait le faire pour toi...
Dison que cela arrive de temps en temps, mais c rare, surtout pour des packages aussi important.
 
De plus la tu es embeté car tu install le package pour la première fois, donc tu n'as rien, tandis que en général c lors des update que cela foire, donc a la limite, sa change pas grand chose...

n°451600
Klaimant
?
Posté le 07-04-2004 à 21:44:55  profilanswer
 

OkYsP a écrit :

J'adore ton expression. [:rofl]
"apt-get install kde" tout simplement? Rien à configurer après, juste à faire "startx"? :??:


 
tu installes kde et apres tu mets startkde dans le .xinitrc de ton user et voilou


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°451601
Okysp
Rien.
Posté le 07-04-2004 à 21:45:08  profilanswer
 

Bon ben go apt-get install kde, merci à vous. :jap:

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Debian] Problème à l'installation de bureau+gestionnaire de fenêtres.

 

Sujets relatifs
[Debian]Ecran bleu[Debian]Ecran bleu
Probleme au boot de red hat 9[ALSA] Problème de son
[boot] Problème Grub disque SCSIprobleme en RTC sous debian
Problème de samba avec Mac OS X[Linux] Probleme de creation de disquette boot
[POSTFIX+SASLAUTHD] problème d'authentification smtp 
Plus de sujets relatifs à : [Debian] Problème à l'installation de bureau+gestionnaire de fenêtres.


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR