Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1687 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Aide pour créer un serveur LINUX Minecraft PE

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Aide pour créer un serveur LINUX Minecraft PE

n°1360798
OxyGrox
Posté le 11-07-2014 à 13:45:11  profilanswer
 

Bonjour, j'aimerai créer un serveur Minecraft PE sur une machine Linux mais à chaque fois que je regarde un tuto il me renvoie toujours une erreur. Si quelqu’un connait un moyen d'en créer un pourrait-il m'aidait plz. Ma machine Linux c'est un VPS sur Debian.
 
Pour info je suit ce tuto:
http://technologyplusblog.com/2013 [...] ed-server/  
 
Mais il y a des erreurs du genre:

Code :
  1. ./bin/php5/bin/php: /lib/libc.so.6: version `GLIBC_2.14' not found (required by ./bin/php5/bin/php)
  2. ./bin/php5/bin/php: /lib/libc.so.6: version `GLIBC_2.15' not found (required by ./bin/php5/bin/php)
  3. ./bin/php5/bin/php: /lib/libm.so.6: version `GLIBC_2.15' not found (required by ./bin/php5/bin/php)
  4. ./bin/php5/bin/php: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /root/bin/php5/bin/../lib/libz.so.1)
  5. ./bin/php5/bin/php: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /root/bin/php5/bin/../lib/libyaml-0.so.2)
  6. ./bin/php5/bin/php: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /root/bin/php5/bin/../lib/libcurl.so.4)
  7. ./bin/php5/bin/php: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /root/bin/php5/bin/../lib/libcurl.so.4)


 
Voilà, D'avance Merci ;)

mood
Publicité
Posté le 11-07-2014 à 13:45:11  profilanswer
 

n°1360875
blazkowicz
Posté le 13-07-2014 à 22:09:41  profilanswer
 

Il te faut savoir la version de glibc6 que tu as. pour cela :
apt-cache show libc6 , ou bien dpkg -l libc6
 
D'ailleurs quelle est ta version de debian ?  
 
en allant voir libc6 sur packages.debian.org je constate que debian squeeze a une glibc 2.11 et wheezy une 2.13.
Solutions pour faire marcher ça, en tt cas avec la méthode d'installation que tu utilises : passer en debian testing voire sid (glibc 2.19), installer ubuntu 12.04 (2.15) ou 14.04 (2.19)

n°1361050
OxyGrox
Posté le 17-07-2014 à 18:49:23  profilanswer
 

Ma version de glibc6 est:

Code :
  1. Package: libc6
  2. Status: install ok installed
  3. Priority: required
  4. Section: libs
  5. Installed-Size: 9868
  6. Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
  7. Architecture: amd64
  8. Source: eglibc
  9. Version: 2.11.3-4
  10. Provides: glibc-2.11-1
  11. Depends: libc-bin (= 2.11.3-4), libgcc1
  12. Suggests: glibc-doc, debconf | debconf-2.0, locales
  13. Breaks: locales (<< 2.11), locales-all (<< 2.11), nscd (<< 2.11)
  14. Conflicts: prelink (<= 0.0.20090311-1), tzdata (<< 2007k-1), tzdata-etch
  15. Conffiles:
  16. /etc/ld.so.conf.d/x86_64-linux-gnu.conf 593ad12389ab2b6f952e7ede67b8fbbf
  17. Description: Embedded GNU C Library: Shared libraries
  18. Contains the standard libraries that are used by nearly all programs on
  19. the system. This package includes shared versions of the standard C library
  20. and the standard math library, as well as many others.
  21. Homepage: http://www.eglibc.org


Et ma version de Debian est:
debian-6.0-x86_64

n°1361055
blazkowicz
Posté le 18-07-2014 à 00:38:54  profilanswer
 

ok.

 

N'y a-t-il pas moyen de compiler les binaires PHP?
Apparemment tu installes un PHP précompilé, incompatible avec ta distribution de linux trop vieille.
Ta distrib n'est pas si vieille que ça, mais ça évolue vite contrairement à Windows par exemple. Il n'y a pas de compatibilité binaire garantie d'une version sur l'autre.

 

donc soit tu compiles ces composants PHP (si possible, et peut-être qu'il y aura d'autres trucs incompatibles après), soit tu installes une autre distro.

 

Un ubuntu 12.04.4 server par exemple, ça devrait marcher et le fonctionnement n'est pas trop différent de debian 6  (debian squeeze)


Message édité par blazkowicz le 18-07-2014 à 00:39:09
n°1361093
OxyGrox
Posté le 18-07-2014 à 16:57:37  profilanswer
 

Je suis passer sous un autre OS (Debian 7) et le serveur marche nickel sauf un détail il ne reste pas ouvert 24h/24 alors que j'ai un vps(c'est à dire quand je ferme Putty le serveur se ferme aussi). J'ai déjà essayer de mettre un serveur Teamspeak et un serveur Minecraft pour PC ouvert 24/24 et ça a marché. Du coup ma question est comment le laisser ouvert 24/7 même si je ferme Putty ?

n°1361106
blazkowicz
Posté le 18-07-2014 à 21:34:03  profilanswer
 

Le programme "screen" est ton ami :)
 
ça permet de garder une session terminal ouverte y compris en cas de déco. On parle de "détacher" ou "s'attacher" à un screen.
 
ça devrait marcher de faire comme ça, bien qu'il serait plus propre que ce soit le système qui lance le serveur (par sysvinit, ou inetd.. ce que moi-même je ne maîtrise pas vraiment)
D'ailleurs, fais-tu tourner le serveur en root ou par un utilisateur standard (la deuxième solution est plus sûre il va sans dire)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Aide pour créer un serveur LINUX Minecraft PE

 

Sujets relatifs
Vos avis sur les distributons Linux à prendreDemande d'aide quatre écrans
problème sur mon serveur tacacs+remote desktop sur linux
Aide installation concerto serveur sur debian wheezy[Ubuntu] noob Linux : problème de carte son (sortie analog kaputt)
VirtualHost (Apache) avec redirection vers Serveur IISMot de passe W8 oublié, comment faire avec Linux par USB
Débutant sur Linux : problème avec lancement de Gparted [Résolu] 
Plus de sujets relatifs à : Aide pour créer un serveur LINUX Minecraft PE


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR