Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1880 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Un écran qui "clignote" ou "flashe" sous Jaunty ?

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Un écran qui "clignote" ou "flashe" sous Jaunty ?

n°1136697
Power Nabo​t
Verticalement désavantagé.
Posté le 20-05-2009 à 21:53:10  profilanswer
 

Bonjour à tous,

 

J'ai installé il y a peu la 9.04 sur mon laptop (Pavilion DV9000: T5500, 7600Go, Chipset 945GM) en remplacement de mon Windows XP qui a à l'occasion d'un reboot totalement disparu du DD (ne me demandez pas pourquoi, la partition est vide). Pas de problèmes, et quelle évolution par rapport à la dernière que j'ai utilisé durant un bon moment en dual boot (Dapper :D) ! Prise en charge des touches tactiles de volume, de lecture, du bouton de désactivation du touchpad, etc. Je suis bluffé, littéralement !
Je ne suis pas un novice complet vu que j'utilise déjà une 8.10 serveur sur une autre bécane, mais j'aime quand même mon interface graphique lorsque je ne comprend pas une commande (bah wé, plutôt que de faire bêtement un C/C je préfère savoir ce que signifie ma ligne de commande). La ligne de commande, oui, mais à condition de comprendre !

 

Bref, ce qui m'amène ici, c'est un petit sushi avec la dernière version des pilotes propriétaires Nvidia (la 180).
J'ai activé Compiz (i.e effets visuels au max), et j'ai dans cette configuration mon écran qui fait de brefs flashs à intervalles plus ou moins réguliers, parfois plusieurs enchaînés, parfois un de temps à autre. Si je désactive tous les effets visuels, il n'y a plus de flashs, mais dès que je remet en "normal" ou "extra", j'y ai à nouveau le droit.
Pas dramatique, mais assez gênant et surtout fatiguant visuellement.

 

J'ai d'abord fouillé les options de Xserver Settings, essayé quelques réglages, puis demandé à mon-ami-le-moteur-de-recherche-préféré et ubuntu-fr s'ils avaient une solution. J'ai trouvé que l'antialiasing pouvait générer ce genre de soucis, or je ne l'avais pas activé.
Je suis redescendu en version 173.
Il m'a été conseillé de désactiver --loose-binding
La température ne semble pas en cause (GPU à 65°).
C'est râpé :/

 


Pour ceux qui feraient une recherche avec le même problème que moi, en trouvant aussi peu d'occurences: tag: linux, ubuntu, jaunty jackalope, nvidia, nv, écran, flash, clignotement.


Message édité par Power Nabot le 21-05-2009 à 11:15:37

---------------
Encore une victoire de canard !
mood
Publicité
Posté le 20-05-2009 à 21:53:10  profilanswer
 

n°1136771
Mjules
Modérateur
Parle dans le vide
Posté le 21-05-2009 à 10:59:41  profilanswer
 

c'est un  LCD ?
 
ce que tu appelles flash, c'est que l'écran devient noir puis réaffiche ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1136773
Power Nabo​t
Verticalement désavantagé.
Posté le 21-05-2009 à 11:15:23  profilanswer
 

Oui, un LCD (je vais préciser que c'est un laptop :D).
Le flash c'est un écran qui devient noir quelques millisecondes avant de réafficher, sur tout l'écran ou partie de celui-ci (généralement dans le bas). Un peu comme un CRT avec un taux de rafraîchissement grandement insuffisant.


---------------
Encore une victoire de canard !
n°1136775
Mjules
Modérateur
Parle dans le vide
Posté le 21-05-2009 à 11:27:36  profilanswer
 

ça me fait penser au flash qu'on a quand on demande les infos EDID à l'écran (taille, résolutions supportées, etc).
 
si dans un term tu tapes xrandr -q  ça te fait les mêmes symptômes ? c'est un soft qui permet de manipuler à la volée résolution/fréquence/bi-écran etc et là, on lui demande de regarder ce que l'écran a dans le ventre.
 


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1136777
Power Nabo​t
Verticalement désavantagé.
Posté le 21-05-2009 à 11:52:27  profilanswer
 

Voilà ce que donne la commande, l'exécution est instantanée et ne génère aucune modification de l'affichage ou symptômes sus-cité ;)

Code :
  1. Screen 0: minimum 320 x 240, current 1440 x 900, maximum 1440 x 900
  2. default connected 1440x900+0+0 0mm x 0mm
  3.    1440x900       50.0*
  4.    1360x768       51.0     52.0 
  5.    1152x864       53.0 
  6.    1024x768       54.0 
  7.    960x600        55.0 
  8.    960x540        56.0 
  9.    840x525        57.0     58.0 
  10.    800x600        59.0     60.0 
  11.    800x512        61.0 
  12.    720x450        62.0 
  13.    680x384        63.0     64.0 
  14.    640x512        65.0 
  15.    640x480        66.0     67.0 
  16.    576x432        68.0 
  17.    512x384        69.0 
  18.    400x300        70.0 
  19.    320x240        71.0


---------------
Encore une victoire de canard !
n°1136778
Mjules
Modérateur
Parle dans le vide
Posté le 21-05-2009 à 11:53:43  profilanswer
 

:/ alors je ne sais pas.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1136780
Power Nabo​t
Verticalement désavantagé.
Posté le 21-05-2009 à 11:55:50  profilanswer
 

Merci des réponses en tout cas ;)


---------------
Encore une victoire de canard !
n°1136781
Mjules
Modérateur
Parle dans le vide
Posté le 21-05-2009 à 11:58:24  profilanswer
 

Je ne connais pas bien compiz mais que se passe t'il si tu désactives les options Detect output et detect refresh rate (en configurant correctement le reste) ?
http://wiki.compiz-fusion.org/Gene [...] y_Settings


Message édité par Mjules le 21-05-2009 à 11:58:40

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1136783
Power Nabo​t
Verticalement désavantagé.
Posté le 21-05-2009 à 12:10:40  profilanswer
 

J'ai désactivé Detect Output et Detect Refresh Rate, et forcé le rafraîchissement à 60 (il était à 50...).
La suite dans le prochain épisode :D


---------------
Encore une victoire de canard !
n°1137195
Power Nabo​t
Verticalement désavantagé.
Posté le 23-05-2009 à 14:02:39  profilanswer
 

Au moins ça aura eu le mérite de ne pas flasher durant 48h, mais ça y est, ça vient de revenir. Sans aucune manipulation quelle qu'elle soit.


---------------
Encore une victoire de canard !
mood
Publicité
Posté le 23-05-2009 à 14:02:39  profilanswer
 

n°1139125
punishthec​at
Posté le 30-05-2009 à 03:07:58  profilanswer
 

une idée au hasard: possibilité d'augmenter la mémoire vive alooué a la carte graphique dans le bios ?
 
sinon tu peut toujours te servir de ton pc comme stromboscope en soirée ...


---------------
GNU/Linux powered | feedback : http://forum.hardware.fr/hfr/Achat [...] 2066_1.htm
n°1139168
BloodyCarn​age
Posté le 30-05-2009 à 15:06:34  profilanswer
 

Je parie sur le système de régulation de fréquence nvidia.
Lance nvidia-settings => onglet "powermizer" et regarde si les flash de l'écran coïncident avec les changements de fréquence du GPU.
 
PS: les changements s'opèrent quand il y a une augmentation/baisse de la charge GPU, ne fixe pas nvidia-settings sans rien faire sinon tu vas y passer la nuit :D

n°1139272
R 34
Posté le 31-05-2009 à 16:08:28  profilanswer
 

J'ai eu le même soucis avec un LCD sur une 9800GX2, mais une fois les drivers nvidia activés cela marche parfaitement.
 
Tu as essayé de désactiver/réactiver les 180 ?


---------------
Feed-Back Achat-Ventes
n°1139380
Power Nabo​t
Verticalement désavantagé.
Posté le 01-06-2009 à 13:18:59  profilanswer
 

BloodyCarnage a écrit :

Je parie sur le système de régulation de fréquence nvidia.
Lance nvidia-settings => onglet "powermizer" et regarde si les flash de l'écran coïncident avec les changements de fréquence du GPU.

 

PS: les changements s'opèrent quand il y a une augmentation/baisse de la charge GPU, ne fixe pas nvidia-settings sans rien faire sinon tu vas y passer la nuit :D

Je n'ai pas de réglages autres que "max perf", les autres modes sont grisés et inaccessibles, j'ai déjà voulu régler ça pour limiter la chauffe et la conso, fait quelques recherches, mais rien à faire pour changer.

 
R 34 a écrit :

J'ai eu le même soucis avec un LCD sur une 9800GX2, mais une fois les drivers nvidia activés cela marche parfaitement.

 

Tu as essayé de désactiver/réactiver les 180 ?

Déjà fait, je suis aussi redescendu aux précédents.

 

Néanmoins, les flashs sont revenus, mais ils sont moins fréquents, ce n'est plus aussi gênant :)

 


Edit: désolé de ne pas avoir donné de nouvelles pendant une semaine, mais je n'avais pas de connexion disponible cause boulot.

 

Message cité 1 fois
Message édité par Power Nabot le 01-06-2009 à 13:20:14

---------------
Encore une victoire de canard !
n°1139406
BloodyCarn​age
Posté le 01-06-2009 à 16:28:26  profilanswer
 

Power Nabot a écrit :

Je n'ai pas de réglages autres que "max perf", les autres modes sont grisés et inaccessibles, j'ai déjà voulu régler ça pour limiter la chauffe et la conso, fait quelques recherches, mais rien à faire pour changer.
 


 
Dans ce cas, ça vient d'ailleurs.
S'ils sont grisés, c'est simplement parce que HP a pondu un bios VGA minimaliste sans définir d'autre palier de fréquence que la fréquence nominale. Le driver ne peut pas activer quelque chose qui n'existe pas. Je te dirais bien que tu peux dumper, éditer et reflasher le bios, mais c'est relativement tendu sur un portable.

n°1139630
Power Nabo​t
Verticalement désavantagé.
Posté le 02-06-2009 à 19:24:25  profilanswer
 

Les drivers vindoze sont capables de moduler la fréquence selon l'utilisation de la CG, voire même de l'OC via Coolbits ;)
Pour moi c'est plutôt Nvidia qui ne se foule pas sur ses drivers Linux.
 
PS: je n'ai pas de mémoire partagée sur ma CG ;)


---------------
Encore une victoire de canard !
n°1139641
BloodyCarn​age
Posté le 02-06-2009 à 20:14:54  profilanswer
 

Drivers windows ou linux, c'est le même principe. Si t'as qu'un palier défini, le driver n'a rien à gérer. Pour ceux qui ont ce support dans le bios de leur carte, ça fonctionne.
De même que coolbits existe aussi sous linux ; sous windows il faut l'activer dans la BdR, sous linux il faut l'activer dans xorg.conf.  
 
PS: il y a toujours une mémoire dédiée sur les IGP nvidia même quand ils utilisent turbocache.

n°1139960
Power Nabo​t
Verticalement désavantagé.
Posté le 03-06-2009 à 21:36:52  profilanswer
 

Sauf que la 7600Go est une carte graphique dédiée et non un IGP :D

 

Edit: déjà regardé, grâce à l'aide, dans le Xorg.conf, mais justement il n'y a pas d'autre palier :/


Message édité par Power Nabot le 03-06-2009 à 21:37:41

---------------
Encore une victoire de canard !
n°1140003
BloodyCarn​age
Posté le 04-06-2009 à 09:21:52  profilanswer
 

Bah oui, sans support dans le bios VGA, il n'y a rien à faire de plus ; c'est le pré-requis minimum pour que ça fonctionne.  
Les paliers ne sont pas définis dans xorg.conf. Au mieux, tu peux verrouiller un mode en passant le bon paramètre au module (tu peux trouver l'info sur le forum nvnews.net). Mais encore une fois, pour verrouiller un mode, faut qu'il existe.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Un écran qui "clignote" ou "flashe" sous Jaunty ?

 

Sujets relatifs
Cheese bugge sous JauntyLe mode pivot ou portrait sous Linux - écran vertical
Image de qualité sur écran TV LCDdual screen full hd, compiz et vidéo plein ecran...
Forte manager (pour ecran lg)Probleme d'affichage avec eeeBox Asus 160G LINUX et écran Asus VK191S
[Probléme] Cd oficiel ecran noirecups : avoir les informations à l'écran (bourrage papier...)
Problème avec kde 4 pour les fonds d'écran {Gentoo}thinkpad => activer la touche FN+F7
Plus de sujets relatifs à : Un écran qui "clignote" ou "flashe" sous Jaunty ?


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR