Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
517 connectés 

 



 Mot :   Pseudo :  
 
 Page :   1  2  3  4  5  6  7  8
Page Suivante
Auteur Sujet :

[wifi] Carte Intel Pro Wireless ipw2100 ipw2200 Centrino sous Linux

n°1205561
susano
Posté le 19-03-2010 à 22:26:21  profilanswer
 

Reprise du message précédent :
je galère à faire tourner ma carte aussi, j'ai ces messages sur un dmesg:  :jap:  
 

[    9.111644] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[    9.111649] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[    9.200989] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[    9.201032] firmware: requesting ipw2200-bss.fw
[    9.975528] ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
[    9.975580] ipw2200: Unable to load firmware: -2
[    9.975623] ipw2200: failed to register network device
[    9.975747] ipw2200: probe of 0000:06:0a.0 failed with error -5

Message cité 1 fois
Message édité par susano le 19-03-2010 à 22:26:47
mood
Publicité
Posté le 19-03-2010 à 22:26:21  profilanswer
 

n°1205563
guepe
J'ai du noir sur la truffe ?
Posté le 19-03-2010 à 22:32:19  profilanswer
 

susano a écrit :

je galère à faire tourner ma carte aussi, j'ai ces messages sur un dmesg:  :jap:

 

[    9.111644] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[    9.111649] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[    9.200989] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[    9.201032] firmware: requesting ipw2200-bss.fw
[    9.975528] ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
[    9.975580] ipw2200: Unable to load firmware: -2
[    9.975623] ipw2200: failed to register network device
[    9.975747] ipw2200: probe of 0000:06:0a.0 failed with error -5



Quelle distrib ? C'est aujourd'hui parfaitement supporté out-of-the-box  :jap:

 

edit : il te faut apparemment le firmware intel, bah suffit de le prendre. Sans doute une mandriva free, ou une arch linux ??

Message cité 1 fois
Message édité par guepe le 19-03-2010 à 22:33:02

---------------
Un blog qu'il est bien
n°1205565
susano
Posté le 19-03-2010 à 22:39:11  profilanswer
 

guepe a écrit :


Quelle distrib ? C'est aujourd'hui parfaitement supporté out-of-the-box  :jap:  
 
edit : il te faut apparemment le firmware intel, bah suffit de le prendre. Sans doute une mandriva free, ou une arch linux ??


 c'est une archi debian lenny  :jap:  :bounce:
 
quand je charge les pilotes de ipws2200.sourceforge.net ça me met:  

make
 
 ERROR: ieee80211.h not found in '/lib/modules/2.6.26-2-686/include'.
 
You need to install the ieee80211 subsystem from http://ieee80211.sf.net
and point this build to the location where you installed those sources, eg.:
 
% make IEEE80211_INC=/usr/src/ieee80211/
 
will look for ieee80211.h in /usr/src/ieee80211/net/
 
make: *** [check_inc] Erreur 1


Message cité 1 fois
Message édité par susano le 19-03-2010 à 22:43:57
n°1205566
perchut2
Hell, it's about time...
Posté le 19-03-2010 à 22:55:40  profilanswer
 

faudrait voir dans la doc du driver ce que signifie l'erreur -2 ?

 

[:haha grillaid]

Message cité 1 fois
Message édité par perchut2 le 19-03-2010 à 22:56:12
n°1205572
susano
Posté le 19-03-2010 à 23:44:08  profilanswer
 

perchut2 a écrit :

faudrait voir dans la doc du driver ce que signifie l'erreur -2 ?
 
 [:haha grillaid]


To work around this, you can increase the default timeout value:
 
 echo 100 > /sys/class/firmware/timeou
 
en fait il faut change le timeout du kernel In some kernel configurations  
(users have most frequently reported the problem only with 2.6.9), the default timeout value for the hotplug subsystem is too low. You may have this problem if you see the following in your kernel log (via dmesg or /var/log/messages)
 
maintenan j'ai un autre soucis :(, msg d'érreur sur modprobe ipw2200 pour charger le module alors qu'avant ça ne me marquait rien... :pt1cable:
 

modprobe ipw2200  
WARNING: Could not open '/lib/modules/2.6.26-2-686/kernel/net/ieee80211/ieee80211_crypt.ko': No such file or directory
WARNING: Could not open '/lib/modules/2.6.26-2-686/kernel/net/ieee80211/ieee80211.ko': No such file or directory


Message édité par susano le 19-03-2010 à 23:44:57
n°1205607
perchut2
Hell, it's about time...
Posté le 20-03-2010 à 12:46:39  profilanswer
 

bon, alors là j'imagine que ces deux modules (bouts de noyau) sont pas compilés / installés sur ta configuration.
Je sais pas si y a une méthode spécifique debian pour compiler / installer un noyau, mais sur ma distrib, j'irais dans les sources du noyau, chargerais la config, irais dans les options wireless pour sélectionner la compilation en module (M) de ces deux options, puis recompile des modules (make modules && make modules_install), puis essai :D


Message édité par perchut2 le 20-03-2010 à 12:47:32
n°1205681
susano
Posté le 21-03-2010 à 00:21:25  profilanswer
 

bon, alors là j'imagine que ces deux modules (bouts de noyau) sont pas compilés / installés sur ta configuration.
Je sais pas si y a une méthode spécifique debian pour compiler / installer un noyau, mais sur ma distrib, j'irais dans les sources du noyau,

 
comment tu fais? ?? :??:  
 

chargerais la config,

idem  :lol:  :fou:  :o  :cry:  :sweat:  :pt1cable:  
 
 

irais dans les options wireless pour sélectionner la compilation en module (M) de ces deux options, puis recompile des modules (make modules && make modules_install), puis essai :D
 


o seccouurrrrr  :bounce:  :ouch:  :(  :bounce:

n°1205686
perchut2
Hell, it's about time...
Posté le 21-03-2010 à 01:22:11  profilanswer
 

susano a écrit :

bon, alors là j'imagine que ces deux modules (bouts de noyau) sont pas compilés / installés sur ta configuration.
Je sais pas si y a une méthode spécifique debian pour compiler / installer un noyau, mais sur ma distrib, j'irais dans les sources du noyau,


comment tu fais? ?? :??:  
 

chargerais la config,

idem  :lol:  :fou:  :o  :cry:  :sweat:  :pt1cable:  
 
 

irais dans les options wireless pour sélectionner la compilation en module (M) de ces deux options, puis recompile des modules (make modules && make modules_install), puis essai :D
 


o seccouurrrrr  :bounce:  :ouch:  :(  :bounce:


pardon :D
 
En fait, je pourrais t'expliquer parfaitement sous gentoo, où c'est relativement générique, mais sous deb ça doit être customisé de manière assez efficace... Un debianeux pour aider ? :o

n°1205712
e_esprit
Posté le 21-03-2010 à 10:29:38  profilanswer
 

susano a écrit :


 c'est une archi debian lenny  :jap:  :bounce:
 
quand je charge les pilotes de ipws2200.sourceforge.net ça me met:  

make
 
 ERROR: ieee80211.h not found in '/lib/modules/2.6.26-2-686/include'.
 
You need to install the ieee80211 subsystem from http://ieee80211.sf.net
and point this build to the location where you installed those sources, eg.:
 
% make IEEE80211_INC=/usr/src/ieee80211/
 
will look for ieee80211.h in /usr/src/ieee80211/net/
 
make: *** [check_inc] Erreur 1




http://wiki.debian.org/ipw2200#Lenny.2CSqueeze :o


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  6  7  8
Page Suivante

Aller à :
Ajouter une réponse
 

Sujets relatifs
problem install linux Mandrake 9.2Driver linux ATI Radeon 9700
Comment savoir si ma carte réseau et reconnue ?problem install linux Mandrake 9.2
Installation d'une carte Intel wireless 2100 avec une Mandrake 10.0Porter VirtualDub sous linux
Linux ou BSDQuelles Carte TV externe USB2.0 pour Linux
Plus de sujets relatifs à : [wifi] Carte Intel Pro Wireless ipw2100 ipw2200 Centrino sous Linux


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR