Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1236 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  [HowTo] Cartes wifi DLink DWL-G520+ & DWL-G650+ sous Linux

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[HowTo] Cartes wifi DLink DWL-G520+ & DWL-G650+ sous Linux

n°450827
glor
Posté le 07-04-2004 à 12:56:22  profilanswer
 

Bonjour,
 
Cela faisait un moment que j'attends la prochaine release des drivers acx100 (acx100.sourceforge.net), qui, selon son développeur (alias andim2 sur sourceforge) devrait supporter les cartes à base de chipset TI TNETW1130 (autrement appellé ACX111 ). Les acx100 sont en version 0.7fixes7 et n'ont qu'un support embryonnaire des cartes à base d'ACX111..
 
En faisant ma recherche quotidienne des dernieres nouvelles pour les cartes D-Link DWL-G520+ et DWL-G650+ que j'ai eu le malheur d'acheter, je suis tombé (à nouveau) sur le forum DLink ou j'ai pu trouver, malgré mon allemand des plus basiques, ce thread: http://forum.dlink.de/topic.asp?TOPIC_ID=21882
Il s'agit la d'un HowTo sur l'installation de ces cartes wifi sous Linux.
 
N'etant pas tres fort en allemand, j'ai vaguement lu ce thread, qui donne un lien vers http://ndiswrapper.sourceforge.net/ , j'ai ainsi étudié cette drole de bete, qui, au premier abord n'est pas tres accueillant..
 
ndiswrapper est en fait un "logiciel" qui vous permet d'utiliser les drivers Windows de certaines cartes wifi sous Linux.
La liste des chipset supportés est accessible la http://ndiswrapper.sourceforge.net [...] psets.html
 
Il vous faut donc télécharger ndiswrapper http://sourceforge.net/projects/ndiswrapper/ (Un CVS est accessible) et posseder les drivers Windows de votre carte. Ils sont disponibles sur le ftp de DLink (ftp.dlink.co.uk/wireless)
Les sources de votre kernel sont aussi necessaire (www.kernel.org) (>=2.4.23 OU >=2.6.0)
 
Une fois ces sacro-saints éléments réunis, il ne vous reste plus qu'a lire le "README" puis "INSTALL" pour installer votre carte wifi..
 
 
Rapidement, pour vous montrer..
En root, décompressez ndiswrapper
$ tar -zxf ndiswrapper-0.6.tar.gz
$ cd ndiswrapper-0.6
# Compile et installe ndiswrapper
$ make install
# Permet a ndiswrapper de charger votre driver Windows (copie les fichier dans /etc/ndiswrapper/
$ ndiswrapper -i </path/to/inffile.inf>
# Liste les drivers installés (doit répondre "xxxx present" )
$ ndiswrapper -l
# Une fois cette configuration terminé, il ne vous reste plus qu'a effectuer un
$ modprobe ndiswrapper
# Puis vérifier le bon chargement de votre carte
$ dmesg
 
Votre carte est maintenant chargé si tout va bien.
Il ne vous reste plus qu'a configurer votre nouvelle interface wifi.
Pour cela, réferrez vous aux pages du manuel de ifconfig et iwconfig.
 
Personnellement je suis en Ad-Hoc, 54MBits/sec, je n'ai pour l'instant effectué aucun test de performance..
 
Une fois la configuration de votre interface terminée, tapez
$ ndiswrapper -m
ndiswrapper va ajouter pour vous un alias dans /etc/modules.conf
 
Enjoy ;)
 
 
PS: Les drivers acx100 ( http://acx100.sourceforge.net ) supportent maintenant les acx111 et donc ces cartes Wifi. Leur état est toujours expérimental, mais je vous encourage à les essayer si vous le pouvez.

Message cité 1 fois
Message édité par glor le 31-12-2004 à 19:02:25
mood
Publicité
Posté le 07-04-2004 à 12:56:22  profilanswer
 

n°450833
Klaimant
?
Posté le 07-04-2004 à 13:04:48  profilanswer
 

Merci :jap:


---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°450836
glor
Posté le 07-04-2004 à 13:07:47  profilanswer
 

Voila ce que iwconfig wlan0 me donne:
 

wlan0     IEEE 802.11b  ESSID:"bombolong"  
          Mode:Ad-Hoc  Frequency:2.437GHz  Cell: C2:05:13:53:D9:7A  
          Bit Rate:54Mb/s   Tx-Power:0 dBm   Sensitivity=0/0  
          RTS thr:4096 B   Fragment thr:4096 B    
          Encryption key:off
          Power Management min timeout:0us  mode:All packets received
          Link Quality:96  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:8   Missed beacon:0


 
Le ping entre mon portable (Windows + DWL-G650+) et mon PC (Linux-2.6.4 + DWL-G520+) :

root@codeine:~$ ping 10.59.59.27
PING 10.59.59.27 (10.59.59.27) 56(84) bytes of data.
64 bytes from 10.59.59.27: icmp_seq=1 ttl=128 time=1.39 ms
64 bytes from 10.59.59.27: icmp_seq=2 ttl=128 time=0.699 ms
64 bytes from 10.59.59.27: icmp_seq=3 ttl=128 time=0.660 ms
64 bytes from 10.59.59.27: icmp_seq=4 ttl=128 time=0.714 ms
64 bytes from 10.59.59.27: icmp_seq=5 ttl=128 time=0.697 ms
64 bytes from 10.59.59.27: icmp_seq=6 ttl=128 time=2.91 ms
64 bytes from 10.59.59.27: icmp_seq=7 ttl=128 time=0.711 ms
 
--- 10.59.59.27 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6006ms
rtt min/avg/max/mdev = 0.660/1.113/2.916/0.775 ms


 
Le débit est actuellement de 2.1Mo/sec a bout portant.. Je ne suis pas sur des performances de mon portables, les performances sont au meme niveau que celle sous Windows, c'est-à-dire pas terrible en download pour du 54MBits/sec..


Message édité par glor le 07-04-2004 à 14:09:59
n°489943
SiriusG
Posté le 29-05-2004 à 10:58:46  profilanswer
 

C'est cool, mais en mode managed et pour avoir internet par le wireless, on configure comment la carte ??
 
Autrement dit, t'as mit quoi comme paramêtres pour ta carte (J'ai le même noyau et la meme carte...)
 
Merci d'avance  ;)


Message édité par SiriusG le 29-05-2004 à 11:00:07
n°490004
glor
Posté le 29-05-2004 à 12:01:38  profilanswer
 

Je partage ma connexion réseau via une carte wifi en Ad-Hoc.
iwconfig wlan0 essid _monessid_ mode Ad-Hoc
ifconfig wlan0 _monip_
Sur les autres machines tu ajoutes ta passerelle comme gateway et les serveurs DNS dans ton /etc/resolv.conf et c'est parti..

n°603647
Anthranox
Posté le 11-12-2004 à 22:57:22  profilanswer
 

J'utilise cette carte sous linux mais le problème est que la carte se remet en managed toute seule à chaque reboot de mon uc. J'éspère que quelqu'un connais la solution à mon problème.

n°604483
STigrou
Posté le 13-12-2004 à 21:28:29  profilanswer
 

Je ne suis pas un grand connaisseur de linux ... J'ai installé fedora core (la dernière version à ce jour (V3 ?)) et j'ai une carte DWL G520+. J'ai placé dans un répertoire ndiswrapper-0.12.tar.gz et mes drivers pour XP.
 
Après faut trouver un noyau sous www.kernel.org .... mais lequel prendre ?
Qq1 aurai une version simplifié ou un lien ou je pourrai trouver les infos nécessaire pour décripter ce "How to" ?

n°613561
tony143
Posté le 01-01-2005 à 15:54:25  profilanswer
 

Stigrou: dans une fenetre de commande  
$su
$tonpassword
#(version du kernel)
$uname -r  
#par exemple  
$2.6.8.1-12mdk
 
Bon moi jusqu'ici c'est ok.
Mais apres ca se complique, je recupere le rpm du kernel-source correspondant a ma version de Kernel.
Je devrais avoir ce repertoire /lib/modules/2.6.8.1-12mdk/build en faite j'ai quedale :(
 
Je retente l'installe du kernel-source et je vous tiens au courant, ca doit etre une mauvaise verion qui me bloque ;)
 
Ps: C'etait bien ca le probleme :p


Message édité par tony143 le 01-01-2005 à 16:23:01
n°613608
Kheops88
Posté le 01-01-2005 à 17:17:36  profilanswer
 

Citation :

Il ne vous reste plus qu'a configurer votre nouvelle interface wifi.
Pour cela, réferrez vous aux pages du manuel de ifconfig et iwconfig


j'en suis la mais de quelle manuel est t-il question ?
(j'ai une carte dlink g520+)


Message édité par Kheops88 le 01-01-2005 à 17:18:28
n°613647
glor
Posté le 01-01-2005 à 19:53:35  profilanswer
 

man ifconfig et man iwconfig.
Ils sont clairs, et exhaustif avec des exemples..
 
Pour plus d'explications sur ces commandes, il faut chercher sur Gogole.
Ce n'est pas le sujet de ce HowTo.
 
D'ailleurs je devrais le mettre à jour puisque les drivers acx100 fonctionnent maintenant avec ces cartes.

mood
Publicité
Posté le 01-01-2005 à 19:53:35  profilanswer
 

n°613653
Kheops88
Posté le 01-01-2005 à 20:30:39  profilanswer
 

glor c'est quelle version des drivers acx100 qui fonction parseque ceux d'origine dans mandrake 10.1 ne semble pas fonctionner ...

n°613654
analfabete
Posté le 01-01-2005 à 20:45:03  profilanswer
 

Merci pour ce tuto que j'ai enfin trouvé car sa faisait deux mois que je me servait pas de linux faute de driver
Je peux enfin découvrir linux !

n°613702
glor
Posté le 01-01-2005 à 22:59:53  profilanswer
 

Kheops88 a écrit :

glor c'est quelle version des drivers acx100 qui fonction parseque ceux d'origine dans mandrake 10.1 ne semble pas fonctionner ...


Je viens de tester la dernière  acx100-0.2.0pre8_plus_fixes_43 (http://rhlx01.fht-esslingen.de/~andi/acx100/), le CVS n'étant plus mis à jour depuis plusieurs mois.
Il faut lire le README en anglais, ça peut paraitre long, mais les informations y sont très intéressante, et ce n'est vraiment pas compliqué..
 
Actuellement mon signal est assez faible, et il m'est impossible de modifier la puissance de l'emetteur. Mon débit est faible (250ko/sec) à distance faible, j'ai fais un rapport sur le forum du projet, je verrais ce qu'en disent les développeur.
 
En attendant, je vous encourage à essayer les ndiwrapper et les acx100, et de comparer les débits atteint, les erreurs dans iwconfig.
Personellement, j'ai l'impression que les ndiswrapper ne rapportent pas de bonnes valeurs. (Il me semble que mon débit était le même mais que la qualité du signal était très élevé, etc..).


Message édité par glor le 01-01-2005 à 23:09:03
n°613831
Kheops88
Posté le 02-01-2005 à 13:30:04  profilanswer
 

jec'est que ce n'est pas vraiment le sujet du how to mais je suis un tout nouveau utilisateur de linux et comment fait on pour installer acx100-0.2.0pre8_plus_fixes_43 ?

n°613840
XK
Posté le 02-01-2005 à 13:39:13  profilanswer
 

merci pour le tuto, j'ai fais l'erreur d'acheter des cartes G520+, même sous windows j'ai des merdes! je testerai à l'occaz le wrapper sous linux :)


---------------
AMD 2700X - Asus Prime X470-Pro - DDR4 32GB ECC @3200 - EVGA 2080 XC Gaming
n°613986
glor
Posté le 02-01-2005 à 17:42:33  profilanswer
 

Kheops88 a écrit :

jec'est que ce n'est pas vraiment le sujet du how to mais je suis un tout nouveau utilisateur de linux et comment fait on pour installer acx100-0.2.0pre8_plus_fixes_43 ?


 
Il suffit de lire de fichier README dans le paquet acx100.
J'ajouterais sans doute la procédure ici lorsque j'aurais les réponses à mes questions.
Un pilote natif est toujours meilleur qu'un pilote wrapper..

n°613995
STigrou
Posté le 02-01-2005 à 17:56:12  profilanswer
 

merci pour votre aide  :)  
 
Bon j'ai un copain qui est passé et qui m'a fait qqes modif ... maitenant voila ce que j'ai :  
 

wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.452GHz  Access Point: 00:00:00:00:00:00    
          Bit Rate:54Mb/s   Tx-Power:10 dBm   Sensitivity=0/3  
          RTS thr:4096 B   Fragment thr:4096 B    
          Encryption key:off
          Power Management:off
          Link Quality:100  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 
lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2872 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2872 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0  
          RX bytes:5322310 (5.0 MiB)  TX bytes:5322310 (5.0 MiB)
 
wlan0     Lien encap:Ethernet  HWaddr 00:0F:3D:56:B7:04  
          inet adr:192.168.0.5  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::20f:3dff:fe56:b704/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:511 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000  
          RX bytes:0 (0.0 b)  TX bytes:22393 (21.8 KiB)
          Interruption:10 Mémoire:dfffe000-dfffffff


 
 
ca avance  doucement .... j'ai fait "man iwconfig", et j'ai tapé iwconfig wlan0 ESSID "monssid" et pourtant ca ne marche pas .... le plus dur J'ai réactivé le boradcast de mon ssid sur mon AP et désactivé le cryptage et a mon avis il ne manque plus grand chose mais comment faire ?
 :??:


Message édité par STigrou le 02-01-2005 à 17:57:00
n°614009
glor
Posté le 02-01-2005 à 18:09:11  profilanswer
 

iwconfig wlan0 essid any
iwconfig wlan0 essid "monssid"

n°619859
analfabete
Posté le 13-01-2005 à 20:49:39  profilanswer
 

Bonjour à tous je rencontre depuis le début un problème
Ma carte sans fil se deconnecte toute les 5 minutes voilà les stat avec iwconfig
wlan0     IEEE 802.11g  ESSID:"default"  Nickname:"localhost"
          Mode:Managed  Frequency:2.437GHz  Access Point: 00:05:5D:7E:DE:4C
          Bit Rate=22Mb/s   Tx-Power:10 dBm   Sensitivity=0/3
          RTS thr=4096 B   Fragment thr=4096 B
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-64 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 
Savez vous d'ou ces deconnexion provienne ?

n°620317
lunix546
Posté le 14-01-2005 à 17:47:34  profilanswer
 

exelent tuto j'ai galèrer pour faire marcher ma dwl-520+ la il la reconner mais mon probleme maintenant c comment se connecter sur internet?

n°631484
HkFF
Intel Powaaa
Posté le 04-02-2005 à 15:47:47  profilanswer
 

bonjour,  
je viens de passer ss linux, g installé la fedora core3 ( je debute, je connai le stricte necessaire)
g une carte wifi dwl 520+, g telechargé ndiswrapper-1.0,  
g fait ca :
$ tar -zxf ndiswrapper-0.6.tar.gz
$ cd ndiswrapper-0.6
# Compile et installe ndiswrapper
$ make install  
mais ca marche pas, il me dit :
[root@MAX hkff]# cd ndiswrapper-1.0
[root@MAX ndiswrapper-1.0]# make
make -C driver
make[1]: Entering directory `/home/hkff/ndiswrapper-1.0/driver'
make -C /lib/modules/2.6.9-1.667/build SUBDIRS=/home/hkff/ndiswrapper-1.0/driver \
        NDISWRAPPER_VERSION=1.0 \
        EXTRA_VERSION= modules
/lib/modules/2.6.9-1.667/build/scripts/gcc-version.sh: line 11: gcc: command not found
/lib/modules/2.6.9-1.667/build/scripts/gcc-version.sh: line 12: gcc: command not found
make[2]: Entering directory `/lib/modules/2.6.9-1.667/build'
  CC [M]  /home/hkff/ndiswrapper-1.0/driver/hal.o
/bin/sh: gcc: command not found
make[3]: *** [/home/hkff/ndiswrapper-1.0/driver/hal.o] Erreur 127
make[2]: *** [_module_/home/hkff/ndiswrapper-1.0/driver] Erreur 2
make[2]: Leaving directory `/lib/modules/2.6.9-1.667/build'
make[1]: *** [default] Erreur 2
make[1]: Leaving directory `/home/hkff/ndiswrapper-1.0/driver'
make: *** [all] Erreur 2
 
Que faire?  
jai aussi mes pilotes windaube : FWRAD17.bin et FwRad16.bin et GPLUS.inf et un .sys
AIdez-moi!!

n°647188
brisssou
8-/
Posté le 09-03-2005 à 10:11:28  profilanswer
 

bon, j'ai pris une D-Link G520+, qui tourne avec les pilotes ACX.
Par contre, elle marche sous Windows, mais sous linux, le dhcp tourne dans le vide...
 
quelqu'un a une idée ?
mon fichier /etc/networking/interfaces a cette tête là :
 
auto wlan0
iface wlan0 inet dhcp
 wireless_essid monESSID
 wireless_mode managed
 wireless_key bla bla bla


---------------
HFR - Mes sujets pour Chrome - Firefox - vérifie les posts des topics suivis/favoris // Votes sur la grosse radio Chrome // FF
n°720149
oderrez
Posté le 23-08-2005 à 05:17:09  profilanswer
 

Pour ma part, çà bloque au moment de la commande
 
ndiswrapper -i gplus.inf
 
Je me trouve bien dans le rep où se trouve les drivers Windows mais le programme me retourne l'erreur suivante :
 
# ndiswrapper -i gplus.inf
Installing gplus
cp: ne peut évaluer `gplus': No such file or directory
 
Quelqu'un a une idée ?

n°720297
glor
Posté le 23-08-2005 à 13:04:59  profilanswer
 

N'y aurait-il pas des espaces dans les noms de fichiers?

n°742651
flash_gord​on
Posté le 20-10-2005 à 00:28:20  profilanswer
 

bonjour, j'ai suivi le tuto à la lettre, ça avait l'air de marcher, la diode de ma carte s'est allumée, tout le monde etait heureux, les petites fleurs les oiseaux etc...
 
 
... jusqu'a ce que je redémarre, et là, plus personne, la carte n'est plus reconnue, j'ai beau commencer à zero, supprimmer ndiswrapper le réinstaller, nada...
 
je suis sur kubuntu 5.10..
 
des idées ? merci

n°742993
flash_gord​on
Posté le 21-10-2005 à 00:49:33  profilanswer
 

sauf que la 650+ n'a pas un atheros (qui aurait en plus été détécté nativement) mais un acx111 ... et là, c'est le bordel...
 
du coup, comme de toute façon, ce n'est pas la carte destinée au final à ce portable, j'arrete de me faire chier, et je commande une G650, qui elle sera reconnue sans rien faire...
 

n°743675
alphakille​r
Posté le 22-10-2005 à 17:56:15  profilanswer
 

glor a écrit :

PS: Les drivers acx100 ( http://acx100.sourceforge.net ) supportent maintenant les acx111 et donc ces cartes Wifi. Leur état est toujours expérimental, mais je vous encourage à les essayer si vous le pouvez.


 
j'aimerais bien télécharger ces drivers mais apparement il faut passer par la console pour le faire (http://acx100.sourceforge.net/download.html) et comme je peux pas me connecter à internet sous linux je voudrais les récupérer sous windows, alors comment faire ?
merci :)


---------------
la seconde est la durée de 9 192 631 770 périodes de la radiation correspondante à la transition entre les 2 niveaux hyperfins de l'état fondamental de l'atome de césium 133 ...
n°743725
brisssou
8-/
Posté le 22-10-2005 à 19:42:16  profilanswer
 

j'te prète mes yeux, mais tu me les rends après hien ! ;-)
 

Citation :

Tarballs
Here you may download snapshots of various acx100 versions.


---------------
HFR - Mes sujets pour Chrome - Firefox - vérifie les posts des topics suivis/favoris // Votes sur la grosse radio Chrome // FF
n°744977
alphakille​r
Posté le 25-10-2005 à 23:34:06  profilanswer
 

j'ai confondu snapshot et screenshot :sarcastic:  
 
[:dehors2]


---------------
la seconde est la durée de 9 192 631 770 périodes de la radiation correspondante à la transition entre les 2 niveaux hyperfins de l'état fondamental de l'atome de césium 133 ...
n°805080
GOLDOKrisk​a
Posté le 26-04-2006 à 02:13:36  profilanswer
 

Bon beh après plusieurs galère j'ai réussi ndiswrapper.
Pour ceux que ca peut aider : axc100 j'ai essayé et ca marchait pas même en suivant le how to sur le site. Pour ndiswrapper j'ai pris les drivers WinXP de la version 2.04 car j'en ai essayer plein et ca marchait pas. Surtout ne pas prendre airplus.inf mais gplus.inf.
Si je résume pour ceux qui ont installé le drivers depuis un executable comme je l'ai fait au début il faut prendre 5 fichiers (rechercher avec windows). Je ne l'ai pas là en tête mais je les post demain.
 
Sinon j'ai donc installé le drivers mais après j'y arrive pas. j'ai fait iwconfig et ifconfig mais pas internet.
J'ai fait :
iwconfig wlan0 essid "Reseau LD" nick "Serveur" channel 11 rate auto
il me trouve la bonne adresse MAC du routeur wifi.
ifconfig wlan0 192.168.1.105
Je peux le pinger mais il refuse de se connecter à internet.
De plus, j'ai éditer le fichier /etc/rc.d/rc.inet1.conf ainsi que rc.wireless.conf en mettant les netmask et compagnie et rien.
Pour les commandes au-dessus ya peut-être une erreur mais c'est parceque je suis sous windows et que j'utilise beaucoups les mans et [TAB] normalement donc je pense pas que l'erreur vienne de là.
Merci
P.S.: bon je sais je deterre ce post mais ca évite d'en faire un nouveau sur le même sujet.

n°805376
GOLDOKrisk​a
Posté le 27-04-2006 à 00:52:26  profilanswer
 

Donc pour ndiswrapper il faut plusieurs fichiers fournis :
FwRad16.bin
FwRad17.bin
gplus.inf
gplus.sys
tnet1130.cat
 
Le dernier je suis pa sur que selon la version des drivers le chiffre ne change pas aussi.
 
Sinon, j'ai réussi à faire ma connection. Donc ce qui n'allait pas c'était tout simplement que je n'avais pas configuré mes addresses de serveurs DNS de mon FAI.
 
Pour ceux que ca peut aider j'ai réalisé un script de connection.
Il faut changer les adresse DNS, le essid, le channel, l'addresse IP, le nom et la gateway (si vous avez un routeur sinon je sais pas trop) en fonction de vos infos. Enregistrez ce script sous le nom de rc.wifi.
 
#-----script de connexion internet-----#
#!/bin/sh
#écrit par Kriska
#Mettre ce fichier dans le repertoire /etc/rc.d  
#pour l'aciver au demarrage de slackware
#
#Il doit être activer en faisant chmod +x rc.wifi
#
#Placer cette entrée dans le fichier rc.M juste en-dessous de  
#inet1 pour l'activer au demarrage
#(Pensez à enlever les # au début des lignes)
#if [ -x /etc/rc.d/rc.wifi ]; then
#  . /etc/rc.d/rc.wifi start
#fi
#
#Sinon demarrer-le en tapant ./rc.wifi start
#
#Bonne chance
 
echo "Configuration du réseau : /etc/rc.d/rc.wifi"
 
wifi_start() {
#fichier de log
if [ -f /var/run/syslogd.pid -a -x /usr/bin/logger ]; then
  LOGGER=/usr/bin/logger
else # output to stdout/stderr:
  LOGGER=/bin/cat
fi
 
#Configuration des DNS
echo "* Configuration des DNS"
DNS1=212.27.54.252
DNS2=212.27.54.252
echo "# fichier généré par ." > /etc/resolv.conf
echo nameserver $DNS1 >> /etc/resolv.conf
echo nameserver $DNS2 >> /etc/resolv.conf
echo "REUSSI"
 
#Lancement du module de drivers
echo "* Chargement de Ndiswrapper"
modprobe ndiswrapper
echo "REUSSI"
 
#Configuration pour la connection au point d'accès
echo "* Configuration IP"
iwconfig wlan0 essid "Reseau LD" nick "Serveur" channel 11
 
#Configuration de l'addresse IP et activation de la carte réseau
ifconfig wlan0 192.168.1.104 up
 
#Configuration pour le routage d'adresse IP
route add default gw 192.168.1.1 wlan0
echo "REUSSI"
}
 
case "$1" in
'start')
  wifi_start
  ;;
*)
  echo "usage $0 start"
esac
 
#-----Fin du script-----#
 
Voilà si ca peut servir à d'autres.

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  [HowTo] Cartes wifi DLink DWL-G520+ & DWL-G650+ sous Linux

 

Sujets relatifs
LE debutant en linux je n'ai jamais installer ny rien du tout donc...question sur linux
[MDK9.2] Authentification client linux sur PDC NT4 via sambaOverclocking sous linux
Copie de la partition linux (ou sauvegarde)Transfert entre win et linux
Ouvrir les .exe sous Linux[LILO] multi-boot et multi-linux
prbleme sur un serveur linux ^^Limiter la taille des dossiers sous linux
Plus de sujets relatifs à : [HowTo] Cartes wifi DLink DWL-G520+ & DWL-G650+ sous Linux


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR