Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1446 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Carte graphique : pas de pilote ... [Impossible à regler dans mon cas]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Carte graphique : pas de pilote ... [Impossible à regler dans mon cas]

n°891137
CNeo
Posté le 28-02-2007 à 17:40:49  profilanswer
 

Bonjour.
 
J'ai une "Hercules 3D Prophet 4000XT 32MB" sur mon vieux PC et quand je déplace une fenêtre elle met du temps à bouger, un peu comme un lag pour ceux qui jouent un peu.
Donc je me suis dit que c'était un problème de pilote de carte graphique et j'ai cherché sur le site du constructeur mais comme c'est une vieille carte il est écrit ça :

Citation :

Linux kernel 2.6 introduced major structural changes to the way driver modules are built and loaded. As a result, existing KYRO drivers are not compatible with any Linux kernel whose version is 2.6 or above. To keep using KYRO drivers, users are requested to use the latest available 2.4 Linux kernel version. We have currently no plans of providing drivers supporting updated kernels.


ici
 
Ma question est donc : y a-t-il des sites pour trouver des pilotes Linux qui ne viennent pas des constructeurs ?
 
Merci d'avance.


Message édité par CNeo le 28-02-2007 à 19:46:42
mood
Publicité
Posté le 28-02-2007 à 17:40:49  profilanswer
 

n°891142
memaster
ki a volé mon 62?
Posté le 28-02-2007 à 17:52:09  profilanswer
 

essaye un driver generique, ex. :
vesa
 :??:  
comment ta carte est détectée par linux?

n°891162
CNeo
Posté le 28-02-2007 à 18:47:07  profilanswer
 

C'est VESA que j'utilise pour l'instant mais comme je l'ai dit je "lag" ( ça saccade quoi ... ) donc je n'ose même pas imaginer pouvoir jouer à un jeu.

 

Autre chose j'ai oublié de préciser mais bon ça ne me paraît important c'est que mon écran n'est pas non plus reconnu par Linux donc j'utilise VESA ...

 

J'ai openSUSE 10.2 et quand je vais dans Yast > Matériel > Informations sur le matériel > Affichage il y a écrit STG4000 [3D Prophet Kyro Series].
En image ça donne ça.


Message édité par CNeo le 28-02-2007 à 18:47:16
n°891167
rawcut
tw: @_rawcut
Posté le 28-02-2007 à 19:09:18  profilanswer
 

Malheureusement, à moins de repasser sur une vieille version de linux, y'a rien à faire.  
 
http://ubuntuforums.org/showthread.php?p=2172605
 
Peut-être que si tu passes sur une résolution plus faible avec un nombre de couleurs inférieur, ca arrangera les choses, mais de toute fàcon, VESA c'est très limité.
 

n°891183
CNeo
Posté le 28-02-2007 à 19:44:48  profilanswer
 

OK. Merci de m'avoir confirmé ça. Bon bah c'est une bonne occasion de changer de carte graphique ... Merci à tous.

n°891184
j_c_p
Linux user
Posté le 28-02-2007 à 19:48:59  profilanswer
 

Tu as testé le dernier noyau 2.4 ?

n°891204
CNeo
Posté le 28-02-2007 à 21:21:43  profilanswer
 

Bah ça aurait sûrement marché mais ça ne m'intéresse pas d'essayer ... Je vais tout simplement changer de carte graphique.
 
Nota : j'ai déjà perdu mon après-midi à chercher alors changer de noyau ...

n°891257
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 01-03-2007 à 08:13:28  profilanswer
 

Quit à changer de CG, je te conseille, comme le ferai pas mal ici je pense, de passer sur du nVidia. Le support pilote est meilleur que celui d'ATI pour Linux.

n°891283
Fork Bomb
Obsédé textuel
Posté le 01-03-2007 à 10:25:21  profilanswer
 

T'as combien en RAM ?


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°891462
CNeo
Posté le 01-03-2007 à 20:06:32  profilanswer
 

Oui c'est ce que j'avais cru comprendre que les nvidia étaient mieux supportées mais là je suis sur un PC qui a une ATI et je n'ai eu aucun problème ... Il n'y aurait pas une doc pour savoir quelles cartes sont supportées ?
 
Pour la RAM, pourquoi cette question ?

mood
Publicité
Posté le 01-03-2007 à 20:06:32  profilanswer
 

n°891466
Nonor_
Ubuntu c'est supaire
Posté le 01-03-2007 à 20:12:54  profilanswer
 

les 3D prophet c'est la misère sous linux... En effet avec les noyaux 2.4 leur driver marche (j'ai un vieu pc qui en est équipé) mais c'est buggué, l'accélération est vite fait efficace, y'a des soucis d'affichage souvent et plantage de X parfois avec reboot obligatoire ou passage par ssh... Il vaut beaucoup mieux se fendre de 20 ou 30 € pour acheter une carte nvidia d'entrée de gamme... Si ça existe..

n°891475
CNeo
Posté le 01-03-2007 à 20:29:48  profilanswer
 

Oui c'est bien ce que je compte faire mais le seul truc dont je voudrais m'assurer c'est que celle que je vais acheter sera bien compatible avec Linux.
Y a-t-il une/des liste(s) de matériels compatibles/imcompatibles Linux ?
Toute les nouvelles cartes graphiques sont-elles compatibles avec Linux ?

n°891480
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 01-03-2007 à 20:50:25  profilanswer
 

Ben même si les ATI fonctionnent aussi sous Linux, y compris avec support de la 3D, il semble qu'il y ai beaucoup plus de problème (solvable) et des complications de configuration qu'avec nVidia où dans la plupart des cas tout se passe sans heurts. Sur un coup comme ça, je te conseille je jouer la sécurité.
Personnellement, je tourne depuis toujours ou presque sous nVidia, dès les premiers drivers livrés avec support de la 3D, tout à toujours fonctionné sans aucun problème (dans l'ordre GeForce4MX, GeForce4 ti4200, GeForce 660GT et maintenant GeForce 7600GS). Je crois qu'on peut affirmer que Toutes les GeForce 6 et 7 sont supportées sans problème, à confirmer avec les séries 8. Vu les complications de cette série sous Vista, il est possible que l'architecture de la carte pose plus de problèmes, potentiellement présents sous Linux. Essaie de trouver de l'info là dessus sur le net (même si je pense qu'une 8800GTX sous Linux est une annerie).

n°891503
Mjules
Modérateur
Parle dans le vide
Posté le 01-03-2007 à 21:42:51  profilanswer
 

CNeo a écrit :

Oui c'est bien ce que je compte faire mais le seul truc dont je voudrais m'assurer c'est que celle que je vais acheter sera bien compatible avec Linux.
Y a-t-il une/des liste(s) de matériels compatibles/imcompatibles Linux ?
Toute les nouvelles cartes graphiques sont-elles compatibles avec Linux ?


 
Toutes les nvidia sont compatibles avec linux. jusqu'au 7xxx pour les pilotes libres nv ou nouveau, pour l'instant uniquement 2D. Toutes les cartes récentes pour les pilotes propriétaires nvidia, 2D et 3D.
 
Les intel sont toutes compatibles avec pilotes libres 2D/3D mais on en trouve pas en cartes seules, uniquement intégrés.
 
Les ATI ont des pilotes libres 2D+3D jusqu'au r200 (radeon 9200) ; un pilote libre 2D+3D pour les r300 (9800 - x800) qui n'est pas encore parfaitement terminé mais déjà très utilisable. Uniquement un pilote propriétaire de qualité moyenne pour les x1xxx.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Carte graphique : pas de pilote ... [Impossible à regler dans mon cas]

 

Sujets relatifs
[Wine] Impossible d'installer Dreamweaverrecherche carte wifi g de qualité
Carte Wifi pour Debiancarte pc 104 et LFS
impossible d'intaller superkaramba sur mandriva 2006 [résolu]pilote trident cyberblade sous SuSE 10.0
installer pilote madwifi sur mandriva 2007[Debian] Impossible de se logguer
Multi Boot, Impossible de lancer WindowsCarte réseau et Linux
Plus de sujets relatifs à : Carte graphique : pas de pilote ... [Impossible à regler dans mon cas]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR