Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
502 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Serveur LAMP non trouvé ds Netcraft mais néanmoins accessible.

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Serveur LAMP non trouvé ds Netcraft mais néanmoins accessible.

n°1289340
Mac Gyver ​974
Posté le 05-09-2011 à 07:54:15  profilanswer
 

Bonjour, depuis une MAJ sur mon serveur LAMP -entre autre apache 2.2.20 et MAJ de php en dernière version-, le site hébergé dessus n'est plus trouvé par netcraft uptime, mais néanmoins accessible par n'importe quel navigateur, que s'est il passé à vôtre avis ? est-ce une histoire de configuration sur le serveur ?
 
Le Linux du LAMP est une Gentoo.
 
 :jap:

mood
Publicité
Posté le 05-09-2011 à 07:54:15  profilanswer
 

n°1289352
O'Gure
Modérateur
Multi grognon de B_L
Posté le 05-09-2011 à 09:08:37  profilanswer
 

C'est le site que tu as en signature ?

Citation :

http://macgyver974.dyndns.org was running Apache on Linux when last queried at 4-Sep-2011 20:38:08 GMT

 

D'ailleurs, il ne m'est pas accessible à cet instant.

Message cité 1 fois
Message édité par O'Gure le 05-09-2011 à 09:11:27
n°1289371
Mac Gyver ​974
Posté le 05-09-2011 à 11:12:32  profilanswer
 

O'Gure a écrit :

C'est le site que tu as en signature ?

Citation :

http://macgyver974.dyndns.org was running Apache on Linux when last queried at 4-Sep-2011 20:38:08 GMT


 
D'ailleurs, il ne m'est pas accessible à cet instant.


Oui il s'agit de celui-ci  :o  
Ah merde  :??:

n°1289460
Mac Gyver ​974
Posté le 05-09-2011 à 21:48:39  profilanswer
 

Et maintenant, est-il accessible ? pour moi il l'était aussi quand il ne l'était pas pour toi (en tapant l'url et non l'ip local bien sur)
 
Donc je ne comprends pas.

n°1289462
Mjules
Modérateur
Parle dans le vide
Posté le 05-09-2011 à 22:06:10  profilanswer
 

ça résoud mais ça ping pas.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1289467
Mac Gyver ​974
Posté le 05-09-2011 à 22:34:20  profilanswer
 

Mince, que peut-il se passer :??: perso j'accède nickel à mon serveur pourtant.

n°1289470
O'Gure
Modérateur
Multi grognon de B_L
Posté le 05-09-2011 à 23:04:01  profilanswer
 

Mac Gyver 974 a écrit :

Mince, que peut-il se passer :??: perso j'accède nickel à mon serveur pourtant.


Ce n'est pas parce qu'il est accessible depuis un endroit du net qu'il l'est de partout. En particulier depuis ton LAN (je suppose que tu testes depuis ton LAN ?) vs depuis Internet. Quelques raisons pouvant l'expliquer (car vu que tu nous donnes pas l'archi réseau / la conf / etc... ni boule de cristal...)
  - mauvaise résolution DNS (pas à jour, vu que tu utilises un dyndns)
  - problème de configuration du serveur
  - problème de routage
  - problème de NAT
  - problème de firewall
  - problème de peering

 

donc allons y...  t'as testé / vérifié quoi dans cette liste de chose ?
Peux tu nous décrire la conf / configuration / archi réseau / DNS / etc...

Message cité 1 fois
Message édité par O'Gure le 05-09-2011 à 23:20:31
n°1289678
Mac Gyver ​974
Posté le 06-09-2011 à 19:39:08  profilanswer
 

O'Gure a écrit :


Ce n'est pas parce qu'il est accessible depuis un endroit du net qu'il l'est de partout. En particulier depuis ton LAN (je suppose que tu testes depuis ton LAN ?) vs depuis Internet. Quelques raisons pouvant l'expliquer (car vu que tu nous donnes pas l'archi réseau / la conf / etc... ni boule de cristal...)
  - mauvaise résolution DNS (pas à jour, vu que tu utilises un dyndns)
  - problème de configuration du serveur
  - problème de routage
  - problème de NAT
  - problème de firewall
  - problème de peering
 
donc allons y...  t'as testé / vérifié quoi dans cette liste de chose ?  
Peux tu nous décrire la conf / configuration / archi réseau / DNS / etc...


 
En fait tout fonctionnait, et là pouf sans raison évidente, ça ne fonctionne plus. Donc comme je soupçonne que mon compte dyndns a expiré, peux-tu me dire ce que ça donne avec mon IP du moment:
 
92.160.237.182
 
L'archi réseau c'est juste un modem/routeur Netgear DGN1000 matériellement parlant, le serveur LAMP est directement branché en Ethernet dessus, aucune modif effectuée.
 
J'ai essayé de me co depuis mon travail et effectivement ça ne joint pas le site...
 
NAT, firewall etc etc rien de tout ça n'a été touché depuis la "panne".
 
Par contre il y a eu une MAJ de php et d'Apache aussi.

n°1289679
O'Gure
Modérateur
Multi grognon de B_L
Posté le 06-09-2011 à 19:42:32  profilanswer
 

Mac Gyver 974 a écrit :

peux-tu me dire ce que ça donne avec mon IP du moment:

 

92.160.237.182

rien
Pour être plus précis, il n'y a rien du tout au niveau TCP. Pas de service écoutant sur le port 80 à cette adresse ou équipement filtrant entre moi et cette adresse


Message édité par O'Gure le 06-09-2011 à 19:45:05
n°1289682
Mac Gyver ​974
Posté le 06-09-2011 à 20:34:13  profilanswer
 

Ah merde, MAJ qui a du mal se passer :/
 
Surement un fichier de config relatif à Apache qui n'est plus d'équerre, vis à vis de la MAJ.
 
Je ne peux plus acceder à mon site via le dyndns désormais ! par contre en local tout fonctionne bien...

mood
Publicité
Posté le 06-09-2011 à 20:34:13  profilanswer
 

n°1289683
Mjules
Modérateur
Parle dans le vide
Posté le 06-09-2011 à 20:44:40  profilanswer
 

sur l'ip cité plus haut, j'ai un site de Paul B. et de son voyage à la réunion.
 
par contre, ton adresse dyndns résout vers une autre IP chez moi.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1289684
O'Gure
Modérateur
Multi grognon de B_L
Posté le 06-09-2011 à 20:46:53  profilanswer
 

idem, ça fonctionne maintenant avec l'adresse IP

n°1289685
O'Gure
Modérateur
Multi grognon de B_L
Posté le 06-09-2011 à 20:47:57  profilanswer
 

le dyndns existe toujours donc le compte n'est pas expiré.
par contre il n'est pas à jour  

> host macgyver974.dyndns.org
macgyver974.dyndns.org has address 92.160.253.218

n°1289686
Mac Gyver ​974
Posté le 06-09-2011 à 20:54:17  profilanswer
 

Ah d'accord, effectivement à l'instant je vérifie mon IP et ça fonctionnait en la tapant directement, suite à une coupure internet que je viens de subir !
Auparant, en tapant mon IP je tombais sur l'interface de mon modem, entre temps il y a juste eu cette coupure internet là...
 
Donc faut que je revois mon ddclient. Bizarre je ne l'ai pas touché, lui, pourtant.
 
Edit: par contre c'est étrange, d'habitude quand j'ai une coupure internet totale, l'IP change lorsque ça reconnecte, et là non  :??:
 
Re Edit: alors là j'ai 2 problèmes:
 
1-) Je n'arrive plus à faire prendre en compte mes nouvelles IP avec ddclient, dyndns s'en fou.
2-) même si je mets manuellement la bonne adresse dans mon compte dyndns, ça n'a pas l'air de rediriger :??: (là je l'ai fait)
 
Re re re Edit: ... ah ben là ça redirige... ça a mis du temps, après que j'ai entré manuellement mon IP du moment... bizarre.


Message édité par Mac Gyver 974 le 06-09-2011 à 21:07:23
n°1289689
Mjules
Modérateur
Parle dans le vide
Posté le 06-09-2011 à 21:10:44  profilanswer
 

effectivement, ça fonctionne maintenant. C'est normal que ça mette du temps, il faut bien que les enregistrements DNS se propagent.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1289692
Mac Gyver ​974
Posté le 06-09-2011 à 21:19:37  profilanswer
 

Mjules a écrit :

effectivement, ça fonctionne maintenant. C'est normal que ça mette du temps, il faut bien que les enregistrements DNS se propagent.


D'accord, je m'imaginais que ça prenait quelques secondes  :D  
 
Par contre je n'ai plus confiance en ddclient, je pense que pour une raison X ou Y il ne joue pas/plus son rôle...
 
Sinon, mon compte dyndns est bien configuré, non ?
 
http://img844.imageshack.us/img844/6529/cran2t.jpg


Message édité par Mac Gyver 974 le 06-09-2011 à 21:20:39
n°1289693
O'Gure
Modérateur
Multi grognon de B_L
Posté le 06-09-2011 à 21:27:05  profilanswer
 

Mac Gyver 974 a écrit :


D'accord, je m'imaginais que ça prenait quelques secondes  :D


Suffit de lire ce qui est indiqué dans la configuration : "TTL value is 60 seconds"

 

Ton TTL est de 60 secondes. C'est à dire que les serveurs DNS mettent en cache pendant 60 secondes (s'ils respectent la chose...). C'est pour cela que c'était "si" lent après que tu l'aies mis à jour pour que tu obtiennes une connection via l'url. Ils ne vont pas aller vérifier si l'adresse IP à changer tant que le cache n'a pas expiré.

 

Après vérifie la configuration de ddclient surtout...

 

edit : Ton modem/routeur n'a pas une option pour du dyndns, c'est une chose assez courante maintenant pour que certains routeurs le fassent.

Message cité 1 fois
Message édité par O'Gure le 06-09-2011 à 21:30:18
n°1289694
Mac Gyver ​974
Posté le 06-09-2011 à 21:31:47  profilanswer
 

O'Gure a écrit :

Ton TTL est de 60 secondes. C'est à dire que les serveurs DNS mettent en cache pendant 60 secondes (s'ils respectent la chose...). C'est pourquoi c'était "si" lent après que tu l'aies mis à jour pour que tu obtiennes une connection via l'url. Ils ne vont pas aller vérifier si l'adresse IP à changer tant que le cache n'a pas expiré.
 
Après vérifie la configuration de ddclient surtout...
 
edit : Ton modem/routeur n'a pas une option pour du dyndns, c'est une chose assez courante maintenant pour que certains routeurs le fassent.


 
Oui mon modem a cette option, car le DGN1000 est plutot récent (je l'ai acheté il y a moins de 5 mois sur materiel.net)
 
Mais je vais revoir ddclient, j'aime l'idée que le serveur se démerde seul...
 
Merci en tout cas  :)

n°1289700
O'Gure
Modérateur
Multi grognon de B_L
Posté le 06-09-2011 à 22:55:21  profilanswer
 

Le plus propre est de le mettre sur le routeur.

 

C'est lui qui a la bonne visibilité de l'adresse WAN. C'est le premier averti dès que l'interface tombe/remonte et donc dès que l'adresse IP change. Pour mettre à jour dyndns.

 

Ton serveur est obligé d'envoyé périodiquement des mises à jour aux serveurs DynDns ou de vérifier si l'adresse publique qu'il utilise (via interrogation de service sur le web) a changé pour updater dyndns.  Bref, plus compliqué, plus de dépendance, plus de timer, moins propre.


Message édité par O'Gure le 06-09-2011 à 23:09:18
n°1289712
Mac Gyver ​974
Posté le 07-09-2011 à 07:02:17  profilanswer
 

Okay, jvais voir à le faire proprement dans ce cas.
Jvais apprendre une fonctionnalité encore inconnu de moi, sur mon DGN1000.

n°1289963
bardiel
Debian powa !
Posté le 09-09-2011 à 21:16:39  profilanswer
 

Mac Gyver 974 a écrit :

Bonjour, depuis une MAJ sur mon serveur LAMP -entre autre apache 2.2.20 et MAJ de php en dernière version-, le site hébergé dessus n'est plus trouvé par netcraft uptime, mais néanmoins accessible par n'importe quel navigateur, que s'est il passé à vôtre avis ? est-ce une histoire de configuration sur le serveur ?
 
Le Linux du LAMP est une Gentoo.


Bon, semblerais que ton site remarche mais j'aurais une petite suggestion : fais un redimensionnement des images/compression JPEG car c'est un peu lourd :o 777Ko pour du 800x600, presque 1Mo pour ta chère et tendre (vas pas lui dire qu'elle est grosse :D ), bah c'est moyen non ?


---------------
"Pendant que vous vous détruisez la cervelle devant une émission de télé débile, nous, sur Internet, nous échangeons librement les informations les plus secrètes et les plus choquantes concernant les paramètres de notre CONFIG.SYSTEM !" - Dave Barr
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Serveur LAMP non trouvé ds Netcraft mais néanmoins accessible.

 

Sujets relatifs
Installation de mon serveur DédiéServeur web : problème accès à certaines URL depuis l'extérieur
Mon Serveur relayeur ne recevoit pas mes messageAMAHI : Home serveur sous Fedora
Lancement Serveur DHCP au démarrageTunnel SSH - limiter les accès ? (côté serveur SSH)
Problèmes logs serveur Apache sous CentOSRsync de 2 serveur linux sous VMware
OpenVPN: Lan accessible mais Internet pas accessibleServeur debian : activer mail() php
Plus de sujets relatifs à : Serveur LAMP non trouvé ds Netcraft mais néanmoins accessible.


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR