Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
740 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  [Xorg] Problème config écran driver nvidia (en cours)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Xorg] Problème config écran driver nvidia (en cours)

n°1145925
spiro86
Posté le 01-07-2009 à 14:48:19  profilanswer
 

Bonjour à tous,
 
Voilà depuis un moment, je n'ai plus la possibilité de mettre mon écran en 1280x1024, je peut, tout au plus le mettre en 1152x864.
Si je met 1280x1024 dans le fichier xorg.conf de la manière suivante :
 

Code :
  1. Option "metamodes" "1152x864 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"


 
Lorsque je redémarre le serveur X, je n'ai plus qu'une seule ligne  en haut de mon écran, je ne pense pas que cela soit utile, mais mon écran est un Philips 170N4.
J'ai aussi constaté que le problème ne venais pas de mon écran, puisque celui-ci est pleinement fonctionnelle sous d'autres OS.
 
Voici, a titre d'information le contenu de mon fichier Xorg.conf :
 

Code :
  1. # nvidia-settings: X configuration file generated by nvidia-settings
  2. # nvidia-settings:  version 1.0  (root@spiro-desktop)  Thu Jun  4 19:10:25 CEST 2009
  3. Section "ServerLayout"
  4.     Identifier     "Layout0"
  5.     Screen      0  "Screen0" 0 0
  6.     InputDevice    "Keyboard0" "CoreKeyboard"
  7.     InputDevice    "Mouse0" "CorePointer"
  8. EndSection
  9. Section "Files"
  10. EndSection
  11. Section "Module"
  12.     Load           "dbe"
  13.     Load           "extmod"
  14.     Load           "type1"
  15.     Load           "freetype"
  16.     Load           "glx"
  17. EndSection
  18. Section "ServerFlags"
  19.     Option         "Xinerama" "0"
  20. EndSection
  21. Section "InputDevice"
  22.     # generated from data in "/etc/conf.d/gpm"
  23.     Identifier     "Mouse0"
  24.     Driver         "mouse"
  25.     Option         "Protocol"
  26.     Option         "Device" "/dev/input/mice"
  27.     Option         "Emulate3Buttons" "no"
  28.     Option         "ZAxisMapping" "4 5"
  29. EndSection
  30. Section "InputDevice"
  31.     # generated from default
  32.     Identifier     "Keyboard0"
  33.     Driver         "kbd"
  34.     Option         "XkbRules" "xorg"
  35.     Option         "XkbModel" "pc105"
  36.     Option         "XkbLayout" "fr-latin9"
  37. EndSection
  38. Section "Monitor"
  39.     # HorizSync source: edid, VertRefresh source: edid
  40.     Identifier     "Monitor0"
  41.     VendorName     "Unknown"
  42.     ModelName      "Philips 170N4"
  43.     HorizSync       30.0 - 82.0
  44.     VertRefresh     56.0 - 76.0
  45.     Option         "DPMS"
  46. EndSection
  47. Section "Device"
  48.     Identifier     "Device0"
  49.     Driver         "nvidia"
  50.     VendorName     "NVIDIA Corporation"
  51.     BoardName      "GeForce 6100"
  52. EndSection
  53. Section "Screen"
  54. # Removed Option "metamodes" "1152x864 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
  55.     Identifier     "Screen0"
  56.     Device         "Device0"
  57.     Monitor        "Monitor0"
  58.     DefaultDepth    24
  59.     Option         "TwinView" "0"
  60.     Option         "TwinViewXineramaInfoOrder" "CRT-0"
  61.     Option         "metamodes" "1152x864 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
  62.     SubSection     "Display"
  63.         Depth       24
  64.     EndSubSection
  65. EndSection


 
Je vous remercie d'avance pour votre aide,
 
À bientôt !


---------------
Spiro
mood
Publicité
Posté le 01-07-2009 à 14:48:19  profilanswer
 

n°1145931
Gavrinis
Open your mind
Posté le 01-07-2009 à 15:06:36  profilanswer
 

Que dit /var/log/messages ?

n°1145935
spiro86
Posté le 01-07-2009 à 15:59:41  profilanswer
 

Gavrinis a écrit :

Que dit /var/log/messages ?


 
Il n'y a rien qui ai un rapport avec Xorg dans ce log.
 
Par contre je vous transmet mon fichier de log de Xorg, bien que je n'y ai rien vu de particulièrement intéressant !
 

Code :
  1. Current Operating System: Linux spiro-desktop 2.6.29-tuxonice-r2-amd64x2-spiro-desktop #2 SMP PREEMPT Sun May 24 21:06:26 CEST 2009 x86_64
  2.         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
  3. (II) Loading extension MIT-SCREEN-SAVER
  4. (EE) Failed to load module "type1" (module does not exist, 0)
  5. (EE) Failed to load module "freetype" (module does not exist, 0)


Message édité par spiro86 le 01-07-2009 à 18:02:23

---------------
Spiro
n°1145938
ogaby
Posté le 01-07-2009 à 16:41:10  profilanswer
 

Dans ton log

Citation :

#  Before reporting problems, check http://wiki.x.org
# to make sure that you have the latest version.
# Markers: (--) probed, (**) from config file, (==) default setting,
# (++) from command line, (!!) notice, (II) informational,
# (WW) warning, (EE) error, (NI) not implemented, (??) unknown.


tu peux faire juste un: dmesg | grep EE  
puis éditer ton post. Là c'est un peut long et difficile à lire.

n°1146889
spiro86
Posté le 06-07-2009 à 23:31:21  profilanswer
 

Up please !


---------------
Spiro
n°1146915
ogaby
Posté le 07-07-2009 à 10:05:34  profilanswer
 

J'ai remarqué que t'as tuxonice et je me demande si ca ne pperturbe pas tes changements. Parce que je suis assez surpris que "freetype" ne peut pas être lancé. freetype est une police de caractère.
 
Est-ce que tu peux enlever (temporairement) tuxonice?

n°1146949
spiro86
Posté le 07-07-2009 à 12:49:41  profilanswer
 

Oui je vais te faire sa... de toutes manière il ne fonctionne pas et je ne l'ai jamais utilisé !


---------------
Spiro

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  [Xorg] Problème config écran driver nvidia (en cours)

 

Sujets relatifs
Enorme problème Phpmyadmin et debianProblème linux mandriva 2009 live cd
Problème de droits avec le serveur apacheproblème avec grub
Problème de connexion yahoo/gaimprobleme d'installation sur mac
Recherche cours de Bourne Shell !Problème de stabilité : démontrer que la machine à un pet au casque
Problème d'interface Backtrack 3Probleme de son VOSTRO 1500 + Debian + Noyau > 2.6.26
Plus de sujets relatifs à : [Xorg] Problème config écran driver nvidia (en cours)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR