Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1793 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  installation cx_oracle

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

installation cx_oracle

n°1451335
intersigne
/!\ SJW /!\
Posté le 06-07-2020 à 17:50:13  profilanswer
 

Bonjour,
 
je ne sais pas si je poste dans la bonne cat.
 
 
Je suis sur une machine virtuel (VMWare) Ubuntu 20.x.
 
J'essaie d'installer cx_Oracle pour une version de python 2.7 via pip. J'ai réussi pour une version 3.
 
Cependant ça plante pour la version de python2. Dans l'idée c'est pas idéal mais les scripts à utiliser ne tournent pas avec python3 pour l'instant.
 
Erreur :

Citation :


pip install cx_oracle
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/devel [...] -2-support
Defaulting to user installation because normal site-packages is not writeable
Collecting cx_oracle
  Using cached cx_Oracle-8.0.0.tar.gz (325 kB)
    ERROR: Command errored out with exit status 1:
     command: /usr/bin/python2 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-_LC2qD/cx-oracle/setup.py'"'"'; __file__='"'"'/tmp/pip-install-_LC2qD/cx-oracle/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-klWoGy
         cwd: /tmp/pip-install-_LC2qD/cx-oracle/
    Complete output (5 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-_LC2qD/cx-oracle/setup.py", line 17, in <module>
        raise Exception("Python 3.5 or higher is required." )
    Exception: Python 3.5 or higher is required.
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.


 
 
 

Citation :


pip --version
pip 20.1.1 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)


 
 
J'ai recherché sur le ne tmais je n'ai rien trouvé de concluant.
j'ai essayé :
pip install --upgrade pip
 

Citation :


DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/devel [...] -2-support
Defaulting to user installation because normal site-packages is not writeable
Requirement already up-to-date: pip in /usr/local/lib/python2.7/dist-packages (20.1.1)


 
Pas de changement de message d'erreur après.
 
En vous remerciant.


---------------
Roll out !
mood
Publicité
Posté le 06-07-2020 à 17:50:13  profilanswer
 

n°1451338
Hermes le ​Messager
Breton Quiétiste
Posté le 06-07-2020 à 20:33:56  profilanswer
 

intersigne a écrit :

Bonjour,
 
je ne sais pas si je poste dans la bonne cat.
 
 
Je suis sur une machine virtuel (VMWare) Ubuntu 20.x.
 
J'essaie d'installer cx_Oracle pour une version de python 2.7 via pip. J'ai réussi pour une version 3.
 
Cependant ça plante pour la version de python2. Dans l'idée c'est pas idéal mais les scripts à utiliser ne tournent pas avec python3 pour l'instant.
 
Erreur :

Citation :


pip install cx_oracle
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/devel [...] -2-support
Defaulting to user installation because normal site-packages is not writeable
Collecting cx_oracle
  Using cached cx_Oracle-8.0.0.tar.gz (325 kB)
    ERROR: Command errored out with exit status 1:
     command: /usr/bin/python2 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-_LC2qD/cx-oracle/setup.py'"'"'; __file__='"'"'/tmp/pip-install-_LC2qD/cx-oracle/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-klWoGy
         cwd: /tmp/pip-install-_LC2qD/cx-oracle/
    Complete output (5 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-_LC2qD/cx-oracle/setup.py", line 17, in <module>
        raise Exception("Python 3.5 or higher is required." )
    Exception: Python 3.5 or higher is required.
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.


 
 
 

Citation :


pip --version
pip 20.1.1 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)


 
 
J'ai recherché sur le ne tmais je n'ai rien trouvé de concluant.
j'ai essayé :
pip install --upgrade pip
 

Citation :


DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/devel [...] -2-support
Defaulting to user installation because normal site-packages is not writeable
Requirement already up-to-date: pip in /usr/local/lib/python2.7/dist-packages (20.1.1)


 
Pas de changement de message d'erreur après.
 
En vous remerciant.


 
Tu as suivi cette doc :
 
https://cx-oracle.readthedocs.io/en [...] ml#python2
 
?


---------------
Expert en expertises
n°1451339
Hermes le ​Messager
Breton Quiétiste
Posté le 06-07-2020 à 20:34:51  profilanswer
 

Oracle 8.0 n’est pas compatible avec python 2.x
 
Il faut une version plus ancienne d’oracle.


---------------
Expert en expertises
n°1451340
Hermes le ​Messager
Breton Quiétiste
Posté le 06-07-2020 à 20:36:04  profilanswer
 

Par contre, je ne comprends pas le :
 
Je suis sur une machine virtuel (VMWare) Ubuntu 20.x.
 
Ubuntu 20.x est ultra récente. Pourquoi vouloir installer une vieille version d’Oracle avec python 2.x ??


---------------
Expert en expertises
n°1451383
intersigne
/!\ SJW /!\
Posté le 07-07-2020 à 17:55:22  profilanswer
 

Hello,
 
Merci pour les réponses.
 
Concernant le pourquoi je respecte un process interne loin d'être optimale. Si ça fonctionne je verrais dans le temps si migrer la solution n'est pas quelque chose d'envisageable.
 
Merci pour ton lien, c'était bien ça la solution pour une version "ancienne" de python. Cela fonctionne  :jap:  
 
Merci !


---------------
Roll out !

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  installation cx_oracle

 

Sujets relatifs
script automatisation installation fedora workstationInstallation de Kaspersky Security Center sous debian
Démarrage sous linux et installation définitive (ou pas..)Installation et configuration hyper v server 2012 r2
[RESOLU] pb installation client oracle oci 8 sur debianUBUNTU: Soucis Oracle 10g Express Edition aprés installation
Installation Apache/SSL/php5 avec support oracle sur RH AS4Oracle: installation en mode texte [RESOLU]
[GROS PROB] Installation Oracle 8.1.7 sur une Suse 8[Apache - PHP - Oracle] Installation
Plus de sujets relatifs à : installation cx_oracle


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR