Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2046 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  Installer QMail sur une Debian 3

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Installer QMail sur une Debian 3

n°201458
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 14:58:46  profilanswer
 

Hello,
 
Je dois mettre en place un serveur mail (~170 comptes).
J'ai une machine installée avec une Deb3. JE n'ai rien installé en sus excepté Joe.
 
Bon, pour être franc, je n'y connais rien. J'espère obtenir le plus d'aide possible :jap:.
 
JE sais déjà qu'il n'y a pas de RPM. Que pour QMail sur une Deb, il faut utiliser des scripts.
 
Mais, où les trouver ? Comment les récupérer (quelle commande ?  [:tilleul]). Comment les installer/utiliser ?
 
 
 
Pour commencer, n'ayant D/L que le 1er CD, j'ai mis à jour la liste des package d'APT avec :

(/etc/apt/sources.list)
 
deb ftp://ftp.lip6.fr/pub/linux/distributions/debian stable main contrib non-free
deb ftp://ftp.free.fr/pub/Distributions_Linux/Debian stable main contrib non-free


(Merci Minusplus ..).
 
 
 
Voilà, je suis bloqué là.
Je ne sais pas quoi faire, ni ce qui est necessaire pour l'install. J'ai juste lu qu'il faut un serveur DNS. ??
J'en ai un en interne, est-ce suffisant ?
 
 
 
En esperant que certains d'entre vous ont du temps libre, et bcp de patience ... :D
Merchi :jap:


Message édité par Groody le 13-12-2002 à 14:59:11

---------------
Vidéo Concorde Air France | www.kiva.org
mood
Publicité
Posté le 13-12-2002 à 14:58:46  profilanswer
 

n°201459
kelus
Posté le 13-12-2002 à 15:03:10  profilanswer
 

tu peux installer qmail a coup de .deb
soit tu recuperes les binaires mais c'est pas conseille soit tu as qmail-src.deb
mais il faut les recompiler sur ta machine  
le mieux est de recuperer les sources en tar.gz quand meme
 
le mieux est que tu ailles voir www.lifewithqmail.org et  
www.lea-linux.org/qmail.php3 pour plus d'infos
 
 

n°201460
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:03:43  profilanswer
 
n°201461
kelus
Posté le 13-12-2002 à 15:04:17  profilanswer
 

deja, tu peux faire
apt-get install make gcc emacs  
ca sera un bon debut
ensuite, tu installeras ce qui manque a chaque erreur renvoyee par le ./configure

n°201462
kelus
Posté le 13-12-2002 à 15:05:00  profilanswer
 

je dois te preciser que qmail est pas super evident a approcher donc lis bien la doc pour comprendre le fonctionnement

n°201463
littlebobo​y
Posté le 13-12-2002 à 15:05:37  profilanswer
 

Je ne me sers pas de debian , mais il fut un temps ou j'ai voulu installé Qmail & il m'avait justement semblé avoir vu du prémaché débian.
Ici peut etre : http://smarden.org/pape/Debian/qmail.html

n°201464
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:06:47  profilanswer
 

kelus a écrit :

je dois te preciser que qmail est pas super evident a approcher donc lis bien la doc pour comprendre le fonctionnement  

Et, une fois installé, je ne peux le configurer directement via WebMin ?


---------------
Vidéo Concorde Air France | www.kiva.org
n°201465
kelus
Posté le 13-12-2002 à 15:07:07  profilanswer
 

ce sont des qmail-src.deb recompiles en .deb tout court
j'avais vu ce lien mais c'est un peu chiant quand tu as des patchs a appliquer :/

n°201466
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:07:33  profilanswer
 

kelus a écrit :

deja, tu peux faire
apt-get install make gcc emacs
ca sera un bon debut
ensuite, tu installeras ce qui manque a chaque erreur renvoyee par le ./configure

Tu peux m'expliquer à quoi ça correspond ?
 
Le APT-GET INSTALL, ok, EMacs, c'est un éditeur de texte ? Mais le reste ?


---------------
Vidéo Concorde Air France | www.kiva.org
n°201467
kelus
Posté le 13-12-2002 à 15:07:50  profilanswer
 

Groody a écrit :

Et, une fois installé, je ne peux le configurer directement via WebMin ?


aucune idee
moi je configure les utilisateurs via qmailadmin et le serveur en ssh

mood
Publicité
Posté le 13-12-2002 à 15:07:50  profilanswer
 

n°201468
kelus
Posté le 13-12-2002 à 15:08:57  profilanswer
 

Groody a écrit :

Tu peux m'expliquer à quoi ça correspond ?
 
Le APT-GET INSTALL, ok, EMacs, c'est un éditeur de texte ? Mais le reste ?


tu auras besoin de make et gcc pour compiler les sources de qmail et des autres logiciels

n°201469
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:11:06  profilanswer
 

kelus a écrit :

deja, tu peux faire
apt-get install make gcc emacs  
ca sera un bon debut
ensuite, tu installeras ce qui manque a chaque erreur renvoyee par le ./configure


 

Deb:~# apt-get install make gcc emacs
Reading Package Lists... Done
Building Dependency Tree... Done
Sorry, make is already the newest version.
Sorry, gcc is already the newest version.
Package emacs has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list
E: Package emacs has no installation candidate
Deb:~#


 
Donc je ne peux récupérer Emacs ?
 
Quelqu'un a une autre adresse de "sources" ?


---------------
Vidéo Concorde Air France | www.kiva.org
n°201471
littlebobo​y
Posté le 13-12-2002 à 15:16:36  profilanswer
 

Tu es obligé de te servir de Emacs comme éditeur de texte ?
car a priori c'est secondaire dans ton cas ?
 
http://packages.debian.org/unstabl [...] acs21.html

n°201472
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:19:35  profilanswer
 

littleboboy a écrit :

Tu es obligé de te servir de Emacs comme éditeur de texte ?
car a priori c'est secondaire dans ton cas ?
 
http://packages.debian.org/unstabl [...] acs21.html

PAs compris.
Tu dis ça car y'a beaucoup de dépendance ?
 
 
(désolé si j'ai vraiment l'air d'une burne, mais, je n'y connais strictement rien [:spamafote](mais ze veutx apprendre [:tilleul]))


---------------
Vidéo Concorde Air France | www.kiva.org
n°201473
kelus
Posté le 13-12-2002 à 15:23:53  profilanswer
 

Groody a écrit :


Donc je ne peux récupérer Emacs ?
 
Quelqu'un a une autre adresse de "sources" ?  


desole, c'est apt-get install emacs21, mais tu peux utiliser l'editeur de texte que tu veux bien sur

n°201474
littlebobo​y
Posté le 13-12-2002 à 15:24:03  profilanswer
 

Groody a écrit :

PAs compris.
Tu dis ça car y'a beaucoup de dépendance ?
 
 
(désolé si j'ai vraiment l'air d'une burne, mais, je n'y connais strictement rien [:spamafote](mais ze veutx apprendre [:tilleul]))


Bah disons que je vois pas en quoi Emacs (éditeur de texte ) a un quelconque rapport avec l'installation de Qmail. Tu peux logiquement te servir de n'importe quel éditeur de texte a mon humble avis.
Pour le serveur dns par serveur interne tu entends quoi ?
il peut résoudre tout ? ou est limité aux domaines locaux ?

n°201475
kelus
Posté le 13-12-2002 à 15:24:36  profilanswer
 

littleboboy a écrit :

Tu es obligé de te servir de Emacs comme éditeur de texte ?
car a priori c'est secondaire dans ton cas ?
 
http://packages.debian.org/unstabl [...] acs21.html


il en aura besoin pour quelques manips quand meme, mais il peut utiliser autre chose qu'emacs

n°201476
kelus
Posté le 13-12-2002 à 15:25:26  profilanswer
 

littleboboy a écrit :


Bah disons que je vois pas en quoi Emacs (éditeur de texte ) a un quelconque rapport avec l'installation de Qmail. Tu peux logiquement te servir de n'importe quel éditeur de texte a mon humble avis.
Pour le serveur dns par serveur interne tu entends quoi ?
il peut résoudre tout ? ou est limité aux domaines locaux ?
 


exact, mais a 1ere vue, il a aucun editeur de texte installe et comme je sais juste me servir d'emacs :D  

n°201478
littlebobo​y
Posté le 13-12-2002 à 15:26:45  profilanswer
 

kelus a écrit :


exact, mais a 1ere vue, il a aucun editeur de texte installe et comme je sais juste me servir d'emacs :D  
 


:jap:
Je te le laisse :o
(Faut dire que j'avais foiré mon install quand j'avais essayé de mettre Qmail (pas assez patient :p ) j'etais revenu sur un facile postfix :D )

n°201479
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:27:15  profilanswer
 

littleboboy a écrit :


Bah disons que je vois pas en quoi Emacs (éditeur de texte ) a un quelconque rapport avec l'installation de Qmail. Tu peux logiquement te servir de n'importe quel éditeur de texte a mon humble avis.
Pour le serveur dns par serveur interne tu entends quoi ?
il peut résoudre tout ? ou est limité aux domaines locaux ?
 

Ok.
Bah j'ai VI (QUE JE NE VEUX PAS UTILISER !!! :D), et j'ai installé JOE, que je ne connais pas.
 
 
Pour le DNS, ouai. En fait plusieurs. L'internet qui résoud aussi vers le net, ceux de notre prestataire, et ceux de notre nouvelle TDSL Oléane. Donc.. oui


---------------
Vidéo Concorde Air France | www.kiva.org
n°201480
kelus
Posté le 13-12-2002 à 15:28:01  profilanswer
 

j'avais essaye postfix mais j'ai finalement succombe a qmail
mais je pense que postfix est plus simple a mettre en oeuvre
 
je precise que je suis pas un expert de qmail, je l'ai installe y a pas longtemps donc je peux essayer d'aider

n°201482
kelus
Posté le 13-12-2002 à 15:28:57  profilanswer
 

je connais pas joe, donc emacs :D  
 
pour les dns, ca devrait aller alors

n°201483
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:29:46  profilanswer
 

Bon, j'install Emacs, je le virerai ensuite à la limite


---------------
Vidéo Concorde Air France | www.kiva.org
n°201484
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:30:19  profilanswer
 

Il me demande d'installer 8 packes (dépenances..).
 
OK ? :D  
 
(48 Mb [:wam])


Message édité par Groody le 13-12-2002 à 15:31:45

---------------
Vidéo Concorde Air France | www.kiva.org
n°201485
kelus
Posté le 13-12-2002 à 15:30:57  profilanswer
 

oui il est assez gourmand en packages :D  
c'est sur que vi est plus leger  ;)

n°201486
kelus
Posté le 13-12-2002 à 15:32:45  profilanswer
 

48 Mo, ah ouais quand meme :D

n°201487
Groody
Utilisez MES smileys §
Posté le 13-12-2002 à 15:33:34  profilanswer
 

Avec ts les Packages, ouai :/
 
 
Bon, je coupe, je reprends l'install lundi matin.
Merci bco en tt cas pour le début :jap:
 
Bon WE :hello:


---------------
Vidéo Concorde Air France | www.kiva.org
n°201489
kelus
Posté le 13-12-2002 à 15:44:11  profilanswer
 

lis au moins mes liens avant de commencer l'install
 :hello: bon week-end a toi

n°201490
houplaboom​42
Posté le 13-12-2002 à 15:45:16  profilanswer
 

juste pour dire que les djbwares sont urpmisé la : http://www.rpmhelp.net/
 
pour une mdk 9.0 , "suffit" de faire
 
 

Code :
  1. urpmi.addmedia rpmhelp ftp://ftp.rpmhelp.net/pub/9.0/RPMS with ../base/hdlist.cz

 
 
puis urpmi qmail , et ca passe a l aise

n°201498
littlebobo​y
Posté le 13-12-2002 à 16:07:50  profilanswer
 

houplaboom42 a écrit :

juste pour dire que les djbwares sont urpmisé la : http://www.rpmhelp.net/
 
pour une mdk 9.0 , "suffit" de faire
 
 

Code :
  1. urpmi.addmedia rpmhelp ftp://ftp.rpmhelp.net/pub/9.0/RPMS with ../base/hdlist.cz

 
 
puis urpmi qmail , et ca passe a l aise


Miam je garde cela sous la main ;)
 

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  Installer QMail sur une Debian 3

 

Sujets relatifs
[MAC] Débutant aimerai installer Linux[Debian Cobalt] Probleme free et cut
[debian] pb squid - proxy transparentle serverx refuse de démarrer sous debian
lan de la asus a7v8x et linux (débian notament)[Debian Sarge] Pb avec OpenOffice
Comment installer les sources?[debian] eth0 a disapru [resolu]
[résolu]Ma Debian mise en francais reviens en anglais[Debian] fonts problemes
Plus de sujets relatifs à : Installer QMail sur une Debian 3


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR