Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1725 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  Le topic BEWAN aDSL PCI ST (Part II) - CARTE DÉJA FONCTIONNELLE

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Le topic BEWAN aDSL PCI ST (Part II) - CARTE DÉJA FONCTIONNELLE

n°131813
Sagittariu​s
Posté le 30-07-2002 à 20:35:28  profilanswer
 

Bonjour à tous,
 
Je vous propose, si vous le voulez bien, une deuxième partie du topic BEWAN aDSL PCI ST qui ne traite de cette carte, qu'une fois la CONFIGURATION DÉJA FONCTIONNELLE.
 
Pour l'installation, la compilation n'hésitez pas à regarder le topic BEWAN ADSL PCI ST (appelons-le Part I), il est désormais extrêmement fourni.
 
Voici les pistes que je soumets à votre sagacité :
 
- partage de connexion sur cette carte lorsqu'elle est en mode pppoe ou pppoatm ;
 
- écriture de scripts pour permettre une prise en charge(chargement/déchargement des modules et lancement/kill des exécutables) à partir des dossiers correspondants aux divers runlevel (et non dans rc.local) des linux MDK et RedHat ;
 
- idem pour ceux tournant sous FreeBSD.
 
Bien entendu, si vous pensez que ce topic n'a pas lieu d'être, et bien n'y répondez pas, il mourra de lui-même.

mood
Publicité
Posté le 30-07-2002 à 20:35:28  profilanswer
 

n°131829
Gaellick
Quoi ??? Noooonn !! Si !
Posté le 30-07-2002 à 20:59:22  profilanswer
 

Desole mais j'ai pas encore redemarre depuis que je l'ai installee :D alors pas de script de demarrage pour l'instant, mais c'est vrai que ca m'interesse :D


---------------
Qui cherche le soleil évite la pluie !
n°131859
bobor
tueur de n44b
Posté le 30-07-2002 à 21:43:26  profilanswer
 

Moi je suis sous Mandrake 8.2 et j'ai donc adapté l'emplacement de mes script pour utiliser le script "internet" dans /etc/init.d:
 
voici les miens:
internet dans /etc/init.d:
 

Code :
  1. #!/bin/bash
  2. #
  3. # internet       Bring up/down internet connection
  4. #
  5. # chkconfig: 2345 11 89
  6. # description: Activates/Deactivates the internet interfaces
  7. #
  8. # dam's (damien@mandrakesoft.com)
  9. # Source function library.
  10. . /etc/rc.d/init.d/functions
  11. case "$1" in
  12.  start)
  13.                 if [ -e /etc/sysconfig/network-scripts/net_cnx_up ]; then
  14.   action "Checking internet connections to start at boot" "/etc/sysconfig/network-scripts/net_cnx_up --boot_time"
  15.  else
  16.   action "No connection to start" "true"
  17.  fi
  18.  touch /var/lock/subsys/internet
  19.  ;;
  20. stop)
  21.                 if [ -e /etc/sysconfig/network-scripts/net_cnx_down ]; then
  22.   action "Stopping internet connection if needed: " "/etc/sysconfig/network-scripts/net_cnx_down --boot_time"
  23.  else
  24.   action "No connection to stop" "true"
  25.  fi
  26.  rm -f /var/lock/subsys/internet
  27.  ;;
  28. restart)
  29.  $0 stop
  30.  echo "Waiting 10 sec before restarting the internet connection."
  31.  sleep 10
  32.  $0 start
  33.  ;;
  34. status)
  35.  ;;
  36. *)
  37. echo "Usage: internet {start|stop|status|restart}"
  38. exit 1
  39. esac
  40. exit 0


 
net_cnx_up dans /etc/sysconfig/network-scripts (de même avec un stop pour net_cnx_down):
 

Code :
  1. #!/bin/bash
  2. /etc/bewan/unicorn-pppoatm start


 
et le script adsl proprement dit dans /etc/bewan:
 

Code :
  1. #!/bin/sh
  2. # Source function library.
  3. . /etc/rc.d/init.d/functions
  4. USER=fti/*******@fti
  5. VPI=8
  6. VCI=35
  7. # ANSI=1,G.lite=2,MULTI=3,G.dmt=4,
  8. MODE=1
  9. MODPROBE="/sbin/modprobe"
  10. # version 2.4.0b2 patched
  11. #PPPD="/usr/src/ppp-2.4.0b2/pppd/pppd"
  12. #PLUGIN="/usr/lib/pppd/plugins/pppoatm.so"
  13. # version 2.4.1
  14. PPPD="/usr/sbin/pppd"
  15. PLUGIN="/usr/lib/pppd/plugins/pppoatm.so"
  16. cleanup() {
  17.      echo ""
  18.      echo "initialization of ADSL PPPoATM failed!"
  19.      echo ""
  20.      killproc $PPPD
  21.      $MODPROBE -r unicorn_pci >/dev/null
  22.      break
  23. }
  24. EXITCODE=1
  25. for x in "1" ; do
  26.   case "$1" in
  27.     stop)
  28. echo -n "killing pppd"
  29. killproc $PPPD
  30. echo
  31.  echo -n "removing unicorn_pci"
  32. $MODPROBE -r unicorn_pci >/dev/null
  33. if test $? -eq 0; then
  34.     echo_success
  35. else
  36.     echo_failure
  37. fi
  38. echo
  39.     ;;
  40.     start)
  41.         echo -n "loading unicorn_pci, mode=$MODE"
  42. $MODPROBE pppoatm
  43. $MODPROBE unicorn_pci ActivationMode=$MODE
  44. if test $? -eq 0; then
  45.     echo_success
  46. else
  47.     echo_failure
  48.     cleanup
  49. fi
  50. echo
  51. # give the modem sw time to activate...
  52. sleep 10
  53. echo -n "starting pppd"
  54. $PPPD plugin $PLUGIN $VPI.$VCI
  55. if test $? -eq 0; then
  56.     echo_success
  57. else
  58.     echo_failure
  59.     cleanup
  60. fi
  61. echo
  62.     ;;  
  63.     'restart')
  64.     $0 stop
  65.     $0 start
  66.     ;;
  67.      
  68.     *)
  69.     ;;
  70.      
  71.   esac
  72.   EXITCODE=0
  73. done
  74. exit $EXITCODE


 
j'ai mis également les ppp/options et ppp/secrets comme y faut. Je peux les fournir si vous voulez, mais comme théoriquement la carte est fonctionnelle, doit pas y avoir de soucis.
 
En tout cas bonne initiative!


---------------
Gitan des temps modernes
n°131866
Sagittariu​s
Posté le 30-07-2002 à 21:49:22  profilanswer
 

Ah bravo, de la belle ouvrage !
Idéal pour ceux en mode pppoatm.
 
Merci infiniment.

n°131869
bobor
tueur de n44b
Posté le 30-07-2002 à 21:55:55  profilanswer
 

pour info je suis sur une plaque ECI donc pppoe???. Je n'y ai jamais rien compris. Avant j'étais sur plaque alcatel mais j'ai mis les drivers pppoe car le singe plantait mon windows sinon. Maintenant je suis sous ECI, mode pppoe sous win mais pppoa sous linux. :pt1cable:


---------------
Gitan des temps modernes
n°140373
jamiroq
Oublies que t'as aucune chance
Posté le 16-08-2002 à 10:00:17  profilanswer
 

ben ecoutes,
 
moi j'ai juste
 
1 - copier le fichier "adsl" dans "/etc/init.d"  (adsl étant le fichier qui lance le pilotes , le module pppoatm et lance pppd)
 
2 - un coup de SystemV, sous kde, pour démarrer le script "adsl" en runlevel 3 et 5 puis l'arret en runlevel 6 et c .... tout !
 
ca roule !!
 
A ce sujet ce script "adsl" il vaut mieux le demarrer ou ?
(ds l'ordre de lancement des services (démons qu'on dit ss unix:d) )
 


---------------
FFFF
n°140379
bobor
tueur de n44b
Posté le 16-08-2002 à 10:38:18  profilanswer
 

bah vers la fin comme ça pas de problème


---------------
Gitan des temps modernes
n°140380
jamiroq
Oublies que t'as aucune chance
Posté le 16-08-2002 à 10:46:29  profilanswer
 

bobor a écrit a écrit :

bah vers la fin comme ça pas de problème




 
vers la fin y'a deja des demons en 99 donc impossibles de l'intercaler ici  , non ?


---------------
FFFF
n°140385
bobor
tueur de n44b
Posté le 16-08-2002 à 11:06:36  profilanswer
 

pas de problème tu peux mettre plusieurs 99. Ce n'est pas très propre car tu maîtrise moins le véritable ordre de lacement. Tu peux faire des mv sur des 99 pour intercaler les différents démons
 
Moi je le lance parès le lancement network, dns, iptables.... Ces daemons n'ont pas besoin que ppp0 soit montés pour se lancer correctement


---------------
Gitan des temps modernes
n°140391
jamiroq
Oublies que t'as aucune chance
Posté le 16-08-2002 à 11:29:41  profilanswer
 

bobor a écrit a écrit :

pas de problème tu peux mettre plusieurs 99. Ce n'est pas très propre car tu maîtrise moins le véritable ordre de lacement. Tu peux faire des mv sur des 99 pour intercaler les différents démons
 
Moi je le lance parès le lancement network, dns, iptables.... Ces daemons n'ont pas besoin que ppp0 soit montés pour se lancer correctement




super, merci a toi!!!
 
sinon le fait d'avoir mis l'option "Persist" ds le fichier "option" suffit pour que ma connection se relance si y'a une deconnect france telecom ??
 
sinon existe t-il des outils pour gerer la reconnection auto ??


---------------
FFFF
mood
Publicité
Posté le 16-08-2002 à 11:29:41  profilanswer
 

n°140393
bobor
tueur de n44b
Posté le 16-08-2002 à 11:58:26  profilanswer
 

persist c'est bon! Une merceille cette carte!

n°140474
jamiroq
Oublies que t'as aucune chance
Posté le 16-08-2002 à 14:45:08  profilanswer
 

bobor a écrit a écrit :

persist c'est bon! Une merceille cette carte!




merci pour ton  info !
 
c clair que c d'la balle !!!
 
(putain je me fait chier au boulot aujourd'hui !!)


---------------
FFFF
n°141377
ashramrak
o_O
Posté le 19-08-2002 à 09:04:29  profilanswer
 

ma config fonctionne nickel mais j'ai des pings horribles, entre 200 et 300 ms, je sais pas vraiment ou chercher donc si qq a une idée :ange:  
 
ma config : rh7.3, drivers 0.3.4, isp nerim, netissimo1
 
ouala ;)

n°148256
ashramrak
o_O
Posté le 31-08-2002 à 17:58:05  profilanswer
 

au fait quand je lance la connexion la route par défaut n'est pas écrasée et j'ai ca dans /var/log/messages :  
 
/etc/hotplug/net.agent: assuming ppp0 is already up
 
donc avant de lancer la connexion je fait un route del default et la ca marche
 
mais si quelqu'un a une explication... :bounce:  

n°308421
KroKette
Posté le 17-08-2003 à 21:25:05  profilanswer
 

Bonjour,
 
J'utilise la disto Mdk 9.1 (2.4.21) avec ma carte Bewan Adsl Pci st.
Pilotes Unicorn 0.6.1.
 
J'ai suivi la tres bonne doc de faust pour installer la carte mais j'ai un probleme au moment de la connection.
 
Une fois les pilotes installer, je fais : cat /proc/net/atm/UNICORN:0
 
Réponse :

Code :
  1. ADSL: status no link, modem state SHOWTIME L0, US rate 0Kbits/s, DS rate 0Kbits/s
  2. Current speed: US 0Kbits/s,DS 0Kbits/s
  3. Current speed: US 0Kbits/s,DS 0Kbits/s,rt-US 0, rt-DS 0Kbits/s
  4. Bridged: 00:00:00:00:00:00
  5. AAL5: tx 0 ( 0 err ), rx 0 ( 0 err, 0 drop )
  6. AAL0: tx 0 ( 0 err ), rx 0 ( 0 err, 0 drop )


 
J'ai completé les fichiers de conf toujours en suivant la doc. Je lance pppd
 
Réponse:

Code :
  1. ... pppd[24389]: Plugin pppoatm.so loaded.
  2. ... pppd[24389]: PPPoATM plugin_init
  3. ... pppd[24389]: PPPoATM setdevname - remove unwanted options
  4. ... pppd[24389]: PPPoATM setdevname_pppoatm - SUCCESS:8.35
  5. ... pppd[24390]: pppd 2.4.1 started by root, uid 0
  6. ... pppd: Plugin pppoatm.so loaded.
  7. ... pppd: PPPoATM plugin_init
  8. ... pppd: PPPoATM setdevname - remove unwanted options
  9. ... pppd: PPPoATM setdevname_pppoatm - SUCCESS:8.35
  10. ... pppd: pppd startup succeeded
  11. ... kernel: unicorn_atm: ESI=00:60:4c:aa:bb:cc
  12. ... pppd[24390]: Using interface ppp0
  13. ... pppd[24390]: Connect: ppp0 <--> 8.35
  14. ... /etc/hotplug/net.agent: assuming ppp0 is already up
  15. ... pppd[24390]: LCP: timeout sending Config-Requests
  16. ... pppd[24390]: Connection terminated.
  17. ... pppd[24390]: Fatal signal 11
  18. ... pppd[24390]: Exit.


 
Impossible d'etablir une connection (j'ai test unicorn 0.6.0 aussi)
 
Au bout de 2 jours de test et retest, de lecture de topic... je ne sait plus koi faire :/
 

n°308445
911GT3
en roue libre
Posté le 17-08-2003 à 21:51:19  profilanswer
 

je sais pas si c'est dû au fait que je suis en dégroupé mais c'est bizarre que tu sois à 0 de débit sur la ligne.
 
 

ADSL: status ATM ready, modem state SHOWTIME L0, US rate 383Kbits/s, DS rate 2399Kbits/s

n°308531
Tomate
Posté le 18-08-2003 à 00:42:33  profilanswer
 

KroKette a écrit :

Bonjour,
 
J'utilise la disto Mdk 9.1 (2.4.21) avec ma carte Bewan Adsl Pci st.
Pilotes Unicorn 0.6.1.
 
J'ai suivi la tres bonne doc de faust pour installer la carte mais j'ai un probleme au moment de la connection.
 
Une fois les pilotes installer, je fais : cat /proc/net/atm/UNICORN:0
 
Réponse :

Code :
  1. ADSL: status no link, modem state SHOWTIME L0, US rate 0Kbits/s, DS rate 0Kbits/s
  2. Current speed: US 0Kbits/s,DS 0Kbits/s
  3. Current speed: US 0Kbits/s,DS 0Kbits/s,rt-US 0, rt-DS 0Kbits/s
  4. Bridged: 00:00:00:00:00:00
  5. AAL5: tx 0 ( 0 err ), rx 0 ( 0 err, 0 drop )
  6. AAL0: tx 0 ( 0 err ), rx 0 ( 0 err, 0 drop )


 
J'ai completé les fichiers de conf toujours en suivant la doc. Je lance pppd
 
Réponse:

Code :
  1. ... pppd[24389]: Plugin pppoatm.so loaded.
  2. ... pppd[24389]: PPPoATM plugin_init
  3. ... pppd[24389]: PPPoATM setdevname - remove unwanted options
  4. ... pppd[24389]: PPPoATM setdevname_pppoatm - SUCCESS:8.35
  5. ... pppd[24390]: pppd 2.4.1 started by root, uid 0
  6. ... pppd: Plugin pppoatm.so loaded.
  7. ... pppd: PPPoATM plugin_init
  8. ... pppd: PPPoATM setdevname - remove unwanted options
  9. ... pppd: PPPoATM setdevname_pppoatm - SUCCESS:8.35
  10. ... pppd: pppd startup succeeded
  11. ... kernel: unicorn_atm: ESI=00:60:4c:aa:bb:cc
  12. ... pppd[24390]: Using interface ppp0
  13. ... pppd[24390]: Connect: ppp0 <--> 8.35
  14. ... /etc/hotplug/net.agent: assuming ppp0 is already up
  15. ... pppd[24390]: LCP: timeout sending Config-Requests
  16. ... pppd[24390]: Connection terminated.
  17. ... pppd[24390]: Fatal signal 11
  18. ... pppd[24390]: Exit.


 
Impossible d'etablir une connection (j'ai test unicorn 0.6.0 aussi)
 
Au bout de 2 jours de test et retest, de lecture de topic... je ne sait plus koi faire :/
 
 


t es sur d avoir la synchro car :
 

Citation :

ADSL: status no link, modem state SHOWTIME L0, US rate 0Kbits/s, DS rate 0Kbits/s
Current speed: US 0Kbits/s,DS 0Kbits/s
Current speed: US 0Kbits/s,DS 0Kbits/s,rt-US 0, rt-DS 0Kbits/s

 
 
[:meganne]


---------------
:: Light is Right ::
n°308871
KroKette
Posté le 18-08-2003 à 15:49:48  profilanswer
 

A priori c bien la cause du probleme. Je n'ai pas la synchro.
 
La question c'est pourquoi ?
 
J'ai probablement raté un truc mais j'ai refait x fois les manip en suivant la doc de faust et franchement je seche completement :cry:  
 
J'ai essayer de changer le parametre ActivationMode=4 en 1, 2 et 3 + depmod -ae et reboot mais le résultat est le meme... Status No Link :/
 
Je précise que cette carte fonctionne sous w2k. La carte et la ligne ne sont donc pas en cause.

n°309003
KroKette
Posté le 18-08-2003 à 22:38:55  profilanswer
 

ha c'est bon sa marche :bounce:  
 
Pour info les pilotes unicorn 0.6.1 & 0.6.2 ne fonctionant pas chez moi j'ai mis la 0.5.4 et la ô miracle, la synchro c'est faite direct :sol:

n°309229
Tomate
Posté le 19-08-2003 à 00:51:00  profilanswer
 

KroKette a écrit :

ha c'est bon sa marche :bounce:  
 
Pour info les pilotes unicorn 0.6.1 & 0.6.2 ne fonctionant pas chez moi j'ai mis la 0.5.4 et la ô miracle, la synchro c'est faite direct :sol:  

juste pour info : c koi ton FAI ??


---------------
:: Light is Right ::
n°310518
KroKette
Posté le 20-08-2003 à 19:16:41  profilanswer
 

Wanadoo

n°310612
Tomate
Posté le 20-08-2003 à 22:30:22  profilanswer
 

au fait :  :hello: jamiroq  
 
 
 
sinon : parfois l option persist ne suffit pas, malheureusement :/


---------------
:: Light is Right ::
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  Le topic BEWAN aDSL PCI ST (Part II) - CARTE DÉJA FONCTIONNELLE

 

Sujets relatifs
ADSL sur port USB, ça marche sous Linux ?Réinitialiser la pile de la carte mère
pb de carte rezo sous debianhelp pour resintal et changement de carte mere.
[ADSL] quelqu'un pourrait 'il m'esxpliquer ???[ADSL] Venez m'aider SVP (c'est bon, y a plus de problémes)!!
Pb déconnexion adsl sous mdk 8.2A part linux ?
[debian] ma carte rézo ne trouve plus le dhcp...Vieux scanner SCSI s/carte ISA comptatible avec linux??
Plus de sujets relatifs à : Le topic BEWAN aDSL PCI ST (Part II) - CARTE DÉJA FONCTIONNELLE


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR