Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1242 connectés 

  FORUM HardWare.fr
  Hardware
  Processeur

  Haswell Refresh écran noir firmware ME ?

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

Haswell Refresh écran noir firmware ME ?

n°10476030
dokko59
Posté le 27-11-2018 à 15:17:53  profilanswer
 

Bonjour à tous,
 
Je viens d'acheter sur ebay un HP envy phoenix 810-340nf sans son processeur d'origine qui était censé être un i7 4790.
Description ici: https://support.hp.com/fr-fr/produc [...] el/7429147
 
Ayant un I7 4790S, j'ai tenté de l'installer mais écran noir...
J'installe un Pentium G3220 et ça fonctionne.
 
J'ai regardé au niveau du Bios et je m'aperçois que la version du bios est antérieur à la date de sortie de ce pc (2014), il n'y a pas de numéro de série, etc...
Il est également indiqué HP internal use only, ce qui me semble bizar...
 
https://i68.servimg.com/u/f68/11/36/97/19/20181111.jpg
https://i68.servimg.com/u/f68/11/36/97/19/20181110.jpg
 
 
La référence carte mère est MS-7826 VER: 0B alors que je ne trouve sur le net, que des versions 1 ou 2
 
 
https://i68.servimg.com/u/f68/11/36/97/19/20181112.jpg
 
 
J'ai mis à jour le bios en sa dernière version trouvée sur le site de HP, la 80.25 Rev.A du 9 novembre 2015 mais j'ai toujours le même problème d'écran noir que ce soit avec l' I7 4790S ou un I7 4790 et même avec un G3240 soit tous des Haswell Refresh.
Le G3220 fonctionne toujours!
 
J'ai re-flashé une seconde fois le bios en passant par l'outil de diagnostique HP mais idem alors que le flashage se passe bien sans erreur...
 
Par contre, en flashant par windows, j'ai toujours cette erreur: Cannot locate ME device driver
 
https://i68.servimg.com/u/f68/11/36/97/19/20181113.jpg
 
Impossible de mettre à jour le firmware Intel ME.
 
Pensez vous que le fait que les Haswell Refresh ne passent pas est dût au fait que le firmware ME n'est pas à jour ?
J'ai passé l'outil intel SA-00086-Detection-Tool https://downloadcenter.intel.com/do [...] ction-Tool
 
Ca me dit qu'il ne peux pas accéder au firmware...
 
Comment pourrais je faire pour mettre ce firmware à jour ?
 
Merci pour votre aide.
 
 

mood
Publicité
Posté le 27-11-2018 à 15:17:53  profilanswer
 

n°10476179
Nono0000
Posté le 27-11-2018 à 18:19:10  profilanswer
 

Salut,
 
Là je lis surtout qu’il ne peut pas accéder au pilote. Tu as bien installé les pilotes Intel ME?


---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10476217
zonka
x58 forever!
Posté le 27-11-2018 à 18:55:18  profilanswer
 

Bon, clairement on t'a refilé un exemplaire "interne" à HP (c'est nettement spécifié, donc pour trouver une MAJ de BIOS stable, ça risque d'être légèrement plus compliqué que la moyenne....)

 

Le plus sage serait de se rabattre sur un Haswell "tout court".

 

Pour le module ME c'est un truc de sécurité Intel bien lourdingue: tu n'as rien en rapport dans le BIOS? https://en.wikipedia.org/wiki/Intel_Management_Engine


Message édité par zonka le 27-11-2018 à 18:55:53

---------------
Guide OC x58 - Guide d'achat de config - ALIMS:qui fait quoi? - RKO - Radiooooo
n°10476650
dokko59
Posté le 28-11-2018 à 11:06:15  profilanswer
 

Salut et merci pour votre aide.
 
J'ai bien installé le pilote mais j'avais toujours une erreur code 10: STATUS_DEVICE_POWER_FAILURE, je suis sur windows 10 , j'avais le même problème en installant windows 8.1...
 
Je n'ai plus cette erreur en applicant la solution de cette vidéo: https://www.youtube.com/watch?v=XaOrPRATaDI.
 
 
En parcourant le net, j'ai vu que quelques personnes avaient eu le même problème avec les refresh mais qu'en installant la mise à jour du firmware Intel ME c'était bon.
 
Le nouveau Bios est bien installé mais apparemment pas ce firmware...
 
Comment pourrais je faire svp ?

n°10477115
Nono0000
Posté le 28-11-2018 à 21:44:03  profilanswer
 

J'ai un peu regardé l'intérieur du bios 80.25 Rev.A.
Il y a déjà le uCode pour le CPUID 306C3 ce qui est un bon début.

 

Le Firmware ME est en version 9.0.30.1482.

 

Avec UBU, tu peux manipuler le bios pour y inclure une version plus récente des uCodes ou du firmware ME (avec l'outil UEFITool)
Mais je ne suis pas sûr à 100% de la version du firmware à utiliser sur ta CM.
Sur ma x99 je sais que c'est une version 9.1.x mais sur z87, je pense que c'est plutôt une version 9.0.x.

 

En dehors de la version 9.0.31.1487, il n'y a pas d'autre version en 9.0.x donc je ne sais pas si on peut charger un ME en version 9.1.x sur ta CM…

 

Par contre il s'agit bien d'une version 1.5Mo et non 5Mo c'est à dire sans AMT. Là aussi j'avais un doute.

 


Message édité par Nono0000 le 29-11-2018 à 08:31:05

---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10477334
dokko59
Posté le 29-11-2018 à 09:32:44  profilanswer
 

Merci pour ta réponse.
 
Le problème, c'est que même en mettant à jour le bios comme j'ai fait avec la dernière version 80.25 qui contient pourtant le firmware Intel ME 9.0.30.1482, celui ci ne se mets pas à jour sur mon PC.
 
C'est comme ci le ME n'existait sur ma carte mère, mais je ne sais pas si c'est possible...
 
D'ailleurs, quand j'installe le driver sous windows, dans le log d'installation, il est indiqué: "could not find ME device"
 
Le z87 utilise la version en 9.0.x donc la dernière est bien la 9.0.31.1487 ce qui me parait suffisant pour pouvoir installer les haswell refresh qui est mon but premier.

n°10477343
Nono0000
Posté le 29-11-2018 à 09:45:52  profilanswer
 

Comme l'a souligné Zonka, cette CM semble être un prototype. Difficile de savoir ce qui a été implémenté ou non.

 

Si tu veux, je peux te faire un bios custom basé sur la version 80.25 avec le ME firmware en 9.0.31.1487 et les derniers uCode pour les CPU Haswell mais cela comporte un risque de "briquer" la CM si quelque chose se passe mal...


Message édité par Nono0000 le 29-11-2018 à 09:46:05

---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10477671
dokko59
Posté le 29-11-2018 à 15:18:06  profilanswer
 

Merci pour ton aide mais comme j'ai déjà mis le bios à jour dans sa dernière version, pourquoi le firmware ME 9.0.30.1482 ne s'installe pas ?
 
La compatibilité avec les refresh est dût à la mise à jour de ce firmware ME ou juste du BIOS ?
 
Je ne comprends pas...

n°10477705
dokko59
Posté le 29-11-2018 à 15:45:06  profilanswer
 

Se pourrait il que le ME de ma carte soit absent ou désactivé comme ici: https://forum.hardware.fr/hfr/Hardw [...] 4572_1.htm
 
Dans ce cas impossible de mettre à jour mon chipset Z87 pour faire passer les hasswell refresh ?
 
https://i62.servimg.com/u/f62/11/36/97/19/20181111.jpg

n°10477948
mooms
EEKUM BOKUM
Posté le 29-11-2018 à 19:50:22  profilanswer
 

On voit clairement sur la photo que le ME est en manufacturing mode, ce qui renforce la thèse du prototype.

 

https://reho.st/self/8434309df2b28ebe1013ffb85867eef0edd929a2.png

 

Essaye de voir si tu arrives à flasher le ME 9.0.31.1487 avec FTK v9:
https://forum.hardware.fr/hfr/Hardw [...] 9459_1.htm
Fais-le depuis DOS, commande meupd.
FTK est une suite de scripts utilisant les outils Intel, mais il est spécialisé sur les cartes-mères ASUS, si jamais ça échoue tu peux directement utiliser Intel FPT (Flash Programing Tool) en version 9.1
Tous les outils et les firmwares sont dispos ici: https://www.win-raid.com/t596f39-In [...] Tools.html

 

Tu as ici une suite d'outils pour diagnostiquer le ME:
https://github.com/chipsec/chipsec
et
https://github.com/ptresearch/mmdetect

 

Autrement, si ta puce BIOS n'est pas soudée tu peux acheter un programmeur SPI USB et flasher directement la puce contenant le BIOS (avec un fichier BIOS mis à jour via UBU comme te l'a proposé Nono0000), voir ce topic. L'avantage d'utiliser un programmeur externe c'est que tu ne risques rien à "bricker" ton BIOS puisque tu pourras toujours re-flasher la sauvegarde faite en premier lieu.


Message édité par mooms le 29-11-2018 à 20:35:01

---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
mood
Publicité
Posté le 29-11-2018 à 19:50:22  profilanswer
 

n°10480297
dokko59
Posté le 03-12-2018 à 15:21:30  profilanswer
 

Salut,
 
Merci pour l'aide!
 
J'ai vu que le ME en manufactoring mode est encore plus vulnérable que le ME en mode classique.
 
J'ai vu ici: https://hub.packtpub.com/intel-me-h [...] searchers/
que l'on pouvait désactiver le mode manufacturing avec la commande -CLOSEMNF, je peux y accéder, c'est une des commandes qui fonctionne sur mon pc mais j'hésite à le faire, que me conseillez vous ?
 
https://i62.servimg.com/u/f62/11/36/97/19/20181211.jpg
 
Impossible par contre de flasher, le ME 9.0.31.1487 que ce soit avec FTK ou FTP, j'ai toujours un message d'erreur.
Un exemple pour le meinfo:
Par contre, quand tu dis de flasher sous DOS, tu parles de l'invite de commande CMD ? sinon je ne sais pas comment ?
 
https://i62.servimg.com/u/f62/11/36/97/19/20181210.jpg
 
 
Par contre, j'ai tenté quelques manip avec FTP que j'ai vu sur ton topic: https://forum.hardware.fr/hfr/Hardw [...] 4572_1.htm
 
Sauvegarder le bios+ME avec la commande FPTW64 -d backup.bin ainsi que celle ci fptW64 -bios -d backup.bin et ça a fonctionné donc j'ai quand même certains accés, si quelqu'un peut confirmer...
 
La carte mère est un dérivé de MSI donc la puce est soudée.
Il y a également un emplacement sur la CM ou on peut mettre des Jumpers, il est indiqué ROM RECOVERY et LPC DEBUG, cela peut il m'aider ?
 
Merci
 
 
 

n°10480322
mooms
EEKUM BOKUM
Posté le 03-12-2018 à 15:57:08  profilanswer
 

Je veux bien que tu m'envoie le fichier backup.bin que tu as créé avec la commande FPTW64 -d backup.bin, comme ça je pourrais jeter un œil dessus, mais à mon avis il doit être incomplet car réalisé sous Windows.

 

Je pense que ça échoue parce que les pilotes MEI Windows ne sont pas chargés:

Citation :

Par contre, en flashant par windows, j'ai toujours cette erreur: Cannot locate ME device driver

 

C'est pour ça que je te disais de flasher sous DOS.
Le DOS c'est l'ancien système exploitation de Microsoft, il est en ligne de commande mais ça n'a rien à voir avec l'invite de commande, qui est un programme Windows.

 


Pour démarrer sous DOS, il te faut une clé USB (pas trop grosse pour rester compatible DOS, en fait la plus petite que tu puisse trouver sera le mieux) que tu va la rendre bootable avec Rufus.
Configure-le de cette manière:
https://reho.st/self/284cd0fd18bef2616eb54ed1002464b7686a8303.png

 

Une fois la clé préparée, il suffit d'y placer le programme de flash (fwupdlcl.exe version DOS) et le fichier bin contenant le firmware ME, ainsi que tous les exécutables te semblant nécessaires.
Tu peux aussi utiliser FTKv9, il y a un dossier DOS, il suffit d'en copier le contenu sur la clé (pas le dossier en lui-même).

 

Ensuite, tu démarre le PC sur la clé (soit en rentrant dans le BIOS et en choisissant la clé comme premier périphérique de boot, soit en faisant apparaitre le menu de choix de boot au démarrage du PC, je ne connais pas la combinaison de touche, ça dépend du PC, mais en général c'est la touche "esc" ou une des touches "F".

 

Une fois sous DOS, tape fwupdlcl -f me.bin (me.bin est le nom du fichier bin contenant le firmware ME) ou alternativement meupd si tu as copié le contenu du dossier FTK (il faut alors impérativement que le fichier s'appelle me.bin)

 

Tu peux aussi utiliser meinfo avant/après, ça devrait fonctionner sous DOS.

 

Si le flash fonctionne, il faut éteindre électriquement le PC pendant 30 secondes (coupe l'alim), pour que le ME se remette à zéro.

 

Pour la commande -CLOSEMNF j'ai l’impression qu'elle va te verrouiller l'accès en écriture (tu ne pourras plus flasher le ME), donc je déconseille.

 

Même si la puce BIOS est soudée, il est possible de la flasher avec un programmeur externe avec une pince spéciale, voir mes deux topics.


Message édité par mooms le 03-12-2018 à 16:07:25

---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10480336
dokko59
Posté le 03-12-2018 à 16:12:05  profilanswer
 

Merci pour les infos, je vais tenter en rentrant ce soir, j'ai une clé usb Sony de 1go.
 
Parc contre, pour les pilotes MEI Windows qui ne sont pas chargés, J'ai pourtant bien installé le pilote mais j'avais toujours une erreur code 10: STATUS_DEVICE_POWER_FAILURE, je suis sur windows 10 , j'avais le même problème en installant windows 8.1
 
Je n'ai plus cette erreur en applicant la solution de cette vidéo: https://www.youtube.com/watch?v=XaOrPRATaDI.
 
Le pilote date de 2018 et avec ca, dans intel management engine interface, il est indiqué que le périphérique fonctionne normalement mais est ce vraiment le cas ?

n°10480358
mooms
EEKUM BOKUM
Posté le 03-12-2018 à 16:30:52  profilanswer
 

Honnêtement je ne sais pas, je n'ai jamais été confronté à ce genre de problème, mais d'après tes photos (au passage tu peux faire des captures d'écrans!) le ME n'arrive pas à communiquer, donc non, il ne fonctionne pas normalement.
 
Si le flash sous DOS ne fonctionne pas, je te conseille d'expliquer ton problème avec le maximum d'infos sur le forum de Fernando, il y a là-bas des spécialistes beaucoup plus calés que moi.
 
Tiens-nous au courant en tout cas, je suis curieux de connaitre l'issue de cette histoire.


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10480375
mooms
EEKUM BOKUM
Posté le 03-12-2018 à 16:59:33  profilanswer
 

D'après https://support.hp.com/us-en/document/c04072036 il semble que ce PC vienne avec un i7 4770 et non 4790.
Je remarque aussi que le i7 4790S n'est pas dans la liste de compatibilité.
 
Si je compare la fiche Intel du 4790 et du 4790S, il n'ont pas le même TDP, ni la même fréquence de base:
https://ark.intel.com/compare/80808,80806
 
Mais il y a peut-être d'autres différences, et si la carte-mère n'a pas été prévue pour supporter le 4790S, il n'y a pas grand-chose à faire, surtout que c'est une carte-mère OEM, donc très limitée par rapport à une carte-mère pour particuliers.
 
Je serais toi, je regarderais le partie A/V du forum, tu trouveras peut-être une carte-mère Z87 ou Z97 pour pas trop cher.


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10480381
Nono0000
Posté le 03-12-2018 à 17:03:02  profilanswer
 

Ma compréhension de l'option CLOSEMNF est plutôt qu'elle permet de fermer le "manufacturing mode" proprement :
"-CLOSEMNF[NO] [PDR] End of Manufacturing. Details on NO & PDR use -exp option"
 
c'est d'ailleurs peut-être l'origine du problème de mise à jour...


---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10480391
mooms
EEKUM BOKUM
Posté le 03-12-2018 à 17:14:53  profilanswer
 

Peut-être oui, mais on a l'impression sur son image que cela va verrouiller en écriture les "flash regions", donc je dirais de ne le tenter qu'en dernier recours, ou de demander à un "spécialiste".
 
Après, pas-sûr du tout que le ME soit à l'origine du problème de toute manière, comme je l'ai démontré le 4790S n'est pas compatible d'après HP.
 
Se dégotter une CM µATX Z87 ou Z97 autour de 50€ me semble la meilleure solution...
 


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10480398
dokko59
Posté le 03-12-2018 à 17:19:37  profilanswer
 

Non à l'origine, il est bien fourni avec un I7 4790 c'est un 810-340nf.
 
Si un G3220 passe, je pense qu'un I7 4770 voir 4770k doit passer aussi ?
 
Par contre, quel est le risque de le laisser comme ça sans pouvoir mettre à jour le ME et le laisser en manufacturing mode avec un i7 4770 ?
 
Au fait, Je viens de revendre l'i7 4790s et acheter un i7 4790 classique ainsi qu'un g3240 mais le résultat reste le même...


Message édité par dokko59 le 03-12-2018 à 17:25:28
n°10480436
mooms
EEKUM BOKUM
Posté le 03-12-2018 à 17:42:25  profilanswer
 

Le 4790 est marqué compatible avec ta CM, mais vu que ta CM est une version bizarre...
Si tu ne veux pas trop t'embêter change la CM.


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10481604
dokko59
Posté le 05-12-2018 à 12:01:23  profilanswer
 

J'ai testé sous DOS hier soir mais idem...
 
Le MEINFO donne une erreur
 
https://i62.servimg.com/u/f62/11/36/97/19/20181212.jpg
 
fwupdlcl -f me.bin et meupd idem
 
https://i62.servimg.com/u/f62/11/36/97/19/20181213.jpg
 
Par contre avec fpt, j'arrive, je pense à dumper l'intégralité du bios et du ME ??
 
https://i62.servimg.com/u/f62/11/36/97/19/20181214.jpg
 
J'arrive à avoir ces infos avec fpt -i
 
https://i62.servimg.com/u/f62/11/36/97/19/20181215.jpg
 
 
Je ne peux pas flasher directement et uniquement le ME.bin avec fpt -f  ?
 
Ou alors directement flasher avec fpt un bios complet modifié ?

n°10481842
mooms
EEKUM BOKUM
Posté le 05-12-2018 à 16:02:06  profilanswer
 

dokko59 a écrit :


Par contre avec fpt, j'arrive, je pense à dumper l'intégralité du bios et du ME ??


 
Peux-tu zipper le fichier obtenu et l'uploader sur zippyshare ou autre pour que je regarde son contenu ?
 
 

dokko59 a écrit :


Je ne peux pas flasher directement et uniquement le ME.bin avec fpt -f  ?
 
Ou alors directement flasher avec fpt un bios complet modifié ?


 
fpt -rewrite -me -f bios.bin devrait ne flasher que la région ME, mais il faut utiliser le fichier BIOS complet comme source, pas ME.bin
 
Le fichier BIOS de chez HP contient bien le ME, donc ça devrait fonctionner:
https://reho.st/self/c4e092f7bc4cd70b5f70e6a93c0e69884648ca5b.png
 
fpt -rewrite -f bios.bin flashe entièrement la puce, mais tu perdras les infos uniques telles que adresse MAC et n° de série de la CM, mais il se peut que fpt -f bios.bin fonctionne sans effacer ces infos. Fait un fpt /? pour voir la liste des commandes disponibles.
 
 
Si ça ne marche toujours pas tu peux aussi tenter de flasher avec AFUDOS:
https://www.wimsbios.com/amiflasher.jsp
https://www.bios-mods.com/forum/Thr [...] AFUDOS-EXE


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10481877
dokko59
Posté le 05-12-2018 à 16:58:30  profilanswer
 

Ce que je ne comprends pas, c'est que j'ai déjà flashé le bios en passant par l'outil de diagnostique HP et que tout c'est bien passé..., le fichier sur la cle était le KAI_8021.
 
Donc en principe le ME a dût être installé ?
 
Pour que la carte mère accepte les haswell refresh, il faut que ce soit le bios qui soit à jour ou le ME ?
 
Je ne comprends plus trôp là .... :pt1cable:

n°10481885
Nono0000
Posté le 05-12-2018 à 17:03:41  profilanswer
 

Le ME je ne sais pas mais il faut que le CPUID soit supporté par le bios et possède un uCode associé, ce qui est le cas du bios 80.25 mais pas du 80.21.
Dans ton message précédent tu parles du 80.25 Rev.A et pas du 80.21... au final tu utilises lequel?


---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10481893
dokko59
Posté le 05-12-2018 à 17:06:39  profilanswer
 

j'ai installé le 80.25

n°10481899
mooms
EEKUM BOKUM
Posté le 05-12-2018 à 17:10:17  profilanswer
 

Si tu décompresse avec 7zip ou WinRAR le fichier HP (sp67055.exe) tu obtiens ça:
https://reho.st/self/195413df658fdaad63488439d5fbfaaafc7f76e9.png
 
Comme tu peux le voir il y a l'image BIOS (KAI_8021.BIN), mais aussi un fichier ME9_1482.BIN et l'outil FWUpdLcl qui permet de le flasher.
Donc visiblement l'outil HP ne sait pas mettre à jour le ME contenu dans l'image BIOS (à priori il utilise afuwin).
 
Il faut donc que tu mettes KAI_8021.BIN sur ta clé USB DOS et que tu le flashes avec la commande FPT que je t'ai donné.
Tu peux tenter sous Windows avec FPTW64.exe, mais je pense que ça a plus de chance de réussir sous DOS (avec FPT.exe)


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10481903
dokko59
Posté le 05-12-2018 à 17:10:25  profilanswer
 

Le cpuid de l'i7 4790 est 306C3 et celui du g3220 est le même, alors pourquoi l'un passe et pas l'autre ?
Si tu peux un peux m'expliquer stp

n°10481909
mooms
EEKUM BOKUM
Posté le 05-12-2018 à 17:15:05  profilanswer
 

Ah je n'avais pas vu qu'il existait un BIOS plus récent (8025).
Le principe reste le même, par contre HP a mis une archive rar sfx dans son archive autoextractible, il faut donc décompresser deux fois et on obtient ça:
https://reho.st/self/75e1f82778ef23f3a36c39d458778675c8bc7b33.png
 
Et c'est KAI_8025.bin qui contient l'image BIOS complète.


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10481928
mooms
EEKUM BOKUM
Posté le 05-12-2018 à 17:36:42  profilanswer
 

Nono0000 a raison, il faut aussi que les microcodes soient à jour, ça te protégera de Spectre au passage.
Du coup j'ai mis à jour les microcodes du BIOS 8025 avec UBU
 
 
Avant
https://reho.st/self/4e808c0b09e42deee269f24034f67f02661a8141.png
 
Après
https://reho.st/self/0c4a5650e0e6e76de577972b09701ebe935c185c.png
 
 
 
Voilà l'archive avec le fichier original et le fichier modifié:  
https://reho.st/self/c17eb934878249d6ca6fa7fb6bc69aaecf4b25e6.png
https://www.mediafire.com/file/pmtr [...] 5.zip/file
 
 
Il faudra donc aussi flasher la région BIOS en plus de la région ME (flash de la puce complète).
 
DOS:
fpt -f mod_KAI_8025.bin ou fpt -rewrite -f mod_KAI_8025.bin
 
Windows (à lancer en tant qu'administrateur):
FPTW64 -f mod_KAI_8025.bin ou FPTW64 -rewrite -f mod_KAI_8025.bin
 


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10482074
dokko59
Posté le 05-12-2018 à 19:43:33  profilanswer
 

Merci pour votre aide !
 
La commande fpt -f mod_KAI_8025.bin le renvoi l'erreur 280: failed to disable write protection for the bios space
 
J'ai ouvert mon backup avec uefi tool et la version de mon ME est 9.0.0.1287

n°10482089
mooms
EEKUM BOKUM
Posté le 05-12-2018 à 20:04:50  profilanswer
 

C'est peut-être parce que le BIOS est modifié.
 
Essaye fpt -f KAI_8025.bin
 
Et si ça ne marche toujours pas fpt -rewrite -me -f KAI_8025.bin, ça ne flashera que la région ME.


---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10482141
dokko59
Posté le 05-12-2018 à 20:45:42  profilanswer
 

Avec fpt -f KAI_8025.bin toujours la même erreur…
 
Par contre avec fpt -rewrite -me -f KAI_8025.bin ca a bien fonctionné :bounce:  
J'ai refait un backup et le ME indiqué par uefi tool est bien 9.0.30.1482  :D  
 
Penses tu que cela suffise pour faire passer les refresh ?
 
Si je fais la même chose avec ton kai_8025 modifié, je peux être en 9.0.31.1487 ?
 
Si je flash ton 80.25 modifié avec l'utilitaire hp, penses tu que ca fonctionnera et que les micro codes seront à jour ??
 

n°10482197
mooms
EEKUM BOKUM
Posté le 05-12-2018 à 21:38:21  profilanswer
 

Citation :

Avec fpt -f KAI_8025.bin toujours la même erreur…


Ça semble vouloir dire que la région BIOS est verrouillée en écriture, mais pas la région ME.

 
Citation :

Par contre avec fpt -rewrite -me -f KAI_8025.bin ca a bien fonctionné :bounce:
J'ai refait un backup et le ME indiqué par uefi tool est bien 9.0.30.1482  :D

 

On avance en tout-cas, et peut-être que maintenant que tu as réussi à mettre à jour le ME en 9.0.30.1482 avec FPT, le mettre à jour en 9.0.31.1487 avec fwupdlcl fonctionnera.

 
Citation :

Si je fais la même chose avec ton kai_8025 modifié, je peux être en 9.0.31.1487 ?

 

Ma modif ne concerne que les microcodes CPU, lorsque j'ai tenté de remplacer le ME en en 9.0.31.1487, UEFITool m'a affiché une erreur, il faut peut-être une étape intermédiaire que je ne connais pas.

 

https://reho.st/self/f73049fbe3603bf109124472829a7e0b16f4d9f9.png

 
Citation :

Si je flash ton 80.25 modifié avec l'utilitaire hp, penses tu que ca fonctionnera et que les micro codes seront à jour ??


Tu peux tenter de flasher mon 80.25 modifié avec l'utilitaire HP, mais à mon avis ça va échouer. Tente toujours.

 


Citation :

Penses tu que cela suffise pour faire passer les refresh ?


Je ne sais pas, essaye d'abord les manips énoncées, il sera toujours temps ensuite de tester le CPU refresh.

 

Quelle est la version affichée lorsque tu rentre dans le BIOS ?


Message édité par mooms le 05-12-2018 à 21:42:31

---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10482219
dokko59
Posté le 05-12-2018 à 22:00:43  profilanswer
 

Ok je tente demain.
 
Depuis le début, j'ai la version de bios 80.25 d'installé.  

n°10482220
mooms
EEKUM BOKUM
Posté le 05-12-2018 à 22:01:15  profilanswer
 

J'ai remplacé le ME 9.0.30.1482 par le 9.0.31.1487 en extrayant la région ME avec UEFITool, en remplaçant les octets via un éditeur hexadécimal, et en réintégrant la région ME via UEFITool, ça à l'air OK:

 

https://reho.st/self/30c09a495fa5980a24177cff5dea059e0140157c.png

 

Voilà le fichier BIOS, il contient donc les microcodes à jour et le ME en 9.0.31.1487

 

https://www.mediafire.com/file/xuxn [...] d.zip/file

 

Tu peux donc mettre à jour le ME en 9.0.31.1487 en utilisant la commande fpt -rewrite -me -f


Message édité par mooms le 05-12-2018 à 22:15:32

---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10482538
dokko59
Posté le 06-12-2018 à 14:14:20  profilanswer
 

MERCI !! :bounce:  
 
Je tente en rentrant ce soir...
 
Je vais tenter aussi de flasher ton bios modifié avec l'utilitaire hp, on verra bien, est ce que ça peut bricker la carte mère par contre ?
 
Si tout fonctionne, comment je peux sortir du manufactoring mode ?

n°10482552
zonka
x58 forever!
Posté le 06-12-2018 à 14:33:43  profilanswer
 

Il y a forcement un risque de Bricker la carte-mère en bricolant des Bios surtout sur une CM 'beta' comme ça.

 

1) absolument faire une sauvegarde / extraire le Bios actuel.

 

2) si le Bios est 'sockete' (EEPROM amovible sur socle, regarde sur la CM), tu pourras pour un quinzaine d'euros acheter sur un site spécialisé une puce qu'ils t'auront reprogrammé avec le Bios sauvegardé.

 

3) sinon tu pourras demander à Robin@hfr de te la sauver le cas échéant.

 

En tout cas chapeau : je bricole depuis longtemps (crossflash, parfois en mode 'bricolo') mais là j'aurais abandonné depuis bien longtemps.


---------------
Guide OC x58 - Guide d'achat de config - ALIMS:qui fait quoi? - RKO - Radiooooo
n°10482578
dokko59
Posté le 06-12-2018 à 15:17:46  profilanswer
 

Oui la sauvegarde du bios est faite.
 
En ce qui concerne la mise à jour des microcodes, ne sont ils pas mis à jour automatiquement par windows ?
 
Passer du ME 9.0.30.1482 à 9.0.31.1487 va t'il m'apporter quelque chose ou risque t'il de me poser des soucis comme j'ai put voir sur le net car pas d'origine dans le bios 80.25 ?
 

n°10482609
dokko59
Posté le 06-12-2018 à 16:06:00  profilanswer
 

Ci après, contenu du changelog 9.0.31.1487:
 
[Important updates]
- Added support for Microsoft Windows 8.1 64-bit.
- Removed support for Microsoft Windows 8 32-bit.
 
[New functions or enhancements]
- Added support for Thinkpad T540p,W540.
 
[Problem fixes]
- Fixed the following issues:
  - Intel AMT network connectivity was disabled if a Non-vPro CPU was replaced
    by a vPro CPU.
  - Some values in Open Manageability Development Tool Kit (DTK) were
    incorrectly displayed.
  - During stress testing of ME Wake on WLAN in S3, system might shut down to S5
    state.
  - Intel AMT was susceptible to a Denial of Service issue due to a
    vulnerability in its TCPIP stack.
  - When Intel ME was in control of the wireless card, power consumption was
    higher than expected.
  - SOL and IDER sessions over WLAN might be closed during restart.

n°10482612
mooms
EEKUM BOKUM
Posté le 06-12-2018 à 16:08:36  profilanswer
 

@dokko59

 

Le risque de brick existe mais il est minime, UBU est un outil fiable.

 

Windows 10 "installe" (temporairement, ça ne survit pas un redémarrage) les microcodes à jour depuis la 1809, (pour les versions précédentes il faut installer la màj soi-même, voir KB4090007 et KB4100347), mais ce n'est fait que lorsque Windows démarre, pas avant, donc ça ne permet pas de booter sur un CPU non-reconnu d'origine.

 

Les microcodes que j'ai mis à jour sont dans le BIOS, et donc utilisés dès le démarrage de la CM, ce qui peut permettre de démarrer sur un CPU non-reconnu d’origine.
Ça te protège aussi des failles Spectre même avec un OS sans les microcodes à jour (Windows 7 ou 8 par exemple).

 

Passer du ME 9.0.30.1482 à 9.0.31.1487 va là-aussi combler des failles de sécurités et corriger des bugs. (edit: ah been je vois que tu as trouvé le changelog).
Je ne peux pas te dire si ça t'apportera autre-chose, il se peut que le 4790 démarre déjà avec la màj que tu a faite, ou même ne démarre jamais (carte beta).

  

@zonka
On trouve des EEPROM sur eBay pour 3€, et sur ali un flasheur de type CH341A pour même pas 2€, qui en plus pourra resservir.
Le problème c'est que l'EEPROM sur cette CM est soudée, il faut donc une pince SOIC8 à utiliser de cette manière:
https://reho.st/thumb/self/69deba314ba5c34ed06d4cbcd23ec5e16d226fc6.png

 


Ou bien carrément dessouder la puce.
On trouve des flasheurs avec la pince pour moins de 4€, ou la pince seule pour 2€.

 

Voir ce sujet pour un tuto sur le flasheur.


Message édité par mooms le 06-12-2018 à 16:17:10

---------------
Le Livre de Vie |“Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet.”
n°10482625
dokko59
Posté le 06-12-2018 à 16:35:23  profilanswer
 

Je vais déjà dans un premier temps monter l'i7 4790 et voir si c'est ok, j'ai vu que dans les bios Asus c'est à partir du ME 9.0.30.1482 que les haswell refresh sont reconnus.

 

Par contre, comme le ME est en manufacturing mode, mon pc met beaucoup de temps pour booter, environ 30s...

 

Comment faire pour le re-passer en "normal" ?


Message édité par dokko59 le 06-12-2018 à 16:43:36
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Processeur

  Haswell Refresh écran noir firmware ME ?

 

Sujets relatifs
Ecran noir avec Ryzen 2600 et gigabyte b450 + GTX 780Ecran bleu sur config neuve
ecran benq 240hzAchat d'écran 75 ou 144 Hz (Graphisme/3D)
Nouvel écran !Écran noir au 1er démarrage après montage
Plus de sujets relatifs à : Haswell Refresh écran noir firmware ME ?


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR